
  



 1 

 

Table of Contents 

Chapter 1 - Introduction 13 

About Navicat 13 

Requirements 13 

Installation 17 

Registration 18 

Migration / Upgrade 19 

End-User License Agreement 19 

Chapter 2 - User Interface 27 

Main Window 27 

Navigation Pane 28 

Object Pane 28 

Information Pane 30 

Chapter 3 - Collaboration 32 

About Collaboration 32 

Manage Cloud 32 

Navicat Cloud 32 

On-Prem Server 34 

Push Synchronization 36 

Cache and Local Copies 37 

Projects 37 

Work With Projects 37 

Manage Members 38 

Chapter 4 - Connection 40 

About Connection 40 

General Settings 42 

MySQL / MariaDB 42 

Oracle 42 

PostgreSQL 43 

SQL Server 43 

SQLite 44 

MongoDB 45 

Redis 45 

Snowflake 46 

GaussDB 47 

Dameng 47 

Advanced Settings 47 

Databases / Attached Databases Settings 51 

SSL Settings 52 

SSH Settings 54 

HTTP Settings 55 



 2 

 

Compatibility Settings 56 

Sentinels / Sentinel SSL Settings 57 

Connect with Different Profiles 57 

Manage Connections 58 

Chapter 5 - Server Objects 60 

About Server Objects 60 

MySQL / MariaDB 60 

Databases 60 

Tables 60 

Views 61 

Procedures / Functions 62 

Tablespaces 63 

Events 63 

Other Objects 63 

Maintain Objects 63 

Oracle 64 

Schemas 64 

Tables 64 

Views 65 

Materialized Views 66 

Procedures / Functions 66 

Packages 67 

Recycle Bin 68 

Other Objects 69 

Maintain Objects 69 

PostgreSQL 72 

Databases & Schemas 72 

Tables 72 

Views 73 

Materialized Views 74 

Procedures / Functions 74 

Types 75 

Foreign Servers 76 

Other Objects 76 

Maintain Objects 76 

Manage Extensions 77 

SQL Server 77 

Databases & Schemas 77 

Tables 78 

Views 79 

Procedures / Functions 79 

Other Objects 80 



 3 

 

Maintain Objects 80 

SQLite 81 

Databases 81 

Tables 82 

Views 82 

Other Objects 83 

Maintain Objects 83 

MongoDB 84 

Databases 84 

Collections 84 

Views 85 

Functions 85 

Indexes 86 

MapReduce 86 

GridFS 86 

Maintain Objects 87 

Redis 88 

Databases 88 

Data 88 

Snowflake 88 

Databases & Schemas 88 

Tables 89 

Views 90 

Materialized Views 90 

Procedures / Functions 91 

Other Objects 92 

Maintain Objects 92 

Chapter 6 - Data Editor 93 

About Data Editor 93 

RDBMS 93 

RDBMS Data Editor 93 

Use Navigation Bar 93 

Edit Records 94 

Sort / Find / Replace Records 100 

Filter Records 101 

Manipulate Raw Data 101 

Format Data View 101 

View Field Information 103 

MongoDB 103 

MongoDB Data Editor 103 

Use Navigation Bar 104 

Grid View 105 



 4 

 

Tree View 108 

JSON View 110 

Sort / Find / Replace Documents 110 

Filter Documents 111 

Format Data View 112 

Redis 113 

Redis Data Editor 113 

Use Navigation Bar 114 

Edit Keys 114 

Sort Keys 115 

Search Keys 115 

Cell Editors 116 

Filter & Sort Pane 116 

Chapter 7 - Data Profiling (Available only in Navicat Premium, Enterprise and Standard Edition) 119 

About Data Profiling 119 

Start Data Profiling 119 

View Profiling Results 119 

Chapter 8 - Query 124 

About Query 124 

RDBMS 125 

Query Editor 125 

Query Builder (Available only in Navicat Premium, Enterprise and Standard Edition) 129 

Query Parameters 134 

Debug Oracle Query (Available only in Navicat Premium, Enterprise and Standard Edition) 134 

Query Results 135 

Query Explain 136 

MongoDB 137 

Query Editor 137 

Find Builder (Available only in Navicat Premium, Enterprise and Standard Edition) 140 

Aggregate Builder (Available only in Navicat Premium, Enterprise and Standard Edition) 141 

Query Results 141 

Query Explain 142 

Redis 143 

Query Editor 143 

Query Results 145 

Code Snippets 147 

Ask AI (Available only in Navicat Premium, Enterprise and Standard Edition) 148 

Fix Query with AI (Available only in Navicat Premium, Enterprise and Standard Edition) 152 

Chapter 9 - AI Assistant (Available only in Navicat Premium, Enterprise and Standard Edition) 153 

About AI Assistant 153 

Enable & Configure AI Assistant 154 

Chat with AI 154 



 5 

 

Chapter 10 - Model (Available only in Navicat Premium and Enterprise Edition) 156 

About Model 156 

Workspace 157 

Model 158 

About Model 158 

Create Conceptual Model 158 

Create Logical Model 159 

Create Physical Model - Relational 159 

Create Physical Model - Dimensional 160 

Create Physical Model - Data Vault 160 

Create Database / Schema 161 

Create Table 161 

Create View 161 

Create Function / Procedure 162 

Create Collection 162 

Create Predefined Object 163 

Create Entity 163 

Diagram 163 

About Diagram 163 

Create Diagram 164 

Add Model Objects 165 

Add Tables 165 

Add Collections 167 

Add Dimensions 168 

Add Facts 170 

Add Outriggers 172 

Add Hubs 173 

Add Links 175 

Add Satellites 177 

Add Bridges 178 

Add Point In Time 180 

Add References 181 

Add Foreign Keys 183 

Add Views 184 

Add Functions / Procedures 185 

Add Entities 187 

Add Labels 188 

Add Notes 189 

Add Images 190 

Add Shapes 191 

Add Layers 193 

Work with Diagram Canvas 194 



 6 

 

Apply Auto Layout 195 

Preview Diagram 196 

Print & Export Diagram 196 

Data Dictionary 196 

About Data Dictionary 196 

Create Data Dictionary 196 

Reverse Engineering 197 

About Reverse Engineering 197 

Synchronize Database to Model 197 

Reverse Database to Model 199 

Forward Engineering 199 

About Forward Engineering 199 

Synchronize Model to Database 199 

Export Model to SQL/Script File 202 

Compare Model Workspace 203 

Model Conversion 204 

Model Hints and Tips 205 

Chapter 11 - Debugger (Available only in Navicat Premium, Enterprise and Standard Edition) 207 

About Debugger 207 

Oracle PL/SQL Debugger 207 

PostgreSQL PL/pgSQL Debugger 208 

Chapter 12 - Pub/Sub (Available only in Navicat Premium, Enterprise and Standard Edition) 210 

About Pub/Sub 210 

Pub/Sub Window 210 

Subscribe Channels 211 

Channel Colorings 212 

Chapter 13 - Aggregation Pipeline (Available only in Navicat Premium, Enterprise and Standard Edition) 213 

About Aggregation Pipeline 213 

Pipeline Builder 213 

Pipeline Results 215 

Pipeline Explain 215 

Chapter 14 - Data Migration Tools 216 

About Data Migration Tools 216 

Import Wizard 216 

About Import Wizard 216 

Choose File Format 216 

Choose Source File 216 

Choose Delimiter 217 

Choose Additional Options 219 

Choose Target Table / Collection 219 

Adjust Field Structures and Map Fields 220 

Choose Import Mode 220 



 7 

 

Save and Start Import 222 

Export Wizard 222 

About Export Wizard 222 

Choose File Format 222 

Choose Saving Path 222 

Choose Columns / Fields for Export 223 

Choose Additional Options 223 

Save and Start Export 225 

Data Transfer (Available only in Navicat Premium, Enterprise and Standard Edition) 226 

About Data Transfer 226 

Choose Connections & Advanced Options (Step 1) 226 

Choose Objects & Transfer Mode (Step 2) 230 

Confirm & Start Data Transfer (Step 3) 231 

Data Synchronization (Available only in Navicat Premium, Enterprise and Standard Edition) 231 

About Data Synchronization 231 

Choose Connections & Comparing Options (Step 1) 232 

Choose Table / Collection Mapping (Step 2) 232 

View Data Comparison Results (Step 3) 232 

Edit & Execute Selected Scripts (Step 4) 233 

Structure Synchronization (Available only in Navicat Premium, Enterprise and Standard Edition) 234 

About Structure Synchronization 234 

Choose Connections & Comparing Options (Step 1) 234 

View Structure Comparison Results (Step 2) 237 

Edit & Execute Selected Scripts (Step 3) 237 

Dump & Execute SQL / Script File 238 

Execute Command File 238 

MongoImport & MongoExport 239 

About MongoImport & MongoExport 239 

MongoImport 239 

MongoExport 239 

Chapter 15 - Data Generation (Available only in Navicat Premium, Enterprise and Standard Edition) 241 

About Data Generation 241 

Choose Target Connection (Step 1) 241 

Choose Objects & Column Properties (Step 2) 242 

Use Generator (Step 2.1) 243 

Number Generator 243 

Date / Time / DateTime Generator 243 

Sequence Generator 244 

Enum Generator 244 

Text Generator 244 

Image/Binary Generator 244 

Foreign Key Generator 245 



 8 

 

UUID Generator 245 

Regular Expression Generator 245 

Name Generator 247 

Gender Generator 247 

Title Generator 247 

Marital Status Generator 247 

Phone Number Generator 248 

Email Generator 248 

Job Title Generator 248 

Social Network ID Generator 248 

Payment Method Generator 249 

Credit Card Type Generator 249 

Credit Card Number Generator 249 

Credit Card Date Generator 249 

Company Name Generator 250 

Department Generator 250 

Industry Generator 250 

Address Generator 250 

City Generator 251 

Region Generator 251 

Product Name Generator 251 

Product Category Generator 251 

Color Generator 252 

Size Generator 252 

Weight Unit Generator 252 

Barcode Generator 252 

SKU Generator 253 

IP Address Generator 253 

MAC Address Generator 253 

File Path Generator 253 

File Name Generator 254 

File Extension Generator 254 

URL Generator 254 

Hostname Generator 254 

Preview Data & Start Generation (Step 3) 255 

Chapter 16 - Data Dictionary (Available only in Navicat Premium, Enterprise and Standard Edition) 256 

About Data Dictionary 256 

Choose Databases (Step 1) 256 

Choose Objects & Change Order (Step 2) 256 

Choose Template (Step 3) 256 

Adjust Layout Settings (Step 4) 256 

Set File Path & Start Generation (Step 5) 257 



 9 

 

Chapter 17 - BI (Available only in Navicat Premium and Enterprise Edition) 259 

About BI 259 

Workspace 260 

Data Source 261 

About Data Source 261 

Create Data Source 262 

Modify Data Source Connections 264 

Filter / Sort / Project Data 265 

Add Custom Fields 267 

Examine Data Source Using Data Profiling 269 

Chart 269 

About Chart 269 

Build Chart 270 

Filter / Sort Data 272 

Apply Aggregate Function 273 

Add Range 274 

Set Value Operation 275 

Present Chart 275 

Chart Types 275 

About Chart Types 275 

Bar Chart 276 

Line / Area Chart 279 

Bar and Line Chart 282 

Waterfall Chart 286 

Tornado Chart 288 

Pie / Donut Chart 290 

Scatter Chart 292 

Heatmap 295 

Treemap 296 

Value 298 

Trend 299 

KPI 300 

Gauge 301 

Table 303 

Pivot Table 304 

Control 306 

DateTime Formats 307 

Dashboard 308 

About Dashboard 308 

Build Dashboard 309 

Add Pages 309 

Add Charts 310 



 10 

 

Add Text Labels 310 

Add Images 311 

Add Shapes 311 

Arrange Objects 312 

Present Dashboard 314 

Print & Export Dashboard 314 

Switch Theme 315 

Chapter 18 - Automation (Available only in Navicat Premium, Enterprise and Standard Edition) 316 

About Automation 316 

Create Batch Job (Step 1) 316 

Schedule Batch Job (Step 2) 318 

Chapter 19 - Backup & Restore 320 

About Backup & Restore 320 

MySQL / PostgreSQL / SQLite / MariaDB / Snowflake (Available only in Navicat Premium, Enterprise and 

Standard Edition) 320 

About Built-in Backup & Restore Tool 320 

Backup 320 

Restore 321 

Extract SQL 323 

Oracle Data Pump (Available only in Navicat Premium, Enterprise and Standard Edition) 324 

About Oracle Data Pump 324 

Oracle Data Pump Export 324 

Oracle Data Pump Import 327 

SQL Server Backup & Restore (Available only in Navicat Premium, Enterprise and Standard Edition) 330 

About SQL Server Backup & Restore 330 

SQL Server Backup 330 

SQL Server Restore 333 

MongoDump & MongoRestore 334 

About MongoDump & MongoRestore 334 

MongoDump 334 

MongoRestore 334 

Redis (Available only in Navicat Premium, Enterprise and Standard Edition) 335 

About Built-in Backup & Restore Tool 335 

Backup 335 

Restore 336 

Extract Command 337 

Chapter 20 - Server Security 339 

About Server Security 339 

MySQL / MariaDB User & Role Management 339 

User Designer 339 

Role Designer 340 

Oracle User & Role Management 341 



 11 

 

User Designer 341 

Role Designer 342 

Maintain User 343 

PostgreSQL User, Group & Role Management 344 

User Designer 344 

Group Designer 345 

Role Designer 345 

SQL Server Login, Role & User Management 347 

Login Designer 347 

Server Role Designer 349 

Database User Designer 349 

Database Role Designer 350 

Application Role Designer 351 

SQLite User Management 352 

MongoDB User & Role Management 353 

User Designer 353 

Role Designer 354 

Redis User Management 355 

Snowflake User & Role Management 356 

User Designer 356 

Role Designer 357 

Database Role Designer 357 

Privilege Manager 358 

Chapter 21 - Other Advanced Tools 359 

Server Monitor (Available only in Navicat Premium, Enterprise and Standard Edition) 359 

Schema Analysis (Available only in Navicat Premium, Enterprise and Standard Edition) 359 

Command Monitor (Available only in Navicat Premium, Enterprise and Standard Edition) 361 

Virtual Grouping 361 

Connection Colorings 362 

Find in Database/Schema (Available only in Navicat Premium, Enterprise and Standard Edition) 362 

Console 363 

Focus Mode (Available only in Navicat Premium, Enterprise and Standard Edition) 363 

Share via URI 364 

Favorites (Available only in Navicat Premium, Enterprise and Standard Edition) 365 

Dark Theme 366 

Search Filter 366 

Chapter 22 - Configurations 367 

Options Settings 367 

General 367 

Tabs 368 

Code Completion 369 

Editor 369 



 12 

 

Records 370 

AI 372 

Auto Recovery 374 

File Locations 374 

Connectivity 376 

Environment 376 

Advanced 377 

Chapter 23 - Hot Keys 379 

Navicat Hot Keys 379 

Chapter 24 - Trace Logs 383 

Log Files 383 

 

  



 13 

 

Chapter 1 - Introduction 

About Navicat 

Navicat is a robust, all-in-one solution for database development that enables seamless connections to multiple 

databases, including MySQL, PostgreSQL, MongoDB, MariaDB, SQL Server, Oracle, SQLite, Redis, and Snowflake, all 

from a single application. Its native user interface delivers a streamlined experience, making database design, 

management, and maintenance easier than ever. 

Navicat is available on three platforms: Microsoft Windows, macOS, and Linux. It can connect to both local and remote 

servers, offering several utility tools, including: 

• Object Designer 

• Data Manipulation 

• Data Profiling 

• Query Builder and Editor 

• AI Assistant 

• Import and Export 

• Data Transfer 

• Data and Structure Synchronization 

• Backup and Restore 

• Data Modeling 

• Business Intelligence (BI) 

• Data Generation 

• Data Dictionary 

• Automation 

• Collaboration 

For details, visit our website: https://www.navicat.com 

Requirements 

Supported Operating Systems 

https://www.navicat.com/
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Windows 

• Microsoft Windows 7, Windows 8, Windows 8.1, Windows 10, Windows 11, Server 2012, Server 2016, Server 

2019, Server 2022 

macOS 

• macOS 11 Big Sur, macOS 12 Monterey, macOS 13 Ventura, macOS 14 Sonoma, macOS 15 Sequoia, 

macOS 26 Tahoe 

Linux 

Flatpak 

• Flatpak supported distributions. 

AppImage (x86_64) 

• Debian 10, Debian 11, Debian 12, Ubuntu 20.04, Ubuntu 22.04, Ubuntu 24.04, Fedora 42, Linux Mint 20, Linux 

Mint 21, Linux Mint 22, Deepin 20, Deepin 23, Deepin 25, KylinOS Desktop 10, Pop!_OS 20.04, Pop!_OS 

22.04 

AppImage (aarch64) 

• Debian 11, Debian 12, Ubuntu 22.04, Ubuntu 24.04, Fedora 42, Linux Mint 20, Linux Mint 21, Linux Mint 22, 

Deepin 23, Deepin 25, KylinOS Desktop 10, Pop!_OS 20.04, Pop!_OS 22.04 

Supported On-Premises Databases 

• MySQL 3.23 or later 

• PostgreSQL 7.3 or later 

• Oracle 8i or later 

• SQLite 2 and 3 

• SQL Server 2000 or later 

• MariaDB 5.1 or later 

• MongoDB 3.0 or later 

• Redis 2.8 or later, Redis Cluster, Redis Sentinel, Microsoft Garnet 

• GaussDB 3.2 or later, openGauss 

• OceanBase Community and Enterprise 3.1.0 or later (Enterprise Oracle Mode is not available in macOS 

Edition) 

https://flatpak.org/setup
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• TiDB 7 or later 

• Dameng 8 or later 

• KingbaseES 8 or later 

• Fujitsu Enterprise Postgres 9.5 or later 

• IvorySQL 1 or later 

• Drizzle, OurDelta, Percona Server 

Supported Cloud Databases 

Amazon AWS 

• Amazon Redshift 

• Amazon Aurora for MySQL 

• Amazon Aurora for PostgreSQL 

• Amazon RDS for MySQL 

• Amazon RDS for PostgreSQL 

• Amazon RDS for Oracle 

• Amazon RDS for SQL Server 

• Amazon RDS for MariaDB 

• Amazon DocumentDB 

• Amazon ElastiCache for Redis 

Google Cloud 

• Google Cloud SQL for MySQL 

• Google Cloud SQL for PostgreSQL 

• Google Cloud SQL for SQL Server 

• Google Memorystore (Redis) 

Oracle Cloud 

• Oracle Database Cloud Service 

• Oracle MySQL Cloud Service 
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Microsoft 

• Microsoft Azure SQL Database 

• Microsoft Azure Database for MySQL 

• Microsoft Azure Database for PostgreSQL 

• Microsoft Azure Database for MariaDB 

• Azure Cosmos DB for MongoDB 

• Microsoft Azure Cache for Redis 

MongoDB Cloud Services 

• MongoDB Atlas 

Redis Enterprise Cloud 

• Redis Enterprise Cloud 

Alibaba Cloud 

• Alibaba Cloud ApsaraDB RDS for MySQL 

• Alibaba Cloud ApsaraDB RDS for PostgreSQL 

• Alibaba Cloud ApsaraDB RDS for SQL Server 

• Alibaba Cloud ApsaraDB for MongoDB 

• Alibaba Cloud ApsaraDB for Redis 

• Alibaba Cloud ApsaraDB for OceanBase (MySQL Mode) 

• Alibaba Cloud ApsaraDB for OceanBase (Oracle Mode) 

• Alibaba Cloud PolarDB for MySQL 

• Alibaba Cloud PolarDB for PostgreSQL 

• Alibaba Cloud PolarDB for Xscale 

Tencent Cloud 

• Tencent Cloud TencentDB for MySQL 

• Tencent Cloud TencentDB for PostgreSQL 

• Tencent Cloud TencentDB for SQL Server 
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• Tencent Cloud TencentDB for MariaDB 

• Tencent Cloud TencentDB for MongoDB 

• Tencent Cloud TencentDB for Redis 

Huawei Cloud 

• Huawei Cloud RDS for MySQL 

• Huawei Cloud RDS for PostgreSQL 

• Huawei Cloud RDS for SQL Server 

• Huawei Cloud Document Database Service 

• Huawei Cloud Distributed Cache Service for Redis 

• Huawei Cloud GaussDB Centralized 

• Huawei Cloud GaussDB Distributed 

• Huawei Cloud GaussDB(DWS) 

Snowflake 

• Snowflake 

Installation 

We strongly suggest that you shut down any opened applications. This will help ensure a smooth installation. 

Installation for Download Version 

1. Download Navicat Windows version. 

2. Open the .exe file. 

3. Click Next at the Welcome Screen. 

4. Read the License Agreement. Accept it and click Next. 

5. Accept the location of the program icons by clicking Next. If you wish to change the destination of the folder, 

click Browse. 

6. Follow the remaining steps. 
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Registration 

When the trial period is finished, Navicat requires a license key or a subscription plan to continue using the features. 

Note: Perpetual License and Subscription Plan cannot be used at the same Navicat. Before changing the registration 

method, you need to deactivate the license key or sign out your Navicat ID. 

Perpetual License 

If you have purchased a perpetual license, you will receive a license key for activating Navicat. 

In the Perpetual License section, paste your license key (16 digits) and click the Activate button. Navicat contacts our 

licensing server to activate the license key. If the activation process is successful, the license key details are displayed. 

Manual Activation 

Manual activation is available when your computer does not have an internet connection. You will need another 

computer with an internet connection to complete this activation process. 

1. If the online activation is failed, click Manual Activation. 

2. Copy the Request Code in the Copy the Request Code Here: box. 

3. Open web browser on a computer with an internet connection and then go to 

https://customer.navicat.com/manual_activate.php. 

4. Paste/Enter the Request Code into the left box. 

5. Click Get Activation Code. 

6. Copy the generated Activation Code in the right box. 

7. Go back to the computer where you are activating Navicat. 

8. Paste the Activation Code into the Paste the Activation Code Here: box. 

9. Click Activate. 

Subscription Plan 

If you have subscribed a plan, you can sign in your Navicat ID to use Navicat during the subscription term. 

Note: Navicat ID is the Email address that you used to subscribe the plan. 

In the Subscription section, provide your Navicat ID and Password. After signed in, the subscription plan details are 

displayed. 

Navicat contacts our licensing server once per hour to auto reload the plan by default. If you have updated your plan in 

the portal site, you can use the Reload Plan button to force reloading the new plan. 
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Note: Each Navicat ID can connect to only one Navicat. If you sign in your Navicat ID in another Navicat, you will be 

signed out from the current Navicat. 

Migration / Upgrade 

Migrate Navicat to a new computer 

1. In Navicat, choose File -> Export Connections. The exported file (.ncx) contains all your connection settings. 

2. Backup the exported file (.ncx). 

3. In Navicat, choose Help -> Registration. 

4. [Perpetual License] Click Deactivate to online deactivate the license key. 

5. [Subscription Plan] Click Sign Out to sign out your Navicat ID. 

6. Uninstall Navicat from the existing computer. 

7. Re-install Navicat in the new computer. 

8. Open Navicat and choose File -> Import Connections in the new computer to import the connection settings 

(.ncx). 

When a new connection is being established, Navicat will create a subfolder under Settings Location. Most files are 

stored within this subfolder. To look for the path, right-click the connection and select Edit Connection -> Advanced -> 

Settings Location. 

Moreover, all your saved profiles are stored under profiles. To look for the path, choose Tools -> Options -> File 

Locations -> Profiles Location. 

Upgrade Navicat 

If you want to upgrade an installed copy of Navicat to the latest release, please choose Help -> Check For Updates to 

start the Updater. It will automatically check your installed version. If there is a new version, simply follow the steps in 

the Updater to upgrade your Navicat. It will replace your previous Navicat and your current settings will remain 

unchanged. 

Or, you can submit your registered email address on the Customer Center to download the latest version installer. 

End-User License Agreement 

Note: For the License Agreement of Navicat Cloud service, please click here. 

IMPORTANT: THIS SOFTWARE END USER LICENSE AGREEMENT ("EULA") IS A LEGAL AGREEMENT 

BETWEEN YOU (EITHER AN INDIVIDUAL OR, IF PURCHASED OR OTHERWISE ACQUIRED BY OR FOR AN 

ENTITY, AN ENTITY) AND PREMIUMSOFT CYBERTECH LTD..READ IT CAREFULLY BEFORE COMPLETING THE 

https://customer.navicat.com/
https://legal.navicat.com/navicatcloud/NavicatCloudLicenseAgreement.rtf
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INSTALLATION PROCESS AND USING THE SOFTWARE. IT PROVIDES A LICENSE TO USE THE SOFTWARE 

AND CONTAINS WARRANTY INFORMATION AND LIABILITY DISCLAIMERS. BY INSTALLING AND USING THE 

SOFTWARE, YOU ARE CONFIRMING YOUR ACCEPTANCE OF THE SOFTWARE AND AGREEING TO BECOME 

BOUND BY THE TERMS OF THIS AGREEMENT. IF YOU DO NOT AGREE TO BE BOUND BY THESE TERMS, 

THEN DO NOT INSTALL THE SOFTWARE AND RETURN THE SOFTWARE TO YOUR PLACE OF PURCHASE. 

THIS EULA SHALL APPLY ONLY TO THE SOFTWARE SUPPLIED BY PREMIUMSOFT CYBERTECH LTD. 

HEREWITH REGARDLESS OF WHETHER OTHER SOFTWARE IS REFERRED TO OR DESCRIBED HEREIN. 

1. Definitions 

a. "Non-commercial Version" means a version of the Software, so identified, for use by i) the individual who is a 

natural person and not a corporation, company, partnership or association or other entity or organization (ii) the 

individual who is a student, faculty or staff member at an educational institution, and (iii) staff of a non-profit 

organization or charity organization only. For purposes of this definition, "educational institution" means a 

public or private school, college, university and other post secondary educational establishment. A non-profit 

organization is an organization whose primary objective is to support an issue or matter of private interest or 

public concern for non-commercial purposes. 

b. "Not For Resale (NFR) Version" means a version, so identified, of the Software to be used to review and 

evaluate the Software, only. 

c. "PremiumSoft" means PREMIUMSOFT CYBERTECH LTD. and its licensors, if any. 

d. "Software" means only the PremiumSoft software program(s) and third party software programs, in each case, 

supplied by PremiumSoft herewith, and corresponding documentation, associated media, printed materials, 

and online or electronic documentation. 

e. "Unregistered version", "Trial version" or "Demo version" means an unregistered copy of the SOFTWARE 

("UNREGISTERED SOFTWARE") which may be used by the USER for evaluation purposes for a period of 

fourteen (14) days following the initial installation of the UNREGISTERED SOFTWARE. At the end of the trial 

period ("TRIAL PERIOD"), the USER must either register the SOFTWARE or remove it from his system. The 

UNREGISTERED SOFTWARE may be freely copied and distributed to other users for their evaluation. 

f. "Navicat Premium Lite" means a free-to-use version of the Software with limited features, identified as "Lite". 

2. License Grants 

The licenses granted in this Section 2 are subject to the terms and conditions set forth in this EULA: 

a. Subject to Section 2(b), you may install and use the Software on a single computer; OR install and store the 

Software on a storage device, such as a network server, used only to install the Software on your other 

computers over an internal network, provided you have a license for each separate computer on which the 

Software is installed and run. Except as otherwise provided in Section 2(b), a license for the Software may not 

be shared, installed or used concurrently on different computers. 
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b. In addition to the single copy of the Software permitted in Section 2(a), the primary user of the computer on 

which the Software is installed may make a second copy of the Software and install it on either a portable 

computer or a computer located at his or her home for his or her exclusive use, provided that: 

A. the second copy of the Software on the portable or home computer (i) is not used at the same time as 

the copy of the Software on the primary computer and (ii) is used by the primary user solely as allowed 

for such version or edition (such as for educational use only), 

B. the second copy of the Software is not installed or used after the time such user is no longer the primary 

user of the primary computer on which the Software is installed. 

c. In the event the Software is distributed along with other PremiumSoft software products as part of a suite of 

products (collectively, the "Studio"), the license of the Studio is licensed as a single product and none of the 

products in the Studio, including the Software, may be separated for installation or use on more than one 

computer. 

d. You may make one copy of the Software in machine-readable form solely for backup purposes. You must 

reproduce on any such copy all copyright notices and any other proprietary legends on the original copy of the 

Software. You may not sell or transfer any copy of the Software made for backup purposes. 

e. You agree that PremiumSoft may audit your use of the Software for compliance with these terms at any time, 

upon reasonable notice. In the event that such audit reveals any use of the Software by you other than in full 

compliance with the terms of this Agreement, you shall reimburse PremiumSoft for all reasonable expenses 

related to such audit in addition to any other liabilities you may incur as a result of such non-compliance. 

f. Your license rights under this EULA are non-exclusive. 

3. License Restrictions 

a. Other than as set forth in Section 2, you may not make or distribute copies of the Software, or electronically 

transfer the Software from one computer to another or over a network. 

b. You may not alter, merge, modify, adapt or translate the Software, or decompile, reverse engineer, 

disassemble, or otherwise reduce the Software to a human-perceivable form. 

c. Unless otherwise provided herein, you may not rent, lease, or sublicense the Software. 

d. Other than with respect to a Trial / Demo Version, Lite Version or a Not For Resale Version of the Software, 

you may permanently transfer all of your rights under this EULA only as part of a sale or transfer, provided you 

retain no copies, you transfer all of the Software (including all component parts, the media and printed 

materials, any upgrades, this EULA, the serial numbers, and, if applicable, all other software products provided 

together with the Software), and the recipient agrees to the terms of this EULA. If the Software is an upgrade, 

any transfer must include all prior versions of the Software from which you are upgrading. If the copy of the 

Software is licensed as part of the whole Studio (as defined above), the Software shall be transferred only with 

and as part of the sale or transfer of the whole Studio, and not separately. You may retain no copies of the 
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Software. You may not sell or transfer any Trial / Demo Version, Lite Version or Not For Resale Version of the 

Software. 

e. Unless otherwise provided herein, you may not modify the Software or create derivative works based upon the 

Software. 

f. Non-commercial Versions of the Software may not be used for, or distributed to any party for, any commercial 

purpose. 

g. Unless otherwise provided herein, you shall not 

A. in the aggregate, install or use more than one copy of the Trial / Demo Version of the Software, 

B. download the Trial / Demo Version of the Software under more than one username, 

C. alter the contents of a hard drive or computer system to enable the use of the Trial / Demo Version of the 

Software for an aggregate period in excess of the trial period for one license to such Trial / Demo 

Version, 

D. disclose the results of software performance benchmarks obtained using the Trial / Demo Version or 

Lite Version to any third party without PremiumSoft prior written consent, or 

E. use the Trial / Demo Version of the Software for a purpose other than the sole purpose of determining 

whether to purchase a license to a commercial or education version of the software; provided, however, 

notwithstanding the foregoing, you are strictly prohibited from installing or using the Trial / Demo Version 

or Lite Version of the Software for any commercial training purpose. 

h. For Navicat Premium Lite: For avoidance of doubt, Navicat Premium Lite is licensed, not sold. Under this EULA, 

PremiumSoft grants you the right to 1) download [one copy] of the software, and 2) install and run [one 

instance] of the software on your [one device], whether physical or virtual with an internal storage device 

capable of running the software, so long as you comply with all the terms of this EULA. 

If you were in possession of multiple software versions, you may only install and run [one] of those versions at 

a time. If you use the software on more than one physical or virtual device, you must obtain a separate license 

for each instance. 

[Commercial Use] 

The number of users at any time within a business, whether incorporated or not, shall not exceed [five persons]. 

To use the software on more than one device, you are required to obtain a dedicated license and you may 

allow up to [five other devices] to access the software installed on the licensed device for commercial use. 

[Non-Commercial Use] 

Users qualified for PremiumSoft's Non-Commercial Licensing Program, subject to the conditions of the 

program as detailed in Navicat Non-Commercial Licensing Program 

(www.navicat.com/en/store/non-commercial), are granted the right to download, install, run, and use the 

software. 

i. You may only use the Not for Resale Version of the Software to review and evaluate the Software. 

https://www.navicat.com/en/store/non-commercial
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j. You may receive the Software in more than one medium but you shall only install or use one medium. 

Regardless of the number of media you receive, you may use only the medium that is appropriate for the 

server or computer on which the Software is to be installed. 

k. You may receive the Software in more than one platform but you shall only install or use one platform. 

l. You shall not use the Software to develop any application having the same primary function as the Software. 

m. In the event that you fail to comply with this EULA, PremiumSoft may terminate the license and you must 

destroy all copies of the Software (with all other rights of both parties and all other provisions of this EULA 

surviving any such termination). 

n. This program may include Oracle Instant Client (OCI). You agree that you shall 

1. not use of the Oracle Instant Client to the business operations; 

2. not assign, give, or transfer the Oracle Instant Client or an interest in them to another individual or entity; 

a. make the Programs available in any manner to any third party for use in the third party's 

business operations; and 

b. title to the Programs from passing to the end user or any other party; 

3. not reverse engineer, disassemble or decompilation the Oracle Instant Client and duplicate the 

Programs except for a sufficient number of copies of each Program for your licensed use and one copy 

of each Program media; 

4. discontinue use and destroy or return to all copies of the Oracle Instant Client and documentation after 

termination of the Agreement; 

5. not publish any results of benchmark tests run on the Programs; 

6. comply fully with all relevant export laws and regulations of the United States and other applicable 

export and import laws to assure that neither the Oracle Instant Client, nor any direct product thereof, 

are exported, directly or indirectly, in violation of applicable laws; 

7. allow PremiumSoft to audit your use of the Oracle Instant Client; 

4. Upgrades 

If this copy of the Software is an upgrade from an earlier version of the Software, it is provided to you on a license 

exchange basis. You agree by your installation and use of such copy of the Software to voluntarily terminate your 

earlier EULA and that you will not continue to use the earlier version of the Software or transfer it to another person or 

entity unless such transfer is pursuant to Section 3. 

5. Ownership 
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The foregoing license gives you limited license to use the Software. PremiumSoft and its suppliers retain all rights, title 

and interest, including all copyright and intellectual property rights, in and to, the Software (as an independent work and 

as an underlying work serving as a basis for any application you may develop), and all copies thereof. All rights not 

specifically granted in this EULA, including Federal and International Copyrights, are reserved by PremiumSoft and its 

suppliers. 

6. LIMITED WARRANTY AND DISCLAIMER 

a. Except with respect to Trial / Demo Version, Lite Version and Not For Resale Version of the Software, 

PremiumSoft warrants that, for a period of thirty (30) days from the date of delivery (as evidenced by a copy of 

your receipt): the physical media on which the Software is furnished will be free from defects in materials and 

workmanship under normal use. The Software is provided "as is". PremiumSoft makes no warranties, express 

or implied, arising from course of dealing or usage of trade, or statutory, as to any matter whatsoever. 

b. PremiumSoft provides no remedies or warranties, whether express or implied, for Trial / Demo version, Lite 

version and the Not for Resale version of the Software. Trial / Demo version, Lite version and the Not for 

Resale version of the Software are provided "as is". 

c. Except as set Forth in the foregoing limited warranty with respect to software other than Trial/ Demo version, 

Lite version and Not for Resale version, PremiumSoft and its suppliers disclaim all other warranties and 

representations, whether express, implied, or otherwise, including the warranties of merchantability or fitness 

for a particular purpose. Also, there is no warranty of non-infringement and title or quiet enjoyment. 

PremiumSoft does not warrant that the Software is error-free or will operate without interruption. The Software 

is not designed, intended or licensed for use in hazardous environments requiring fail-safe controls, including 

without limitation, the design, construction, maintenance or operation of nuclear facilities, aircraft navigation or 

communication systems, air traffic control, and life support or weapons systems. PremiumSoft specifically 

disclaims any express or implied warranty of fitness for such purposes. 

d. If applicable law requires any warranties with respect to the Software, all such warranties are limited in duration 

to thirty (30) days from the date of delivery. 

e. No oral or written information or advice given by PremiumSoft, its dealers, distributors, agents or employees 

shall create a warranty or in any way increase the scope of ANY warranty PROVIDED HEREIN. 

7. LIMITATION OF LIABILITY 

(a) Neither PremiumSoft nor its suppliers shall be liable to you or any third party for any indirect, special, incidental, 

punitive or consequential damages (including, but not limited to, damages for the inability to use equipment or access 

data, loss of business, loss of profits, business interruption or the like), arising out of the use of, or inability to use, the 

Software and based on any theory of liability including breach of contract, breach of warranty, tort (including 

negligence), product liability or otherwise, even if PremiumSoft or its representatives have been advised of the 

possibility of such damages. 

8. Third Party Software 
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The Software may contain third party software which requires notices and/or additional terms and conditions. By 

accepting this EULA, you are also accepting the additional terms and conditions of the third party software. 

9. General 

No PremiumSoft dealer, agent or employee is authorized to make any amendment to this EULA. 

This EULA contains the complete agreement between the parties with respect to the subject matter hereof, and 

supersedes all prior or contemporaneous agreements or understandings, whether oral or written. You agree that any 

varying or additional terms contained in any purchase order or other written notification or document issued by you in 

relation to the Software licensed hereunder shall be of no effect. The failure or delay of PremiumSoft to exercise any of 

its rights under this EULA or upon any breach of this EULA shall not be deemed a waiver of those rights or of the 

breach. 

If any provision of this EULA shall be held by a court of competent jurisdiction to be contrary to law, that provision will 

be enforced to the maximum extent permissible, and the remaining provisions of this EULA will remain in full force and 

Effect. 

10. Basis of Bargain 

The Limited Warranty and Disclaimer and Limited Liability set forth above are fundamental elements of the basis of the 

agreement between PremiumSoft and you. PremiumSoft would not be able to provide the Software on an economic 

basis without such limitations. Such Limited Warranty and Disclaimer and Limited Liability inure to the benefit of 

PremiumSoft's licensors. 

11. Term 

By downloading and/or installing this SOFTWARE, the Licensor agrees to the terms of this EULA. 

This license is effective until terminated. Licensor has the right to terminate your License immediately if you fail to 

comply with any term of this License. 

"as is". Licensor makes no warranties, express or implied, arising from course of dealing or usage of trade, or statutory, 

as to any matter whatsoever. In particular, any and all warranties or merchantability, fitness for a particular purpose or 

non-infringement of third party rights are expressly excluded. 

12. License Termination 

Without prejudice to any other rights, PremiumSoft may terminate this EULA if you fail to comply with the terms and 

conditions of this EULA. In such event, you must destroy all copies of the software and all of its component parts. 

13. Governing Law 

This License will be governed by the laws in force in Hong Kong. You hereby consent to the non-exclusive jurisdiction 

and venue sitting in Hong Kong to resolve any disputes arising under this EULA. 
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Should you have any questions concerning the validity of this License, please contact: licensing@navicat.com. If you 

desire to contact the Licensor for any other reason, please contact support@navicat.com. 

PremiumSoft and other trademarks contained in the Software are trademarks or registered trademarks of PremiumSoft 

CyberTech Ltd. in the United States and/or other countries. Third party trademarks, trade names, product names and 

logos may be the trademarks or registered trademarks of their respective owners. You may not remove or alter any 

trademark, trade names, product names, logo, copyright or other proprietary notices, legends, symbols or labels in the 

Software. This EULA does not authorize you to use PremiumSoft or its licensors names or any of their respective 

trademarks.  
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Chapter 2 - User Interface 

Main Window 

The Main Window consists of several toolbars and panes for you to work on connections, database objects and 

advanced tools. 

 

 Main Toolbar 

The Main Toolbar allows you to access basic objects and features, such as connections, users, tables, collections, 

backup, automation and more. To use small icons or hide the captions, right-click on the toolbar and disable Use Big 

Icons or Show Caption. 

 Navigation Pane 

The Navigation Pane is the basic way to navigate with connections, databases and database objects. If the Navigation 

Pane is hidden, choose View -> Navigation Pane -> Show Navigation Pane from the menu bar. 

 Tab Bar 

The Tab Bar allows you to switch among the tabbed windows on the Object Pane. You can choose to always display 

pop-ups on a new tab, or to always display them in a new window. If you have multiple tabs open, you can use 

CTRL+TAB to easily switch to other tabs. See also Options. 

 Object Toolbar 

The Object Toolbar provides other controls that you can use to manipulate the objects. 

 Object Pane 
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The Object Pane displays a list of objects (such as tables, collections, views, queries) and the tabbed window forms. 

Use the  List,  Detail and  ER Diagram buttons to change the view of the Objects tab. 

 Information Pane 

The Information Pane displays detailed object information, project activities, the DDL of database objects, object 

dependencies, and user/role memberships. It also provides a preview of query statements and gives you access to the 

AI Assistant. If the Information Pane is hidden, choose View -> Information Pane -> Show Information Pane from the 

menu bar. 

 Status Bar 

The Status Bar displays the current window's status information. 

Navigation Pane 

The Navigation pane employs tree structure which allows you to take action upon the database and their objects 

through their pop-up menus quickly and easily. If the Show objects under schema in navigation pane option is 

checked at the Options window, all database objects are also displayed in the pane. To connect to a database or 

schema, simply double-click it in the pane. 

After logged in Navicat Cloud or On-Prem Server, you can find it in the Navigation pane, and all connections stored 

locally will be located under the My Connections section. 

Table elements, such as fields, indexes and foreign keys, are display under each table. Click the arrow to the left of the 

table name to expand the list. If the elements are hidden, enable the Show objects under table in navigation pane 

option in the Options window. 

You can simply rename a field by using the pop-up menu, or you can double-click an element to open the table 

designer. 

If you want to hide the group structure in the Navigation pane, choose View -> Navigation Pane -> Flatten 

Connection. 

If the Navigation pane is hidden, choose View -> Navigation Pane -> Show Navigation Pane. 

Filter Connections 

Entering a search string in the Search text box will only show items containing the string. All groups, opened 

connections and objects that containing search result will also automatically expand to show the filtered results. 

The  and  icons on the right of the text box let you quickly filter for specific connection types and venders, active 

objects or starred connections. 

Object Pane 

In the Objects tab, you can use the  List,  Detail and  ER Diagram buttons to change the object view. 
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If you want to hide the group structure in List view or Details view, choose View -> Flatten Object List from the menu 

bar. 

List View 

By default, Navicat uses the List view. It only shows the names of objects. 

Detail View 

Detail view shows the name and several properties of objects in columns. To change the display columns of properties, 

choose View -> Choose Columns from the menu bar and choose display columns for different objects from the 

pop-up window. 

ER Diagram View (Available only in Navicat Premium, Enterprise and Standard Edition) 

Note: Available only for MySQL, Oracle, PostgreSQL, SQLite, SQL Server and MariaDB. Only tables provide ER 

Diagram view. 

An ER diagram will be generated automatically if the selected database/schema contains tables. ER diagram files are 

stored under Settings Location. 

 

 Diagram Canvas 

Display table fields and relationships between tables in a database/schema graphically. 

Add a Foreign Key 

Click  from the bottom toolbar. Drag and drop a field from the child table to the parent table. 

Edit or Delete a Foreign Key 



 30 

 

Right-click a relation line and select Design Foreign Key or Delete Foreign Key from the pop-up menu. 

Note: Double-click a table in the ER Diagram view will open the Table Designer, while double-click a table in the List or 

Detail view will open the Table Viewer. 

 Overview 

To zoom in or zoom out the selected area of the diagram, adjust the slider of the Overview. Same effect can be achieved 

with keyboard shortcuts: 

Zoom In: [CTRL++] or [CTRL+Mousewheel up] 

Zoom Out: [CTRL+-] or [CTRL+Mousewheel down] 

 Bottom Toolbar 

Button Description 

 Refresh Refresh - Refresh the ER diagram. 

Regenerate ER Diagram - Regenerate the ER diagram with using the auto 

layout feature. 
 

Switch the cursor to the Select mode. 
 

Switch the cursor to the hand mode for moving the diagram. Or, you can 

press and hold the SPACE key, then move the diagram. 
 

Add a relation between two table fields. Click this button, and then drag and 

drop a field from the child table to the parent table. 
 

Set the color of the selected tables or relations. 
 

Automatically arrange all tables or selected tables on the canvas. 
 

Export the ER diagram to a PNG file. 

 Preview Preview the diagram in a fullscreen mode. 

Size Select a paper size from the drop-down list. The corresponding paper size 

will reflect in the Overview pane. 

 

Information Pane 

The Information Pane displays detailed object information, project activities, the DDL of database objects, object 

dependencies, and user/role memberships. It also provides a preview of query statements and gives you access to the 

AI Assistant. If the Information Pane is hidden, choose View -> Information Pane -> Show Information Pane from the 

menu bar. 

You can select any connections, objects or projects, and then select the corresponding buttons on the Information 

Pane. 

Button Description 
 

General - Show the general information of the object/project. 

 AI Assistant - Chat with AI assistant. 
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Preview - Show the SQL statements in the query. 
 

DDL - Show the DDL statements of the object. Press CTRL+F to open the search 

box. 
 

Using - Show the objects that the selected object depends on. 

Objects - Show the objects in the tablespace. 

Member Of - Show the roles that the user or the role assigned to. 
 

Used By - Show the objects that depend on the selected object. 

Members - Show the members of the role. 
 

Code Snippet - Show all built-in and custom code snippets. 
 

Identifiers - Show all available tables, collections, views or fields in the selected 

database or schema. 

Field - Show the information of the selected field in Table Viewer. 
 

Privileges - Show the privileges granted to the user. 
 

Project - Show the project members and the project activities done by the 

members. Click + to add members to the project. 
 

Type Color - Set the color of particular types for highlighting cells in Grid View. 

(Available only for MongoDB) 

 Pub/Sub Info - Show which channels are active on the Redis server. 

 

Expand and Collapse Pane 

The Information Pane's width can be adjusted for optimal viewing. 

• Click the  icon at the top right of the pane to instantly maximize its size. 

• Click the  icon to return the pane to its original width. 

This functionality provides a convenient alternative to manually dragging the pane's border. 
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Chapter 3 - Collaboration 

About Collaboration 

Navicat allows you to synchronize connection settings, queries, aggregation pipelines, snippets, model workspaces, BI 

workspaces and virtual group information from Navicat, other Navicat family members, different machines and different 

platforms. You can use Navicat Cloud to host the files. Or, if you have installed our another product, Navicat On-Prem 

Server, in your environment, you can hosts everything in-house. 

Our collaboration feature allows you to give your teammates access to your projects when they log into their accounts. 

That way, you and your teammates can work on the same project without revealing your username and password. You 

can even choose to restrict the type of access your teammates have to your project. 

Manage Cloud 

Navicat Cloud 

Navicat Cloud is a cloud service provided by PremiumSoft for synchronizing connection settings, queries, aggregation 

pipelines, snippets, model workspaces, BI workspaces and virtual group information. 

Navicat Cloud could not connect and access your databases. By which it means, it could only store your connection 

settings, queries, aggregation pipelines, snippets, model workspaces, BI workspaces and virtual group information; your 

database passwords and data (e.g. tables, views, etc) will not be stored to Navicat Cloud. 

Note: You can only sign in to one Navicat Cloud account in the software. PremiumSoft will keep all synchronized files 

strictly confidential, and all employees are prohibited from viewing/accessing content of files you may store in your 

Navicat Cloud account. 

Create Navicat Cloud Account 

1. In the menu bar, choose File -> Manage Cloud. 

2. In the Manage Cloud window, select Navicat Cloud. 

3. Click Create Navicat ID. 

4. Enter the required information and click Sign Up. A verification email will send to your email address. 

5. Click the link in the email to verify the new account. 

Hint: You can sign in with the same Navicat ID you use for the Navicat Customer Center. 

Sign In Navicat Cloud 

1. In the menu bar, choose File -> Manage Cloud. 

2. In the Manage Cloud window, select Navicat Cloud. 
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3. Enter your Navicat ID and Password. 

4. Click Sign In. 

5. If you enabled two-step verification in Navicat Cloud Portal, a code will be sent to your phone via your mobile 

app. Enter the received code to sign in. 

Sign Out Navicat Cloud 

1. In the main window, right-click Navicat Cloud and select Close All Connections to close all connections 

under Navicat Cloud. 

2. At the top right, click your avatar. 

3. In the Manage Cloud window, select Navicat Cloud. 

4. Click Sign Out. 

View Usage 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, select Navicat Cloud. 

3. Your usage and current plan will be shown. 

Change Your Picture 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, select Navicat Cloud. 

3. Click your avatar. 

4. Choose an image file. 

Manage Your Account 

You can change your password, enable Two-Step Verification, upgrade Cloud Plan, etc in Navicat Cloud Portal. 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, select Navicat Cloud. 

3. Click Manage Account. 

4. A web browser will automatically open up to Navicat Cloud Portal. 

https://cloud.navicat.com/
https://cloud.navicat.com/
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On-Prem Server 

Navicat On-Prem Server is an on-premise solution that provides you with the option to host a cloud environment for 

storing Navicat objects (connection settings, queries, aggregation pipelines, snippets, model workspaces, BI 

workspaces and virtual group information) internally at your location. 

Before you can add an On-Prem Server, you must first set up Navicat On-Prem Server in your environment. 

Note: You can add multiple On-Prem Server in the software. 

Add New On-Prem Server 

1. In the menu bar, choose File -> Manage Cloud. 

2. In the Manage Cloud window, click + New On-Prem Server -> New On-Prem Server. 

3. Enter your On-Prem Server login information. 

Option Description 

Host The host name or IP address of your On-Prem Server. 

Port The port number of your On-Prem Server. 

Verify Server Certificate Enable this option to verify the server certificates. 

Enable Push 

Synchronization 

Navicat receives a silent push notification whenever its files stored in 

your On-Prem Server changes. 

4. Click OK. 

Add New On-Prem Server with URI 

1. In the menu bar, choose File -> Manage Cloud. 

2. In the Manage Cloud window, click + New On-Prem Server -> New On-Prem Server with URI. 

3. Paste your On-Prem Server URI. 

4. Click OK. 

Note: The URI can be copied from your On-Prem Server portal site. 

Sign In On-Prem Server 

1. In the menu bar, choose File -> Manage Cloud. 

2. In the Manage Cloud window, select the On-Prem Server. 

3. Enter your Username and Password. 

4. Click Sign In. 
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5. If you enabled two-step verification, a code will be sent to you via the verification method you have selected. 

Enter the received code to sign in. 

Sign Out On-Prem Server 

1. In the main window, right-click the On-Prem Server and select Close All Connections to close all connections 

in your server. 

2. At the top right, click your avatar. 

3. In the Manage Cloud window, select the On-Prem Server. 

4. Click Sign Out. 

Edit On-Prem Server 

1. In the main window, right-click the On-Prem Server and select Close All Connections to close all connections 

in your server. 

2. At the top right, click your avatar. 

3. In the Manage Cloud window, select the On-Prem Server. 

4. Click Sign Out. 

5. Right-click your server and select Edit On-Prem Server. 

6. Edit the On-Prem Server information. 

7. Sign in your server. 

Rename On-Prem Server 

1. In the main window, right-click the On-Prem Server and select Close All Connections to close all connections 

in your server. 

2. At the top right, click your avatar. 

3. In the Manage Cloud window, select the On-Prem Server. 

4. Click Sign Out. 

5. Right-click your server and select Rename. 

6. Enter the name to describe your On-Prem Server. 

7. Sign in your server. 

Remove On-Prem Server 
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1. In the main window, right-click the On-Prem Server and select Close All Connections to close all connections 

in your server. 

2. At the top right, click your avatar. 

3. In the Manage Cloud window, select the On-Prem Server. 

4. Click Sign Out. 

5. Right-click your server and select Remove On-Prem Server. 

6. Click Delete. 

View Usage 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, select the On-Prem Server. 

3. Your usage will be shown. 

Change Your Picture 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, select the On-Prem Server. 

3. Click your avatar. 

4. Choose an image file. 

Manage Your Account 

You can change your password, enable Two-Step Verification, etc in your On-Prem Server web portal. 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, select the On-Prem Server. 

3. Click Manage Account. 

4. A web browser will automatically open up to your On-Prem Server web portal. 

Push Synchronization 

Push Synchronization enables Navicat to receive a silent push notification whenever the files stored in Navicat Cloud or 

On-Prem Server changes. 

Enable Push Synchronization 
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1. At the top right, click your avatar. 

2. In the Manage Cloud window, right-click Navicat Cloud or your On-Prem Server. 

3. Turn on Enable Push Synchronization. 

Disable Push Synchronization 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, right-click Navicat Cloud or your On-Prem Server. 

3. Turn off Enable Push Synchronization. 

Cache and Local Copies 

When you logged into Navicat Cloud or your On-Prem Server, Navicat saves the cloud object files and some 

information in the local computer. The cache and local copies use to make sure your changes are saved in the cloud. 

Clear Cache and Local Copies 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, select Navicat Cloud or your On-Prem Server. 

3. Click Sign Out. 

4. Right-click Navicat Cloud or your On-Prem Server and select Clear Cache and Local Copies. 

5. Click Clear. 

Open Containing Folder 

1. In the main window, select Navicat Cloud or your On-Prem Server. 

2. Open your project, connection, database and/or schema. 

3. Click the Query, Model or BI icon. 

4. Right-click anywhere in the Objects tab and select Open Containing Folder. 

Projects 

Work With Projects 

A project is a way to structure and organize Navicat objects. You can put related objects in one project, and then share 

the project with other accounts for collaboration if necessary. 

Create New Projects 
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1. In the main window, right-click Navicat Cloud or your On-Prem Server. 

2. Select New Project. 

3. Enter the name of the new project. 

4. Click OK. 

Manage Existing Projects 

To rename a project 

1. In the main window, right-click the project and select Rename. 

2. Enter a new project name. 

Note: Only the project owner and the members with the Can Manage & Edit right can rename the project. 

To delete a project 

1. In the main window, right-click the project and select Delete Project. 

2. Click Delete. 

Note: Only the project owner can delete the project. 

Note: Before you delete the project, you must remove all objects in the project. 

To quit a project 

1. In the main window, right-click the project and select Quit Project. 

2. Click Quit. 

Manage Members 

Add Members 

1. In the main window, right-click the project and select Manage Members. 

2. Click Add Members. 

3. [Navicat Cloud] Enter the member's Navicat ID and press ENTER. 

4. [On-Prem Server] Check the boxes of the users that you want to add. 

5. Select the member right. 

6. Click Add. 
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Member Rights Privileges 

Can Manage & Edit Read Objects, Write Objects, Manage Members and Rename 

Projects 

Can Edit Read Objects and Write Objects 

Can View Read Objects 

Manage Existing Members 

To edit the right of a member 

1. In the main window, right-click the project and select Manage Members. 

2. Use the drop-down list next to the member to change the right. 

3. Click Apply. 

To remove a member from a project 

1. In the main window, right-click the project and select Manage Members. 

2. Click the X icon next to the member. 

3. Click Apply. 
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Chapter 4 - Connection 

About Connection 

To start working with your server in Navicat, you should first establish a connection or several connections using the 

Connection window. If you are new to the server or 'Net in general' and are not quite sure how things work, you may 

want to look at: 

• MySQL User Manual 

• Oracle Database Documentation 

• PostgreSQL User Manual 

• SQLite User Manual 

• Microsoft SQL documentation 

• MariaDB Documentation 

• MongoDB Manual 

• Redis Documentation 

• Snowflake Documentation 

Create Connection 

1. In the main window, click  Connection. 

2. In the new connection window, select your server type and click Next. 

3. Enter the necessary information. 

4. Click OK. 

Note: Navicat authorizes you to make connection to remote servers running on different platforms (i.e. Windows, 

macOS, Linux and UNIX), and supports PAM, Kerberos and LDAP authentication. Kerberos is only available in Navicat 

Premium, Enterprise and Standard Editon. 

Create Connection with URI 

1. In the main window, click  Connection. 

2. In the New Connection window, click New Connection with URI. 

3. Paste your Navicat URI or MongoDB URI. 

4. Click Apply. 

https://dev.mysql.com/doc/
https://docs.oracle.com/en/database/
https://www.postgresql.org/docs/
https://www.sqlite.org/docs.html
https://learn.microsoft.com/en-us/sql/
https://mariadb.com/kb/en/documentation/
https://docs.mongodb.com/manual/
https://redis.io/docs/
https://docs.snowflake.com/
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5. Navicat automatically fills out the options in the connection window. Modify your connection information if 

necessary. 

6. Click OK. 

Hint: The Navicat URI can be copied from the Edit Connection window. 

Edit Connection Settings 

1. In the main window, right-click your connection and select Edit Connection. 

2. In the Edit Connection window, modify your connection information. 

3. Click OK. 

Hint: You can view / copy your Navicat URI or MongoDB URI by clicking URI. 

Move / Copy Connection To Project 

If you have logged in to Navicat Cloud or On-Prem Server, you can synchronize the connection in My Connections to a 

project. 

1. Right-click a connection under My Connections and select Move Connection To or Copy Connection To. 

2. Select an existing project or create a new project. 

3. Choose whether to include all queries and virtual groups in the connection and click OK. 

4. The connection will be moved or copied to the project. 

Hint: You can move / copy a connection in a project to My Connections in a similar way. 

Flush MySQL/MariaDB Connection 

To clear or reload various internal caches, flush tables, or acquire locks, right-click your connection in the Navigation 

pane and select Flush and choose the flush option. You must have the RELOAD privilege to use this feature. 

Manage Azure SQL Database Firewall Rules 

You cannot connect to Azure SQL Database until you have granted your client IP access. To access Azure SQL 

Database from your computer, ensure that your firewall allows outgoing TCP communication on TCP port 1433. You 

must have at least one firewall rule before you can connection to Azure SQL Database. 

To manage the Firewall Rule settings, right-click your Azure SQL Database connection in the Navigation pane and 

select SQL Azure Firewall Rules. Add a new rule by providing an IP address range. 

Testing Account 

Navicat provides evaluated accounts for testing purpose. 
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MySQL 

 Host: server1.navicat.com 

 Port: 4406 

 User Name: navicat 

 Password: testnavicat 

PostgreSQL 

 Host: server1.navicat.com 

 Port: 5432 

 Initial Database: HR 

 User Name: navicat 

 Password: testnavicat 

General Settings 

MySQL / MariaDB 

To successfully establish a new connection to local/remote server - no matter via SSL, SSH or HTTP, set the database 

login information in the General tab. If your Internet Service Provider (ISP) does not provide direct access to its server, 

Secure Tunneling Protocol (SSH) / HTTP is another solution. 

Option Description 

Connection Name Enter a friendly name to best describe your connection. 

Add To After you logged in Navicat Cloud or On-Prem Server, you can choose to 

save the connection to My Connections or a project. 

Host A host name where the database is situated or the IP address of the server. 

Endpoint The Endpoint for connecting to the Amazon Web Services instance. 

Port A TCP/IP port for connecting to the database server. 

User Name User name for connecting to the database server. 

Password Password for connecting to the database server. 

 

Oracle 

To successfully establish a new connection to local/remote server - no matter via SSH, set the database login 

information in the General tab. If your Internet Service Provider (ISP) does not provide direct access to its server, 

Secure Tunneling Protocol (SSH) is another solution. 

Option Description 
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Connection Name Enter a friendly name to best describe your connection. 

Add To After you logged in Navicat Cloud or On-Prem Server, you can choose to 

save the connection to My Connections or a project. 

Connection Type Basic - In Basic mode, it connects to Oracle through the Oracle Call 

Interface (OCI). 

TNS - In TNS mode, it connects to Oracle server using an alias entry from a 

tnsnames.ora file through the Oracle Call Interface (OCI). 

Host A host name where the database is situated or the IP address of the server. 

Endpoint The Endpoint for connecting to the Amazon Web Services instance. 

Port A TCP/IP port for connecting to the database server. 

Service Name Enter the Service Name or SID. Select the corresponding radio button. 

Net Service Name Enter the Net Service Name. 

User Name User name for connecting to the database server. 

Password Password for connecting to the database server. 

Note: OCI is an application programming interface that allows an application developer to use a third-generation 

language's native procedure or function calls to access the Oracle database server and control all phases of SQL 

statement execution. OCI is a library of standard database access and retrieval functions in the form of a dynamic-link 

library. See also: OCI options 

PostgreSQL 

To successfully establish a new connection to local/remote server - no matter via SSL, SSH or HTTP, set the database 

login information in the General tab. If your Internet Service Provider (ISP) does not provide direct access to its server, 

Secure Tunneling Protocol (SSH) / HTTP is another solution. 

Option Description 

Connection Name Enter a friendly name to best describe your connection. 

Add To After you logged in Navicat Cloud or On-Prem Server, you can choose to 

save the connection to My Connections or a project. 

Host A host name where the database is situated or the IP address of the server. 

Endpoint The Endpoint for connecting to the Amazon Web Services instance. 

Port A TCP/IP port for connecting to the database server. 

Initial Database Set the initial database which user connects when making connection. 

User Name User name for connecting to the database server. 

Password Password for connecting to the database server. 

 

SQL Server 

To successfully establish a new connection to local/remote server - no matter via SSH, set the database login 

information in the General tab. If your Internet Service Provider (ISP) does not provide direct access to its server, 

Secure Tunneling Protocol (SSH) is another solution. 

Option Description 
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Connection Name Enter a friendly name to best describe your connection. 

Add To After you logged in Navicat Cloud or On-Prem Server, you can choose to 

save the connection to My Connections or a project. 

Host A host name where the database is situated or the IP address of the server. 

Endpoint The Endpoint for connecting to the Amazon Web Services instance. 

Initial Database Set the initial database which user connects when making connection. 

Authentication SQL Server Authentication - Use login records to validate the connection. 

Windows Authentication - When a user connects through a Windows user 

account, SQL Server validates the account name and password using the 

Windows principal token in the operating system. 

Microsoft Entra - Password - Use an identity and password in Microsoft 

Entra ID to connect the server. 

Microsoft Entra - Integrated - Use Windows identity federated with 

Microsoft Entra ID to connect the server. 

Microsoft Entra - MFA - Use a user account with multifactor authentication 

(MFA) enabled to connect the server. 

Microsoft Entra - Managed Identity - Authenticate to the database in SQL 

Database or SQL Managed Instance with Microsoft Entra managed 

identities. 

Microsoft Entra - Service Principal - Authenticate to the database in SQL 

Database or SQL Managed Instance with Microsoft Entra service principals 

(Microsoft Entra applications). 

User Name User name for connecting to the database server. 

Password Password for connecting to the database server. 

 

SQLite 

To successfully establish a new connection to local/remote server - no matter via HTTP, set the database login 

information in the General tab. If your Internet Service Provider (ISP) does not provide direct access to its server, HTTP 

is another solution. 

Option Description 

Connection Name Enter a friendly name to best describe your connection. 

Add To After you logged in Navicat Cloud or On-Prem Server, you can choose to 

save the connection to My Connections or a project. 

Type Existing Database File - Connect to an existing database in the Database 

File. 

New SQLite 3 - Create a new SQLite 3 database in the Database File. 

New SQLite 2 - Create a new SQLite 2 database in the Database File. 

Database File Specify the initial database file. If the HTTP Tunnel is enabled, you need to 

enter an absolute file path of the database file in your web server. 

User Name User name for connecting to the database. 
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Password Password for connecting to the database. 

 

MongoDB 

To successfully establish a new connection to local/remote server - no matter via SSL or SSH, set the database login 

information in the General tab. If your Internet Service Provider (ISP) does not provide direct access to its server, 

Secure Tunneling Protocol (SSH) is another solution. 

Option Description 

Connection Name Enter a friendly name to best describe your connection. 

Add To After you logged in Navicat Cloud or On-Prem Server, you can choose to 

save the connection to My Connections or a project. 

Type The type of your MongoDB server: Standalone, Shard Cluster or Replica 

Set. 

SRV Record Check this option to connect the server using an SRV Record. 

Host A host name where the database is situated or the IP address of the server. 

Endpoint The Endpoint for connecting to the Amazon Web Services instance. 

Port A TCP/IP port for connecting to the database server. 

Member Add or remove the members of replica set or the instances of sharded 

cluster to the connection. 

Read Preference Choose the replica set read preference for this connection. 

Replica Set The name of the replica set. 

Authentication None - No authentication. 

Password - Specify the Authentication Database name associated with 

the User Name and Password. 

LDAP - Specify the User Name and Password. 

Kerberos - Set the Kerberos Service Name and the user Principal. 

X.509 - x.509 certificate authentication. 

Use MongoDB URI 

You can also use a MongoDB URI to connect your MongoDB server. Simply click the URI button and paste the URI. 

Navicat will automatically fill out the options in the General, SSL and SSH tabs. 

Redis 

To successfully establish a new connection to local/remote server - no matter via SSL or SSH, set the database login 

information in the General tab. If your Internet Service Provider (ISP) does not provide direct access to its server, 

Secure Tunneling Protocol (SSH) is another solution. 

Option Description 

Connection Name Enter a friendly name to best describe your connection. 

Add To After you logged in Navicat Cloud or On-Prem Server, you can choose to 

save the connection to My Connections or a project. 
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Type The type of your Redis server: Standalone, Cluster or Sentinel. 

Role The role of your Redis instance: Master or Replica. 

Host A host name where the database is situated or the IP address of the server. 

Port A TCP/IP port for connecting to the database server. 

Authentication None - No authentication. 

Password - Enter the Password if the Redis server is password protected 

via the requirepass option. 

Username & Password - Enter the User Name and Password if Redis ACLs 

are used. 

Sentinel Host The IP address of the Sentinel instance. 

Sentinel Port A TCP/IP port for connecting to the Sentinel instance. 

Sentinel Authentication None - No authentication. 

Password - Enter the Sentinel Password for the Sentinel instance. 

Username & Password - Enter the Sentinel User Name and Sentinel 

Password for the Sentinel instance. 

Group Name The group of Redis instances composed of a master and one or more 

slaves. 

Group Authentication None - No authentication. 

Password - Enter the Group Password for the group. 

Username & Password - Enter the Group User Name and Group 

Password for the group. 

 

Snowflake 

To successfully establish a new connection, set the database login information in the General tab. 

Option Description 

Connection Name Enter a friendly name to best describe your connection. 

Add To After you logged in Navicat Cloud or On-Prem Server, you can choose to 

save the connection to My Connections or a project. 

Configuration Method Choose the configuration method of the database server. Either using user 

credentials (Default), data source names (DSN), Native SSO or 

Browser-Based SSO. 

Host A host name where the database is situated or the IP address of the server. 

Warehouse The warehouse to use once connected. 

Role The default access control role to use. 

Port A TCP/IP port for connecting to the database server. 

User Name User name for connecting to the database server. 

Password Password for connecting to the database server. 

Use MFA passcode Check this option if your user account has multi-factor authentication (MFA) 

enabled. 

Data Source Choose the data source you have set. 
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Native SSO URL The Okta URL endpoint for your Okta account. 

 

GaussDB 

To successfully establish a new connection to local/remote server - no matter via SSL or SSH, set the database login 

information in the General tab. If your Internet Service Provider (ISP) does not provide direct access to its server, 

Secure Tunneling Protocol (SSH) is another solution. 

Option Description 

Connection Name Enter a friendly name to best describe your connection. 

Add To After you logged in Navicat Cloud or On-Prem Server, you can choose to 

save the connection to My Connections or a project. 

Type The type of your GaussDB server: Single Host or Multiple Hosts. 

Host / Hosts A host name where the database is situated or the IP address of the server. 

Port A TCP/IP port for connecting to the database server. 

Host Type Preference The type of the host to be connected. 

Initial Database Set the initial database which user connects when making connection. 

User Name User name for connecting to the database server. 

Password Password for connecting to the database server. 

 

Dameng 

To successfully establish a new connection to local/remote server - no matter via SSH, set the database login 

information in the General tab. If your Internet Service Provider (ISP) does not provide direct access to its server, 

Secure Tunneling Protocol (SSH) is another solution. 

Option Description 

Connection Name Enter a friendly name to best describe your connection. 

Add To After you logged in Navicat Cloud or On-Prem Server, you can choose to 

save the connection to My Connections or a project. 

Configuration Method Choose the configuration method of the database server. Either using user 

credentials (Default) or data source names (DSN). 

Host A host name where the database is situated or the IP address of the server. 

Port A TCP/IP port for connecting to the database server. 

User Name User name for connecting to the database server. 

Password Password for connecting to the database server. 

Data Source Choose the data source you have set. 

 

Advanced Settings 

Note: The following options depend on the connection server type and sort in ascending order. 

Auto connect 
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Open the connection at application startup automatically. 

Cipher Name 

Choose the encryption algorithm when connecting to an encrypted SQLite database. 

Client Character Set 

Choose the session client character set used in Navicat. 

Client Driver Version 

Choose the client driver used to connect the server. If the default driver does not work, you can change this setting to 

Legacy. 

Compatibility 

Enable the Compatibility tab for setting the compatibility mode for MySQL connection. 

Connection Parameters 

Enter advanced parameters that don't have an equivalent option exposed in any other tab, e.g. 

Trusted_Connection=yes;ApplicationIntent=ReadOnly; 

Connection Timeout 

Specify the amount of time to wait for a connection to be established before timing out. 

Encoding 

Choose a codepage for converting data to display in Navicat UI. 

Encrypted 

Enable this option and provide Password when connecting to an encrypted SQLite database. 

Execution Timeout 

Specify the amount of time to wait before execution of a task is completed on the server. 

Initial Queries 

Specify the initial query commands to be executed when connecting to the server. 

Keepalive interval 

Keep the connection with the server alive by pinging it. You can set the period between pings in the edit box. 

Limit connection sessions 



 49 

 

Specify the maximum number of concurrent connections that the server allows. 

Native Client Driver 

Choose the SQL Server Native Client used for the connection. 

OS authentication 

Use OS user login credentials to authenticate database users. 

Read Timeout 

Specify the amount of time to wait for more data from a connection before aborting the read. 

Retryable Reads 

Disable this option to specify "retryReads=false" in the connection string. 

Retryable Writes 

Disable this option to specify "retryWrites=false" in the connection string. 

Role 

Indicate that the database user is connecting with either the Default, SYSOPER or SYSDBA system privilege. 

Server Selection Timeout 

Specify the amount of time to block for server selection before throwing an exception. 

Settings Location 

When a new connection is being established, Navicat will create a subfolder under the Settings Location. Most files are 

stored within this subfolder: 

File in Settings Location Server Type File Extension 

Aggregation Pipeline MongoDB .nagg 

Backup MySQL, PostgreSQL, SQLite, 

MariaDB and Snowflake 

.nb3 

Redis .nbr 

Backup Profile MySQL .nbakmysql 

PostgreSQL .nbakpgsql 

SQLite .nbaksqlite 

SQL Server .nbakmssql 

MariaDB .nbakmariadb 

Redis .nbakredis 

Snowflake .nbaksnowflake 

Collection Profile MongoDB .ntablep 
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Data Pump Export Profile Oracle .nbakora 

Data View Profile Redis .ndvredis 

ER Diagram File MySQL, Oracle, PostgreSQL, 

SQLite, SQL Server, MariaDB 

and Showflake 

.nmodel 

Export Materialized View Profile Oracle .nexpmora 

PostgreSQL .nexpmpgsql 

Snowflake .nexpmsnowflake 

Export Query Result Profile MySQL .nexpqmysql 

Oracle .nexpqora 

PostgreSQL .nexpqpgsql 

SQLite .nexpqsqlite 

SQL Server .nexpqmssql 

MariaDB .nexpqmariadb 

MongoDB .nexpqmongodb 

Snowflake .nexpqsnowflake 

Export Table/Collection Profile MySQL .nexptmysql 

Oracle .nexptora 

PostgreSQL .nexptpgsql 

SQLite .nexptsqlite 

SQL Server .nexptmssql 

MariaDB .nexptmariadb 

MongoDB .nexptmongodb 

Snowflake .nexptsnowflake 

Export View Result Profile MySQL .nexpvmysql 

Oracle .nexpvora 

PostgreSQL .nexpvpgsql 

SQLite .nexpvsqlite 

SQL Server .nexpvmssql 

MariaDB .nexpvmariadb 

MongoDB .nexpvmongodb 

Snowflake .nexpvsnowflake 

Import Table/Collection Profile MySQL .nimpmysql 

Oracle .nimpora 

PostgreSQL .nimppgsql 

SQLite .nimpsqlite 

SQL Server .nimpmssql 

MariaDB .nimpmariadb 

MongoDB .nimpmongodb 

Snowflake .nimpsnowflake 

MapReduce MongoDB .mapreduce 
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Pub/Sub Redis .npsbredis 

Pub/Sub Archive File Redis .nrpsbmlog 

Query MySQL, Oracle, PostgreSQL, 

SQLite, SQL Server, MariaDB 

and Snowflake 

.sql 

MongoDB .js 

Redis .redis 

Schema Analysis MongoDB .nsatmongodb 

Table Profile MySQL, Oracle, PostgreSQL, 

SQLite, SQL Server, MariaDB 

and Snowflake 

.ntablep 

Socket Timeout 

Specify the amount of time to wait for an inactive socket before closing it. 

Trust Server Certificate 

Skip the step that validates the server certificate. The server certificate is automatically trusted. 

Use compression 

Use compression protocol. It is used if both client and server support zlib compression, and the client requests 

compression. 

Use encryption 

Use encryption for SQL Server connection. 

Use named pipe, socket 

Use socket file for localhost connection. 

Write Timeout 

Specify the amount of time to wait for a block to be written to a connection before aborting the write. 

Databases / Attached Databases Settings 

MySQL, Oracle, PostgreSQL, SQL Server, MariaDB, MongoDB, Redis 

In the Databases tab, you can set which databases will be shown in the Navigation pane when connecting to your 

server. It is not obligatory. To start working with custom database settings, check Use custom database list. Then, 

check the preferable databases in the Database column. If you want Navicat automatically open the databases at 

connection, check the Auto Open box. 

Add a hidden database to the list 
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1. Click the Add Database to List button. 

2. Enter the database name. 

3. Check the newly added database in the database list. 

Remove a database from the list 

1. Select the database in the database list. 

2. Click the Remove Database from List button. 

Note: The database will be just removed from the database list box, it will still exist in the server. 

SQLite 

In the Attached Databases tab, you can attach SQLite database files to the connection. Click the Attach Database 

button and enter the information: 

Option Description 

Database File Choose the file path of a database file. 

Database Name Enter the database name which displays in Navicat. 

Encrypted Check this option and provide the Password if the database file is encrypted. 

To detach a database, select it from the list and click the Detach Database button. 

SSL Settings 

Secure Sockets Layer(SSL) is a protocol for transmitting private documents via the Internet. To get a secure 

connection, the first thing you need to do is to install OpenSSL Library and download Database Source. 

Note: Available only for MySQL, PostgreSQL, MariaDB, MongoDB and Redis. Support from PostgreSQL 8.4 or later. 

MySQL and MariaDB Connections 

To provide authentication details, enable Use authentication and fill in the required information: 

Client Key 

The SSL key file in PEM format to use for establishing a secure connection. 

Client Certificate 

The SSL certificate file in PEM format to use for establishing a secure connection. 

CA Certificate 

The path to a file in PEM format that contains a list of trusted SSL certificate authorities. 

Verify server certificate against CA 
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Check the server's Common Name value in the certificate that the server sends to the client. 

Specified Cipher 

A list of permissible ciphers to use for SSL encryption. 

PostgreSQL Connection 

Choose the SSL Mode: 

require Only try an SSL connection. 

verify-ca Only try an SSL connection, and verify that the server certificate is issued by a 

trusted CA. 

verify-full Only try an SSL connection, verify that the server certificate is issued by a trusted 

CA and that the server hostname matches that in the certificate. 

To provide authentication details, enable Use authentication and fill in the required information: 

Client Key 

The path of the client private key. 

Client Certificate 

The path of the client certificate. 

Root Certificate 

The path of the trusted certificate authorities. 

Certificate Revocation List 

The file path of the SSL certificate revocation list (CRL). 

MongoDB Connection 

To provide authentication details, enable Use authentication and fill in the required information: 

Client Key 

The SSL key file in PEM format to use for establishing a secure connection. 

Client Key Password 

The password of the key file. 

Allow any server SSL certificates 

Check this option if your MongoDB server allows any server SSL certificates. 
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CA Certificate 

The path to a file in PEM format that contains a list of trusted SSL certificate authorities. 

Certificate Revocation List 

The file path of the SSL certificate revocation list (CRL). 

Allow invalid host names 

Check this option to allow invalid hostnames in SSL certificates. 

Redis Connection 

To provide authentication details, enable Use authentication and fill in the required information: 

Client Key 

The SSL key file in PEM format to use for establishing a secure connection. 

Client Key Password 

The password of the key file. 

Allow any server SSL certificates 

Check this option if your Redis server allows any server SSL certificates. 

CA Certificate 

The path to a file in PEM format that contains a list of trusted SSL certificate authorities. 

Server Name Indication 

The Server Name Indication (SNI) value used when establishing the SSL connection to the Redis server. 

SSH Settings 

Secure SHell (SSH) is a program to log in into another computer over a network, execute commands on a remote 

server, and move files from one machine to another. It provides strong authentication and secure encrypted 

communications between two hosts, known as SSH Port Forwarding (Tunneling), over an insecure network. 

Typically, it is employed as an encrypted version of Telnet. 

In a Telnet session, all communications, including username and password, are transmitted in plain-text, allowing 

anyone to listen-in on your session and steal passwords and other information. Such sessions are also susceptible to 

session hijacking, where a malicious user takes over your session once you have authenticated. SSH serves to prevent 

such vulnerabilities and allows you to access a remote server's shell without compromising security. 

Note: Available only for MySQL, Oracle, PostgreSQL, SQL Server, MariaDB, MongoDB and Redis. 
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Please make sure that the parameter - "AllowTcpForwarding" in the Linux server must be set to value "yes", otherwise, 

the SSH port forwarding will be disabled. To look for the path: /etc/ssh/sshd_config. By default, the SSH port forwarding 

should be enabled. Please double check the value settings. 

Even the server support SSH tunnel, however, if the port forwarding being disabled, Navicat cannot connect via SSH 

Port 22. 

Host 

A host where SSH server is activated. 

Note: The host name in the General tab should be set relatively to the SSH server which provided by your database 

hosting company. 

Port 

A port where SSH server is activated, by default it is 22. 

User Name 

A user on SSH server machine. (It is not a user of database server.) 

Authentication Method 

Password Provide the SSH server user Password. 

Public Key Private Key 

It is used together with your public key. The private key should be readable only by 

you. 

Passphrase 

A passphrase is exactly like a password, except that it applies to the keys you are 

generating and not an account. 

Note: HTTP Tunnel and SSH Tunnel cannot be function simultaneously. The SSH Tunnel is disabled when you select 

the HTTP Tunnel and vice versa. 

HTTP Settings 

HTTP Tunneling is a method for connecting to a server that uses the same protocol (http://) and the same port (port 80) 

as a web server does. It is used while your ISPs do not allow direct connections, but allows establishing HTTP 

connections. 

Note: Available only for MySQL, PostgreSQL, SQLite and MariaDB. 

Uploading the Tunneling Script 

To use this connection method, first thing you need to do is to upload the tunneling script to the web server where your 

server is located. 
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Note: ntunnel_mysql.php (for both MySQL and MariaDB), ntunnel_pgsql.php or ntunnel_sqlite.php is available in 

the Navicat installation folder. 

Setting up HTTP Tunnel 

The following instruction guides you through the process of configuring a HTTP connection. 

1. Select the HTTP tab and enable Use HTTP tunnel. 

2. Enter URL of the tunneling script. 

e.g. http://www.navicat.com/ntunnel_mysql.php 

3. If your server installed a Web Application Firewall, you can check the Encode outgoing query with base64 

option. 

4. If the tunneling script is hosted in a password protected server or you have to access internet over a proxy 

server, you can provide the required authentication details in the Authentication or Proxy tab. 

Note: HTTP Tunnel and SSH Tunnel cannot be function simultaneously. The SSH Tunnel is disabled when you select 

the HTTP Tunnel and vice versa. 

Compatibility Settings 

If your server is a variant of MySQL or has proxy middleware installed, you can enable compatibility mode and set the 

corresponding settings for the connection. 

Note: Available only for MySQL. 

Force lower_case_table_names as 

Set the value of the lower_case_table_name system variable. 

Force sql_mode as 

Set the value of the sql_mode system variable. 

Force NDB cluster support as 

Include or exclude the support for the NDBCLUSTER storage engine. 

Force database listing method as 

Use the SHOW DATABASES statement to retrieve the information for listing databases, or select the information from 

the INFORMATION_SCHEMA database. 

Force view listing method as 

Use the SHOW FULL TABLES statement to retrieve the information for listing tables, or select the information from the 

INFORMATION_SCHEMA database. 
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Sentinels / Sentinel SSL Settings 

If you are connecting to Redis Sentinel, you can provide additional configuration options in the Sentinels and Sentinel 

SSL tabs. 

Note: Available only for Redis. 

Sentinels 

You can enable Use extra sentinels to specify additional Sentinel nodes. 

Sentinel SSL 

If your Redis Sentinels configured to use SSL/TLS for secure communication, you can enable Use SSL. 

To provide authentication details, enable Use authentication and fill in the required information: 

Client Key 

The SSL key file in PEM format to use for establishing a secure connection. 

Client Key Password 

The password of the key file. 

Allow any server SSL certificates 

Check this option if your Redis server allows any server SSL certificates. 

CA Certificate 

The path to a file in PEM format that contains a list of trusted SSL certificate authorities. 

Server Name Indication 

The Server Name Indication (SNI) value used when establishing the SSL connection to the Redis server. 

Connect with Different Profiles 

You can have multiple profiles for each connection, with slightly different connection settings. For example, different 

database users. 

Create Connection Profile 

1. In the connection window, click . 

2. Click . 

3. Enter the name of the profile. 
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4. Enter the connection settings. 

5. Click OK. 

Switch Profile 

1. In the main window, right-click a connection and select Switch Connection Profile. 

2. Select the profile name. 

Hint: You can also set the default active profile in the connection window. 

Manage Connections 

The Manage Connections feature is a centralized way to manage connections in My Connections or projects. To open 

the manager, you can hover over My Connections or a project and click . 

Note: Changes made in the Manage Connection window will be immediately applied to the Navigation pane. 

Create Connection 

1. In the Manage Connections window, click  New Connection. 

2. In the New Connection window, select your server type and click Next. 

3. Enter the necessary information. 

4. Click OK. 

Edit Connection Settings 

1. In the Manage Connections window, select your connection. 

2. Click  Edit Connection. 

3. In the Edit Connection window, modify your connection information. 

4. Click OK. 

Hint: You can view / copy your Navicat URI or MongoDB URI by clicking URI. 

Star / Unstar Connections 

1. In the Manage Connections window, select the connections you want to add or remove stars. 

2. Click  Add Star or  Remove Star. 

Hide / Unhide Connections 

1. In the Manage Connections window, select the connections you want to hide or unhide. 
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2. Click  Hide or  Unhide. 

Delete Connections 

1. In the Manage Connections window, select the connections you want to delete. 

2. Click  Delete Connection. 

3. Click Delete. 

Search Connection Information 

Navicat allows you to quickly search for specific connection information within the application. It helps you locate 

specific connections by searching for keywords related to the connection details. You can search for connection 

information such as connection names, host names, IP addresses, port numbers and other relevant settings. 

In the Manage Connections window, simply enter the search string in the Search connection info box. As you type, 

search results automatically update and all matching text strings are highlighted. 
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Chapter 5 - Server Objects 

About Server Objects 

Navicat provides powerful tools to manage server objects, such as databases, tables, views, functions, etc. 

Some server objects may have been hidden by Navicat. These objects include system databases, system tables and 

so on. To show the hidden items, choose View -> Show Hidden Items from the menu bar. 

Note: Before working with the server objects in Navicat, you should establish the connection first. 

In object designers, you can preview the necessary SQL statements, scripts or commands for creating or editing the 

object on the SQL Preview, Script Preview or Command Preview tab. For some database or schema objects, you 

can use the bottom drop-down list to show the SQL, scripts or commands which will be run when choosing Save or 

Save As from the File menu. 

MySQL / MariaDB 

Databases 

To start working with the server objects, you should create and open a connection. If the server is empty, you need to 

create a new database. 

Create a new database 

1. In the Navigation pane, right-click a connection and select New Database. 

2. Enter the database properties in the pop-up window. 

Edit an existing database 

1. In the Navigation pane, right-click a database and select Edit Database. 

2. Edit the database properties in the pop-up window. 

Note: MySQL does not support renaming database through its interface at this moment. Access the directory in which 

databases being stored. By default, all databases store within a directory called data under MySQL Installation folder. 

For example: C:\mysql5\data. You must stop MySQL before you can rename the database. 

Tables 

Tables are database objects that contain all data in a database. A table is a set of rows and columns, and their 

intersections are fields. In the main window, click  Table to open the table object list. 

There are two ways to open a table with graphical fields, right-click a table and select: 

Option Description 
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Open Table Navicat loads all your BLOB fields (images) while opening the table. 

Open Table (Quick) Faster performance for opening the graphical table, as BLOB fields (images) will 

not be loaded until you click on the cell. (It is invisible by default until you hold 

down the SHIFT key when right-clicking the table.) 

You can create a table shortcut by right-clicking a table in the Objects tab and select Create Open Table Shortcut 

from the pop-up menu. This option is used to provide a convenient way for you to open your table for entering data 

directly without activating the Navicat main window. 

To empty a table, right-click the selected table and select Empty Table from the pop-up menu. This option is only 

applied when you wish to clear all the existing records without resetting the auto-increment value. To reset the 

auto-increment value while emptying your table, use Truncate Table. 

Table Designer 

Table Designer is the basic Navicat tool for working with tables. It allows you to create, edit and drop table's fields, 

indexes, foreign keys, and much more. 

In the Fields tab, you can search a field name by choosing Edit -> Find or pressing CTRL+F. 

Note: The tabs and options in the designer depend on the server type and version. 

Table Viewer 

When you open a table, Table Viewer displays data as a grid. Data can be displayed in two modes: Grid View and 

Form View. See Data Editor for details. 

Note: Transaction is only available for INNODB tables. 

Views 

A view allows users to access a set of tables as if it is a single table. You can use views to restrict access to rows. In the 

main window, click  View to open the view object list. 

You can create a view shortcut by right-clicking a view in the Objects tab and select Create Open View Shortcut from 

the pop-up menu. This option is used to provide a convenient way for you to open your view directly without activating 

the Navicat main window. 

View Designer 

View Designer is the basic Navicat tool for working with views. You can edit the view definition as SQL statement 

(SELECT statement it implements) in the Definition tab. To customize the view of the editor and find out more features 

for SQL editing, see Query Editor for details. If you want to load SQL statement from a SQL file to the editor, you can 

choose File -> Import SQL. 

Button Description 

 Preview Preview the data of the view. 
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 Explain Show the Query Plan of the view. 

 View Builder Build the view visually. It allows you to create and edit views without knowledge 

of SQL. See Query Builder for details. 

 Beautify SQL Format the codes with the Beautify SQL settings in Editor. 

Hint: You can choose to show the preview results below the editor or in a new tab by choosing View -> Result -> 

Show Below Editor or Show in New Page. 

View Viewer 

When you open a view, View Viewer displays data as a grid. Data can be displayed in two modes: Grid View and Form 

View. See Data Editor for details. 

Note: Transaction is only available for updatable views. 

Procedures / Functions 

Procedures and functions (stored routines) are supported in MySQL 5.0. A stored routine is a set of SQL statements 

that can be stored in the server. In the main window, click  Function to open the function object list. 

Function Wizard 

Click  New Function from the object toolbar. Function Wizard will pop up and it allows you to create a 

procedure/function easily. 

1. Select the type of the routine: Procedure or Function. 

2. Define the parameters. Set the Mode, Name and/or Type under the corresponding columns. 

3. If you create a function, select the Return Type from the list and enter the corresponding information: Length, 

Decimals, Character set and/or Enum. 

Hint: Once uncheck the Show wizard next time option, you can go to Options to enable it. 

Function Designer 

Function Designer is the basic Navicat tool for working with procedures/functions. You can enter a valid SQL 

statement in the Definition tab. This can be a simple statement such as SELECT or INSERT, or it can be a compound 

statement written using BEGIN and END. Compound statements can contain declarations, loops, and other control 

structure statements. To customize the view of the editor and find out more features for SQL editing, see Query Editor 

for details. 

Results 

To execute the procedure/function, click  Execute on the toolbar. If the SQL statement is correct, the statement will 

be executed and, if the statement is supposed to return data, the Result tab opens with the data returned. If an error 

occurs while executing the procedure/function, execution stops, the appropriate error message is displayed. If the 
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procedure/function requires input parameters, the Input Parameter dialog will pop up. Check the Raw Mode option to 

pass the inputted values to the procedure/function without quotation marks. 

Note: Navicat supports to return 20 result sets. 

Tablespaces 

An InnoDB general tablespace is a shared tablespace which can hold multiple tables, and supports all table row 

formats. An InnoDB undo tablespace contains undo logs. In MySQL NDB Cluster, tablespace can contain one or more 

data files, providing storage space for NDB Cluster Disk Data table. In the main window, click  Others -> 

Tablespace to open the tablespace object list. 

Tablespace Designer 

Tablespace Designer is the basic Navicat tool for working with tablespaces. It allows you to set the table engine, 

specify the data file, etc. 

Events 

An event is a task that run according to a schedule. In the main window, click  Others -> Event to open the event 

object list. 

Event Designer 

Event Designer is the basic Navicat tool for working with events. You can enter a valid SQL procedure statement in 

the Definition tab. This can be a simple statement such as SELECT or INSERT, or it can be a compound statement 

written using BEGIN and END. Compound statements can contain declarations, loops, and other control structure 

statements. To customize the view of the editor and find out more features for SQL editing, see Query Editor for details. 

Other Objects 

Navicat also allows you to manage other MySQL / MariaDB objects: Sequence. In the main window, click  Others 

and select an object to open the object list. 

Note: Sequences are available for MariaDB 10.3 or later. 

Maintain Objects 

Navicat provides a complete solution for maintaining MySQL / MariaDB objects. 

1. In the main window, select objects in the Navigation pane or the Objects tab. 

2. Right-click the selected objects. 

3. Choose Maintain, and then choose a maintain option from the pop-up menu. 

4. Results show in a pop-up window. 
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Table 

Option Description 

Analyze Tables Analyze and store the key distribution for the table. 

Check Tables Check the table for errors. 

Optimize Tables Optimize the table to reduce storage space and improve I/O 

efficiency. 

Repair Tables Repair the possibly corrupted table. 

Get Rows Count Count the number of rows in the table. 

Tablespace 

Option Description 

Set Active Mark an InnoDB undo tablespace as active. 

Set Inactive Mark an InnoDB undo tablespace as inactive. 

 

Oracle 

Schemas 

To start working with the server objects, you should create and open a connection. When you create a user account, 

you are also implicitly creating a schema for that user. A schema is a logical container for the database objects (such 

as tables, views, triggers, and so on) that the user creates. The schema name is the same as the user name, and can 

be used to unambiguously refer to objects owned by the user. 

Hint: Oracle interprets non-quoted object identifiers as uppercase. In Navicat, all object identifiers will be quoted. That 

is, Navicat saves exactly what you have inputted. 

Tables 

Tables are database objects that contain all data in a database. A table is a set of rows and columns, and their 

intersections are fields. In the main window, click  Table to open the table object list. 

You can create Normal / External / Index Organized tables. Click the down arrow next to  New Table from the 

object toolbar and choose the table type. 

There are two ways to open a table with graphical fields, right-click a table and select: 

Option Description 

Open Table Navicat loads all your BLOB fields (images) while opening the table. 

Open Table (Quick) Faster performance for opening the graphical table, as BLOB fields (images) will 

not be loaded until you click on the cell. (It is invisible by default until you hold 

down the SHIFT key when right-clicking the table.) 

You can create a table shortcut by right-clicking a table in the Object pane and select Create Open Table Shortcut 

from the pop-up menu. This option is used to provide a convenient way for you to open your table for entering data 

directly without activating the Navicat main window. 
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To empty a table, right-click the selected table and select Empty Table from the pop-up menu. This option is only 

applied when you wish to clear all the existing records without resetting the auto-increment value. To reset the 

auto-increment value while emptying your table, use Truncate Table. 

Table Designer 

Table Designer is the basic Navicat tool for working with tables. It allows you to create, edit and drop table's fields, 

indexes, foreign keys, and much more. 

In the Fields tab, you can search a field name by choosing Edit -> Find or pressing CTRL+F. When creating a new 

table, you are allowed to insert fields or rearrange the order of the fields. 

Note: The tabs and options in the designer depend on the server version and the table type. 

Table Viewer 

When you open a table, Table Viewer displays data as a grid. Data can be displayed in two modes: Grid View and 

Form View. See Data Editor for details. 

Views 

A view allows users to access a set of tables as if it is a single table. You can use views to restrict access to rows. In the 

main window, click  View to open the view object list. 

You can create a view shortcut by right-clicking a view in the Objects tab and select Create Open View Shortcut from 

the pop-up menu. This option is used to provide a convenient way for you to open your view directly without activating 

the Navicat main window. 

View Designer 

View Designer is the basic Navicat tool for working with views. You can edit the view definition as SQL statement 

(SELECT statement it implements) in the Definition tab. To customize the view of the editor and find out more features 

for SQL editing, see Query Editor for details. If you want to load SQL statement from a SQL file to the editor, you can 

choose File -> Import SQL. 

Button Description 

 Preview Preview the data of the view. 

 Explain Show the Query Plan of the view. 

 View Builder Build the view visually. It allows you to create and edit views without knowledge 

of SQL. See Query Builder for details. 

 Beautify SQL Format the codes with the Beautify SQL settings in Editor. 

Hint: You can choose to show the preview results below the editor or in a new tab by choosing View -> Result -> 

Show Below Editor or Show in New Page. 

View Viewer 

http://192.168.1.247/online_manual/en/navicat/win_manual/#/data_viewer


 66 

 

When you open a view, View Viewer displays data as a grid. Data can be displayed in two modes: Grid View and Form 

View. See Data Editor for details. 

Materialized Views 

Materialized Views are schema objects that used to summarize, compute, replicate, and distribute data. In the main 

window, click  Materialized View to open the materialized view object list. 

You can create a materialized view shortcut by right-clicking a materialized view in the Objects tab and select Create 

Open Materialized View Shortcut from the pop-up menu. This option is used to provide a convenient way for you to 

open your materialized view directly without activating the Navicat main window. 

To refresh a materialized view, right-click it in the Objects tab and select Refresh Materialized View from the pop-up 

menu. 

Materialized View Designer 

Materialized View Designer is the basic Navicat tool for working with materialized views. You can edit the view 

definition as SQL statement (SELECT statement it implements) in the Definition tab. To customize the view of the 

editor and find out more features for SQL editing, see Query Editor for details. If you want to load SQL statement from a 

SQL file to the editor, you can choose File -> Import SQL. 

Button Description 

 Preview Preview the data of the materialized view. 

 Explain Show the Query Plan of the materialized view. 

 View Builder Build the materialized view visually. It allows you to create and edit materialized 

views without knowledge of SQL. See Query Builder for details. 

 Beautify SQL Format the codes with the Beautify SQL settings in Editor. 

Hint: You can choose to show the preview results below the editor or in a new tab by choosing View -> Result -> 

Show Below Editor or Show in New Page. 

Materialized View Viewer 

When you open a materialized view, Materialized View Viewer displays data as a grid. Data can be displayed in two 

modes: Grid View and Form View. See Data Editor for details. 

Procedures / Functions 

Procedures and functions are schema objects that consist a set of SQL statements and stored in the server. In the 

main window, click  Function to open the function object list. 

Function Wizard 

Click  New Function from the object toolbar. Function Wizard will pop up and it allows you to create a 

procedure/function easily. 

1. Specify the Name of the routine and select the type of the routine: Procedure or Function. 
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2. Define the parameters. Set the Name, Type, Mode and Default Value under the corresponding columns. 

3. If you create a function, select the Return Type from the list. 

Hint: Once uncheck the Show wizard next time option, you can go to Options to enable it. 

Function Designer 

Function Designer is the basic Navicat tool for working with procedures/functions. You can enter a valid SQL 

statement in the Definition tab. To customize the view of the editor and find out more features for SQL editing, see 

Query Editor for details. 

The Code Outline pane displays information about the procedure/function including parameters, code body, etc. If the 

Code Outline pane is hidden, choose View -> Code Outline. 

Note: Available only in Navicat Premium, Enterprise and Standard Edition. 

Button Description 

 

Refresh the code outline. 

 

Show the detail view of the code outline. 

 

Turn mouse over highlight on or off. 

 

Expand the selected item. 

 

Collapse the selected item. 

 

Toggle sorting by position. 

Results 

To execute the procedure/function, click  Execute on the toolbar. If the SQL statement is correct, the statement will 

be executed and, if the statement is supposed to return data, the DBMS Output tab opens with the data returned. If an 

error occurs while executing the procedure/function, execution stops, the appropriate error message is displayed. If the 

procedure/function requires input parameters, the Input Parameter dialog will pop up. Check the Raw Mode option to 

pass the inputted values to the procedure/function without quotation marks. 

Note: Navicat supports to return 20 result sets. 

Debug (Available only in Navicat Premium, Enterprise and Standard Edition) 

You can add/remove breakpoints for debugging by clicking  in the grey area beside each statement. 

Before debugging, click  Save As Debug to save and compile the procedure/function. Then, click  Debug on 

the toolbar to launch the Oracle Debugger. Enter the input parameters if necessary. 

Packages 

Packages are encapsulated collections of related procedures, stored functions, and other program objects stored 

together in the database. A package consists of two parts: a specification and a body. In the main window, click  

Others -> Package to open the package object list. 
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Package Designer & Package Body Designer 

Package Designer and Package Body Designer are the basic Navicat tools for working with packages. After saving 

the package in Package Designer, you can edit its package body by clicking  New Package Body or  Design 

Package Body. 

Likewise, you can edit its package specification by clicking  Design Package Specification in Package Body 

Designer. 

You can enter a valid SQL statement in the Definition tab. To customize the view of the editor and find out more 

features for SQL editing, see Query Editor for details. 

The Code Outline pane displays information about the package/package body including function, procedure, 

parameter, code body, etc. If the Code Outline pane is hidden, choose View -> Code Outline. 

Note: Available only in Navicat Premium, Enterprise and Standard Edition. 

Button Description 

 

Refresh the code outline. 

 

Show the detail view of the code outline. 

 

Turn mouse over highlight on or off. 

 

Expand the selected item. 

 

Collapse the selected item. 

 

Toggle sorting by position. 

Results 

To execute the package, click  Execute on the toolbar. If the SQL statement is correct, the statement will be 

executed and, if the statement is supposed to return data, the DBMS Output tab opens with the data returned. If an 

error occurs while executing the package, execution stops, the appropriate error message is displayed. If the package 

requires input parameters, the Input Parameter dialog will pop up. 

Debug (Available only in Navicat Premium, Enterprise and Standard Edition) 

You can add/remove breakpoints for debugging by clicking  in the grey area beside each statement. 

Before debugging, click  Save As Debug to save and compile the package. Then, click  Debug on the toolbar 

to launch the Oracle Debugger. Enter the input parameters if necessary. 

Recycle Bin 

Recycle bin contains dropped tables and any associated objects such as indexes, constraints, nested tables. In the 

main window, click  Others -> Recycle Bin to open the recycle bin object list. 

Restore a table 

1. Select a table in the Objects tab. 
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2. Click  Flashback Table. 

Remove an object 

1. Select an object for purging in the Objects tab. 

2. Click  Purge Object. 

3. Confirm deleting in the dialog window. 

Remove all objects 

1. Right-click anywhere in the Objects tab and select Purge Recycle Bin from the pop-up menu. 

2. Confirm deleting in the dialog window. 

Remove all objects of any users 

1. Log in a user with SYSDBA privilege. 

2. Right-click anywhere in the Objects tab and select Purge DBA Recycle Bin from the pop-up menu. 

3. Confirm deleting in the dialog window. 

Other Objects 

Navicat also allows you to manage other Oracle objects: Database Link, Index, Java, Materialized View Log, Sequence, 

Synonym, Trigger, Type, XML Schema, Directory, Public Database Link, Public Synonym and Tablespace. In the main 

window, click  Others and select an object to open the object list. 

Maintain Objects 

Navicat provides a complete solution for maintaining Oracle objects. 

1. In the main window, select objects in the Navigation pane or the Objects tab. 

2. Right-click the selected objects. 

3. Choose Maintain, and then choose a maintain option from the pop-up menu. 

4. Results show in a pop-up window. 

Table 

Option Description 

Enable Table Lock Allow DDL operations on the table. 

Disable Table Lock Prevent DDL operations on the table. 

Enable Row Movement Allow the database to move a row, thus changing the rowid. 

Disable Row Movement Prevent the database from moving a row, thus preventing a change of 
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rowid. 

Shrink Space Shrink space in the table. 

Move Relocate data of the table. 

Collect Statistics Analyze the contents of the table. 

Validate Structure Verify the integrity of the structure of the table. 

View 

Option Description 

Compile Recompile the view specification or body. 

Procedure / Function 

Option Description 

Compile Recompile the specification or body. 

Compile for Debug Recompile the specification or body. Instruct the PL/SQL compiler to 

generate and store the code for use by the debugger. 

Index 

Option Description 

Rebuild Re-create the index or one of its partitions or subpartitions. 

Make Unusable Make the index unusable. 

Coalesce Merge the contents of index blocks where possible to free blocks for 

reuse. 

Compute Statistics Compute the statistics of the index. 

Monitoring Usage Begin monitoring the index. 

No Monitoring Usage Terminate monitoring the index. 

Java 

Option Description 

Compile or Resolve Resolve the primary Java class schema object. 

Set AuthID Current User Set the invoker rights to AUTHID CURRENT_USER. 

Set AuthID Definer Set the invoker rights to AUTHID DEFINER. 

Materialized View 

Option Description 

Enable Row Movement Allow the database to move a row, thus changing the rowid. 

Disable Row Movement Prevent the database from moving a row, thus preventing a change of 

rowid. 

Shrink Compact the materialized view segment. 

Compile Revalidate the materialized view. 

Force Refresh Refresh the materialized view. 

Materialized View Log 
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Option Description 

Enable Row Movement Allow the database to move a row, thus changing the rowid. 

Disable Row Movement Prevent the database from moving a row, thus preventing a change of 

rowid. 

Shrink Space Compact the materialized view log segments. 

Package 

Option Description 

Compile Recompile the package specification and body. 

Compile for Debug Recompile the package specification and body. Instruct the PL/SQL 

compiler to generate and store the code for use by the debugger. 

Trigger 

Option Description 

Enable Enable the trigger. 

Disable Disable the trigger. 

Compile Recompile the trigger. 

Compile for Debug Recompile the trigger. Instruct the PL/SQL compiler to generate and store 

the code for use by the debugger. 

Type 

Option Description 

Compile Recompile the type specification and body. 

Compile for Debug Recompile the type specification and body. Instruct the PL/SQL compiler to 

generate and store the code for use by the debugger. 

XML Schema 

Option Description 

Compile Recompile the already registered XML schema. 

Purge Removes the XML schema completely from Oracle XML DB. 

Tablespace 

Option Description 

Read Only Place the tablespace in transition read-only mode. 

Read Write Allow write operations on a previously read-only tablespace. 

Online Take the tablespace online. 

Offline Take the tablespace offline. 

Coalesce Combine all contiguous free extents into larger contiguous extents for 

each datafile in the tablespace. 

Shrink Space Reduce the amount of space the tablespace is taking. 
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PostgreSQL 

Databases & Schemas 

To start working with the server objects, you should create and open a connection. If the server is empty, you need to 

create a new database and/or a new schema. 

Create a new database 

1. In the Navigation pane, right-click a connection and select New Database. 

2. Enter the database properties in the pop-up window. 

Edit an existing database 

1. In the Navigation pane, right-click a database and select Edit Database. 

2. Edit the database properties in the pop-up window. 

Create a new schema 

1. In the Navigation pane, right-click a database and select New Schema. 

2. Enter the schema properties in the pop-up window. 

Edit an existing schema 

1. In the Navigation pane, right-click a schema and select Edit Schema. 

2. Edit the schema properties in the pop-up window. 

Tables 

Tables are database objects that contain all data in a database. A table is a set of rows and columns, and their 

intersections are fields. In the main window, click  Table to open the table object list. 

You can create Normal / Foreign / Partitioned tables. Click the down arrow next to  New Table from the object 

toolbar and choose the table type. 

There are two ways to open a table with graphical fields, right-click a table and select: 

Option Description 

Open Table Navicat loads all your BLOB fields (images) while opening the table. 

Open Table (Quick) Faster performance for opening the graphical table, as BLOB fields (images) will 

not be loaded until you click on the cell. (It is invisible by default until you hold 

down the SHIFT key when right-clicking the table.) 
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You can create a table shortcut by right-clicking a table in the Objects tab and select Create Open Table Shortcut 

from the pop-up menu. This option is used to provide a convenient way for you to open your table for entering data 

directly without activating the Navicat main window. 

To empty a table, right-click the selected table and select Empty Table from the pop-up menu. This option is only 

applied when you wish to clear all the existing records without resetting the auto-increment value. To reset the 

auto-increment value while emptying your table, use Truncate Table. 

Table Designer 

Table Designer is the basic Navicat tool for working with tables. It allows you to create, edit and drop table's fields, 

indexes, foreign keys, and much more. 

In the Fields tab, you can search a field name by choosing Edit -> Find or pressing CTRL+F. When creating a new 

table, you are allowed to insert fields or rearrange the order of the fields. 

Note: The tabs and options in the designer depend on the server version and the table type. 

Table Viewer 

When you open a table, Table Viewer displays data as a grid. Data can be displayed in two modes: Grid View and 

Form View. See Data Editor for details. 

Views 

A view allows users to access a set of tables as if it is a single table. You can use views to restrict access to rows. In the 

main window, click  View to open the view object list. 

You can create a view shortcut by right-clicking a view in the Objects tab and select Create Open View Shortcut from 

the pop-up menu. This option is used to provide a convenient way for you to open your view directly without activating 

the Navicat main window. 

View Designer 

View Designer is the basic Navicat tool for working with views. You can edit the view definition as SQL statement 

(SELECT statement it implements) in the Definition tab. To customize the view of the editor and find out more features 

for SQL editing, see Query Editor for details. If you want to load SQL statement from a SQL file to the editor, you can 

choose File -> Import SQL. 

Button Description 

 Preview Preview the data of the view. 

 Explain Show the Query Plan of the view. 

 View Builder Build the view visually. It allows you to create and edit views without knowledge of 

SQL. See Query Builder for details. 

 Beautify SQL Format the codes with the Beautify SQL settings in Editor. 
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Hint: You can choose to show the preview results below the editor or in a new tab by choosing View -> Result -> 

Show Below Editor or Show in New Page. 

View Viewer 

When you open a view, View Viewer displays data as a grid. Data can be displayed in two modes: Grid View and Form 

View. See Data Editor for details. 

Materialized Views 

Materialized Views are schema objects that used to summarize, compute, replicate, and distribute data. In the main 

window, click  Materialized View to open the materialized view object list. 

You can create a materialized view shortcut by right-clicking a materialized view in the Objects tab and select Create 

Open Materialized View Shortcut from the pop-up menu. This option is used to provide a convenient way for you to 

open your materialized view directly without activating the Navicat main window. 

To refresh and completely replace the contents of a materialized view, right-click it in the Objects tab and select 

Refresh Materialized View With -> Data or No Data from the pop-up menu. 

Materialized View Designer 

Materialized View Designer is the basic Navicat tool for working with materialized views. You can edit the view 

definition as SQL statement (SELECT statement it implements) in the Definition tab. To customize the view of the 

editor and find out more features for SQL editing, see Query Editor for details. If you want to load SQL statement from a 

SQL file to the editor, you can choose File -> Import SQL. 

Button Description 

 Preview Preview the data of the materialized view. 

 Explain Show the Query Plan of the materialized view. 

 View Builder Build the materialized view visually. It allows you to create and edit materialized 

views without knowledge of SQL. See Query Builder for details. 

 Beautify SQL Format the codes with the Beautify SQL settings in Editor. 

Hint: You can choose to show the preview results below the editor or in a new tab by choosing View -> Result -> 

Show Below Editor or Show in New Page. 

Materialized View Viewer 

When you open a materialized view, Materialized View Viewer displays data as a grid. Data can be displayed in two 

modes: Grid View and Form View. See Data Editor for details. 

Procedures / Functions 

Procedures and functions are schema objects that consist a set of SQL statements and stored in the server. 

Procedures are supported in PostgreSQL 11. In the main window, click  Function to open the function object list. 
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Function Wizard 

Click  New Function from the object toolbar. Function Wizard will pop up and it allows you to create a function 

easily. 

1. Select the type of the routine: Procedure or Function. 

2. Define the parameters. Set the Mode, Type Schema, Type, Name and Default Value under the 

corresponding columns. 

3. If you create a function, select the Schema and Return Type from the list. 

Hint: Once uncheck the Show wizard next time option, you can go to Options to enable it. 

Function Designer 

Function Designer is the basic Navicat tool for working with procedures/functions. You can enter a valid SQL 

statement in the Definition tab. This can be a simple statement such as SELECT or INSERT, or it can be a compound 

statement written using BEGIN and END. To customize the view of the editor and find out more features for SQL 

editing, see Query Editor for details. 

Results 

To execute the procedure/function, click  Execute on the toolbar. If the SQL statement is correct, the statement will 

be executed and, if the statement is supposed to return data, the Result tab opens with the data returned. If an error 

occurs while executing the procedure/function, execution stops, the appropriate error message is displayed. If the 

procedure/function requires input parameters, the Input Parameter dialog will pop up. Check the Raw Mode option to 

pass the inputted values to the procedure/function without quotation marks. 

Note: Navicat supports to return 20 result sets. 

Debug (Available only in Navicat Premium, Enterprise and Standard Edition) 

Before debugging PL/pgSQL procedures/functions, you need to install the pldbgapi extension. You can right-click 

anywhere in the function object list and select Install pldbgapi Extension. 

Note: This option is only available for PostgreSQL 9.1 or later. If your server is PostgreSQL 8.3 to 9.0, you need to 

enable the debugger plugin manually in the server. 

Then, open a PL/pgSQL procedure/function. You can add/remove breakpoints for debugging by clicking  in the 

grey area beside each statement. 

Click  Debug on the toolbar to launch the PostgreSQL Debugger. 

Types 

Types register new data types for use in the current database. In the main window, click  Others -> Type to open 

the type object list. 
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You can create Base / Composite / Enum / Range types. Click the down arrow next to  New Type from the object 

toolbar and choose the type. 

Type Designer 

Type Designer is the basic Navicat tool for working with types. It allows you to create or edit a type. 

Note: The tabs and options in the designer depend on the server version and the type you are chosen. 

Foreign Servers 

A foreign server typically encapsulates connection information that a foreign-data wrapper uses to access an external 

data resource. In the main window, click  Others -> Foreign Server to open the foreign server object list. 

To install the postgres_fdw extension for accessing data stored in external PostgreSQL servers, you can right-click 

anywhere in the foreign server object list and select Install postgres_fdw Extension. 

Foreign Server Designer 

Foreign Server Designer is the basic Navicat tool for working with foreign servers. It allows you to create or edit a 

foreign server. 

Other Objects 

Navicat also allows you to manage other PostgreSQL objects: Aggregate, Conversion, Domain, Index, Operator, 

Operator Class, Sequence, Trigger, Tablespace, Cast and Language. In the main window, click  Others and select 

an object to open the object list. 

Maintain Objects 

Navicat provides a complete solution for maintaining PostgreSQL objects. 

1. In the main window, select objects in the Navigation pane or the Objects tab. 

2. Right-click the selected objects. 

3. Choose Maintain, and then choose a maintain option from the pop-up menu. 

4. Results show in a pop-up window. 

Database 

Option Description 

Allow Users can connect to the database. 

Disallow No users can connect to the database. 

Analyze Database Collect statistics about the database. 

Vacuum Database Garbage-collect and optionally analyze the database. 

Reindex Database Recreate all indexes within the database. 
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Table / Materialized View 

Option Description 

Analyze Tables / Analyze 

Materialized Views 

Collect statistics about the contents of the table. 

Vacuum Tables / Vacuum 

Materialized Views 

Garbage-collect and optionally analyze the table. 

Reindex Tables / Reindex 

Materialized Views 

Recreate all indexes of the table. 

 

Manage Extensions 

PostgreSQL has various extensions, supplying extra functions, operators, or types to extend the functionality of a 

database. You can install the extensions that are supported by your PostgreSQL server. 

Install an extension 

1. In the Navigation pane, right-click a database and select Manage Extensions. 

2. All available extensions are listed on the left. Move an available extension to the Installed list. 

3. Click OK. 

Remove an extension 

1. In the Navigation pane, right-click a database and select Manage Extensions. 

2. Move an installed extension to the Available list. 

3. Click OK. 

SQL Server 

Databases & Schemas 

To start working with the server objects, you should create and open a connection. If the server is empty, you need to 

create a new database and/or a new schema. 

Create a new database 

1. In the Navigation pane, right-click a connection and select New Database. 

2. Enter the database properties in the pop-up window. 

Edit an existing database 

1. In the Navigation pane, right-click a database and select Edit Database. 
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2. Edit the database properties in the pop-up window. 

Create a new schema 

1. In the Navigation pane, right-click a database and select New Schema. 

2. Enter the schema properties in the pop-up window. 

Edit an existing schema 

1. In the Navigation pane, right-click a schema and select Edit Schema. 

2. Edit the schema properties in the pop-up window. 

Tables 

Tables are database objects that contain all data in a database. A table is a set of rows and columns, and their 

intersections are fields. In the main window, click  Table to open the table object list. 

There are two ways to open a table with graphical fields, right-click a table and select: 

Option Description 

Open Table Navicat loads all your BLOB fields (images) while opening the table. 

Open Table (Quick) Faster performance for opening the graphical table, as BLOB fields (images) will 

not be loaded until you click on the cell. (It is invisible by default until you hold 

down the SHIFT key when right-clicking the table.) 

You can create a table shortcut by right-clicking a table in the Objects tab and select Create Open Table Shortcut 

from the pop-up menu. This option is used to provide a convenient way for you to open your table for entering data 

directly without activating the Navicat main window. 

To empty a table, right-click the selected table and select Empty Table from the pop-up menu. This option is only 

applied when you wish to clear all the existing records without resetting the auto-increment value. To reset the 

auto-increment value while emptying your table, use Truncate Table. 

Table Designer 

Table Designer is the basic Navicat tool for working with tables. It allows you to create, edit and drop table's fields, 

indexes, foreign keys, and much more. 

In the Fields tab, you can search a field name by choosing Edit -> Find or pressing CTRL+F. When creating a new 

table, you are allowed to insert fields or rearrange the order of the fields. 

Note: The tabs and options in the designer depend on the server version. 

Table Viewer 

When you open a table, Table Viewer displays data as a grid. Data can be displayed in two modes: Grid View and 

Form View. See Data Editor for details. 
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Views 

A view allows users to access a set of tables as if it is a single table. You can use views to restrict access to rows. In the 

main window, click  View to open the view object list. 

You can create a view shortcut by right-clicking a view in the Objects tab and select Create Open View Shortcut from 

the pop-up menu. This option is used to provide a convenient way for you to open your view directly without activating 

the Navicat main window. 

View Designer 

View Designer is the basic Navicat tool for working with views. You can edit the view definition as SQL statement 

(SELECT statement it implements) in the Definition tab. To customize the view of the editor and find out more features 

for SQL editing, see Query Editor for details. If you want to load SQL statement from a SQL file to the editor, you can 

choose File -> Import SQL. 

Button Description 

 Preview Preview the data of the view. 

 Explain Show the Query Plan of the view. 

 View Builder Build the view visually. It allows you to create and edit views without knowledge 

of SQL. See Query Builder for details. 

 Beautify SQL Format the codes with the Beautify SQL settings in Editor. 

Hint: You can choose to show the preview results below the editor or in a new tab by choosing View -> Result -> 

Show Below Editor or Show in New Page. 

View Viewer 

When you open a view, View Viewer displays data as a grid. Data can be displayed in two modes: Grid View and Form 

View. See Data Editor for details. 

Procedures / Functions 

Procedures and functions are schema objects that consist a set of SQL statements and stored in the server. In the 

main window, click  Function to open the function object list. 

Function Wizard 

Click  New Function from the object toolbar. Function Wizard will pop up and it allows you to create a 

procedure/function easily. 

1. Specify the Name of the routine and select the type of the routine: Procedure or Function. 

2. Define the parameters. Set the Name, Type Schema, Type, Default Value, Output and/or Read Only under 

the corresponding columns. 

3. If you create a function, select the Function Type from the list. Then, choose the Schema and the Return 

Type if necessary. 
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4. Set the advanced options. 

Hint: Once uncheck the Show wizard next time option, you can go to Options to enable it. 

Function Designer 

Function Designer is the basic Navicat tool for working with procedures/functions. You can enter a valid SQL 

statement in the Definition tab. To customize the view of the editor and find out more features for SQL editing, see 

Query Editor for details. 

The Code Outline pane displays information about the procedure/function including parameters, code body, etc. If the 

Code Outline pane is hidden, choose View -> Code Outline. 

Note: Available only in Navicat Premium, Enterprise and Standard Edition. 

Button Description 

 

Refresh the code outline. 

 

Show the detail view of the code outline. 

 

Turn mouse over highlight on or off. 

 

Expand the selected item. 

 

Collapse the selected item. 

 

Toggle sorting by position. 

Results 

To execute the procedure/function, click  Execute on the toolbar. If the SQL statement is correct, the statement will 

be executed and, if the statement is supposed to return data, the Result tab opens with the data returned. If an error 

occurs while executing the procedure/function, execution stops, the appropriate error message is displayed. If the 

procedure/function requires input parameters, the Input Parameter dialog will pop up. Check the Raw Mode option to 

pass the inputted values to the procedure/function without quotation marks. 

Note: Navicat supports to return 20 result sets. 

Other Objects 

Navicat also allows you to manage other SQL Server objects: Index, Synonym, Trigger, Backup Device, Linked Server, 

Server Trigger, Assembly, Database Trigger, Partition Function and Partition Scheme. In the main window, click  

Others and select an object to open the object list. 

Maintain Objects 

Navicat provides a complete solution for maintaining SQL Server objects. 

1. In the main window, select objects in the Navigation pane or the Objects tab. 

2. Right-click the selected objects. 

3. Choose Maintain, and then choose a maintain option from the pop-up menu. 
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4. Results show in a pop-up window. 

Database 

Option Description 

Read Write Set the database to Read and Write mode. 

Read Only Set the database to Read Only mode. 

Online Bring the database online. 

Offline Take the database offline. 

Emergency Set the database to the Emergency state. 

Multi User Set the database to Multi User mode. 

Single User Set the database to Single User mode. 

Restricted User Set the database to Restricted User mode. 

Assembly 

Option Description 

Visible Set the assembly to visible. 

Invisible Set the assembly to not visible. 

Index 

Option Description 

Rebuild Rebuild and enable the index. 

Reorganize Reorganize the enabled index. 

Disable Disable the index. 

Trigger / Database Trigger / Server Trigger 

Option Description 

Enable Enable the trigger. 

Disable Disable the trigger. 

 

SQLite 

Databases 

To start working with the server objects, you should create and open a connection. The database file set in the General 

tab of the Connection window is named as the main database. 

Attach a database file 

1. In the Navigation pane, right-click a connection and select Attach Database. 

2. Enter the database properties in the pop-up window. 

Detach a database 
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1. In the Navigation pane, right-click an attached database and select Detach Database. 

Encrypt main database 

1. In the Navigation pane, right-click the main database and select Encrypt Database. 

2. Enter the password in the pop-up window. 

Decrypt main database 

1. In the Navigation pane, right-click the main database and select Decrypt Database. 

2. Confirm decrypting in the dialog window. 

View the sqlite_master table 

1. In the Navigation pane, right-click a database and select View Master Table. 

2. The sqlite_master table opens in Table Viewer. 

Tables 

Tables are database objects that contain all data in a database. A table is a set of rows and columns, and their 

intersections are fields. In the main window, click  Table to open the table object list. 

You can create a table shortcut by right-clicking a table in the Objects tab and select Create Open Table Shortcut 

from the pop-up menu. This option is used to provide a convenient way for you to open your table for entering data 

directly without activating the Navicat main window. 

To empty a table, right-click the selected table and select Empty Table from the pop-up menu. 

Table Designer 

Table Designer is the basic Navicat tool for working with tables. It allows you to create, edit and drop table's fields, 

indexes, foreign keys, and much more. 

In the Fields tab, you can search a field name by choosing Edit -> Find or pressing CTRL+F. 

Note: The tabs and options in the designer depend on the server version. 

Table Viewer 

When you open a table, Table Viewer displays data as a grid. Data can be displayed in two modes: Grid View and 

Form View. See Data Editor for details. 

Views 

A view allows users to access a set of tables as if it is a single table. You can use views to restrict access to rows. In the 

main window, click  View to open the view object list. 
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You can create a view shortcut by right-clicking a view in the Objects tab and select Create Open View Shortcut from 

the pop-up menu. This option is used to provide a convenient way for you to open your view directly without activating 

the Navicat main window. 

View Designer 

View Designer is the basic Navicat tool for working with views. You can edit the view definition as SQL statement 

(SELECT statement it implements) in the Definition tab. To customize the view of the editor and find out more features 

for SQL editing, see Query Editor for details. If you want to load SQL statement from a SQL file to the editor, you can 

choose File -> Import SQL. 

Button Description 

 Preview Preview the data of the view. 

 Explain Show the Query Plan of the view. 

 View Builder Build the view visually. It allows you to create and edit views without 

knowledge of SQL. See Query Builder for details. 

 Beautify SQL Format the codes with the Beautify SQL settings in Editor. 

Hint: You can choose to show the preview results below the editor or in a new tab by choosing View -> Result -> 

Show Below Editor or Show in New Page. 

View Viewer 

When you open a view, View Viewer displays data as a grid. Data can be displayed in two modes: Grid View and Form 

View. See Data Editor for details. 

Other Objects 

Navicat also allows you to manage other SQLite objects: Index and Trigger. In the main window, click the 

corresponding button from the main toolbar to open the object list. 

Maintain Objects 

Navicat provides a complete solution for maintaining SQLite objects. 

1. In the main window, select objects in the Navigation pane or the Objects tab. 

2. Right-click the selected objects. 

3. Choose Maintain, and then choose a maintain option from the pop-up menu. 

4. Results show in a pop-up window. 

Database 

Option Description 

Analyze Database Collect statistics about the database. 

Vacuum Database Rebuild the database file. It only works on the main database. 
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Reindex Database Delete and recreate all indexes within the database. 

Table 

Option Description 

Analyze Tables Collect statistics about the contents of the table. 

Reindex Tables Delete and recreate all indexes of the table. 

Get Rows Count Count the number of rows in the table. 

Index 

Option Description 

Reindex Delete and recreate the index. 

 

MongoDB 

Databases 

To start working with the server objects, you should create and open a connection. If the server is empty, you need to 

create a new database. 

Create a new database 

1. In the Navigation pane, right-click a connection and select New Database. 

2. Enter the database properties in the pop-up window. 

Collections 

Collections are analogous to relational database tables for storing documents. In the main window, click  

Collection to open the collection object list. 

You can create Normal / Time Series collections. Click the down arrow next to  New Collection from the object 

toolbar and choose the collection type. 

You can create a collection shortcut by right-clicking a collection in the Objects tab and select Create Open Collection 

Shortcut from the pop-up menu. This option is used to provide a convenient way for you to open your collection for 

entering data directly without activating the Navicat main window. 

To empty a collection, right-click the selected collection and select Empty Collection from the pop-up menu. 

Collection Designer 

Collection Designer is the basic Navicat tool for working with collections. It allows you to set the collection properties, 

indexes, validation, storage engine, and much more. 

Note: The tabs and options in the designer depend on the server version. 
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Collection Viewer 

When you open a collection, Collection Viewer displays data as a grid. Data can be displayed in three modes: Grid 

View, Tree View and JSON View. See Data Editor for details. 

Views 

A view is the result of the applying the specified aggregation pipeline to the source collection or view. In the main 

window, click  View to open the view object list. 

You can create a view shortcut by right-clicking a view in the Objects tab and select Create Open View Shortcut from 

the pop-up menu. This option is used to provide a convenient way for you to open your view directly without activating 

the Navicat main window. 

View Designer 

View Designer is the basic Navicat tool for working with views. 

Button Description 

 Preview Preview the data of the view. 

 Explain Show the Query Plan of the view. 

See Pipeline Builder for details. 

View Viewer 

When you open a view, View Viewer displays data as a grid. Data can be displayed in three modes: Grid View, Tree 

View and JSON View. See Data Editor for details. 

Functions 

You can store JavaScript functions for reuse. In the main window, click  Function to open the function object list. 

Function Designer 

Function Designer is the basic Navicat tool for working with functions. You can enter the function definition in the 

Definition tab. To customize the view of the editor and find out more features for script editing, see Query Editor for 

details. 

Results 

To execute the function, click  Execute on the toolbar. If the script is correct, the Execute Function dialog will pop 

up. Enter input parameters if necessary and click OK. If the function is supposed to return data, the Result tab opens 

with the data returned. If an error occurs while executing the function, execution stops, the appropriate error message 

is displayed. 
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Indexes 

Navicat allows you to manage MongoDB indexes. In the main window, click  Index to open the index object list. 

MapReduce 

Map-Reduce is a data processing paradigm for condensing large volumes of data into useful aggregated results. In the 

main window, click  MapReduce to open the map-reduce object list. 

You can set automation tasks to schedule Map-Reduce jobs. 

Map-Reduce Designer 

Map-Reduce Designer is the basic Navicat tool for working with Map-Reduce jobs. 

Button Description 

 Run Run the Map-Reduce job. 

 Stop Stop the running Map-Reduce job. 

 Preview Preview the documents by applying Input, Mapper, Reducer or Finalizer. 

 Import Function Import an existing function to Mapper, Reducer or Finalizer. 

Results 

To run the Map-Reduce job, click  Run on the toolbar. If you set to output the results inline, the Result tab opens 

with the documents returned, the number of documents and the timing information. If you set to write the results to a 

collection, the results return a document to the specified output collection. 

GridFS 

GridFS is a specification for storing and retrieving files. In the main window, click  GridFS to open the GridFS 

object list. 

You can create multiple buckets in a database for storing files. Click  New Bucket and enter the name of the 

bucket. 

To open the selected bucket, click  Open Bucket. 

Bucket Viewer 

Bucket Viewer is the basic Navicat tool for working with GridFS buckets. You can upload, download and view GridFS 

files that are inside the bucket. 

Button Description 

 Open File Open the selected GridFS file. 

 Delete File Delete the selected GridFS files. 

 Upload File Upload files into the bucket. 

 Download File Download the selected GridFS files. 
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 Filter Filter the GridFS file table by creating and applying filter criteria. 

 Preview Preview an image file that is less than 1 MB. 

 Progress Check the status of file uploads and downloads. 

File Table 

The File table displays all the files that are uploaded to the bucket. 

You can edit the GridFS file's name, content type, alias or metadata. In the table, right-click the name of the file and 

select Modify File Name, Modify Content Type, Modify Alias or Modify Metadata. Then, enter the information in the 

pop-up window. 

Filter Pane 

If you have many files uploaded to the bucket, you can find matching files using a filter. To toggle the Filter pane, click 

 Filter. 

Progress Pane 

The Progress pane displays the status of all file uploads and downloads in the current window. Parallel downloads and 

uploads are supported. If the window is closed, the list will be cleared. 

When a file is starting to upload or download, click the corresponding buttons next to the progress bar to pause, resume 

and stop the process. After the process is finished, you can click  to open the folder that contains the file, or hover 

over an item and click  to remove it from the list. 

If you want to pause, resume and stop all items that are in progress, right-click the list and select the appropriate 

options. 

To clear the finished items, right-click the list and select Clear All Finished. 

Maintain Objects 

Navicat provides a complete solution for maintaining MongoDB objects. 

1. In the main window, select objects in the Navigation pane or the Objects tab. 

2. Right-click the selected objects. 

3. Choose Maintain, and then choose a maintain option from the pop-up menu. 

4. Results show in a pop-up window. 

Database 

Option Description 

Repair Database Rebuild the database and indexes by discarding invalid or corrupt data. 
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Collection 

Option Description 

Compact Collection Rewrite and defragment all data and indexes in the collection. 

Validate Collection Check the structures within a namespace for correctness by scanning the 

collection’s data and indexes. 

Reindex Collection Drop and recreate all indexes on the collection. 

 

Redis 

Databases 

Redis supports 16 databases by default and databases are numbered from 0 to 15. Navicat lists all databases and the 

number of keys in each database when you connect to your Redis server. Simply double-click a database to open it. 

Show / Hide empty databases 

1. In the Navigation pane, right-click the connection and select Show Empty Databases. 

Hint: You can configure Redis to support more databases by adjusting databases parameter value in the Redis 

configuration file (redis.conf). After setting, restart Redis to complete the configuration. 

Data 

All key-value data in a database is in a data view named All Data. 

When you open All Data, the viewer displays data as a grid with key names, key types, key values, size and 

Time-to-Live (TTL). See Data Editor for details. 

Snowflake 

Databases & Schemas 

To start working with the server objects, you should create and open a connection. If the server is empty, you need to 

create a new database and/or a new schema. 

Create a new database 

1. In the Navigation pane, right-click a connection and select New Database. 

2. Enter the database properties in the pop-up window. 

Edit an existing database 

1. In the Navigation pane, right-click a database and select Edit Database. 

2. Edit the database properties in the pop-up window. 
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Create a new schema 

1. In the Navigation pane, right-click a database and select New Schema. 

2. Enter the schema properties in the pop-up window. 

Edit an existing schema 

1. In the Navigation pane, right-click a schema and select Edit Schema. 

2. Edit the schema properties in the pop-up window. 

Tables 

Tables are database objects that contain all data in a database. A table is a set of rows and columns, and their 

intersections are fields. In the main window, click  Table to open the table object list. 

You can create Standard / Hybrid / Dynamic tables. Click the down arrow next to  New Table from the object 

toolbar and choose the table type. 

There are two ways to open a table with graphical fields, right-click a table and select: 

Option Description 

Open Table Navicat loads all your BLOB fields (images) while opening the table. 

Open Table (Quick) Faster performance for opening the graphical table, as BLOB fields (images) 

will not be loaded until you click on the cell. (It is invisible by default until you 

hold down the SHIFT key when right-clicking the table.) 

You can create a table shortcut by right-clicking a table in the Objects tab and select Create Open Table Shortcut 

from the pop-up menu. This option is used to provide a convenient way for you to open your table for entering data 

directly without activating the Navicat main window. 

To empty a table, right-click the selected table and select Empty Table from the pop-up menu. This option is only 

applied when you wish to clear all the existing records without resetting the auto-increment value. To reset the 

auto-increment value while emptying your table, use Truncate Table. 

Table Designer 

Table Designer is the basic Navicat tool for working with tables. It allows you to create, edit and drop table's fields, 

indexes, foreign keys, and much more. 

In the Fields tab, you can search a field name by choosing Edit -> Find or pressing CTRL+F. When creating a new 

table, you are allowed to insert fields or rearrange the order of the fields. 

Note: The tabs and options in the designer depend on the server version and the table type. 

Table Viewer 
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When you open a table, Table Viewer displays data as a grid. Data can be displayed in two modes: Grid View and 

Form View. See Data Editor for details. 

Views 

A view allows users to access a set of tables as if it is a single table. You can use views to restrict access to rows. In the 

main window, click  View to open the view object list. 

You can create a view shortcut by right-clicking a view in the Objects tab and select Create Open View Shortcut from 

the pop-up menu. This option is used to provide a convenient way for you to open your view directly without activating 

the Navicat main window. 

View Designer 

View Designer is the basic Navicat tool for working with views. You can edit the view definition as SQL statement 

(SELECT statement it implements) in the Definition tab. To customize the view of the editor and find out more features 

for SQL editing, see Query Editor for details. If you want to load SQL statement from a SQL file to the editor, you can 

choose File -> Import SQL. 

Button Description 

 Preview Preview the data of the view. 

 Explain Show the Query Plan of the view. 

 View Builder Build the view visually. It allows you to create and edit views without 

knowledge of SQL. See Query Builder for details. 

 Beautify SQL Format the codes with the Beautify SQL settings in Editor. 

Hint: You can choose to show the preview results below the editor or in a new tab by choosing View -> Result -> 

Show Below Editor or Show in New Page. 

View Viewer 

When you open a view, View Viewer displays data as a grid. Data can be displayed in two modes: Grid View and Form 

View. See Data Editor for details. 

Materialized Views 

Materialized Views are schema objects that used to summarize, compute, replicate, and distribute data. In the main 

window, click  Materialized View to open the materialized view object list. 

You can create a materialized view shortcut by right-clicking a materialized view in the Objects tab and select Create 

Open Materialized View Shortcut from the pop-up menu. This option is used to provide a convenient way for you to 

open your materialized view directly without activating the Navicat main window. 

Materialized View Designer 

Materialized View Designer is the basic Navicat tool for working with materialized views. You can edit the view 

definition as SQL statement (SELECT statement it implements) in the Definition tab. To customize the view of the 
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editor and find out more features for SQL editing, see Query Editor for details. If you want to load SQL statement from a 

SQL file to the editor, you can choose File -> Import SQL. 

Button Description 

 Preview Preview the data of the materialized view. 

 Explain Show the Query Plan of the materialized view. 

 View Builder Build the materialized view visually. It allows you to create and edit 

materialized views without knowledge of SQL. See Query Builder for details. 

 Beautify SQL Format the codes with the Beautify SQL settings in Editor. 

Hint: You can choose to show the preview results below the editor or in a new tab by choosing View -> Result -> 

Show Below Editor or Show in New Page. 

Materialized View Viewer 

When you open a materialized view, Materialized View Viewer displays data as a grid. Data can be displayed in two 

modes: Grid View and Form View. See Data Editor for details. 

Procedures / Functions 

Procedures and functions are schema objects that consist a set of SQL statements and stored in the server. In the 

main window, click  Function to open the function object list. 

Function Wizard 

Click  New Function from the object toolbar. Function Wizard will pop up and it allows you to create a function 

easily. 

1. Select the type of the routine: Procedure or Function. 

2. Define the parameters. Set the Name and Type under the corresponding columns. 

3. Select the Return Type from the list. 

Hint: Once uncheck the Show wizard next time option, you can go to Options to enable it. 

Function Designer 

Function Designer is the basic Navicat tool for working with procedures/functions. You can enter a valid SQL 

statement in the Definition tab. This can be a simple statement such as SELECT or INSERT, or it can be a compound 

statement written using BEGIN and END. To customize the view of the editor and find out more features for SQL 

editing, see Query Editor for details. 

Results 

To execute the procedure/function, click  Execute on the toolbar. If the SQL statement is correct, the statement will 

be executed and, if the statement is supposed to return data, the Result tab opens with the data returned. If an error 

occurs while executing the procedure/function, execution stops, the appropriate error message is displayed. If the 
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procedure/function requires input parameters, the Input Parameter dialog will pop up. Check the Raw Mode option to 

pass the inputted values to the procedure/function without quotation marks. 

Note: Navicat supports to return 20 result sets. 

Other Objects 

Navicat also allows you to manage other Snowflake objects: Sequence. In the main window, click  Others and 

select an object to open the object list. 

Maintain Objects 

Navicat provides a complete solution for maintaining Snowflake objects. 

1. In the main window, select objects in the Navigation pane or the Objects tab. 

2. Right-click the selected objects. 

3. Choose Maintain, and then choose a maintain option from the pop-up menu. 

4. Results show in a pop-up window. 

Table 

Option Description 

Recluster Enable or disable automatic clustering for the table: Suspend or Resume. 

Dynamic Table Choose the action to perform on the dynamic table: Refresh, Suspend or 

Resume. 

Get Rows Count Count the number of rows in the table. 

Materialized View 

Option Description 

Recluster Enable or disable automatic clustering for the materialized view: Suspend or 

Resume. 

Suspend Suspend the maintenance and use of the materialized view. 

Resume Resume the maintenance and use of the materialized view. 
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Chapter 6 - Data Editor 

About Data Editor 

Navicat includes a Data Editor that allows you to view, update, or delete data. The data editor also includes advanced 

features and editors that can help you understand the data as you manipulate it. You can use common keyboard 

navigation to browse your data. 

RDBMS 

RDBMS Data Editor 

RDBMS Data Editor displays the data as a grid or a form. To switch the view, click  or  at the bottom. 

Note: Form View is available only in Navicat Premium, Enterprise and Standard Edition. 

The toolbar of the data editor provides the following functions for managing data: 

Button Description 

 Table Profile Manage Profile - Manage the saved table profiles and view the profile information. 

Load Profile - Load a table profile. 

Save Profile - Create a profile with the current filter, sort and column settings. 

Save Profile As - Save the settings as a new profile. 

(Available only in Navicat Premium, Enterprise and Standard Edition) 

 Begin Transaction Start a transaction. If Auto begin transaction is enabled in Options, transaction will 

be started automatically when opening the data editor. 

 Commit Make permanent all changes performed in the current transaction. 

 Rollback Undo work done in the current transaction. 

 Cell Editor Activate the cell editors for viewing and editing data. 

 Filter &Sort Filter and sort records by applying filter and sorting criteria for the data grid. 

 Columns Show / Hide columns. 

 Data Profiling Profile the data in the table. 

 Tools 

 Data Generation Generate data for the table. 

 Create BI Workspace Create a new BI workspace with a data source using the table data. 

 Import Import data from files. 

 Export Export data to files. 

 

Use Navigation Bar 

Data Editor provides a convenient way to navigate among the records/pages using the Navigation Bar buttons. 

 

Button Description 
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Add Record - enter a new record. At any point when you are working in the data 

editor, click on this button to get a blank display for a record. 
 

Delete Records - delete an existing record. 
 

Apply Changes - apply the changes. 
 

Discard Changes - remove all edits made to the current record. 
 

Refresh - refresh the data. 
 

Stop - stop when loading enormous data from server. 
 

First Page - move to the first page. 
 

Previous Page - move to the previous page. 
 

Next Page - move to the next page. 
 

Last Page - move to the last page. 
 

First Record - move to the first record. 
 

Previous Record - move one record back (if there is one) from the current 

record. 
 

Next Record - move one record ahead. 
 

Last Record - move to the last record. 
 

Limit Record Setting - set number of records showing on each page. 
 

Grid View - switch to Grid View. 
 

Form View - switch to Form View. 

Use the Limit Record Setting  button to enter to the edit mode. 

Limit records  records per page 

Check this option if you want to limit the number of records showed on each page. Otherwise, all records will be 

displayed in one single page. And, set the value in the edit box. The number representing the number of records 

showed per page. 

Note: This setting mode will take effect on current object only. To adjust the global settings, see Options. 

 

Record a of b in page c 

Display the numbers representing the selected record and page. 

a - the selected record. 

b - number of records in the current page. 

c - the current page. 

Edit Records 

Grid View 



 95 

 

Grid View is a spreadsheet-like view showing records and fields as rows and columns. The navigation bar allows you to 

switch the records quickly, insert or delete records. 

To add a record 

1. Make sure that your cursor is situated in the first blank cell on the table, then enter the desired data. If you are 

adding the new record into an existing table, just simply click on an existing record and click  from the 

navigation bar or press CTRL+N to get a blank display for a record. 

2. Watch the graphics symbol in the record selectors box just to the left of your record. It will change from , which 

indicates that it is the current record, to , which indicates that you are editing this record. 

3. Just simply move to another record to save the record or click  from the navigation bar. 

To edit a record 

1. Select the record that you wish to edit by clicking in the specific field you want to change. 

2. Type in the new data for that field. 

3. Just simply move to another record, the new data will overwrite the previous data or click  from the 

navigation bar.  

Note: Close the table is another way to save the records. 

To edit multiple cells with same data 

1. Select a block of cells in the data grid. 

2. Type in the new data. 

Note: Changes will apply to multiple fields with compatible data type. 

To delete a record 

1. Select the record that you wish to delete. 

2. Just simply right-click and select Delete Record or click  from the navigation bar. 

Form View 

Form View displays a single record at a time from a table. The navigation bar allows you to switch the records quickly, 

insert or delete records. 

To add a record 

1. Click  from the navigation bar or press CTRL+N to get a blank display for a record. 

2. Enter the desired data. 
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3. Click  from the navigation bar to save the record. 

To edit a record 

1. Go to the record that you wish to edit. 

2. Type in the new data for the specific field you want to change. 

3. Click  from the navigation bar. The new data will overwrite the previous data. 

Note: Close the table is another way to save the records. 

To delete a record 

1. Go to the record that you wish to delete. 

2. Just simply right-click and select Delete Record or click  from the navigation bar. 

Edit Records with Special Handling 

To set the cell value to an empty string or NULL, right-click the selected cell and select Set to Empty String or Set to 

NULL. 

To view images in the grid, just simply choose View -> Display -> Show Image In Grid. 

Note: Available only for MySQL, Oracle, PostgreSQL, SQL Server and MariaDB. 

 

Hint: To view/edit images in an ease way, see Image Editor. 

To edit a Date/Time record, just simply click  or press CTRL+ENTER to open the editor for editing. Choose/enter 

the desired data. The editor used in cell is determined by the field type assigned to the column. 

Note: Available only for MySQL, Oracle, PostgreSQL, SQL Server and MariaDB. 

Date Time DateTime/Timestamp 

 

 

 

To edit an Enum record, just simply choose the record from the drop-down list. 
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Note: Available only for MySQL, PostgreSQL and MariaDB. 

 

To edit a Set record, just simply click  or press CTRL+ENTER to open the editor for editing. Select the records from 

the list. To remove the records, uncheck them in the same way. 

Note: Available only for MySQL and MariaDB. 

 

To view BFile content, just simply choose View -> Display -> Preview BFile. 

Note: Available only for Oracle. 

To generate UUID/GUID, right-click the selected cell and select Generate UUID. 

Note: Available only for PostgreSQL and SQL Server. 

Edit Records with Foreign Key (Foreign Key Data Selection - Available only in Navicat Premium, Enterprise and 

Standard Edition) 

Foreign Key Data Selection is a useful tool for letting you to get the available value from the reference table in an 

easy way. It allows you to show additional records from the reference table and search for particular records. 

To include data to the record, just simply click  or press CTRL+ENTER to open the editor for editing. 
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Just simply double-click to select the desired data. 

Hint: By default, the number of records showed is 1000. To show all records, click . To refresh the records, click 

 or press F5. 

Click  to open a pane on the left for showing a list of column names. Just simply click to show the additional column. 

To remove the columns, uncheck them in the same way. 

 

Hint: To set column in ascending or descending mode, right-click anywhere on the column and select Sort -> Sort 

Ascending / Sort Descending. 

Enter a search string into the Filter edit box and press ENTER to filter for the particular records. 
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Hint: To remove the filter results, simply remove the search string and press ENTER. 

Copy Data from Grid View 

Data that being copied from Navicat goes into the Windows clipboard with the fields delimited by tabs and the records 

delimited by carriage returns. It allows you to easily paste the clipboard contents into any application you want. 

Spreadsheet applications in general will notice the tab character between the fields and will neatly separate the 

clipboard data into rows and columns. 

To select data using keyboard shortcuts 

CTRL+A Toggle the selection of all rows and columns in the data grid. 

SHIFT+ARROW Toggle the selection of cells as you move up/down/left/right in the data grid. 

To select data using mouse actions 

 Select the desired records by holding down the CTRL key while clicking on each row. 

 Select range of records by clicking the first row you want to select and holding down the SHIFT key together 

with moving your cursor to the last row you wish to select. 

 Select a block of cells. 

Note: After you have selected the desired records, just simply press CTRL+C or right-click it and select Copy. 

Paste Data into Grid View 

Data are copied into the clipboard will be arranged as below format: 

 Data are arranged into rows and column. 

 Rows and columns are delimited by carriage returns/tab respectively. 

 Columns in the clipboard have the same sequence as the columns in the data grid you have selected. 

When pasting data into Navicat, you can replace the contents of current records and append the clipboard data into the 

table. To replace the contents of current records in a table, you must select the cells in the data grid whose contents 

must be replaced by the data in the clipboard. Just simply press CTRL+V or right-click and select Paste from the 

pop-up menu. Navicat will paste all the content in the clipboard into the selected cells. The paste action cannot be 

undone if you do not enable transaction. 

Copy Records as Insert/Update Statements 

To copy records as Insert/Update statement, right-click the column/row header or the selected cells and select Copy 

As -> Insert Statement or Update Statement. Then, you can paste the statements in any editors. 

Copy Field Name 
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To copy field names as tab separated values, right-click the column/row header or the selected cells and select Copy 

As -> Tab Separated Values (Field Name only). If you want to copy data only or both field names and data, you can 

choose Tab Separated Values (Data only) or Tab Separated Values (Field Name and Data) respectively. 

Save Data as a File 

You can save the data in the table grid to a file. Simply right-click a cell and select Save Data As. Enter the file name 

and file extension in the Save As dialog. 

Note: Not available when multiple selection. 

Sort / Find / Replace Records 

Sort Records 

Server stores records in the order they were added to the table. Sorting in Navicat is used to temporarily rearrange 

records, so that you can view or update them in a different sequence. 

Hover over the column caption whose contents you want to sort by, click the right side of the column and select Sort 

Ascending, Sort Descending or Remove Sort. 

 

To sort by custom order of multiple columns, click  Filter & Sort from the toolbar. 

Find and Replace 

Find Records 

The Find bar is provided for quick searching for the text in the data editor. Just simply choose Edit-> Find or press 

CTRL+F. Then, choose Find Data and enter a search string. The search starts at the cursor's current position to the 

end of the file. 

To find for the next text, just simply click Next or press F3. 

Replace Records 

In the Find bar, check the Replace box and enter the text you want to search and replace. Click Replace or Replace 

All to replace the first occurrence or all occurrences automatically. If you clicked Replace All, you can click Apply to 

apply the changes or Cancel to cancel the changes. 

Find Fields 

To search a field, just simply choose Edit -> Find or press CTRL+F. Then, choose Find Field and enter a search 

string. 
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There are some additional options for Find and Replace, click : 

Option Description 

Highlight All Highlight all matches in the data editor. 

Incremental Search Find matched text for the search string as each character is typed. 

Match Case Enable case sensitive search. 

 

Filter Records 

Use either of the following methods to filter the data in the grid: 

 Right-click a cell and select Filter -> Field xxx Value from the pop-up menu to filter records by the current value 

in the cell. 

 The Custom Filter dialog is provided for quick building a simple filter. Just simply right-click the grid and select 

Filter -> Custom Filter from the pop-up menu. Use character '_' to represent any single symbol in the condition 

and use character '%' to represent any series of symbols in the condition. 

 You can also customize your filter in a more complicated way by right-clicking a field and selecting Filter -> 

Filter & Sort from the pop-up menu or clicking  Filter & Sort from the toolbar. The Filter & Sort pane 

becomes visible at the top of the grid, where you can see the active filtering condition and easily enable or 

disable it by clicking a check box at the left. 

Manipulate Raw Data 

Navicat normally recognize what user has input in a table as normal string, any special characters or functions would 

be processed as plain text (that is, its functionality would be skipped). 

Editing data in Raw Mode provides an ease and direct method to apply server built-in functions. To access Raw Mode, 

just simply choose View -> Display -> Raw Mode. 

Note: Available only for MySQL, PostgreSQL, SQLite, SQL Server and MariaDB. 

 

Format Data View 

Use the following methods to format the table: 

Hint: Form View only supports Show/Hide Columns. 

Move Columns 

1. Click on the column header and hold down the left mouse button. 
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2. Move the pointer to the desired location. 

3. Release the mouse and the column will move. 

Freeze Column 

If there are many columns in the table and you want to freeze one or more columns to identify the record, just simply 

right-click the column header and select Freeze Column or select from the View menu. 

The frozen columns will move to the leftmost position in the table grid. This action will lock the frozen columns, 

preventing them from being edited. 

To unfreeze the columns, just simply right-click any column header on the table grid and select Unfreeze All Columns 

or select from the View menu. 

Set Column Width 

• Click right border at top of column and drag either left or right. 

• Double-click right border at top of column to obtain the best fit for the column. 

• Right-click the column header and select Set Column Width or select from the View menu. Specify width in the 

Set Column Width dialog. 

Hint: The result only applies on the selected column. 

Set Row Height 

Right-click the row header and select Set Row Height or select from the View menu. Specify row height in the Set Row 

Height dialog. Specify row height in the Set Row Height dialog. 

Hint: This action applies on the current table grid only. 

Show/Hide Columns 

If there are many columns in the table and you want to hide some of them from the grid/form, just simply click  

Columns. Select the columns that you would like to hide. 

The hidden columns will disappear from the grid/form. 

To unhide the columns, just simply click  Columns. Select the columns that you would like to redisplay. 

Show/Hide ROWID 

If you want to display or hide the rowid (address) of every row, right-click anywhere on the table grid and select 

Show/Hide ROWID or select from the View menu. 

The ROWID column will be showed in the last column. 
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Note: Available only for Oracle and SQLite. 

View Field Information 

Data Type 

You can display the data types of fields in the column header. To do so, right-click the column header and select Show 

Field Type. 

 

Field Comment 

If you have added comments to the table fields, you can right-click the column header and select Show Comment. 

Field comments are displayed as the column header. 

Note: Available only for MySQL, Oracle, PostgreSQL, SQL Server and MariaDB. 

 

MongoDB 

MongoDB Data Editor 

MongoDB Data Editor displays the data as a grid or a tree, or in JSON format. To switch the view, click ,  or  

at the bottom. 

The toolbar of the data editor provides the following functions for managing data: 

Button Description 

 Collection Profile Manage Profile - Manage the saved collection profiles and view the 

profile information. 

Load Profile - Load a collection profile. 

Save Profile - Create a profile with the current filter, sort and column 

settings. 

Save Profile As - Save the settings as a new profile. 

(Available only in Navicat Premium, Enterprise and Standard Edition) 
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 Begin Transaction Start a transaction. If Auto begin transaction is enabled in Options, 

transaction will be started automatically when opening the data editor. 

 Commit Make permanent all changes performed in the current transaction. 

 Rollback Undo work done in the current transaction. 

 Cell Editor Activate the cell editors for viewing and editing data. 

Available only for Grid View and Tree View. 

 Filter & Sort Filter records by creating and applying filter criteria for the data grid. 

 Columns Show / Hide columns. 

 Expand All [Tree View] Expand all embedded documents and arrays. 

 Collapse All [Grid View] Collapse all embedded documents. 

[Tree View] Collapse all embedded documents and arrays. 

 Type Color [Grid View] Use the specified type color set on the Type Color pane to 

highlight cells. 

 Analyze Analyze the collection. 

 Tools 

 Data Generation Generate data for the collection. 

 Create BI Workspace Create a new BI workspace with a data source using the collection data. 

 Import Import data from files. 

 Export Export data to files. 

 

Use Navigation Bar 

Data Editor provides a convenient way to navigate among the documents/pages using the Navigation Bar buttons. 

 

Button Description 
 

Add Document - enter a new document. At any point when you are working in 

the data editor, click on this button to get a blank display for a document. 
 

Delete Documents - delete an existing document. 
 

Apply Changes - apply the changes. 
 

Discard Changes - remove all edits made to the current document. 
 

Refresh - refresh the data. 
 

Stop - stop when loading enormous data from server. 
 

First Page - move to the first page. 
 

Previous Page - move to the previous page. 
 

Next Page - move to the next page. 
 

Last Page - move to the last page. 
 

First Document - move to the first document. 
 

Previous Document - move one document back (if there is one) from the 

current document. 
 

Next Document - move one document ahead. 
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Last Document - move to the last document. 
 

Limit Document Setting - set number of documents showing on each page. 
 

Grid View - switch to Grid View. 
 

Tree View - switch to Tree View. 
 

JSON View - switch to JSON view. 

Use the Limit Document Setting  button to enter to the edit mode. 

Limit documents  documents per page 

Check this option if you want to limit the number of documents showed on each page. Otherwise, all documents will be 

displayed in one single page. And, set the value in the edit box. The number representing the number of documents 

showed per page. 

Note: This setting mode will take effect on current object only. To adjust the global settings, see Options. 

 

Document a of b in page c 

Display the numbers representing the selected document and page. 

a - the selected document. 

b - number of documents in the current page. 

c - the current page. 

Grid View 

Grid View is a spreadsheet-like view showing documents and fields as rows and columns. The navigation bar allows 

you to switch the documents quickly, insert or delete documents. 

To add a document using the grid 

1. Click on an existing document and click  from the navigation bar or press CTRL+N to get a blank display for 

a document. 

2. Enter the desired data. 

3. Watch the graphics symbol in the document selectors box just to the left of your document. It will change from 

, which indicates that it is the current document, to , which indicates that you are editing this document. 

4. Just simply move to another document to save the document or click  from the navigation bar. 

Note: If your collection is empty, a window will pop up for you to add documents. 

To add a document using the pop-up window 
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1. Right-click the grid and select Add Document. 

2. Write the document in the pop-up window. 

3. Click Validate to ensure the document is correct. 

4. Click Add. 

To edit a document using the grid 

1. Select the document that you wish to edit by clicking in the specific cell you want to change. 

2. Type in the new data for that cell. 

3. Just simply move to another document or click  from the navigation bar, the new data will overwrite the 

previous data. 

To edit a document using the pop-up window 

1. Right-click the document that you wish to edit and select Edit Document. 

2. Edit the document in the pop-up window. 

3. Click Validate to ensure the document is correct. 

4. Click Update. 

Note: Close the collection is another way to save the documents. 

To edit multiple cells with same data 

1. Select a block of cells in the data grid. 

2. Type in the new data. 

Note: Changes will apply to multiple cells with compatible data type. 

To delete a document 

1. Select the document that you wish to delete. 

2. Just simply right-click and select Delete Document or click  from the navigation bar. 

Edit Documents with Special Handling 

To set the cell value to an empty string or NULL, right-click the selected cell and select Set to Empty String or Set to 

NULL. 

To edit a DateTime data, just simply click  or press CTRL+ENTER to open the editor for editing. Choose/enter the 

desired data. 
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To change the type of a cell value, right-click the selected cell and select Value Type. Then, select the desired type. 

Copy Data from Navicat 

Data that being copied from Navicat goes into the Windows clipboard with the fields delimited by tabs and the 

documents delimited by carriage returns. It allows you to easily paste the clipboard contents into any application you 

want. Spreadsheet applications in general will notice the tab character between the fields and will neatly separate the 

clipboard data into rows and columns. 

To select data using keyboard shortcuts 

CTRL+A Toggle the selection of all rows and columns in the data grid. 

SHIFT+ARROW Toggle the selection of cells as you move up/down/left/right in the data 

grid. 

To select data using mouse actions 

 Select the desired documents by holding down the CTRL key while clicking on each row. 

 Select range of documents by clicking the first row you want to select and holding down the SHIFT key together 

with moving your cursor to the last row you wish to select. 

 Select a block of cells. 

Note: After you have selected the desired documents, just simply press CTRL+C or right-click it and select Copy. 

Paste Data into Navicat 

Data are copied into the clipboard will be arranged as below format: 

 Data are arranged into rows and column. 

 Rows and columns are delimited by carriage returns/tab respectively. 

 Columns in the clipboard have the same sequence as the columns in the data grid you have selected. 

When pasting data into Navicat, you can replace the contents of current documents and append the clipboard data into 

the collection. To replace the contents of current documents in a collection, you must select the cells in the data grid 

whose contents must be replaced by the data in the clipboard. Just simply press CTRL+V or right-click and select 

Paste from the pop-up menu. Navicat will paste all the content in the clipboard into the selected cells. The paste action 

cannot be undone if you do not enable transaction. 
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Copy Records as Insert/Update Statements 

To copy records as Insert/Update statement, right-click the column/row header or the selected cells and select Copy 

As -> Insert Statement or Update Statement. Then, you can paste the statements in any editors. 

Copy Field Name 

To copy field names as tab separated values, right-click the column/row header or the selected cells and select Copy 

As -> Tab Separated Values (Field Name only). If you want to copy data only or both field names and data, you can 

choose Tab Separated Values (Data only) or Tab Separated Values (Field Name and Data) respectively. 

Save Data as a File 

You can save the data in the grid to a file. Simply right-click a cell and select Save Data As. Enter the file name and file 

extension in the Save As dialog. 

Note: Not available when multiple selection. 

Tree View 

Tree View displays documents in a hierarchical view. The navigation bar allows you to switch the documents quickly, 

insert or delete documents. 

To add a document 

1. Click  from the navigation bar or press CTRL+N to get a blank display for a document. 

2. Enter the desired data. 

3. Click  from the navigation bar to save the document. 

Note: If your collection is empty, you need to click  to add a new field. 

To edit a document 

1. Go to the document that you wish to edit. 

2. Click on a field name, a value or a type to modify. 

3. Click  from the navigation bar to apply the changes. 

To add a field or an item 

1. Go to the document that you wish to edit. 

2. Click  to add a new field/item. 

3. Enter the desired data. 

To delete a field or an item 
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1. Go to the document that you wish to edit. 

2. Right-click the field/item you want to delete and select Delete Value. 

Note: Close the collection is another way to save the documents. 

To delete a document 

1. Go to the document that you wish to delete. 

2. Just simply click  from the navigation bar. 

Edit Documents with Special Handling 

To set the value to an empty string or NULL, right-click the selected item and select Set to Empty String or Set to 

NULL. 

To edit a DateTime data, just simply click  to open the editor for editing. Choose/enter the desired data. 

 

Format Tree View 

Expand/Collapse Embedded Documents & Arrays 

All embedded Documents and arrays are represented as nodes. The nodes can be expanded or collapsed by clicking 

the node icon. 
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JSON View 

JSON View displays documents in JSON format. The navigation bar allows you to switch the documents quickly, insert 

or delete documents. 

To add a document 

1. Click  from the navigation bar or press CTRL+N. 

2. Write the document in the pop-up window. 

3. Click Validate to ensure the document is correct. 

4. Click Add. 

To edit a document 

1. Right-click the document that you wish to edit and select Edit Document. 

2. Edit the document in the pop-up window. 

3. Click Validate to ensure the document is correct. 

4. Click Update. 

To delete a document 

1. Click on the document that you wish to delete. 

2. Just simply click  from the navigation bar. 

Sort / Find / Replace Documents 

Sort Documents 

Server stores documents in the order they were added to the collection. Sorting in Navicat is used to temporarily 

rearrange documents, so that you can view or update them in a different sequence. 

Hover over the field caption whose contents you want to sort by, click the right side of the field and select Sort 

Ascending, Sort Descending or Remove Sort. 

 

To sort by custom order of multiple fields, click  Filter & Sort from the toolbar. 
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Find and Replace 

Find Documents 

The Find bar is provided for quick searching for the text in the data editor. Just simply choose Edit -> Find or press 

CTRL+F. Then, enter a search string. The search starts at the cursor's current position to the end of the file. 

For Grid View or Tree View, you need to choose Find Data or Find Value. 

To find for the next text, just simply click Next or press F3. 

Replace Documents 

In the Find bar, check the Replace box and enter the text you want to search and replace. Click Replace or Replace 

All to replace the first occurrence or all occurrences automatically. If you clicked Replace All, you can click Apply to 

apply the changes or Cancel to cancel the changes. 

 

Find Fields 

In Grid View or Tree View, you can search for fields in the collection. Just simply choose Edit -> Find or press CTRL+F. 

Then, choose Find Field and enter a search string. 

There are some additional options for Find and Replace, click : 

Option Description 

Highlight All Highlight all matches in the data editor. 

Incremental Search Find matched text for the search string as each character is typed. 

Match Case Enable case sensitive search. 

 

Filter Documents 

Use either of the following methods to filter the data in the grid: 

• Right-click a cell and select Filter -> Field xxx Value from the pop-up menu to filter documents by the current 

value in the cell. 

• The Custom Filter dialog is provided for quick building a simple filter. Just simply right-click the grid and select 

Filter -> Custom Filter from the pop-up menu. In the dialog, enter a query likes: { MyFIeld: { $gt: MyValue } }. 

• You can also customize your filter in a more complicated way by right-clicking a field and selecting Filter -> 

Filter & Sort from the pop-up menu or clicking  Filter & Sort from the toolbar. The Filter & Sort pane 

becomes visible at the top of the grid, where you can see the active filtering condition and easily enable or 

disable it by clicking a check box at the left. 
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Format Data View 

Use the following methods to format the collection grid: 

Highlight Cells based on Types 

Grid View allows highlighting cells based on data types to make particular cells easy to identify. The Type Color pane is 

on the right side of the grid. If the grid window is docked to the Navicat main window, you can click the icon in the 

Information pane to set the color. 

To apply the color, click the  Type Color button on the toolbar or check the Enable Coloring option on the Type 

Color pane. 

Expand/Collapse Embedded Documents 

Grid View allows embedded documents to be expanded alongside other columns for easier data analysis. To expand 

or collapse an embedded document, just simply click on the cell with embedded document and click or , or 

right-click the cell and select Expand, Collapse or Collapse All Embedded Documents. 

 

Expand Arrays 

Grid View allows showing all elements in an array. To expand array elements, just simply click on the cell with array 

elements and click , or right-click the cell with array elements and select Expand. 

 

All array elements display on a new grid. You can view, add or delete the elements here. Click the collection name to 

jump back to the collection grid. 

Move Columns 

1. Click on the column header and hold down the left mouse button. 

2. Move the pointer to the desired location. 

3. Release the mouse and the column will move. 

Freeze Column 

If there are many columns in the collection and you want to freeze one or more columns to identify the document, just 

simply right-click the column you want to freeze and select Freeze Column or select from the View menu. 
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The frozen columns will move to the leftmost position in the collection grid. This action will lock the frozen columns, 

preventing them from being edited. 

To unfreeze the columns, just simply right-click anywhere on the collection grid and select Unfreeze Columns or select 

from the View menu. 

Set Column Width 

• Click right border at top of column and drag either left or right. 

• Double-click right border at top of column to obtain the best fit for the column. 

• Right-click on the column header and select Set Column Width or select from the View menu. Specify width in 

the Set Column Width dialog. 

Hint: The result only applies on the selected column. 

Set Row Height 

Right-click on the row header and select Set Row Height or select from the View menu. Specify row height in the Set 

Row Height dialog. 

Hint: This action applies on the current collection grid only. 

Show/Hide Columns 

If there are many columns in the collection and you want to hide some of them from the collection grid, just simply click 

 Columns. Select the columns that you would like to hide. 

The hidden columns will disappear from the collection grid. 

To unhide the columns, just simply click  Columns. Select the columns that you would like to redisplay. 

Redis 

Redis Data Editor 

Navicat lets you explore keys in your Redis server using a spreadsheet-like data grid. You can add, edit and delete a 

key, even update the key expiry using the editor. 

The toolbar of the data editor provides the following functions for managing data: 

Button Description 

 Save Profile Create a profile with the current view of the key data. 

 Flatten Convert nested data structure to flat format. 

 Editor Activate the editor for viewing and editing the key's name, type, value and TTL. 

 Search Search for keys using a string or a key pattern. 

 Display keys in a tabular format, resembling a spreadsheet. 
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 Display keys in a hierarchical format, showing nested structures. 

 

Use Navigation Bar 

Data Editor provides a convenient way to navigate among the keys using the Navigation Bar buttons. 

 

Button Description 
 

Add Key - enter a new key. At any point when you are working in the data 

editor, click on this button to get a blank display for a key. 
 

Delete Keys - delete an existing key. 

Last Refresh Last Refresh - display the last refresh date and time or the elapsed time 

since the last refresh. 

 Refresh Refresh - refresh the data. 

 Fetch More Fetch More - fetch the next batch size of keys. 

 Fetch All Fetch All - fetch all remaining keys. 
 

Batch Size Settings - set number of keys showing when opening the data 

view. 

Use the Batch Size Settings  button to enter to the edit mode. 

Batch Size  

Set the value in the edit box. The number representing the number of keys fetched from the server. 

Note: This setting mode will take effect on current data view only. 

 

Edit Keys 

Data View is a spreadsheet-like view showing keys as rows and columns. The navigation bar allows you to insert or 

delete keys. 

By default, when opening the data editor, Navicat loads the number of keys in batch size. If you want to fetch more keys, 

you can click  Fetch More or  Fetch All. 

Hint: Newly fetched keys are marked with green indicators. You can unmark them by right-clicking on the grid and 

selecting Unmark All Indicators. 

To add a key 

1. Click  from the navigation bar or press CTRL+N to get a blank display for a key. 

2. Enter the key properties using the Editor. 
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3. Just simply move to another key to save the key or click Apply. 

To edit a key 

1. Double-click the key that you wish to edit. 

2. Type in the new data using the Editor. 

3. Just simply move to another key or click Apply, the new data will overwrite the previous data. 

Hint: You can modify key names, key types, key values and time to live (TTL). 

To delete a key 

1. Select the key that you wish to delete. 

2. Just simply right-click and select Delete Key or click  from the navigation bar. 

Hint: You can hold down the SHIFT or CTRL key and click to select multiple keys at a time. 

Sort Keys 

By default, the data grid displays keys in ascending order by key name. Sorting in Navicat is used to temporarily 

rearrange keys, so that you can view or update them in a different sequence. 

Click the column caption whose contents you want to sort by and select Sort Asc, Sort Desc or Remove Sort. 

 

Search Keys 

The Search feature is provided for quick searching for keys in the database. Just simply enter a key name in the 

Search box and click  Search or press ENTER. 

There are some additional options for Search, click : 

Option Description 

Keys Contain Return all keys contains the search string (case insensitive). 

Keys Contain (Match 

Case) 

Enable case sensitive search. 

Keys Match Pattern Return all keys matching the pattern. 

To remove the search, just simply click  Clear Search. 
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Cell Editors 

Navicat provides powerful cell editors to view and edit fields content. The editor allows you to view, update, insert, or 

delete data in a table or a collection. Click  Cell Editor from the toolbar to activate the appropriate viewer/editor. 

Note: Oracle BFile fields cannot be edited. MongoDB JSON View does not support cell editors. 

MySQL, Oracle, PostgreSQL, SQLite, SQL Server, MariaDB, MongoDB, Snowflake 

The Text pane allows you to edit data as a simple text. To change the syntax highlight, simply right-click the empty 

space and select Language. Use the  button on the navigation bar to update the changed records or documents. 

The Hex pane allows you to edit data in hexadecimal mode. Use the  button on the navigation bar to update the 

changed records or documents. 

Note: Use the INSERT key on the keyboard to switch between Insert and Overwrite modes. 

The Image pane allows you to show data as image. Use the  Load,  Save to disk and  Clear buttons to 

load/remove the image from a file, and save the image to a file. 

The Web pane allows you to show data with HTML codes as in a web browser. 

Filter & Sort Pane 

The Filter & Sort pane allows you to facilitate applying filter and sorting criteria that you specify for the data grid. Click 

 Filter & Sort from the toolbar to activate the Filter & Sort pane. 

There are two ways in which you can filter and sort data in the table. Either using the builder or enter SQL expressions. 

Note: Available only for MySQL, Oracle, PostgreSQL, SQLite, SQL Server, MariaDB, MongoDB and Snowflake. 

Use Builder to Filter & Sort 

To filter data 

1. To add a new condition to the criteria, just simply click . If you want to add a condition with parentheses, 

click . 

Hint: To add parentheses to existing conditions, simply right-click on the selected conditions and select Group 

with Bracket. To remove the parentheses, right-click a bracket and select Delete Bracket or Delete Bracket 

and Conditions. 

2. Click on the field name (next to the checkbox) and choose a field from the list. 

3. Click on the operator (next to the field name) and choose a filter operator. You can choose [Custom] from the 

list to enter the condition manually. 

Filter Operator Operator Description 
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= The field is equal to 'value'. 

!= The field is not equal to 'value'. 

< The field is less than 'value'. 

<= The field is less than or equal to 'value'. 

> The field is greater than 'value'. 

>= The field is greater than or equal to 'value'. 

contains The field contains 'value'. 

contains (case 

insensitive) 

The field contains 'value' (case insensitive). 

Available only for PostgreSQL. 

does not contain The field does not contain 'value'. 

does not contain (case 

insensitive) 

The field does not contain 'value' (case insensitive). 

Available only for PostgreSQL. 

begin with The field starts with 'value'. 

does not begin with The field does not start with 'value'. 

end with The field ends with 'value'. 

does not end with The field does not end with 'value'. 

is null The field is NULL. 

is not null The field is NOT NULL. 

is empty The field is empty. 

is not empty The field is not empty. 

is between The field is between 'value1' and 'value2'. 

is not between The field is not between 'value1' and 'value2'. 

is in list The field is in the list of ('value1','value2',...). 

is not in list The field is not in the list of ('value1','value2',...). 

exists The field exists. 

Available only for MongoDB. 

does not exist The field does not exist. 

Available only for MongoDB. 

is field type The field type is 'value'. 

Available only for MongoDB. 

is not field type The field type is not 'value'. 

Available only for MongoDB. 

4. Click on <?> to activate the appropriate editor and enter the criteria values. The editor used in the criteria 

values box is determined by the data type assigned to the corresponding field. 

Hint: For MongoDB, you can change the editor type in the criteria values box. 

5. Click on the logical operator (next to the criteria values) to choose and or or. 

6. Repeat step 1-5 to add another new condition. 

7. Click Apply Filter & Sort to see the result of the filtering you made. 
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Hint: If you want to reverse the meaning of the conditions, right-click the selected conditions and select Toggle 

Negator. (Available only for MySQL, Oracle, PostgreSQL, SQLite, SQL Server and MariaDB) 

To sort data 

1. Click . 

2. Click on the field name and choose a field you want to sort from the list. 

3. Click  or  to change the sorting order. 

4. Repeat step 1-3 to add another field. 

5. Click Apply Filter & Sort to see the result of the sorting you made. 

Hint: If you have more than one field in the Sort by area, you can rearrange the order by dragging the fields into the 

precise position you want. 

Enter Expressions to Filter & Sort 

To filter data 

1. Choose Text. 

2. Enter the filtering expression in the input field. 

3. Click Apply Filter & Sort to see the result of the filtering you made. 

To sort data 

1. Choose Text. 

2. Enter the sorting expression in the input field. 

3. Click Apply Filter & Sort to see the result of the sorting you made. 

Change Layout 

You can change the appearance of the Filter & Sort pane: Tabbed or Integrated. In the tabbed layout, the filter and 

sort options are compartmentalized into individual tabs for organization. Conversely, the integrated layout consolidates 

the filter and sort options into a unified pane. 

To access these layout options, you can choose View -> Filter & Sort Layout. 
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Chapter 7 - Data Profiling (Available only in 

Navicat Premium, Enterprise and Standard 

Edition) 

About Data Profiling 

The Data Profiling tool in Navicat allows you to gain comprehensive insights into your data. This information helps you 

to better understand your data assets, identify data quality issues, make informed decisions about data usage, and 

ensure the data meets the required standards for analysis. 

It offers various functionalities to assist you in exploring your data. It enables you to examine data types, formats, 

distributions, and statistical properties within your datasets. You can easily identify missing values, outliers, and data 

inconsistencies, ensuring data accuracy and completeness. 

Note: Available only for MySQL, Oracle, PostgreSQL, SQLite, SQL Server, MariaDB and Snowflake. 

Start Data Profiling 

Data profiling is resource intensive and execution times can be quite long, especially with large data volumes. Besides 

profiling all records, you can use filter to select the data that a profile scans. If you add a filter, the profile scans only on 

the data values that meet the filter criteria that you specify. 

To enable the Data Profiling tool, open a table and click  Data Profiling. In the Data Profiling pane, enable the 

profiling options you want and click Start Profiling. 

Option Description 

All Records All data in the table is scanned in the data profiling scan. 

Add Filter You can filter data to be scanned for profiling and set a range of records (No 

Limit or First # records) to sample for running profiling scan. 

 

View Profiling Results 

After the profiling finished, the data profile results appear. The results show all the columns and their statistics in the 

profile run. You can modify the profiling options by clicking  Data Settings and then re-profile the data. 
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Column Quality & Distribution 

The Column Quality & Distribution pane provides the quality of the data in terms of distinct values, unique values, NULL 

values and non-NULL values, also it displays column distribution charts associated with the column values. 

Column Quality 

The column quality includes a small bar chart and column quality categories (displayed as percentages). It displays 

directly underneath the column name. 

 

By hovering over any category, it will show you the numerical distribution of the value qualities throughout the column. 

 

Column Distribution 

In column distribution charts, you can see the frequency and distribution of the values in each of the columns as in 

histogram. 

By default, the data in these visualizations is sorted in ascending order of the values. You can change the sorting order 

and category by right-clicking the chart and select Sort Distribution. 
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By hovering over any bar, it will show you the value and the numerical distribution of the quality of that value throughout 

the column. 

You can change the display style that works best for you by right-clicking a bar and choosing Compact or Detailed. 

Compact View hides Column Quality information, while Detailed View shows both Column Quality & Distribution 

information. 

Column Statistics 

The Column Statistics pane provides a more in-depth look at the data in a column. It contains column statistics with 

distribution measures like Count, Distinct, Unique, Empty String, Min, Max. Apart from the value distribution, you can 

select a measure to shown a column statistics chart. 

 

Add Spotlight 

Use spotlights to draw attention to specific values on the result. To spotlight values, use one of the following methods: 

• Click a column quality category or a bar in the Column Quality & Distribution pane. 

• Right-click a bar in the Column Quality & Distribution pane and select Spotlight This Value or Add Spotlight. 

• Right-click a value in the grid and select Spotlight This Value or Add Spotlight. 

• Right-click a bar in the Value Distribution chart and select Spotlight This Value or Add Spotlight. 

Hint: Remove the spotlighted values in the same way. 
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Copy Column Statistics 

In the Column Statistics pane, you can hover over a measure and click . 
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Chapter 8 - Query 

About Query 

A query is used to extract data from the database in a readable format according to the user's request. Navicat provides 

powerful tools for working with queries: Query Editor for editing the query text directly, and Query Builder, Find Builder 

or Aggregate Builder for building queries visually. You can save your queries for setting automation tasks. In the main 

window, click  Query to open the query object list. You can also click  New Query in the main toolbar to create 

a new query without opening any connections. 

To open a query using an external editor, right-click it and select Open with External Editor. You can set the file path 

of an external editor in Options. 

Hint: Queries (.sql, .js or .redis) are stored under the Settings Location. To open the folder, right-click a query and 

select Open Containing Folder. If the connection is synchronized to Navicat Cloud or On-Prem Server, its queries will 

be stored in the cloud. 

Query Designer 

Query Designer is the basic Navicat tool for working with queries. 

Button Description 

MySQL, Oracle, PostgreSQL, SQLite, SQL Server, MariaDB, Snowflake 

 Query Builder Open the Query Builder for building queries visually. 

 Beautify SQL Format the codes with the Beautify SQL settings in Editor. 

 Explain Show the execution plan of the query: Explain or Explain Selected (when 

highlighted code). 

MongoDB 

 Find Builder Open the Find Builder for building queries visually. 

 Aggregate Builder Open the Aggregate Builder for building queries visually. 

 Beautify Script Format the codes in Editor. 

 Explain Show the execution plan of the query: Explain or Explain Selected (when 

highlighted code). 

Common 

 Code Snippet Show the Code Snippet pane. 

 Run Run - Execute the entire query. 

Run Current Statement - Execute the current statement based on the 

cursor position. 

Run Selected - Execute the highlighted code. 

Continue on Error - Ignore errors that are encountered during the execution 

process. 

(MongoDB does not support Run Current Statement and Continue on Error.) 

 Stop Stop the executing query. 
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 Ask AI Provide AI-driven assistance for query writing, including optimization, 

beautification and conversion. 

Create BI workspace using the query as a data source 

1. In Query Designer, choose File -> Create BI Workspace. 

Open an external file in Navicat 

1. In the menu bar, choose File -> Open External File -> Query. 

2. Select the file and choose the encoding. 

3. Click Open. 

Save an opened external file as a Navicat query 

1. In Query Designer, choose File -> Save to Navicat. 

2. Enter the query name and choose the save location. 

3. Click OK. 

Save a Navicat query as an external file 

1. In Query Designer, choose File -> Save As External File. 

2. Choose the save path and enter the file name. 

3. Click Save. 

RDBMS 

Query Editor 

SQL Editor allows you to create and edit SQL text, prepare and execute selected queries. You can define multiple SQL 

statements in one query window. Drag-and-drop or double-click an identifier in the right Identifiers pane to add it to the 

editor. 

Hint: SELECT statement will be automatically generated in Query Editor while you build in Query Builder. 

Navicat provides a wide range advanced features, such as compelling code editing capabilities, smart code-completion, 

SQL formatting, and more. 

SQL Formatting 

To change the SQL statement format, simply choose from the Format menu -  

Indent 
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Increase/decrease indent for the selected lines of codes. 

Comment 

Comment/uncomment the selected lines of codes. 

Convert case 

Format the selected codes into upper/lower case. 

Beautify SQL 

Format the selected codes with the Beautify SQL settings. 

Beautify SQL With 

Change the SQL beautifier options. 

Option / Button Description 

Single Line Braces Word/Symbol Limit Set the length of the short brace. 

Upper case keywords Format all the SQL keywords to upper case. 

Beautify Save and apply the SQL beautifier options. 

Minify SQL 

Minify the format of the SQL in the Query Editor. 

Code Completion 

Code completion feature in Navicat pops up a list of suggestions as you type your SQL statement in the editor. It 

assists you with statement completion and the available properties of database objects, for example databases, tables, 

fields, views etc with their appropriate icons and information. You can update the code suggestions with latest 

database information by choosing Edit -> Code Completion -> Update Code Completion Info. 

To invoke code completion, just simply press '.' for the available properties of database object currently in the scope. 

When the suggestion list appears, press TAB to insert the first item. You can also select the needed item using UPPER 

ARROW or DOWN ARROW and then press TAB or ENTER. 

 



 127 

 

In addition, code completion can be invoked by typing a character or pressing ESC on your keyboard for SQL 

keywords/database objects. 

If you select a snippet name from the list, the saved code will be inserted to the editor. 

 

Hint: Resize the suggestion list by dragging the lower right corner. 

You can enable or disable the code completion feature in Options. 

Clipboard Stack 

When you copy or cut some codes as usual in the editor, the copied content will also be added to Clipboard Stack. 

Clipboard Stack can store up to 10 items and use the last-in-first-out logic. To paste an item from Clipboard Stack, you 

can press CTRL+SHIFT+V. Press CTRL+SHIFT+V multiple times to cycle through Clipboard Stack. 

Code Folding 

Code folding feature enables you to collapse blocks of code such that only the first line of the block appears in Query 

Editor. 

A block of code that can be folded is indicated by an icon  to the left of the first line of the block. A vertical line 

extends from the icon to the bottom of the foldable code. In contrast, a folded block of code is indicated by an icon  

to left of the code block. You can fold the block by clicking  or expand it by clicking . 

 

Syntax Highlight 

Navicat uses syntax highlighting which depending on the database associated with the query. Different databases have 

different sets of reserved keywords. You can configure the associated colors for different text fragments in Options. 
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Brace Highlight 

Navicat supports to highlight the matching brace in the editor, i.e. () . 

Note: The cursor must be on a brace to show the highlight. 

 

Find and Replace 

Find 

The Find bar is provided for quick searching for the text in the editor. Just simply choose Edit -> Find from the menu or 

press CTRL+F, and then enter a search string. 

The search starts at the cursor's current position to the end of the file. 

To find the next occurrence, just simply click Next or press F3. 

Replace 

To open the Replace bar, simply check the Replace box. Then, enter the text you want to search and replace. 

Click the Replace button to replace the first occurrence. 

Click the Replace All button to replace all occurrences automatically. 

There are some additional options for Find and Replace, click : 

Option Description 

Highlight All Highlight all matches in the editor. 

Incremental Search Find matched text for the search string as each character is typed. 

Match Case Enable case sensitive search. 

Regular Expression Search regular expressions. 

Whole Word Return the objects that match the entire word of the search string. 

Copy with Quotes 

To copy the SQL statement with quotes, just simply right-click the highlighted SQL. Then, select Copy with Quotes 

and choose the format. 

Word Wrap 



 129 

 

In the Word Wrap mode, the horizontal scrollbar is removed. SQL statement that exceeds the width of the editor 

window size wraps to the next line. To enable Word Wrap, choose View -> Word Wrap. 

Zoom In/Zoom Out 

Navicat has the ability to zoom in or zoom out the SQL in the editor. The zooming options are available in View -> 

Display -> Zoom. The same effect can be achieved with keyboard shortcuts. 

Zoom In: [CTRL+=] 

Zoom Out: [CTRL+-] 

Reset: [CTRL+0] 

Note: Editors that are opened in different tabs or windows will not be affected by the zoom. 

Query Builder (Available only in Navicat Premium, Enterprise and Standard Edition) 

Navicat provides a useful tool called Query Builder for building queries, views and materialized views visually. It allows 

you to create and edit queries without knowledge of SQL. Even if you are familiar with SQL, the convenient and fluent 

graphical interface makes it easier to create relations and visualize the query. 

In Query Designer, click the  Query Builder button to open the visual Query Builder. 

All database objects are displayed on the left Object pane. Whereas on the middle pane, it is divided into two portions: 

the upper Diagram pane, and the lower Criteria pane. When building the query, you can view the auto-generated 

query on the right SQL pane. 

Note: Query Builder supports SELECT statement only. Use Query Editor for creating other complex queries (e.g. 

INSERT, UPDATE, DELETE). 

 

Add Objects to Query 
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The first step is to decide which tables and views you need to add to the query. 

To add tables and views to the query, use one of the following methods: 

 Drag them from the Object pane to the Diagram pane. 

 Double-click them on the Object pane. 

You can set aliases for tables, views and subqueries by double-clicking the object title on the Diagram pane and 

entering the name to use as an alias for the object name. 

After you have added objects to the diagram, you can use the FROM tab to adjust the query to your needs. 

 To change the object, click the object and select an identifier. 

 To add the table alias, click <Alias>. 

 

You can right-click an object on the Diagram pane and select Remove, or simply press DELETE key to remove the 

selected object from the query. 

When you remove an object, Query Builder automatically removes joins that involve that object. 

Choose Output Fields 

To include fields in the query, use one of the following methods: 

 Check the left checkbox of a field name you want to add to the query on the Diagram pane. 

 To include all the fields for an object, check the * checkbox on the Diagram pane. 

 To add all fields for all objects, click  on the SELECT tab and select All fields(*). 

The selected fields display on the SELECT tab. You can specify additional output field options. 

 Check the DISTINCT checkbox to force the query to return distinct results. 

 To add the field alias, click <Alias> and enter the name. 

 Click the identifier and select the Aggregate function. 

 Use the up arrow and down arrow buttons to change the order of fields. 
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Set Field Association 

Query Builder will automatically join the tables as per the foreign key relations. If you want to associate database 

objects manually, just select a field from an object and drag it to a field in another object. A connector line appears 

between the two objects to visually represent the relationship and the join type. 

There are two views to show the connector lines: Table Relation and Field Relation. The Field Relation view allows 

you to identify matching fields in two tables, while the Table Relation view displays the join relationship between the 

two tables. 

All joins are initially created as INNER JOIN by default. To change the association, click or double-click the connector 

line on the Diagram pane or click the JOIN keyword on the FROM tab, and then select a join type. If a join type is not 

listed, you can enter a customized one in the Custom textbox. 

 

To remove a join, right-click the connector line and select Remove. 

To modify the join condition, right-click a connector line and select Edit Join, or click the condition on the FROM tab. 

 

The pop-up menu options of the FROM tab: 

Option Description 
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Insert Add an identifier, an expression or a subquery. 

Insert Bracket Add a pair of parentheses. 

Remove Remove the identifier, expression or subquery. 

Clear and Convert to 

USING Clause 

Remove the ON condition and convert it to USING clause. 

Clear and Convert to ON 

Clause 

Remove the USING condition and convert it to ON clause. 

Group with Bracket Add parentheses to group the selected conditions. 

Ungroup Remove the parentheses. 

Set Filter Criteria 

When retrieving data, you may want to set up a filtering expression. To filter data returned by the query, right-click a 

field on the Diagram pane and select Add Field To -> WHERE and an operator. 

The condition is added to the WHERE tab. You can edit the value there by clicking <Value>. If you want to add a 

condition with parentheses, click . You can change a logical operator (and/or) by clicking it. Use the up arrow and 

down arrow buttons to change the order of conditions. 

 

The pop-up menu options of the WHERE tab: 

Option Description 

Toggle Negator Reverse the meaning of the condition. 

Insert Add a condition. 

Insert Custom Add a custom condition. 

Insert Bracket Add a pair of parentheses. 

Remove Remove the condition. 

Group with Bracket Add parentheses to group the selected conditions. 

Ungroup Remove the parentheses. 

Group Resulting Data 

You can set the conditions for grouping query records by right-clicking a field in the Diagram pane and selecting Add 

Field To -> GROUP BY. 

The condition is added to the GROUP BY tab. Use the up arrow and down arrow buttons to change the order of fields. 
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On the HAVING tab, you can filter summarized data or grouped data. Select the identifiers, operators, aggregate or 

enter expressions to include in the condition. Use the up arrow and down arrow buttons to change the order of 

conditions. 

The pop-up menu options of the HAVING tab: 

Option Description 

Toggle Negator Reverse the meaning of the condition. 

Insert Add a condition. 

Insert Custom Add a custom condition. 

Insert Bracket Add a pair of parentheses. 

Remove Remove the condition. 

Group with Bracket Add parentheses to group the selected conditions. 

Ungroup Remove the parentheses. 

Sort Resulting Data 

You can set the way of sorting query records by right-clicking a field on the Diagram pane and selecting Add Field To 

-> ORDER BY -> ASC or DESC. The condition will be added to the ORDER BY tab. 

Limit Resulting Data 

On the LIMIT tab, you can limit your query results to those that fall within a specified range. 

Offset 

Specify the number of records to be skipped. It is optional. 

Limit 

Specify the number of records to be displayed. 

Note: Available only for MySQL, PostgreSQL, SQLite and MariaDB. 

Add Expressions/Subqueries 

You can add an expression or a subquery to further limit the query results. On the FROM tab, click  and select the 

Expression/Subquery tab. 

After entered an expression or a subquery, confirm editing by pressing the ENTER key. It will be added to the Diagram 

pane indicates that the statement contains an expression or a subquery and identifies the columns it is on. 
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By clicking the  button, you will be switched to a subquery layer where you can build it visually in the same way as 

the main query. 

You can always go back to the main query by clicking (Main Query). 

View Generated SQL 

The SQL pane presents a read-only, formatted representation of the SQL generated by Query Builder. You can copy 

the SQL that appears in the SQL pane for use in other tools. In a subquery layer, you can enable Show Current Layer 

Only to show the subquery SQL. 

Zoom In/Zoom Out 

Navicat has the ability to zoom in or zoom out the diagram. Right-click anywhere on the Diagram pane and select 

Zoom -> Zoom In/Zoom Out/100%. The same effect can be achieved with keyboard shortcuts. 

Zoom In: [CTRL+=] 

Zoom Out: [CTRL+-] 

Reset: [CTRL+0] 

Query Parameters 

Query supports using of parameters inside the query text. You can set query parameters to add variable values to a 

query each time you run it. The parameter should appear as an identifier with $ at its beginning, quote with [ ], e.g. 

[$any_name]. 

Execute the query and the Input Parameter dialog is provided for you to enter the desired data you wish to search. 

Check the Raw Mode option to pass the inputted values to the query without quotation marks. 

Debug Oracle Query (Available only in Navicat Premium, Enterprise and Standard 

Edition) 

To debug an Oracle query, click  Debug on the toolbar to launch the Oracle Debugger. 

Enter the parameters if the query has input parameters. 
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Query Results 

You can run the query in any servers. Select the target connection, database and/or schema from the drop-down list on 

the toolbar, and then click  Run. If the query statement is correct, the query executes and, if the query statement is 

supposed to return data, the Result tab opens with the data returned by the query. If an error occurs while executing 

the query, execution stops, the appropriate error message is displayed. 

Hint: For Snowflake servers, you can change the system-defined role used to execute queries using drop-down menu. 

The Result tab displays the result data, returned by the query, as a grid. Data can be displayed in two modes: Grid 

View and Form View. See Data Editor for details. 

Button Description 

 Cell Editor Activate the cell editors for viewing and editing data. 

 Data Profiling Profile the data in the query. 

 Export Export the result of the query. 

 Pin Pin the tab. 

Note: Navicat supports to return 20 result sets. 

You are allowed to run selected portion of query, just simply highlight SQL in Query Editor and click  Run Selected. 

To run the current statement your cursor is on (position the cursor within the desired statement), just simply click the 

down arrow next to the  Run button and select Run Current Statement. 

Adjust Result Position 

In Navicat, you have the flexibility to configure how query results are displayed. You can choose to show the query 

results on an entire page, on the right side of the editor, or at the bottom of the editor. This allows you to adapt the 

display layout based on your specific needs and preferences during data analysis and exploration in Navicat. To 

change the result position, use the  or  icon located in the upper right corner, or access the View -> Result 

menu. 

Pin Query Result (Available only in Navicat Premium, Enterprise and Standard Edition) 

Existing result tabs are removed when you re-execute the query. You can pin a result tab so that it remains visible after 

re-executing the query. Simply click  Pin and its contents will not be cleared the next time you execute it. 

When you pin a tab, it will display a pin icon and automatically moves towards the left side of the tab bar. All pinned 

tabs appear from left to right in the order you pinned. Hover over a pinned tab will show its execution time and the query. 

You can pin any number of results and quickly see what's pinned and what's not pinned. Simply click  Unpin to 

unpin a tab. 

Custom Tab Name 

To customize the names of the result tabs, simply add -- NAME:tab_name or /*NAME:tab_name*/ before each 

SELECT statement in the Query Editor. 
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Show Query Profiling and Status (Available only for MySQL and MariaDB) 

To show the query profiling and status when running the query, simply choose View -> Show Query Profiling and 

Status and click  Run on the toolbar. 

The Query Profiling tab under the Result tab displays the query profiling: Table lock, System lock, Statistic, etc. 

Note: For MySQL 5.0, supported from 5.0.37. For MySQL 5.1, supported from 5.1.24. 

The Status tab displays the query status: Bytes received, Bytes sent, etc. 

Query Explain 

Query Explain provides detailed information about how a database query is executed by the database server. It helps 

you understand and optimize the performance of queries by analyzing the query execution plan. 

When you click  Explain, Navicat sends an EXPLAIN statement to the database server. The server then generates 

an execution plan that outlines the steps it will take to execute the query and retrieve the requested data. 

The Explain tab displays the execution plan. You can pin the tab by clicking  Pin. 

You are allowed to explain selected portion of query, just simply highlight SQL in Query Editor and click  Explain 

Selected. 

Note: The supported plan formats depend on the server types. 

Execution Plan - Visual (Available only in Navicat Premium, Enterprise and Standard Edition) 

The diagram displays the operations performed by the query and the data passed between them. If the cost of an 

operation equals or exceeds the threshold value in the daigram, the number turns red. Click on an operation to view its 

statistical information. The information helps to understand what is happening internally when the query is executed. 

Button / Option Description 
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Cost Threshold(%) Set the threshold value to determine when certain operations in the 

execution plan are considered important enough to be marked red. 

 &  Zoom in or zoom out the diagram. 
 

Download the diagram as a PNG file. 
 

Filter the nodes in the diagram by the node type. 

Find Enter a search string to find matches. 

Execution Plan - JSON 

The text-based plan provides a complete set of information about the query execution displayed in JSON format. This 

format can be difficult to read and analyze, but is easy to share with others. 

Execution Plan - Text 

The text-based plan provides a complete set of information about the query execution. 

Execution Plan - Grid 

The grid-based plan provides a complete set of information about the query execution. 

Execution Plan - Statistic 

Per Node Type - It shows the summary information of each node type in the visual graph. 

Per Relation - It shows the statistical information that related to each table. 

MongoDB 

Query Editor 

Query Editor allows you to create and edit a script, prepare and execute selected script. Drag-and-drop or double-click 

an identifier in the right Identifiers pane to add it to the editor. 

Hint: Script will be automatically generated in Query Editor while you build in Find Builder or Aggregate Builder. 

Navicat provides a wide range advanced features, such as compelling code editing capabilities, smart code-completion, 

script formatting, and more. 

Script Formatting 

To change the script format, simply choose from the Format menu - 

Indent 

Increase/decrease indent for the selected lines of codes. 

Comment 

Comment/uncomment the selected lines of codes. 
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Beautify Script 

Format the selected codes. 

Code Completion 

Code completion feature in Navicat pops up a list of suggestions as you type your script in the editor. It assists you with 

database names, collection names, view names, document field names and shell methods with their appropriate icons 

and information. You can update the code suggestions with latest database information by choosing Edit -> Code 

Completion -> Update Code Completion Info. 

Code completion can be invoked by typing a dot (.), a character or pressing ESC. 

 

When the suggestion list appears, press TAB to insert the first item. You can also select the needed item using UPPER 

ARROW or DOWN ARROW and then press TAB or ENTER. 

If you select a snippet name from the list, the saved code will be inserted to the editor. 

 

Hint: Resize the suggestion list by dragging the lower right corner. 

You can enable or disable the code completion feature in Options. 

Code Folding 

Code folding feature enables you to collapse blocks of code such that only the first line of the block appears in Query 

Editor. 
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A block of code that can be folded is indicated by an icon  to the left of the first line of the block. A vertical line extends 

from the icon to the bottom of the foldable code. In contrast, a folded block of code is indicated by an icon  to left of 

the code block. You can fold the block by clicking  or expand it by clicking . 

 

Syntax Highlight 

Navicat uses syntax highlighting which depending on the database associated with the query. Different databases have 

different sets of reserved keywords. You can configure the associated colors for different text fragments in Options. 

Brace Highlight 

Navicat supports to highlight the matching brace in the editor, i.e. () . 

Note: The cursor must be on a brace to show the highlight. 

 

Find and Replace 

Find 

The Find bar is provided for quick searching for the text in the editor. Just simply choose Edit -> Find from the menu or 

press CTRL+F, and then enter a search string. 

The search starts at the cursor's current position to the end of the file. 

To find the next occurrence, just simply click Next or press F3. 

Replace 

To open the Replace bar, simply check the Replace box. Then, enter the text you want to search and replace. 

Click the Replace button to replace the first occurrence. 

Click the Replace All button to replace all occurrences automatically. 

There are some additional options for Find and Replace, click : 
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Option Description 

Highlight All Highlight all matches in the editor. 

Incremental Search Find matched text for the search string as each character is typed. 

Match Case Enable case sensitive search. 

Regular Expression Search regular expressions. 

Whole Word Return the objects that match the entire word of the search string. 

Copy with Quotes 

To copy the script with quotes, just simply right-click the highlighted script. Then, select Copy with quotes and choose 

the format. 

Word Wrap 

In the Word Wrap mode, the horizontal scrollbar is removed. Script that exceeds the width of the editor window size 

wraps to the next line. To enable Word Wrap, choose View -> Word Wrap. 

Zoom In/Zoom Out 

Navicat has the ability to zoom in or zoom out the script in the editor. The zooming options are available in View -> 

Display -> Zoom. The same effect can be achieved with keyboard shortcuts. 

Zoom In: [CTRL+=] 

Zoom Out: [CTRL+-] 

Reset: [CTRL+0] 

Note: Editors that are opened in different tabs or windows will not be affected by the zoom. 

Find Builder (Available only in Navicat Premium, Enterprise and Standard Edition) 

Navicat provides Find Builder for building queries visually to select documents in a collection or view. It allows you to 

create and edit queries without knowledge of the find command. 

In Query Designer, click the  Find Builder button to open the visual Find Builder. 

Select the name of the collection or view to query from the Collection/View drop-down list. 

Filter 

In this tab, you can specify selection filters for the query. Documents that meet the conditions will be returned. If you not 

specify the filter, all documents will be returned. See Filter & Sort for details. 

Projection 

In this tab, you can choose which fields to include or exclude in the returned documents. If you not specify the 

projection, all fields will be returned. 

http://192.168.1.247/online_manual_v17/en/navicat/win_manual/#/data_filter_wizard
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Sort 

In this tab, you can sort the returned documents by fields in ascending or descending order. 

Limit 

In this tab, you can limit the maximum number of documents to return and set the number of documents to skip. 

Aggregate Builder (Available only in Navicat Premium, Enterprise and Standard 

Edition) 

Navicat provides Aggregate Builder for building queries visually to return computed results. It allows you to create and 

edit queries without knowledge of the aggregate command. 

In Query Designer, click the  Aggregate Builder button to open the visual Aggregate Builder. 

Query Results 

You can run the query in any servers. Select the target connection and database from the drop-down list on the toolbar, 

and then click  Run. If the query script is correct, the query executes and, if the query script is supposed to return 

data, the Result tab opens with the data returned by the query. If an error occurs while executing the query, execution 

stops, the appropriate error message is displayed. 

The Result tab displays the result data, returned by the query, as a grid. Data can be displayed in three modes: Grid 

View, Tree View and JSON View. See Data Editor for details. 

Button Description 

 Cell Editor Activate the cell editors for viewing and editing data. 

 Type Color [Grid View] Use the specified type color set on the Type Color pane to 

highlight cells. 

 Export Export the result of the query. 

 Pin Pin the tab. 

Note: Navicat only returns the last result data. 

You are allowed to run selected portion of query, just simply highlight script in the editor and click  Run Selected. 

Adjust Result Position 

In Navicat, you have the flexibility to configure how query results are displayed. You can choose to show the query 

results on an entire page, on the right side of the editor, or at the bottom of the editor. This allows you to adapt the 

display layout based on your specific needs and preferences during data analysis and exploration in Navicat. To 

change the result position, use the  or  icon located in the upper right corner, or access the View -> Result 

menu. 

Pin Query Result (Available only in Navicat Premium, Enterprise and Standard Edition) 
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Existing result tabs are removed when you re-execute the query. You can pin a result tab so that it remains visible after 

re-executing the query. Simply click  Pin and its contents will not be cleared the next time you execute it. 

When you pin a tab, it will display a pin icon and automatically moves towards the left side of the tab bar. All pinned 

tabs appear from left to right in the order you pinned. Hover over a pinned tab will show its execution time and the query. 

You can pin any number of results and quickly see what's pinned and what's not pinned. Simply click  Unpin to 

unpin a tab. 

Query Explain 

Query Explain provides detailed information about how a database query is executed by the database server. It helps 

you understand and optimize the performance of queries by analyzing the query execution plan. 

When you click  Explain, Navicat sends an explain script to the database server. The server then generates an 

execution plan that outlines the steps it will take to execute the query and retrieve the requested data. 

The Explain tab displays the execution plan. You can pin the tab by clicking  Pin. 

You are allowed to explain selected portion of query, just simply highlight script in Query Editor and click  Explain 

Selected. 

Execution Plan - Visual (Available only in Navicat Premium, Enterprise and Standard Edition) 

The diagram displays the operations performed by the query and the data passed between them. If the cost of an 

operation equals or exceeds the threshold value in the daigram, the number turns red. Click on an operation to view its 

statistical information. The information helps to understand what is happening internally when the query is executed. 

Button / Option Description 

Cost Threshold(%) Set the threshold value to determine when certain operations in the 

execution plan are considered important enough to be marked red. 

 &  Zoom in or zoom out the diagram. 
 

Download the diagram as a PNG file. 
 

Filter the nodes in the diagram by the node type. 

Find Enter a search string to find matches. 

Execution Plan - JSON 

The text-based plan provides a complete set of information about the query execution displayed in JSON format. This 

format can be difficult to read and analyze, but is easy to share with others. 

Execution Plan - Grid 

The grid-based plan provides a complete set of information about the query execution. 

Execution Plan - Statistic 

Per Node Type - It shows the summary information of each node type in the visual graph. 
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Per Relation - It shows the statistical information that related to each collection. 

Redis 

Query Editor 

Query Editor allows you to create and edit commands, prepare and execute selected queries. You can define multiple 

commands in one query window. 

Navicat provides a wide range advanced features, such as compelling code editing capabilities, smart code-completion, 

command formatting, and more. 

Command Formatting 

To change the command format, simply choose from the Format menu - 

Indent 

Increase/decrease indent for the selected lines of codes. 

Comment 

Comment/uncomment the selected lines of codes. 

Convert case 

Format the selected codes into upper/lower case. 

Code Completion 

Code completion feature in Navicat pops up a list of suggestions as you type your command in the editor. It assists you 

with command completion and the available functions with their appropriate icons and information. 

Code completion can be invoked by typing a character or pressing ESC. 

 

When the suggestion list appears, press TAB to insert the first item. You can also select the needed item using UPPER 

ARROW or DOWN ARROW and then press TAB or ENTER. 
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If you select a snippet name from the list, the saved code will be inserted to the editor. 

 

Hint: Resize the suggestion list by dragging the lower right corner. 

You can enable or disable the code completion feature in Options. 

Clipboard Stack 

When you copy or cut some codes as usual in the editor, the copied content will also be added to Clipboard Stack. 

Clipboard Stack can store up to 10 items and use the last-in-first-out logic. To paste an item from Clipboard Stack, you 

can press CTRL+SHIFT+V. Press CTRL+SHIFT+V multiple times to cycle through Clipboard Stack. 

Syntax Highlight 

Navicat uses syntax highlighting which depending on the database associated with the query. Different databases have 

different sets of reserved keywords. You can configure the associated colors for different text fragments in Options. 

Brace Highlight 

Navicat supports to highlight the matching brace in the editor, i.e. () . 

Note: The cursor must be on a brace to show the highlight. 

 

Find and Replace 

Find 

The Find bar is provided for quick searching for the text in the editor. Just simply choose Edit -> Find from the menu or 

press CTRL+F, and then enter a search string. 

The search starts at the cursor's current position to the end of the file. 

To find the next occurrence, just simply click Next or press F3. 

Replace 
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To open the Replace bar, simply check the Replace box. Then, enter the text you want to search and replace. 

Click the Replace button to replace the first occurrence. 

Click the Replace All button to replace all occurrences automatically. 

There are some additional options for Find and Replace, click : 

Option Description 

Highlight All Highlight all matches in the editor. 

Incremental Search Find matched text for the search string as each character is typed. 

Match Case Enable case sensitive search. 

Regular Expression Search regular expressions. 

Whole Word Return the objects that match the entire word of the search string. 

Copy with Quotes 

To copy the command with quotes, just simply right-click the highlighted command. Then, select Copy with quotes 

and choose the format. 

Word Wrap 

In the Word Wrap mode, the horizontal scrollbar is removed. Command that exceeds the width of the editor window 

size wraps to the next line. To enable Word Wrap, choose View -> Word Wrap. 

Zoom In/Zoom Out 

Navicat has the ability to zoom in or zoom out the command in the editor. The zooming options are available in View -> 

Display -> Zoom. The same effect can be achieved with keyboard shortcuts. 

Zoom In: [CTRL+=] 

Zoom Out: [CTRL+-] 

Reset: [CTRL+0] 

Note: Editors that are opened in different tabs or windows will not be affected by the zoom. 

Query Results 

You can run the query in any servers. Select the target connection and database from the drop-down list on the toolbar, 

and then click  Run. If the query command is correct, the query executes and, if the query command is supposed to 

return data, the Result tab opens with the data returned by the query. If an error occurs while executing the query, 

execution stops, the appropriate error message is displayed. 

Navicat displays query results in a user-friendly format. The Result tab displays the result data, returned by the query, 

as a grid. See Data Editor for details. 



 146 

 

Button Description 

 Editor Activate the editor for viewing and editing data. 

 Pin Pin the tab. 

Note: Navicat supports to return 20 result sets. 

You are allowed to run selected portion of query, just simply highlight commands in the editor and click  Run 

Selected. To run the current command your cursor is on (position the cursor within the desired command), just simply 

click the down arrow next to the  Run button and select Run Current Statement. 

Adjust Result Position 

In Navicat, you have the flexibility to configure how query results are displayed. You can choose to show the query 

results on an entire page, on the right side of the editor, or at the bottom of the editor. This allows you to adapt the 

display layout based on your specific needs and preferences during data analysis and exploration in Navicat. To 

change the result position, use the  or  icon located in the upper right corner, or access the View -> Result 

menu. 

Pin Query Result (Available only in Navicat Premium, Enterprise and Standard Edition) 

Existing result tabs are removed when you re-execute the query. You can pin a result tab so that it remains visible after 

re-executing the query. Simply click  Pin and its contents will not be cleared the next time you execute it. 

When you pin a tab, it will display a pin icon and automatically moves towards the left side of the tab bar. All pinned 

tabs appear from left to right in the order you pinned. Hover over a pinned tab will show its execution time and the query. 

You can pin any number of results and quickly see what's pinned and what's not pinned. Simply click  Unpin to 

unpin a tab. 

Custom Tab Name 

To customize the names of the result tabs, simply add // NAME:tab_name before each command in the Query Editor. 
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Code Snippets 

Code Snippets provide an easy way for you to insert reusable code into editor when writing statements or scripts. The 

Code Snippet pane is on the right side of the editor. If the editor window is docked to the Navicat main window, you can 

click the  icon in the Information pane to open the library. 

The library includes built-in and user-defined snippets. Choose a label from the drop-down list or enter a search string 

in the Search box to filter the list. If you want to show the available snippets according to your database type, you can 

right-click anywhere on the library and disable Show Snippets For Other Database Type. 

 

Built-in snippets are non-editable. A user-defined snippet can be edited by double-clicking it in the library. If you want to 

hide the built-in snippets, you can right-click anywhere on the library and disable Show Preset Snippets. 

Use Code Snippets 

There are two ways to insert a snippet into the editor. 

 You can start typing the name of a snippet in the editor. Smart code completion will pop up a list of suggestions 

for the word completion automatically. Select a snippet name from the list, the saved code will be inserted to the 

editor. 
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 You can simply drag and drop a snippet from the library into the editor. 

After inserting the snippet with placeholders to the editor, you can easily navigate to them by clicking on one of the 

placeholders, and then using the TAB key and entering the information. 

 

Create Code Snippets 

You can create your own code snippets and add them to the library. To create a code snippet, select your desired code 

in the editor, then right-click and select Create Snippet. 

Alternatively, click  in the Code Snippet pane. If you use this method, you must manually enter the code in the New 

Snippet window; code selected in the editor is not automatically added to the Code box. 

Hint: Code snippets (.nsnippet) are stored in the snippets folder under the Profiles Location. 

Option / Button Description 

Untitled text box Enter the name of the snippet that displays in the library and the code completion 

list. 

Database Type Choose the database server type of the snippet. 

Label Choose an existing label or enter a new label name for the snippet. 

Remarks Enter a description for the snippet that displays in the library. 

Code Enter the code. 

 

Add a placeholder by highlighting any words in the code and click this button. The 

placeholder will be highlighted in light green. 

 

Remove a placeholder by highlighting it in the code and click this button. 

Move / Copy Snippet To Project 

If you have logged in to Navicat Cloud or On-Prem Server, you can synchronize the custom snippet in My Connections 

to a project. 

1. Right-click a snippet and select Move Snippet To or Copy Snippet To. 

2. Select an existing project. 

3. The snippet will be moved or copied to the project. 

Hint: You can move / copy a snippet in a project to My Connections in a similar way. 

Ask AI (Available only in Navicat Premium, Enterprise and 



 149 

 

Standard Edition) 

Ask AI enables users to leverage AI in the process of writing queries, streamlining the query development workflow for 

enhanced efficiency and user experience. Users can instruct Ask AI to perform the following actions: 

• Explain SQL - Get a detailed explanation of your queries, including their components and functionality. 

• Optimize SQL - Enhance the performance and efficiency of queries through concrete optimization 

suggestions. 

• Beautify SQL - Automatically format code to improve readability and maintainability. 

• Convert SQL to another Database Type - Transform queries to be compatible with different database 

systems. 

When utilizing the default actions of Ask AI, the following information is transmitted to the AI provider: 

• The full text or selected text of your query. 

• The server version of the selected server in the editor. 

• The information of the selected schema in the editor. 

Additionally, you can customize AI actions, such as explaining queries and correcting errors. 

Explain SQL 

The Explain SQL feature offers detailed insights into your queries, aiding in the understanding of complex SQL 

statements. 

To explain a query 

1. Enter your query in the editor. 

2. Click the down arrow next to  Ask AI and select Explain SQL. 

3. The AI will instantly generate a detailed explanation of your query, including insights into its components. 

Optimize SQL 

The Optimize SQL feature provides actionable suggestions that help you optimize query execution, reduce resource 

consumption, and improve overall database performance. 

To obtain an optimized query 

1. Enter your query in the editor. 

2. Click the down arrow next to  Ask AI and select Optimize SQL. 
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3. The AI will instantly generate an optimized query. 

Hint: By default, differences are highlighted. You can right-click on the pane and uncheck Show Diff to turn off 

the highlighting. 

4. You can choose one of the following options for applying the code to the editor: 

Option Description 

Append to Editor Add the code to the end of the existing content. 

Replace All in Editor Clear the existing content and replace it entirely with the new code. 

Replace Selection in 

Editor 

Clear the selected content and replace it with the new code. 

Beautify SQL 

The Beautify SQL feature employs AI technology to automatically format queries, enhancing code readability and 

manageability. 

To obtain a beautified query 

1. Enter your query in the editor. 

2. Click the down arrow next to  Ask AI and select Beautify SQL. 

3. The AI will instantly generate a beautified query. 

Hint: By default, differences are highlighted. You can right-click on the pane and uncheck Show Diff to turn off 

the highlighting. 

4. You can choose one of the following options for applying the code to the editor: 

Option Description 

Append to Editor Add the code to the end of the existing content. 

Replace All in Editor Clear the existing content and replace it entirely with the new code. 

Replace Selection in 

Editor 

Clear the selected content and replace it with the new code. 

Convert SQL to another Database Type 

The Convert SQL to another Database Type feature assists in converting statements, views, and stored procedures to 

syntax compatible with Navicat-supported servers. 

To obtain a converted query 

1. Enter your query in the editor. 

2. Click the down arrow next to  Ask AI and select Convert SQL to another Database Type. 



 151 

 

3. Choose the database type and enter the version number. 

4. Click Convert. 

5. The AI will instantly generate a converted query. 

Hint: By default, differences are highlighted. You can right-click on the pane and uncheck Show Diff to turn off 

the highlighting. 

6. You can choose one of the following options for applying the code to the editor: 

Option Description 

Append to Editor Add the code to the end of the existing content. 

Replace All in Editor Clear the existing content and replace it entirely with the new code. 

Replace Selection in 

Editor 

Clear the selected content and replace it with the new code. 

Hint: You can click New Query to create a new query. 

Custom AI Action 

You can tailor AI actions by submitting specific questions and attaching relevant information. 

To customize an AI action 

1. Enter your query in the editor. 

2. Click  Ask AI. 

3. Enter your question. 

4. Choose the AI's response format. 

Option Description 

Code Instruct the AI to respond exclusively with code. 

Natural Language Instruct the AI to respond in a conversational or explanatory style. 

5. Click the following options to attached additional information to be sent to the AI provider. 

Option Description 

Selected Text The selected text in the query editor. 

All Text All text in the query editor. 

Current Schema Information about the selected schema in the query editor. 

Server Version The server version of the selected server in the query editor. 

6. Click Save Action to save the new AI action.  

Hint: You can hover over a new action in the left pane and click . The pinned action will be added to the  

Ask AI button as an item for easy access. 
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7. Click Ask AI to receive a response. 

8. You can choose one of the following options for applying the code to the editor: 

Option Description 

Insert at Editor Cursor Add the code where your cursor is currently positioned. 

Append to Editor Add the code to the end of the existing content. 

Replace All in Editor Clear the existing content and replace it entirely with the new code. 

Replace Selection in 

Editor 

Clear the selected content and replace it with the new code. 

Hint: If you selected Natural Language, you can click Continue in New Chat to continue chatting in the right AI 

Assistant pane. 

Fix Query with AI (Available only in Navicat Premium, Enterprise 

and Standard Edition) 

If a query fails to run and returns error, you can ask AI to debug the query and suggest a possible fix. 

To obtain a fix suggestion 

1. Select the Summary tab and locate the error. 

2. In the Query column, click Fix with AI. 

3. The AI will instantly generate a fix suggestion. 

Hint: By default, differences are highlighted. You can right-click on the pane and uncheck Show Diff to turn off 

the highlighting. 

4. You can choose one of the following options for applying the code to the editor: 

Option Description 

Append to Editor Add the code to the end of the existing content. 

Replace All in Editor Clear the existing content and replace it entirely with the new code. 

Replace Selection in 

Editor 

Clear the selected content and replace it with the new code. 

To explain the error message 

1. Select the Summary tab and locate the error. 

2. In the Message column, click Ask AI. 

3. The AI will instantly generate a detailed explanation of the error message. 
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Chapter 9 - AI Assistant (Available only in Navicat 

Premium, Enterprise and Standard Edition) 

About AI Assistant 

AI Assistant is a generative artificial intelligence (AI) powered conversational assistant that provides users with 

real-time suggestions and guidance while writing queries using natural language processing technology. It can chat 

queries, generate new statements, and perform query upgrades and improvements such as language updates, 

debugging, and optimization. AI Assistant helps users quickly access support for syntax, expressions, keywords, and 

more, ultimately improving query efficiency and accuracy. 

AI Assistant can be accessed via the information pane located in the main window. This feature is seamlessly 

integrated with various components, including queries, views, and functions, enhancing user interaction and 

productivity. 

With AI Assistant in Navicat, you can: 

• Interact with your databases using natural language. 

• Generate query statements. 

• Fix code mistakes. 

• Optimize SQL queries. 

• Select relevant data from your database. 

In Navicat, AI Assistant relies on external AI providers to complete tasks. To use the AI Assistant feature, you need an 

account from an AI provider. Here is the list of AI providers currently supported by Navicat: 

• OpenAI ChatGPT 

• Google Gemini 

• DeepSeek 

• Ollama 

• xAI Grok 

• Anthropic Claude 

• Alibaba Qwen 
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Enable & Configure AI Assistant 

Navicat provides users with the ability to enable and configure multiple AI Assistants. Here’s a comprehensive guide on 

how to do this effectively: 

1. On the Information pane, click . 

2. Click  -> Options. 

3. In the Options window, enable Enable AI Assistant. 

4. Click + and choose an AI provider to add an Assistant. 

5. Enter the AI Assistant information. See Options for details. 

6. Click OK. 

Hint: By enabling AI Assistant, you agree to our Navicat AI Assistant Disclaimer. 

Chat with AI 

Start New Chat 

After configured an AI Assistant, you can chat with it anytime on the AI Assistant pane. You can ask questions, which 

are answered by the AI Assistant. 

1. On the Information pane, click . 

2. Click . 

3. In the input field, type your question. 

4. Press ENTER to submit your message. 

Attach Database Schema 

You can enhance the quality of generated queries or replies with the context of a database/schema that you are 

working with. AI Assistant will get access to the structure of the attached schema, providing the information about it. 

1. On the Information pane, click . 

2. Click  -> Attach Schemas. 

3. Select the schema that you want to attach and click Attach. 

Copy Code to New Query Window 

1. Hover over a block of code. 
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2. Click . 

Insert Code to Current Editor 

1. Hover over a block of code. 

2. Click  and select an insert option. 

Change AI Assistant in Chat Room 

1. In the input field, click the down arrow next to the AI Assistant. 

2. Select your preferred assistant from the list. 

Compare Replies with Other Assistants 

After you receive an answer from the AI Assistant, you can compare it with responses from other assistants to evaluate 

the consistency and quality of the information provided. 

To initiate a comparison, simply select the option to view responses from other assistants after receiving your initial 

answer. 

Note: You can enable or disable this feature in Options. 
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Chapter 10 - Model (Available only in Navicat 

Premium and Enterprise Edition) 

About Model 

Model is a powerful tool for creating and manipulating database models. In the main window, click  Model to open 

the model object list. 

Note: Available only for MySQL, Oracle, PostgreSQL, SQLite, SQL Server, MariaDB, MongoDB and Snowflake. 

Some of key features are listed here: 

• Create and manipulate conceptual/logical/physical models.  

Note: Only Navicat Premium supports conceptual and logical models. 

• Support Relational, Dimensional and Data Vault modeling methods. 

• Reverse engineer databases/schemas to a model. 

• Forward engineer a physical model to a SQL/Script file or a database/schema. 

• Compare two model workspaces. 

• Generate data dictionaries from models. 

• Create and edit table structures directly. 

Hint: Model files (.nmodel) are saved under the Profiles Location. To open the folder, right-click a workspace file and 

select Open Containing Folder. If the workspace is synchronized to Navicat Cloud or On-Prem Server, it will be stored 

in the cloud. 

Open an external model file 

1. In the menu bar, choose File -> Open External File -> Model. 

2. Browse the file and click Open in the dialog window. 

Save an opened external file as a Navicat workspace 

1. In Workspace Designer, choose File -> Save to Navicat. 

2. Enter the model name and choose the save location. 

3. Click OK. 

Save a Navicat workspace as an external file 

1. In Workspace Designer, choose File -> Save As External File. 
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2. Choose the save path and enter the file name. 

3. Click Save. 

Workspace 

A workspace is the place that comprises models, diagrams and data dictionaries. You can create multiple models, 

diagrams and data dictionaries in a workspace. 

 

 Workspace Toolbar 

The Workspace Toolbar provides controls that you can use to create models, diagrams and data dictionaries. 

 Tab Bar 

The Tab Bar allows you to switch among the opened items. 

 Content Pane 

The Content pane shows all items in the workspace. To change the view, click the  Detail or  Icon button at the 

bottom of the window. 

Detail View displays additional information about each item. You can sort items in Detail View, click the column header 

by which you want to sort the items. 

Icon View displays your items as a grid of thumbnail images. You can filter the items by clicking a category (All, Model, 

Diagram, Data Dictionary) in this view. 

 Properties Pane 

The  General tab shows the general information of the workspace or the selected item. 
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If the Properties pane is hidden, choose View -> Show Properties from the menu bar. 

Model 

About Model 

A model is a collection of database objects that can be effectively utilized within diagrams. These objects can be 

reused across various diagrams, thereby increasing efficiency and consistency in the design and presentation of 

database structures. 

 

 Model Pane 

The Model pane is the basic way to navigate with databases/schemas, tables, views, functions or entities. 

 Object Toolbar 

The Object Toolbar provides controls that you can use to manipulate the object. 

 Object Pane 

The Object pane shows the objects you created in the model. 

 Properties Pane 

The  General tab shows the general information of the selected object. 

The  DDL tab shows the DDL of the selected object. 

If the Properties pane is hidden, choose View -> Show Properties from the menu bar. 

Create Conceptual Model 

The essential steps to create a conceptual model are: 

1. In the Workspace window, click  New Model. 
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2. Enter the name of the model and choose Conceptual. 

3. Click OK. 

4. A tab will open for you to edit the model. 

Conceptual models include the following core objects: 

• Entities 

Create Logical Model 

The essential steps to create a logical model are: 

1. In the Workspace window, click  New Model. 

2. Enter the name of the model and choose Logical. 

3. Click OK. 

4. A tab will open for you to edit the model. 

Logical models include the following core objects: 

• Entities 

Create Physical Model - Relational 

The essential steps to create a relational model are: 

1. In the Workspace window, click  New Model. 

2. Enter the name of the model and choose Physical. 

3. Select Relational modeling method. 

4. Select target database, and database version. 

5. Click OK. 

6. A tab will open for you to edit the model. 

Physical models include the following core objects: 

• Tables 

• Collections 

• Views 

• Function / Procedures 
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Create Physical Model - Dimensional 

The essential steps to create a dimensional model are: 

1. In the Workspace window, click  New Model. 

2. Enter the name of the model and choose Physical. 

3. Select Dimensional modeling method. 

4. Select target database, and database version. 

5. Click OK. 

6. A tab will open for you to edit the model. 

Physical models include the following core objects: 

• Tables 

• Collections 

• Views 

• Function / Procedures 

Create Physical Model - Data Vault 

The essential steps to create a data vault model are: 

1. In the Workspace window, click  New Model. 

2. Enter the name of the model and choose Physical. 

3. Select Data Vault modeling method. 

4. Select target database, and database version. 

5. Click OK. 

6. A tab will open for you to edit the model. 

Physical models include the following core objects: 

• Tables 

• Collections 

• Views 

• Function / Procedures 
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Create Database / Schema 

When creating a new model, a database (named default) is automatically created and it is the default database. 

You can view all databases/schemas with their objects as tree structure on the Model pane. 

To create a new database 

1. On the Model pane, right-click the model name or database and select New Database. 

2. Enter the name of the database. 

3. Click OK. 

To create a new schema 

1. On the Model pane, right-click the database or schema and select New Schema. 

2. Enter the name of the schema. 

3. Click OK. 

Create Table 

The essential steps to create a table are: 

1. On the Model tab, select Tables in the Model pane. 

2. Click  New Table, or click the down arrow and choose the table type. 

3. Enter the name of the table. 

4. Click OK. 

5. A tab will open for you to edit the table. 

Create View 

The essential steps to create a view are: 

1. On the Model tab, select Views in the Model pane. 

2. Click  New View. 

3. Enter the name of the view. 

4. Click OK. 

5. A tab will open for you to edit the view. 
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Create Function / Procedure 

The essential steps to create a function/procedure are: 

1. On the Model tab, select Functions in the Model pane. 

2. Click  New Function. 

3. Function Wizard will pop up and it allows you to create a function/procedure easily. 

4. Click Finish. 

5. A tab will open for you to edit the function/procedure. 

Create Collection 

The essential steps to create a collection are: 

1. On the Model tab, select Collections in the Model pane. 

2. Click  New Collection, or click the down arrow and choose the collection type. 

3. Enter the name of the collection. 

4. Click OK. 

5. A tab will open for you to edit the collection. 

Add Embedded Document 

1. Click  Add Field. 

2. Enter the name of the field and select object data type. 

3. Click the arrow icon left to the field name. 

4. Click  Add Field and define the item. 

Add Embedded Array of Documents 

1. Click  Add Field. 

2. Enter the name of the field and select object data type. 

3. Enable Is Array. 

4. Click the arrow icon left to the field name. 

5. Click  Add Field and define the item. 
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Add Predefined Object 

1. Click  Add Field. 

2. Enter the name of the field and select (Predefined Object) data type. 

3. Choose the predefined object. 

Create Predefined Object 

A predefined object refers to a specific document structure that is predefined or preconfigured. It is a predetermined 

schema or template that defines the fields and their data types within a MongoDB document. You can use predefined 

objects in any collection in the model to help maintain data integrity and establish consistent document structures. 

The essential steps to create a predefined object are: 

1. On the Model tab, select Predefined Object in the Model pane. 

2. Click  New Predefined Object. 

3. Enter the name of the predefined object. 

4. Click OK. 

5. A tab will open for you to edit the predefined object. 

Create Entity 

The essential steps to create an entity are: 

1. On the Model tab, select Entities in the Model pane. 

2. Click  New Entity. 

3. Enter the name of the entity. 

4. Click OK. 

5. A tab will open for you to edit the entity if your model is a logical model. 

Diagram 

About Diagram 

A diagram is a visual representation of the relationships and structure of a data model. It depicts the tables, fields, 

collections, entities, attributes, and relationships between them in a clear and concise manner. You can use it in 

database design and development processes to communicate and document the logical organization of data within 

your system. 
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 Object Pane 

The Object pane displays a list of all objects used in the diagram. 

 Toolbar 

The Toolbar is located near the top of the diagram. The buttons display in the toolbar depend on the model type 

(physical, logical and conceptual) and server type. You can use the toolbar to perform some basic tasks, such as 

adding tables, views, functions, collections or entities, applying Auto Layout feature, etc. 

 Canvas 

You can design your diagram on the Diagram Canvas. All added objects can be moved (by dragging them with mouse 

or by keyboard), resized, aligned to the grid, etc. 

 Properties Pane 

The  Properties tab includes the basic layout settings, object settings and so on. The properties vary with the type 

of the object selected. 

The  DDL tab shows the DDL of the selected object. 

 Overview Pane 

The Overview pane displays the whole active diagram in the canvas. To zoom in or zoom out the selected area of the 

diagram, adjust the slider. Same effect can be achieved with keyboard shortcuts: 

Zoom In: [CTRL++] or [CTRL+Mousewheel Up] 

Zoom out: [CTRL+-] or [CTRL+Mousewheel Down] 

Create Diagram 

The essential steps to create a diagram are: 
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1. In the Workspace window, click  New Diagram. 

2. Enter the name of the diagram. 

3. Click OK. 

4. A tab will open for you to edit the diagram. 

Properties 

Once you have selected the diagram canvas, you can customize the diagram by changing its properties: 

Option Description 

Diagram 

Default Model Choose the default model of the diagram. All objects created in the diagram 

belong to the default model. 

Diagram Notation Choose the notation of the diagram. 

Database Object Font Set the font style of the database objects. 

Black and white Change the diagram color to black and white. 

Show database object 

comments 

Show object comments in the diagram. 

Show table field 

comments 

Show field comments in the diagram. 

Show collection subfields Show subfields in MongoDB collections. 

Show database names Show the database names of objects in the diagram. 

Paper Size Set the paper size of the canvas. 

Pages Set the Width and Height (pages) of the canvas. 

 

Add Model Objects 

If you have already created a model, you can add existing objects in the model to the diagram. 

The essential steps to add a model object are: 

1. In the Diagram tab, click  Existing Model Objects. 

2. Choose a model. 

3. Double-click the object you want to insert into the diagram, or use the drag-and-drop method. 

Add Tables 

To add a new table 

1. Click the  button from the toolbar. 
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2. Place it on the canvas. 

3. Double-click the table to open the designer. 

Hint: The new table will also add to the default model. 

For Default diagram notation, the  icon means the field is a primary key. The icon indicates that the field serves 

as an index. 

The pop-up menu options of the table object in the canvas include: 

Option Description 

Design Table Edit the table structure in a table designer, e.g. fields, indexes, foreign keys, 

etc. The tabs and options in the designer depend on the diagram database 

type you are chosen. 

Add Related Objects Add all related objects to the selected table. 

Add Field Add a field at the end of the table. 

Insert Field Add a field above the selected field. 

Delete Field Delete the selected field. 

Primary Key Set the selected field as primary key. 

Rename Field Change the name of the selected field. 

Cut Remove the table from the diagram and put it on the clipboard. 

Copy Copy the table from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the table as a PNG file. 

Select All Connected 

Objects 

Select all objects in the diagram that are connected to the table. 

Select All Tables Select all tables in the diagram. 

Delete from Diagram / 

Delete from Diagram and 

Model 

Delete the table from the diagram or from both diagram and model. 

Rename Change the name of the table. 

Color Change the color of the table. 

Size to Fit Resize the table automatically to fit its contents. 

Bring to Front Bring the table to the foreground. 

Send to Back Move the table to the background. 

Group / Ungroup Group or ungroup the table and other objects in the diagram. 

Lock / Unlock Lock or unlock the table in the diagram. 

Properties 

Once you have selected the table, you can customize the table by changing its properties: 

Option Description 
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Table 

Table Name Enter the name of the table. 

Database Name Enter the name of the database to which the table belongs. 

Model Name Show the name of the model to which the table belongs. 

Position Customize the position of the table. 

Size Customize the size of the table. 

Style Choose the style of the table. 

Auto - Auto-arrange the table into a compact or standard style when 

resizing. 

Standard - Show the table name and its fields. 

Compact - Show a table icon with its name below the icon. 

Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 

Color Set the color of the table. 

Bold Make the table border bold. 

Group / Ungroup Group or ungroup the table and other objects in the diagram. 

Lock / Unlock Lock or unlock the table in the diagram. 

 

Add Collections 

To add a new collection 

1. Click the  button from the toolbar. 

2. Place it on the canvas. 

3. Double-click the collection to open the designer. 

Hint: The new collection will also add to the default model. 

For Default diagram notation, the  icon means the field is a primary key. The  icon indicates that the field serves 

as an index. 

The pop-up menu options of the collection object in the canvas include: 

Option Description 

Design Collection Edit the collection structure in a collection designer, e.g. fields, indexes, 

relations, etc. 

Add Related Objects Add all related objects to the selected collection. 

Add Field Add a field at the end of the collection. 

Insert Field Add a field above the selected field. 

Delete Field Delete the selected field. 

Primary Key Set the selected field as primary key. 

Rename Field Change the name of the selected field. 

Cut Remove the collection from the diagram and put it on the clipboard. 
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Copy Copy the collection from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the collection as a PNG file. 

Select All Connected 

Objects 

Select all objects in the diagram that are connected to the collection. 

Select All Collections Select all collections in the diagram. 

Delete from Diagram / 

Delete from Diagram and 

Model 

Delete the collection from the diagram or from both diagram and model. 

Rename Change the name of the collection. 

Color Change the color of the collection. 

Size to Fit Resize the collection automatically to fit its contents. 

Bring to Front Bring the collection to the foreground. 

Send to Back Move the collection to the background. 

Group / Ungroup Group or ungroup the collection and other objects in the diagram. 

Lock / Unlock Lock or unlock the collection in the diagram. 

Properties 

Once you have selected the collection, you can customize the collection by changing its properties: 

Option Description 

Collection 

Collection Name Enter the name of the collection. 

Database Name Enter the name of the database to which the collection belongs. 

Model Name Show the name of the model to which the collection belongs. 

Position Customize the position of the collection. 

Size Customize the size of the collection. 

Style Choose the style of the collection. 

Auto - Auto-arrange the collection into a compact or standard style when 

resizing. 

Standard - Show the collection name and its fields. 

Compact - Show a collection icon with its name below the icon. 

Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 

Color Set the color of the collection. 

Bold Make the collection border bold. 

Group / Ungroup Group or ungroup the collection and other objects in the diagram. 

Lock / Unlock Lock or unlock the collection in the diagram. 

 

Add Dimensions 

A dimension table is a key component in data warehousing and is used in star schema designs. It typically contains 

descriptive fields that provide context to the data in fact tables. 
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To add a new table 

1. Click the  button from the toolbar. 

2. Place it on the canvas. 

3. Double-click the table to open the designer. 

Hint: The new table will also add to the default model. 

For Default diagram notation, the  icon means the field is a primary key. The  icon indicates that the field serves 

as an index. 

The pop-up menu options of the table object in the canvas include: 

Option Description 

Design Table Edit the table structure in a table designer, e.g. fields, indexes, foreign keys, 

etc. The tabs and options in the designer depend on the diagram database 

type you are chosen. 

Add Related Objects Add all related objects to the selected table. 

Add Field Add a field at the end of the table. 

Insert Field Add a field above the selected field. 

Delete Field Delete the selected field. 

Primary Key Set the selected field as primary key. 

Rename Field Change the name of the selected field. 

Cut Remove the table from the diagram and put it on the clipboard. 

Copy Copy the table from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the table as a PNG file. 

Select All Connected 

Objects 

Select all objects in the diagram that are connected to the table. 

Select All Tables Select all tables in the diagram. 

Select All Dimensions Select all dimension tables in the diagram. 

Delete from Diagram / 

Delete from Diagram and 

Model 

Delete the table from the diagram or from both diagram and model. 

Rename Change the name of the table. 

Color Change the color of the table. 

Size to Fit Resize the table automatically to fit its contents. 

Bring to Front Bring the table to the foreground. 

Send to Back Move the table to the background. 

Group / Ungroup Group or ungroup the table and other objects in the diagram. 

Lock / Unlock Lock or unlock the table in the diagram. 
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Properties 

Once you have selected the table, you can customize the table by changing its properties: 

Option Description 

Table 

Table Name Enter the name of the table. 

Database Name Enter the name of the database to which the table belongs. 

Model Name Show the name of the model to which the table belongs. 

Position Customize the position of the table. 

Size Customize the size of the table. 

Style Choose the style of the table. 

Auto - Auto-arrange the table into a compact or standard style when 

resizing. 

Standard - Show the table name and its fields. 

Compact - Show a table icon with its name below the icon. 

Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 

Color Set the color of the table. 

Bold Make the table border bold. 

Group / Ungroup Group or ungroup the table and other objects in the diagram. 

Lock / Unlock Lock or unlock the table in the diagram. 

 

Add Facts 

A fact table in data modeling is a central component of a data warehouse that stores quantitative data for analysis and 

reporting. It typically contains measurable, numerical data about business processes and events, allowing users to 

perform various types of analysis. 

To add a new table 

1. Click the  button from the toolbar. 

2. Place it on the canvas. 

3. Double-click the table to open the designer. 

Hint: The new table will also add to the default model. 

For Default diagram notation, the  icon means the field is a primary key. The  icon indicates that the field serves 

as an index. 

The pop-up menu options of the table object in the canvas include: 

Option Description 

Design Table Edit the table structure in a table designer, e.g. fields, indexes, foreign keys, 
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etc. The tabs and options in the designer depend on the diagram database 

type you are chosen. 

Add Related Objects Add all related objects to the selected table. 

Add Field Add a field at the end of the table. 

Insert Field Add a field above the selected field. 

Delete Field Delete the selected field. 

Primary Key Set the selected field as primary key. 

Rename Field Change the name of the selected field. 

Cut Remove the table from the diagram and put it on the clipboard. 

Copy Copy the table from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the table as a PNG file. 

Select All Connected 

Objects 

Select all objects in the diagram that are connected to the table. 

Select All Tables Select all tables in the diagram. 

Select All Facts Select all fact tables in the diagram. 

Delete from Diagram / 

Delete from Diagram and 

Model 

Delete the table from the diagram or from both diagram and model. 

Rename Change the name of the table. 

Color Change the color of the table. 

Size to Fit Resize the table automatically to fit its contents. 

Bring to Front Bring the table to the foreground. 

Send to Back Move the table to the background. 

Group / Ungroup Group or ungroup the table and other objects in the diagram. 

Lock / Unlock Lock or unlock the table in the diagram. 

Properties 

Once you have selected the table, you can customize the table by changing its properties: 

Option Description 

Table 

Table Name Enter the name of the table. 

Database Name Enter the name of the database to which the table belongs. 

Model Name Show the name of the model to which the table belongs. 

Position Customize the position of the table. 

Size Customize the size of the table. 

Style Choose the style of the table. 

Auto - Auto-arrange the table into a compact or standard style when 

resizing. 

Standard - Show the table name and its fields. 

Compact - Show a table icon with its name below the icon. 
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Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 

Color Set the color of the table. 

Bold Make the table border bold. 

Group / Ungroup Group or ungroup the table and other objects in the diagram. 

Lock / Unlock Lock or unlock the table in the diagram. 

 

Add Outriggers 

An outrigger table is a type of table used in a star schema that extends the dimensional model by providing additional 

detail to a dimension table. It is typically used to normalize complex dimensions and can help manage hierarchical 

relationships or provide more detailed attributes without cluttering the main dimension table. 

To add a new table 

1. Click the  button from the toolbar. 

2. Place it on the canvas. 

3. Double-click the table to open the designer. 

Hint: The new table will also add to the default model. 

For Default diagram notation, the  icon means the field is a primary key. The  icon indicates that the field serves 

as an index. 

The pop-up menu options of the table object in the canvas include: 

Option Description 

Design Table Edit the table structure in a table designer, e.g. fields, indexes, foreign keys, 

etc. The tabs and options in the designer depend on the diagram database 

type you are chosen. 

Add Related Objects Add all related objects to the selected table. 

Add Field Add a field at the end of the table. 

Insert Field Add a field above the selected field. 

Delete Field Delete the selected field. 

Primary Key Set the selected field as primary key. 

Rename Field Change the name of the selected field. 

Cut Remove the table from the diagram and put it on the clipboard. 

Copy Copy the table from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the table as a PNG file. 

Select All Connected 

Objects 

Select all objects in the diagram that are connected to the table. 

Select All Tables Select all tables in the diagram. 

Select All Outriggers Select all outrigger tables in the diagram. 
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Delete from Diagram / 

Delete from Diagram and 

Model 

Delete the table from the diagram or from both diagram and model. 

Rename Change the name of the table. 

Color Change the color of the table. 

Size to Fit Resize the table automatically to fit its contents. 

Bring to Front Bring the table to the foreground. 

Send to Back Move the table to the background. 

Group / Ungroup Group or ungroup the table and other objects in the diagram. 

Lock / Unlock Lock or unlock the table in the diagram. 

Properties 

Once you have selected the table, you can customize the table by changing its properties: 

Option Description 

Table 

Table Name Enter the name of the table. 

Database Name Enter the name of the database to which the table belongs. 

Model Name Show the name of the model to which the table belongs. 

Position Customize the position of the table. 

Size Customize the size of the table. 

Style Choose the style of the table. 

Auto - Auto-arrange the table into a compact or standard style when 

resizing. 

Standard - Show the table name and its fields. 

Compact - Show a table icon with its name below the icon. 

Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 

Color Set the color of the table. 

Bold Make the table border bold. 

Group / Ungroup Group or ungroup the table and other objects in the diagram. 

Lock / Unlock Lock or unlock the table in the diagram. 

 

Add Hubs 

A hub table is designed for handling large-scale data warehousing and analytics. It serves as the central repository for 

storing unique business keys and their associated metadata, providing a foundation for tracking and managing data 

across multiple operational systems. 

To add a new table 

1. Click the  button from the toolbar. 

2. Place it on the canvas. 
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3. Double-click the table to open the designer. 

Hint: The new table will also add to the default model. 

For Default diagram notation, the  icon means the field is a primary key. The  icon indicates that the field serves 

as an index. 

The pop-up menu options of the table object in the canvas include: 

Option Description 

Design Table Edit the table structure in a table designer, e.g. fields, indexes, foreign keys, 

etc. The tabs and options in the designer depend on the diagram database 

type you are chosen. 

Add Related Objects Add all related objects to the selected table. 

Add Field Add a field at the end of the table. 

Insert Field Add a field above the selected field. 

Delete Field Delete the selected field. 

Primary Key Set the selected field as primary key. 

Rename Field Change the name of the selected field. 

Cut Remove the table from the diagram and put it on the clipboard. 

Copy Copy the table from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the table as a PNG file. 

Select All Connected 

Objects 

Select all objects in the diagram that are connected to the table. 

Select All Tables Select all tables in the diagram. 

Select All Hubs Select all hub tables in the diagram. 

Delete from Diagram / 

Delete from Diagram and 

Model 

Delete the table from the diagram or from both diagram and model. 

Rename Change the name of the table. 

Color Change the color of the table. 

Size to Fit Resize the table automatically to fit its contents. 

Bring to Front Bring the table to the foreground. 

Send to Back Move the table to the background. 

Group / Ungroup Group or ungroup the table and other objects in the diagram. 

Lock / Unlock Lock or unlock the table in the diagram. 

Properties 

Once you have selected the table, you can customize the table by changing its properties: 

Option Description 

Table 
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Table Name Enter the name of the table. 

Database Name Enter the name of the database to which the table belongs. 

Model Name Show the name of the model to which the table belongs. 

Position Customize the position of the table. 

Size Customize the size of the table. 

Style Choose the style of the table. 

Auto - Auto-arrange the table into a compact or standard style when resizing. 

Standard - Show the table name and its fields. 

Compact - Show a table icon with its name below the icon. 

Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 

Color Set the color of the table. 

Bold Make the table border bold. 

Group / Ungroup Group or ungroup the table and other objects in the diagram. 

Lock / Unlock Lock or unlock the table in the diagram. 

 

Add Links 

A link table is used to establish and manage relationships between hub tables. It plays a crucial role in connecting 

different entities represented by the hub tables, allowing for a more flexible and comprehensive data model. 

To add a new table 

1. Click the  button from the toolbar. 

2. Place it on the canvas. 

3. Double-click the table to open the designer. 

Hint: The new table will also add to the default model. 

For Default diagram notation, the  icon means the field is a primary key. The  icon indicates that the field serves 

as an index. 

The pop-up menu options of the table object in the canvas include: 

Option Description 

Design Table Edit the table structure in a table designer, e.g. fields, indexes, foreign keys, 

etc. The tabs and options in the designer depend on the diagram database 

type you are chosen. 

Add Related Objects Add all related objects to the selected table. 

Add Field Add a field at the end of the table. 

Insert Field Add a field above the selected field. 

Delete Field Delete the selected field. 

Primary Key Set the selected field as primary key. 

Rename Field Change the name of the selected field. 
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Cut Remove the table from the diagram and put it on the clipboard. 

Copy Copy the table from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the table as a PNG file. 

Select All Connected 

Objects 

Select all objects in the diagram that are connected to the table. 

Select All Tables Select all tables in the diagram. 

Select All Links Select all link tables in the diagram. 

Delete from Diagram / 

Delete from Diagram and 

Model 

Delete the table from the diagram or from both diagram and model. 

Rename Change the name of the table. 

Color Change the color of the table. 

Size to Fit Resize the table automatically to fit its contents. 

Bring to Front Bring the table to the foreground. 

Send to Back Move the table to the background. 

Group / Ungroup Group or ungroup the table and other objects in the diagram. 

Lock / Unlock Lock or unlock the table in the diagram. 

Properties 

Once you have selected the table, you can customize the table by changing its properties: 

Option Description 

Table 

Table Name Enter the name of the table. 

Database Name Enter the name of the database to which the table belongs. 

Model Name Show the name of the model to which the table belongs. 

Position Customize the position of the table. 

Size Customize the size of the table. 

Style Choose the style of the table. 

Auto - Auto-arrange the table into a compact or standard style when 

resizing. 

Standard - Show the table name and its fields. 

Compact - Show a table icon with its name below the icon. 

Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 

Color Set the color of the table. 

Bold Make the table border bold. 

Group / Ungroup Group or ungroup the table and other objects in the diagram. 

Lock / Unlock Lock or unlock the table in the diagram. 
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Add Satellites 

A satellite table is designed to store descriptive attributes and historical changes related to the entities represented by 

hub tables and relationships defined by link tables. It enhances the overall flexibility and scalability of the data model. 

To add a new table 

1. Click the  button from the toolbar. 

2. Place it on the canvas. 

3. Double-click the table to open the designer. 

Hint: The new table will also add to the default model. 

For Default diagram notation, the  icon means the field is a primary key. The  icon indicates that the field serves 

as an index. 

The pop-up menu options of the table object in the canvas include: 

Option Description 

Design Table Edit the table structure in a table designer, e.g. fields, indexes, foreign keys, 

etc. The tabs and options in the designer depend on the diagram database 

type you are chosen. 

Add Related Objects Add all related objects to the selected table. 

Add Field Add a field at the end of the table. 

Insert Field Add a field above the selected field. 

Delete Field Delete the selected field. 

Primary Key Set the selected field as primary key. 

Rename Field Change the name of the selected field. 

Cut Remove the table from the diagram and put it on the clipboard. 

Copy Copy the table from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the table as a PNG file. 

Select All Connected 

Objects 

Select all objects in the diagram that are connected to the table. 

Select All Tables Select all tables in the diagram. 

Select All Satellites Select all satellite tables in the diagram. 

Delete from Diagram / 

Delete from Diagram and 

Model 

Delete the table from the diagram or from both diagram and model. 

Rename Change the name of the table. 

Color Change the color of the table. 

Size to Fit Resize the table automatically to fit its contents. 

Bring to Front Bring the table to the foreground. 
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Send to Back Move the table to the background. 

Group / Ungroup Group or ungroup the table and other objects in the diagram. 

Lock / Unlock Lock or unlock the table in the diagram. 

Properties 

Once you have selected the table, you can customize the table by changing its properties: 

Option Description 

Table 

Table Name Enter the name of the table. 

Database Name Enter the name of the database to which the table belongs. 

Model Name Show the name of the model to which the table belongs. 

Position Customize the position of the table. 

Size Customize the size of the table. 

Style Choose the style of the table. 

Auto - Auto-arrange the table into a compact or standard style when 

resizing. 

Standard - Show the table name and its fields. 

Compact - Show a table icon with its name below the icon. 

Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 

Color Set the color of the table. 

Bold Make the table border bold. 

Group / Ungroup Group or ungroup the table and other objects in the diagram. 

Lock / Unlock Lock or unlock the table in the diagram. 

 

Add Bridges 

A bridge table is used to resolve many-to-many relationships between two dimension tables in a star schema within a 

data warehouse. It acts as an intermediary that allows for the linking of data from two or more tables, facilitating more 

complex queries and analyses. 

To add a new table 

1. Click the  button from the toolbar. 

2. Place it on the canvas. 

3. Double-click the table to open the designer. 

Hint: The new table will also add to the default model. 

For Default diagram notation, the  icon means the field is a primary key. The  icon indicates that the field serves 

as an index. 

The pop-up menu options of the table object in the canvas include: 
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Option Description 

Design Table Edit the table structure in a table designer, e.g. fields, indexes, foreign keys, 

etc. The tabs and options in the designer depend on the diagram database 

type you are chosen. 

Add Related Objects Add all related objects to the selected table. 

Add Field Add a field at the end of the table. 

Insert Field Add a field above the selected field. 

Delete Field Delete the selected field. 

Primary Key Set the selected field as primary key. 

Rename Field Change the name of the selected field. 

Cut Remove the table from the diagram and put it on the clipboard. 

Copy Copy the table from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the table as a PNG file. 

Select All Connected 

Objects 

Select all objects in the diagram that are connected to the table. 

Select All Tables Select all tables in the diagram. 

Select All Bridges Select all bridge tables in the diagram. 

Delete from Diagram / 

Delete from Diagram and 

Model 

Delete the table from the diagram or from both diagram and model. 

Rename Change the name of the table. 

Color Change the color of the table. 

Size to Fit Resize the table automatically to fit its contents. 

Bring to Front Bring the table to the foreground. 

Send to Back Move the table to the background. 

Group / Ungroup Group or ungroup the table and other objects in the diagram. 

Lock / Unlock Lock or unlock the table in the diagram. 

Properties 

Once you have selected the table, you can customize the table by changing its properties: 

Option Description 

Table 

Table Name Enter the name of the table. 

Database Name Enter the name of the database to which the table belongs. 

Model Name Show the name of the model to which the table belongs. 

Position Customize the position of the table. 

Size Customize the size of the table. 

Style Choose the style of the table. 

Auto - Auto-arrange the table into a compact or standard style when 
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resizing. 

Standard - Show the table name and its fields. 

Compact - Show a table icon with its name below the icon. 

Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 

Color Set the color of the table. 

Bold Make the table border bold. 

Group / Ungroup Group or ungroup the table and other objects in the diagram. 

Lock / Unlock Lock or unlock the table in the diagram. 

 

Add Point In Time 

A point-in-time table is a type of table that captures the state of data at a specific moment, often used in scenarios 

where historical accuracy and auditability are critical. These tables are particularly useful for tracking changes over time, 

enabling users to analyze data as it existed at particular points in history. 

To add a new table 

1. Click the  button from the toolbar. 

2. Place it on the canvas. 

3. Double-click the table to open the designer. 

Hint: The new table will also add to the default model. 

For Default diagram notation, the  icon means the field is a primary key. The  icon indicates that the field serves 

as an index. 

The pop-up menu options of the table object in the canvas include: 

Option Description 

Design Table Edit the table structure in a table designer, e.g. fields, indexes, foreign keys, 

etc. The tabs and options in the designer depend on the diagram database 

type you are chosen. 

Add Related Objects Add all related objects to the selected table. 

Add Field Add a field at the end of the table. 

Insert Field Add a field above the selected field. 

Delete Field Delete the selected field. 

Primary Key Set the selected field as primary key. 

Rename Field Change the name of the selected field. 

Cut Remove the table from the diagram and put it on the clipboard. 

Copy Copy the table from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the table as a PNG file. 

Select All Connected Select all objects in the diagram that are connected to the table. 
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Objects 

Select All Tables Select all tables in the diagram. 

Select All Point In Time Select all point in time tables in the diagram. 

Delete from Diagram / 

Delete from Diagram and 

Model 

Delete the table from the diagram or from both diagram and model. 

Rename Change the name of the table. 

Color Change the color of the table. 

Size to Fit Resize the table automatically to fit its contents. 

Bring to Front Bring the table to the foreground. 

Send to Back Move the table to the background. 

Group / Ungroup Group or ungroup the table and other objects in the diagram. 

Lock / Unlock Lock or unlock the table in the diagram. 

Properties 

Once you have selected the table, you can customize the table by changing its properties: 

Option Description 

Table 

Table Name Enter the name of the table. 

Database Name Enter the name of the database to which the table belongs. 

Model Name Show the name of the model to which the table belongs. 

Position Customize the position of the table. 

Size Customize the size of the table. 

Style Choose the style of the table. 

Auto - Auto-arrange the table into a compact or standard style when 

resizing. 

Standard - Show the table name and its fields. 

Compact - Show a table icon with its name below the icon. 

Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 

Color Set the color of the table. 

Bold Make the table border bold. 

Group / Ungroup Group or ungroup the table and other objects in the diagram. 

Lock / Unlock Lock or unlock the table in the diagram. 

 

Add References 

A reference table serves a specific purpose in providing additional context or metadata about the data stored in the 

core components of the Data Vault, primarily hub, link, and satellite tables. 

To add a new table 

1. Click the  button from the toolbar. 
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2. Place it on the canvas. 

3. Double-click the table to open the designer. 

Hint: The new table will also add to the default model. 

For Default diagram notation, the  icon means the field is a primary key. The  icon indicates that the field serves 

as an index. 

The pop-up menu options of the table object in the canvas include: 

Option Description 

Design Table Edit the table structure in a table designer, e.g. fields, indexes, foreign keys, 

etc. The tabs and options in the designer depend on the diagram database 

type you are chosen. 

Add Related Objects Add all related objects to the selected table. 

Add Field Add a field at the end of the table. 

Insert Field Add a field above the selected field. 

Delete Field Delete the selected field. 

Primary Key Set the selected field as primary key. 

Rename Field Change the name of the selected field. 

Cut Remove the table from the diagram and put it on the clipboard. 

Copy Copy the table from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the table as a PNG file. 

Select All Connected 

Objects 

Select all objects in the diagram that are connected to the table. 

Select All Tables Select all tables in the diagram. 

Select All References Select all reference tables in the diagram. 

Delete from Diagram / 

Delete from Diagram and 

Model 

Delete the table from the diagram or from both diagram and model. 

Rename Change the name of the table. 

Color Change the color of the table. 

Size to Fit Resize the table automatically to fit its contents. 

Bring to Front Bring the table to the foreground. 

Send to Back Move the table to the background. 

Group / Ungroup Group or ungroup the table and other objects in the diagram. 

Lock / Unlock Lock or unlock the table in the diagram. 

Properties 

Once you have selected the table, you can customize the table by changing its properties: 
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Option Description 

Table 

Table Name Enter the name of the table. 

Database Name Enter the name of the database to which the table belongs. 

Model Name Show the name of the model to which the table belongs. 

Position Customize the position of the table. 

Size Customize the size of the table. 

Style Choose the style of the table. 

Auto - Auto-arrange the table into a compact or standard style when resizing. 

Standard - Show the table name and its fields. 

Compact - Show a table icon with its name below the icon. 

Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 

Color Set the color of the table. 

Bold Make the table border bold. 

Group / Ungroup Group or ungroup the table and other objects in the diagram. 

Lock / Unlock Lock or unlock the table in the diagram. 

 

Add Foreign Keys 

To add a foreign key 

1. Click the  button from the toolbar. 

2. Drag and drop the field of the child table/collection to the field of the parent table/collection. 

OR 

Drag and drop the child field to the empty space of the parent table/collection. The referenced field will be 

automatically created in the parent table/collection. 

3. Double-click the foreign key connector to open the designer. 

Hint: When you hover over a foreign key line, the referenced fields and the referencing fields are highlighted. 

The pop-up menu options of the foreign key in the canvas include: 

Option Description 

Design Foreign Key Edit the foreign key in a table designer. The options in the designer depend 

on the diagram database type you are chosen. 

Go to Go to and select the connected table/collection. 

Reroute Connectors Reroute the connector to the closest points between two connected objects. 

Copy Copy the foreign key from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the foreign key as a PNG file. 

Select All Connected 

Objects 

Select all objects in the diagram that are connected by the foreign key. 
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Select All Relations Select all foreign keys in the diagram. 

Delete from Diagram and 

Model 

Delete a foreign key from both diagram and model. 

Color Change the color of the foreign key. 

Group / Ungroup Group or ungroup the foreign key and other objects in the diagram. 

Lock / Unlock Lock or unlock the foreign key in the diagram. 

Properties 

Once you have selected the foreign key, you can customize the foreign key by changing its properties: 

Option Description 

Foreign Key 

Name Enter the name of the foreign key. 

Position Customize the position of the line. 

Offset Customize offset values for the start and end of the line. 

Show name Display the name of the foreign key. 

Font Set the font style of the name. 

Bold Apply a bold style to the name. 

Italic Apply an italic style to the name. 

Color Set the color of the line. 

Line Width Choose the thickness of the line. 

Cardinality Specify the relationship cardinality of the table/collection. 

Visible Show the connector. 

Group / Ungroup Group or ungroup the foreign key and other objects in the diagram. 

Lock / Unlock Lock or unlock the foreign key in the diagram. 

 

Add Views 

To add a new view 

1. Click the  button from the toolbar. 

2. Place it on the canvas. 

3. Double-click the view to open the designer. 

Hint: The new view will also add to the default model. 

The pop-up menu options of the view object in the canvas include: 

Option Description 

Design View Edit the view structure in a view designer. The tabs and options in the 

designer depend on the diagram database type you are chosen. 

Add Related Objects Add all related objects to the selected view. 
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Cut Remove the view from the diagram and put it on the clipboard. 

Copy Copy the view from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the view as a PNG file. 

Select All Views Select all views in the diagram. 

Delete from Diagram / 

Delete from Diagram and 

Model 

Delete the view from the diagram or from both diagram and model. 

Rename Change the name of the view. 

Color Change the color of the view. 

Size to Fit Resize the view automatically to fit its contents. 

Bring to Front Bring the view to the foreground. 

Send to Back Move the view to the background. 

Group / Ungroup Group or ungroup the view and other objects in the diagram. 

Lock / Unlock Lock or unlock the view in the diagram. 

Properties 

Once you have selected the view, you can customize the view by changing its properties: 

Option Description 

View 

View Name Enter the name of the view. 

Database Name Enter the name of the database to which the view belongs. 

Model Name Show the name of the model to which the view belongs. 

Position Customize the position of the view. 

Size Customize the size of the view. 

Style Choose the style of the view. 

Auto - Auto-arrange the view into a compact or standard style when resizing. 

Standard - Show the view name and its content. 

Compact - Show a view icon with its name below the icon. 

Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 

Color Set the color of the view. 

Bold Make the view border bold. 

Group / Ungroup Group or ungroup the view and other objects in the diagram. 

Lock / Unlock Lock or unlock the view in the diagram. 

 

Add Functions / Procedures 

To add a new function/procedure 

1. Click the  or  button from the toolbar. 

2. Place it on the canvas. 
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3. Double-click the function/procedure to open the designer. 

Hint: The new function/procedure will also add to the default model. 

The pop-up menu options of the function/procedure object in the canvas include: 

Option Description 

Design Function / Design 

Procedure 

Edit the function/procedure structure in a function/procedure designer. The 

tabs and options in the designer depend on the diagram database type you 

are chosen. 

Cut Remove the function/procedure from the diagram and put it on the clipboard. 

Copy Copy the function/procedure from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the function/procedure as a PNG file. 

Select All Functions Select all functions/procedures in the diagram. 

Delete from Diagram / 

Delete from Diagram and 

Model 

Delete the function/procedure from the diagram or from both diagram and 

model. 

Rename Change the name of the function/procedure. 

Color Change the color of the function/procedure. 

Size to Fit Resize the function/procedure automatically to fit its contents. 

Bring to Front Bring the function/procedure to the foreground. 

Send to Back Move the function/procedure to the background. 

Group / Ungroup Group or ungroup the function/procedure and other objects in the diagram. 

Lock / Unlock Lock or unlock the function/procedure in the diagram. 

Properties 

Once you have selected the function/procedure, you can customize the function/procedure by changing its properties: 

Option Description 

Function / Procedure 

Function Name / 

Procedure Name 

Enter the name of the function/procedure. 

Database Name Enter the name of the database to which the function/procedure belongs. 

Model Name Show the name of the model to which the function/procedure belongs. 

Position Customize the position of the function/procedure. 

Size Customize the size of the function/procedure. 

Style Choose the style of the function/procedure. 

Auto - Auto-arrange the function/procedure into a compact or standard style 

when resizing. 

Standard - Show the function/procedure name and its content. 

Compact - Show a function/procedure icon with its name below the icon. 

Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 
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Color Set the color of the function/procedure. 

Bold Make the function/procedure border bold. 

Group / Ungroup Group or ungroup the function/procedure and other objects in the diagram. 

Lock / Unlock Lock or unlock the function/procedure in the diagram. 

 

Add Entities 

To add a new entity 

1. Click the  button from the toolbar. 

2. Place it on the canvas. 

3. [Logical Model] Double-click the entity to open the designer. 

Hint: The new entity will also add to the default model. 

For Default diagram notation, the  icon means the attribute is a primary key. The  icon indicates that the 

attribute serves as an index. 

The pop-up menu options of the entity object in the canvas include: 

Option Description 

Design Entity Edit the entity structure in an entity designer, e.g. attributes, indexes, 

relations, etc. 

Only for Logical Model. 

Add Related Objects Add all related objects to the selected entity. 

Add Attribute Add an attribute at the end of the entity. 

Insert Attribute Add an attribute above the selected attribute. 

Delete Attribute Delete the selected attribute. 

Primary Key Set the selected attribute as primary key. 

Rename Attribute Change the name of the selected attribute. 

Cut Remove the entity from the diagram and put it on the clipboard. 

Copy Copy the entity from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the entity as a PNG file. 

Select All Connected 

Objects 

Select all objects in the diagram that are connected to the entity. 

Select All Entities Select all entities in the diagram. 

Delete from Diagram / 

Delete from Diagram and 

Model 

Delete the entity from the diagram or from both diagram and model. 

Rename Change the name of the entity. 

Color Change the color of the entity. 
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Size to Fit Resize the entity automatically to fit its contents. 

Bring to Front Bring the entity to the foreground. 

Send to Back Move the entity to the background. 

Group / Ungroup Group or ungroup the entity and other objects in the diagram. 

Lock / Unlock Lock or unlock the entity in the diagram. 

Properties 

Once you have selected the entity, you can customize the entity by changing its properties: 

Option Description 

Entity 

Entity Name Enter the name of the entity. 

Database Name Enter the name of the database to which the entity belongs. 

Model Name Show the name of the model to which the entity belongs. 

Position Customize the position of the entity. 

Size Customize the size of the entity. 

Style Choose the style of the entity. 

Auto - Auto-arrange the entity into a compact or standard style when 

resizing. 

Standard - Show the entity name and/or its attributes. 

Compact - Show an entity icon with its name below the icon. 

Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 

Color Set the color of the entity. 

Bold Make the entity border bold. 

Group / Ungroup Group or ungroup the entity and other objects in the diagram. 

Lock / Unlock Lock or unlock the entity in the diagram. 

 

Add Labels 

Labels are typically used to help document the diagram design process. For example, to explain a grouping table 

objects. 

To add a new label 

1. Click the  button from the toolbar. 

2. Place it on the canvas. 

3. Enter the caption. 

The pop-up menu options of the label object in the canvas include: 

Option Description 

Cut Remove the label from the diagram and put it on the clipboard. 
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Copy Copy the label from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the label as a PNG file. 

Select All Labels Select all labels in the diagram. 

Delete from Diagram Delete a label from the diagram. 

Size to Fit Resize the label automatically to fit its contents. 

Bring to Front Bring the label to the foreground. 

Send to Back Move the label to the background. 

Group / Ungroup Group or ungroup the label and other objects in the diagram. 

Lock / Unlock Lock or unlock the label in the diagram. 

Properties 

Once you have selected the label, you can customize the label by changing its properties: 

Option Description 

Label 

Name Enter the name of the label. 

Position Customize the position of the label. 

Size Customize the size of the label. 

Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 

Font Set the font style of the label caption. 

Bold Apply a bold style to the label caption. 

Italic Apply an italic style to the label caption. 

URL Enter URL path to set the text as a hyperlink. 

Group / Ungroup Group or ungroup the label and other objects in the diagram. 

Lock / Unlock Lock or unlock the label in the diagram. 

 

Add Notes 

Notes are typically used to help document the diagram design process. For example, to explain a grouping table 

objects. 

To add a new note 

1. Click the  button from the toolbar. 

2. Place it on the canvas. 

3. Enter the content. 

The pop-up menu options of the note object in the canvas include: 

Option Description 

Cut Remove the note from the diagram and put it on the clipboard. 
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Copy Copy the note from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the note as a PNG file. 

Select All Notes Select all notes in the diagram. 

Delete from Diagram Delete a note from the diagram. 

Color Change the color of the note. 

Size to Fit Resize the note automatically to fit its contents. 

Bring to Front Bring the note to the foreground. 

Send to Back Move the note to the background. 

Group / Ungroup Group or ungroup the note and other objects in the diagram. 

Lock / Unlock Lock or unlock the note in the diagram. 

Properties 

Once you have selected the note, you can customize the note by changing its properties: 

Option Description 

Note 

Name Enter the name of the note. 

Position Customize the position of the note. 

Size Customize the size of the note. 

Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 

Font Set the font style of the note content. 

Bold Apply a bold style to the note content. 

Italic Apply an italic style to the note content. 

Color Set the color of the note. 

Group / Ungroup Group or ungroup the note and other objects in the diagram. 

Lock / Unlock Lock or unlock the note in the diagram. 

 

Add Images 

You can insert images (BMP, JPG, JPEG or PNG files) to your diagram for design or identification purposes. 

To add a new image 

1. Click the  button from the toolbar. 

2. Place it on the canvas. 

3. Select an image file in the Open dialog box. 

Hint: You can simply add an image from the clipboard by pressing CTRL+V. 

The pop-up menu options of the image object in the canvas include: 
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Option Description 

Cut Remove the image the diagram and put it on the clipboard. 

Copy Copy the image from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the image as a PNG file. 

Select All Images Select all images in the diagram. 

Delete from Diagram Delete an image from the diagram. 

Bring to Front Bring the image to the foreground. 

Send to Back Move the image to the background. 

Group / Ungroup Group or ungroup the image and other objects in the diagram. 

Lock / Unlock Lock or unlock the image in the diagram. 

Properties 

Once you have selected the image, you can customize the image by changing its properties: 

Option Description 

Image 

Name Enter the name of the image. 

Opacity Set the opacity of the image. 

Position Customize the position of the image. 

Size Customize the size of the image. 

Original Size Reset the image to its original size. 

Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 

URL Enter URL path to set the image as a hyperlink. 

Group / Ungroup Group or ungroup the image and other objects in the diagram. 

Lock / Unlock Lock or unlock the image in the diagram. 

 

Add Shapes 

Navicat includes some pre-defined shapes for creating database model diagrams: line, arrow, curve, connector, 

rectangle, ellipse, user, database, cloud, trigger, server, desktop, laptop, mobile, man, woman. 

To add a new shape 

1. Click the  button from the toolbar. 

2. Select a shape. 

3. Place it on the canvas. 

To connect objects with a connector 

1. Drag one endpoint of the connector to an object until it snaps to the object (a blue outline appears around the 

object). 
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2. Drag the other endpoint until the connector snaps to another object. 

Hint: Lines, arrows and curves can act as connectors. You can enable the As connector option in the Properties 

pane. 

The pop-up menu options of the shape object in the canvas include: 

Option Description 

Common 

Cut Remove the shape from the diagram and put it on the clipboard. 

Copy Copy the shape from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the shape as a PNG file. 

Select All Shapes Select all shapes in the diagram. 

Delete from Diagram Delete a shape from the diagram. 

Color Change the color of the shape. 

Bring to Front Bring the shape to the foreground. 

Send to Back Move the shape to the background. 

Group / Ungroup Group or ungroup the shape and other objects in the diagram. 

Lock / Unlock Lock or unlock the shape in the diagram. 

Line, Arrow and Curve 

Add Vertex Add a vertex at the mouse cursor position. 

Delete Vertex Delete a vertex at the mouse cursor position. 

Delete All Vertices Delete all vertices on the selected line. 

Go to Go to and select the connected object. 

Connector 

Go to Go to and select the connected object. 

Reroute Connectors Reroute the connector to the closest points between two connected 

objects. 

Properties 

Once you have selected the shape, you can customize the shape by changing its properties: 

Option Description 

Common 

Name Enter the name of the shape. 

Position Customize the position of the shape. 

Show name Display the name label of the shape. 

Name Position Change the label position. 

Font Set the font style of the name. 

Bold Apply a bold style to the name. 

Italic Apply an italic style to the name. 
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Color Set the color of the shape. 

Group / Ungroup Group or ungroup the shape and other objects in the diagram. 

Lock / Unlock Lock or unlock the shape in the diagram. 

Line, Arrow, Curve and Connecter 

Offset Customize offset values for the start and end of the line. 

Line Width Choose the thickness of the line. 

Cap Style Choose the cap style of the line. 

Dash Style Choose the dash style of the line. 

Join Style Choose the join style of the line. 

Begin Style Choose the style of the line's back. 

End Style Choose the style of the line's front. 

As connector Allow you to connect objects. 

Rectangle, Ellipse, User, Database, Cloud, Trigger, Server, Desktop, Laptop, Mobile, Man and 

Woman 

Size Customize the size of the shape. 

Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 

Border Color Change the color of the shape's border. 

Border Width Choose the thickness of the border. 

Shape Style Change the style of the shape. 

 

Add Layers 

Layers are used to help organize objects (e.g. tables, notes, images, etc) on the canvas. You can add all related 

objects to the same layer. For example, you may choose to add all your sales related tables to one layer. 

To add a new layer 

1. Click the  button from the toolbar. 

2. Place it on the canvas. 

3. Move objects into the layer and select Add To Layer. 

The pop-up menu options of the layer object in the canvas include: 

Option Description 

Cut Remove the layer from the diagram and put it on the clipboard. 

Copy Copy the layer from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Save as Image Save the layer as a PNG file. 

Select All Layers Select all layers in the diagram. 

Delete from Diagram Delete a layer from the diagram. 

Color Change the color of the layer. 

Size to Fit Resize the layer automatically to fit its contents. 
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Bring to Front Bring the layer to the foreground. 

Send to Back Move the layer to the background. 

Group / Ungroup Group or ungroup the layer and other objects in the diagram. 

Lock / Unlock Lock or unlock the layer in the diagram. 

Properties 

Once you have selected the layer, you can customize the layer by changing its properties: 

Option Description 

Layer 

Name Enter the name of the layer. 

Position Customize the position of the layer. 

Size Customize the size of the layer. 

Constrain proportions Maintain the aspect ratio (the ratio of width to height) when resizing. 

Font Set the font style of the title. 

Title Position Change the title position. 

Color Set the color of the layer. 

Group / Ungroup Group or ungroup the layer and other objects in the diagram. 

Lock / Unlock Lock or unlock the layer in the diagram. 

 

Work with Diagram Canvas 

Show Grid 

To turn the grid on in the diagram canvas, choose View -> Show Grid from the menu bar. 

Show Page Border 

To turn the page border on in the diagram canvas, choose View -> Show Page Border from the menu bar. 

Snap to Grid 

To align objects on the canvas with the grid, choose View -> Snap To Grid from the menu bar. 

Align Multiple Objects 

1. Select the objects you want to align. 

2. Right-click the selected objects, and then select one of these commands from the Alignment menu: 

Option Description 

Align Left Align objects along their left edges. 

Align Center Align objects vertically through their centers. 

Align Right Align objects along their right edges. 

Align Top Align objects along their top edges. 
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Align Middle Align objects horizontally through their middles. 

Align Bottom Align objects along their bottom edges. 

Arrange Objects Equidistant 

1. Select at least three objects. 

2. Right-click the selected objects, and then select one of these commands from the Distribute menu: 

Option Description 

Horizontally Arrange the objects horizontally. 

Vertically Arrange the objects vertically. 

 

Apply Auto Layout 

Navicat provides a layout facility for arranging objects on diagrams. Your diagram is reorganized following the specific 

settings you define. Objects do not overlap and connectors do not cross over one another. 

Apply Auto Layout to Entire Diagram 

1. Click on the canvas. 

2. Click . 

Apply Auto Layout to Selected Objects 

1. Select the objects you want to apply auto layout. 

2. Click . 

Apply Auto Layout to All Objects in Layer 

1. Select the layer. 

2. Click . 

Change Auto Layout Settings 

To change the Auto Layout format settings, simply choose Diagram -> Auto Layout With from the menu and set the 

following options: 

Option Description 

Auto Diagram Dimension Choose the suitable diagram dimension automatically. 

Auto Size Tables To Fit Resize the table to fit its content automatically. 

Quality The quality of the auto layout output. 

Object Distance The distance between the objects in the diagram. 
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Preview Diagram 

You can preview the diagram using the whole screen. The title bar, toolbar, tab bar, Objects pane and Properties pane 

will be hidden while in this mode. To preview a diagram, click  Preview. 

To exit the preview mode, press the ESC key and the workspace window will be returned to its previous state. 

Print & Export Diagram 

Print Diagram 

You can print the current diagram to the printer. 

1. Choose File -> Print. 

2. Select your print options. 

3. Click OK. 

Export Diagram to File 

You can export the current diagram to various types of images and files: PDF, PNG, SVG or JPG. 

1. Choose File -> Export To and choose the file format. 

2. Choose the path and enter the file name. 

3. Click Save. 

Data Dictionary 

About Data Dictionary 

Data Dictionary serves as a reference for understanding and documenting the structure and semantics of the data 

model. It provides a comprehensive description of the structure, relationships, and constraints of the objects in the 

model. 

Create Data Dictionary 

The essential steps to create a data dictionary are: 

1. In the Workspace window, click  New Data Dictionary. 

2. Enter the name of the data dictionary. 

3. Click OK. 

4. A tab will open for you to edit the data dictionary. 
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5. Click  Generate. 

Reverse Engineering 

About Reverse Engineering 

Reverse Engineering is the process of creating a data model from a database/schema. Navicat allows you to load 

existing database structures to create new models, or synchronize database differences to an existing model. 

Synchronize Database to Model 

The Synchronize Database to Model feature allows you to compare a database or schema with an existing model, 

states the differences between their structures, and offers synchronizing modifications in the database or schema into 

the model. 

Navicat provides a step-by-step wizard for you to complete the task: 

1. In the Workspace window, choose Tools -> Reverse Engineering -> Synchronize Database to Model. 

2. Select the source connection, database, schema, and select the target model, database, schema. 

3. Click Options and select the compare / advanced options. 

4. Click Compare to show the differences between source and target objects. 

5. Select the objects you want to synchronize. 

6. Click Next to execute the process. 

Choose Connections 

The first step is to define the source connection and the target model. 

Choose Comparing Options 

Then, click the Options button to select the compare / advanced options for the synchronization process. 

Note: The following options depend on the diagram database type you are chosen and sort in ascending order. 

Option Description 

Compare auto increment 

value 

Compare the auto increment values of tables. 

Compare character set Compare the character sets of tables. 

Compare checks Compare check constraints. 

Compare collation Compare the collations of tables. 

Compare definers Compare the definers of views. 

Compare excludes Compare exclusion constraints. 

Compare foreign keys Compare the foreign keys of tables. 
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Compare functions Compare function and procedure objects. 

Compare identity last 

value 

Compare the identity last values of tables. 

Compare indexes Compare table indexes. 

Compare owners Compare the owners of database objects. 

Compare partitions Compare table partitions. 

Compare primary keys Compare the primary keys of tables. 

Compare rules Compare rule objects. 

Compare sequences Compare sequence objects. 

Compare sequence last 

values 

Compare the last values of sequences. 

Compare storage Compare table storages. 

Compare table options Compare other table options. 

Compare tables Compare table objects. 

Compare triggers Compare table triggers. 

Compare uniques Compare unique constraints. 

Compare views Compare view objects. 

Drop with CASCADE Drop the dependent database objects with the CASCADE option. 

Identifier Case Sensitivity Ignore or consider the case of identifiers when mapping, or use the server 

default setting. 

Start Comparison 

Click the Compare button to compare the source database and the target model. 

View Comparison Results 

After comparing structures, the tree view shows the differences between the source and target databases or schemas. 

Check the objects you want to apply to the target. You can expand the objects to view the detailed structure. 

You can choose to group the objects in the tree views by object types or operations by selecting Group by Object 

Type or Group by Operation. 

Operation Description 
 

Object exists in both source and target databases/schemas, but they have 

different definition. The target object will be modified based on the source 

object. 
 

Object does not exist in the target database/schema. It will be created in the 

target. 
 

Object does not exist in the source database/schema. The target object will 

be deleted. 
 

Object exists in both source and target databases/schemas and they have 

identical definition. No operation will be applied. 
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When you select an object from the comparison results, the DDL Comparison tab displays the statements for that 

object from both the source database and the target model side by side. Any differences in the statements, such as 

added, modified, or removed fields, are highlighted for quick identification. 

Furthermore, the Deployment Script tab shows the specific scripts of the object that will be updated in the target model. 

Click the Next button to execute the process. The window will display the execution progress, execution time, and 

success or failure messages. 

Reverse Database to Model 

The Reverse Database to Model feature allows you to create a database model from an existing database or schema. 

Navicat provides a step-by-step wizard for you to complete the task: 

1. In the Workspace window, choose Tools -> Reverse Engineering -> Reverse Database to Model. 

2. Select the source connection, database, schema, and select the target model, database, schema. Choose 

New Model and the model type if you want to create a new model. 

3. Click New. 

4. Select the objects you want to import. 

5. Enable Import To Diagram and select a diagram if you want to add the objects to a diagram. Choose New 

Diagram if you want to import objects to a new diagram. 

6. Click Start. 

You can also simply create a new model diagram using reverse engineering in the Navicat main window. For example, 

right-click an opened database and select Reverse Database to Model. 

Forward Engineering 

About Forward Engineering 

Forward engineering is the process of generating the physical database schema from a physical model. Navicat allows 

you to synchronize model differences to an existing database, or export models to .sql or .script files. 

Synchronize Model to Database 

The Synchronize Model to Database feature allows you to compare a model with an existing database or schema, 

states the differences between their structures, and offers synchronizing the structures in model to the target 

connection. 

Navicat provides a step-by-step wizard for you to complete the task: 

1. In the Workspace window, choose Tools -> Forward Engineering -> Synchronize Model to Database. 
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2. Select the source model, database, schema, and select the target connection, database, schema. 

3. Click Options and select the compare / advanced options. 

4. Click Compare to show the differences between source and target objects. 

5. Select the objects you want to synchronize. 

6. Click Next to generate a set of scripts. 

7. Click Start. 

Choose Connections 

The first step is to define the source model and the target connection. 

Choose Comparing Options 

Then, click the Options button to select the compare / advanced options for the synchronization process. 

Note: The following options depend on the diagram database type you are chosen and sort in ascending order. 

Option Description 

Compare auto increment 

value 

Compare the auto increment values of tables. 

Compare character set Compare the character sets of tables. 

Compare checks Compare check constraints. 

Compare collation Compare the collations of tables. 

Compare definers Compare the definers of views. 

Compare excludes Compare exclusion constraints. 

Compare foreign keys Compare the foreign keys of tables. 

Compare functions Compare function and procedure objects. 

Compare identity last 

value 

Compare the identity last values of tables. 

Compare indexes Compare table indexes. 

Compare owners Compare the owners of database objects. 

Compare partitions Compare table partitions. 

Compare primary keys Compare the primary keys of tables. 

Compare rules Compare rule objects. 

Compare sequences Compare sequence objects. 

Compare sequence last 

values 

Compare the last values of sequences. 

Compare storage Compare table storages. 

Compare table options Compare other table options. 

Compare tables Compare table objects. 
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Compare triggers Compare table triggers. 

Compare uniques Compare unique constraints. 

Compare views Compare view objects. 

Drop with CASCADE Drop the dependent database objects with the CASCADE option. 

Identifier Case Sensitivity Ignore or consider the case of identifiers when mapping, or use the server 

default setting. 

Start Comparison 

Click the Compare button to compare the source model and the target database. 

View Comparison Results 

After comparing structures, the tree view shows the differences between the source and target databases or schemas. 

Check the objects you want to apply to the target. You can expand the objects to view the detailed structure. 

You can choose to group the objects in the tree views by object types or operations by selecting Group by Object 

Type or Group by Operation. 

Operation Description 
 

Object exists in both source and target databases/schemas, but they have 

different definition. The target object will be modified based on the source 

object. 
 

Object does not exist in the target database/schema. It will be created in the 

target. 
 

Object does not exist in the source database/schema. The target object will 

be deleted. 
 

Object exists in both source and target databases/schemas and they have 

identical definition. No operation will be applied. 

When you select an object from the comparison results, the DDL Comparison tab displays the statements for that 

object from both the source model and the target database side by side. Any differences in the statements, such as 

added, modified, or removed fields, are highlighted for quick identification. 

Furthermore, the Deployment Script tab shows the specific scripts that will be executed on the target database to apply 

the selected changes. 

Click the Next button to show the scripts of all selected objects. 

Edit & Execute Selected Scripts 

You can view all scripts that will be executed in the target database in the Deployment Script tab. 

Deployment Options Button Description 

Deployment Options Continue on error - Ignore errors that are encountered during the 

execution process if necessary. 
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Include deployment query in message log - Show the deployment 

queries in the Message Log tab during execution. 

Edit Script Open the Edit Deployment Script window to rearrange the order of 

the scripts. 

Copy Script to Clipboard Copy all scripts from the Deployment Script tab to the clipboard. 

Open Script in Query Editor Open a new query window and display the scripts. 

In the Edit Deployment Script window, use the arrow buttons to move the scripts. 

Then, click the Start button to execute the scripts. The window will display the execution progress, execution time, and 

success or failure messages. 

Export Model to SQL/Script File 

After finishing your model, you can save structures and relations from the model into a sql or script file. 

Navicat provides a step-by-step wizard for you to complete the task: 

1. In the Workspace window, choose Tools -> Forward Engineering -> Export Model to SQL/Script File. 

2. Enter the file information and select the objects. 

3. Click OK. 

General Properties 

Option Description 

File Set the location path of the output file. 

Model Choose the model you wish to export. 

Schema Choose the schema you wish to export. 

Objects Choose objects in the model you wish to export. 

Advanced Properties 

Note: The following options depend on the diagram database type you are chosen and sort in ascending order. 

Option Description 

Include auto increment Include the auto increment values of tables. 

Include character set Include table and field character sets. 

Include checks Include check constraints. 

Include collation Include the collations of tables. 

Include Drop SQL Include drop object SQL statements. 

Include Drop With 

CASCADE 

Include drop object SQL statements with the CASCADE option. 

Include excludes Include exclusion constraints. 

Include foreign keys Include the foreign keys of tables. 

Include indexes Include table indexes. 
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Include primary keys Include the primary keys of tables. 

Include rules Include rule objects. 

Include schema Qualify object names with the schema name. Otherwise, only object names 

are included in SQL statements. 

Include triggers Include table triggers. 

Include uniques Include unique constraints. 

Server Version Select the server version for the file. 

 

Compare Model Workspace 

Compare Model Workspace is a powerful tool that allows you to compare two model workspaces, view and resolve 

differences between them. 

Navicat provides a step-by-step wizard for you to complete the task: 

1. In the Workspace window, choose Tools -> Compare Model Workspace. 

2. Select the workspace you want to sync with the current workspace. 

3. Click Compare to show the differences between source and target objects. 

4. Select the objects you want to synchronize. 

5. Click Apply Changes to view the number of changes. 

6. Click Apply. 

Choose Source Workspace 

The first step is to define the source workspace. You can choose an existing workspace in Navicat or an external 

workspace file. 

Then, click the Compare button. 

View Comparison Results 

After comparing, the tree view shows the differences between the source and target workspaces. Check the objects 

you want to apply to the target. You can expand the objects to view the detailed structure. 

Choose an option from the drop-down list to show the objects. 

Option Description 

All Objects Show all objects in the source and target. 

Objects with Difference Show all objects that are different in the source and target. 

Objects To Be Added Only show the objects that do not exist in the target. 

Objects To Be Updated Only show the objects that exist in both source and target, but they have 
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different structures. 

Objects To Be Deleted Only show the objects that do not exist in the source. 

When you selected an object in the tree view, the DDL Comparison tab shows the DDL statements/scripts of that 

object in the source and the target, and the Reference Script tab shows the detailed statements/scripts of the object 

that will be executed in the target database. 

Apply Changes 

Click the Apply Changes button to apply changes to the selected objects. 

Model Conversion 

Navicat allows you to convert your models from one database type to another database type, e.g. MariaDB 10.0 

physical model to PostgreSQL 9.0 physical model. With Navicat Premium, you can also convert your models from one 

model type to another model type, e.g. physical model to logical model. 

Convert a model 

1. In the Workspace window, choose Tools -> Convert Model. 

2. Select the target workspace. 

3. Enter the model name. 

4. Choose the model type. 

5. Choose the target database and version if necessary. 

6. If you want to convert all related diagrams, enable Convert with related Diagram. 

7. Click Convert. 

8. A tab will open for you to edit the model. 

Conversion Behaviour 

• All data types are converted automatically. 

• When converting from one database type to another, the conversion process does not change the syntax of 

views, functions, and procedures. 

• When converting a physical model to a logical/conceptual model, all views are converted to entities, and all 

functions and procedures are removed. 

• If the target database version is MySQL 4.0 or below, all views are removed. 

• If the source database type is MongoDB, all views, functions, and procedures are removed. 



 205 

 

• If the target database type is MongoDB, all views, functions, and procedures are removed. 

• If the target database type is SQLite, all functions and procedures are removed. 

Model Hints and Tips 

Navicat provides some useful hints to work on the model more effectively. 

Locate Object in the Diagram Canvas 

Double-click an object in the left pane will jump to the corresponding object on the canvas. 

Delete Object from Model 

Select an object in the canvas and press SHIFT+DELETE. 

Open Object Designer 

Double-click an object in the left pane or the canvas. 

Get Object Statement 

Select and copy an object on the canvas, and paste it to other text editors. 

Add / Edit Field without Object Designer 

Select an object and click the object name on the canvas, and then press DOWN ARROW to add/edit fields. Navicat 

will predict field types according to field names you entered. 

INTEGER/int/int4/NUMBER 

• suffix "id", "no" (if it is the first column, it will be predicted as a primary key) 

• suffix "num" 

• "qty", "number" 

• exactly "age", "count" 

DECIMAL(10,2)/decimal(10,2)/NUMBER/REAL/money 

• suffix "price", "cost", "salary" 

FLOAT/double/float8/NUMBER/REAL/float 

• "size", "height", "width", "length", "weight", "speed", "distance" 

DATE/datetime/date/TEXT/datetime2 

• "date", "time" 
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VARCHAR(255)/varchar(255)/VARCHAR2(255)/TEXT 

• other field names 

Enter * before the field name to recognize as primary key. e.g. *itemNo:int. 

Enter : between field name and field type to custom field type, e.g. itemName:varchar(255). 

Reorder Field 

Select an object on the canvas, then press and hold the SHIFT key. Use  to drag the field to a desired location. 

Delete Field 

Select an object on the canvas, then press and hold the SHIFT key. Use  to drag the desired field out of the object. 

Add Vertex to Line / Arrow / Curve 

Select a line, arrow or curve on the canvas. Press and hold the SHIFT key and click on it to add vertex. 

Delete Vertex on Line / Arrow / Curve 

Select a line, arrow or curve on the canvas. Press and hold the SHIFT key and click on the vertex. 

View Object's Model and Database 

Press and hold the SPACE key. 

Switch to Hand Mode 

Press and hold the SPACE key, then move the diagram. 
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Chapter 11 - Debugger (Available only in Navicat 

Premium, Enterprise and Standard Edition) 

About Debugger 

Navicat provides two code debuggers: Oracle PL/SQL Debugger and PostgreSQL PL/pgSQL Debugger. With the 

debuggers, you can toggle breakpoints, fetch call stacks, view variable values, trace the code, etc. 

Oracle PL/SQL Debugger 

Oracle PL/SQL Debugger provides step-by-step code debugging for functions, procedures, packages and queries. To 

launch the debugger, click the  Debug button in the designer of the mentioned objects. 

You can perform the most commonly used actions for debugging on the toolbar or menu: 

Button Description 

 Run Start running code in debug mode. Enter the Input Parameters if necessary. The 

debugger executes your code until the end of the code or the next breakpoint is reached. 

Keyboard shortcut: F9 

 Step Over Resume the execution. The current line will be executed. If the line is a procedure or 

function call, it will bypass the procedure or function. The counter will then move to the 

next line of code. Keyboard shortcut: F10 

 Step In Resume the execution. The current line will be executed. If the line is a procedure or 

function call, the counter goes to the first statement in the procedure or function. 

Otherwise, the counter will move to the next line of code. Keyboard shortcut: F11 

 Step Out Resume the execution. The remaining part of the code within the current procedure or 

function will be executed. Subsequently, the counter will jump to the line which is just 

after the caller of the procedure or function. Keyboard shortcut: SHIFT+F11 

 Step End Resume the execution. The counter will jump to the last line of the procedure or function. 

 Stop Stop stepping the code. The execution will stop and cannot resume it. 

The Code pane shows the code of the procedure or function. You can add/remove breakpoints for debugging by 

clicking  in the grey area beside each statement. To add a variable to the watch list, right-click the highlighted code 

and select Add to Watch List. 

The Call Stack pane displays a list of procedures and functions as they are called. To jump to a procedure or function, 

right-click it and select Goto Function. 

The Breakpoints pane displays all the breakpoints which allowing you to delete, enable or disable breakpoints. To 

enable/disable a breakpoint, check/uncheck the check box. Also, you can delete a breakpoint or all breakpoints, 

right-click a breakpoint and select Remove Breakpoint or Remove All Breakpoints. To jump to the line of a 

breakpoint, right-click it and select Goto Function. 

The Local Variables pane displays all local variables and their values. Click on a value in the Value column to edit. To 
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add a variable to the watch list, right-click it and select Add to Watch List. 

The Parameters pane displays the inputted parameters. To add a parameter to the watch list, right-click it and select 

Add to Watch List. 

The Watch List pane displays information about the variables being watched, allowing you to add, delete or edit watch 

variables. To add a watch variable, right-click anywhere on the pane and select Add Variable. Then, enter the Variable 

Name. Click on a value in the Value column to edit. To delete a watch variable or all watch variables, right-click a 

variable and select Remove Variable or Remove All Variables. 

The Log pane displays the message log when debugging the code and the results after the procedure or function has 

completed the execution. 

PostgreSQL PL/pgSQL Debugger 

PostgreSQL PL/pgSQL Debugger provides step-by-step code debugging for PL/pgSQL procedures/functions. To 

launch the debugger, click the  Debug button in the function designer. 

You can perform the most commonly used actions for debugging on the toolbar or menu: 

Button Description 

 Run Start running code in debug mode. Enter the Input Parameters if necessary. The 

debugger executes your code until the end of the code or the next breakpoint is 

reached. Keyboard shortcut: F9 

 Step Over Resume the execution. The current line will be executed. If the line is a procedure 

or function call, it will bypass the procedure or function. The counter will then move 

to the next line of code. Keyboard shortcut: F10 

 Step In Resume the execution. The current line will be executed. If the line is a procedure 

or function call, the counter goes to the first statement in the procedure or function. 

Otherwise, the counter will move to the next line of code. Keyboard shortcut: F11 

 Step Out Resume the execution. The remaining part of the code within the current procedure 

or function will be executed. Subsequently, the counter will jump to the line which is 

just after the caller of the procedure or function. Keyboard shortcut: SHIFT+F11 

 Stop Stop stepping the code. The execution will stop and cannot resume it. 

The Code pane shows the code of the procedure or function. You can add/remove breakpoints for debugging by 

clicking  in the grey area beside each statement. 

The Call Stack pane displays a list of procedures or functions as they are called. 

The Breakpoints pane displays all the breakpoints. You can delete a breakpoint or all breakpoints, right-click a 

breakpoint and select Remove Breakpoint or Remove All Breakpoints. To jump to the line of a breakpoint, right-click 

it and select Goto Function. 

The Local Variables pane displays all local variables and their values. Click on a value in the Value column to edit. To 

add a parameter to the watches, right-click it and select Add Watch. 
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The Parameters pane displays the inputted parameters. 

The Watches pane displays information about the variables being watched, allowing you to add, delete or edit watch 

variables. To add a watch variable, right-click anywhere on the pane and select Add Watch. Then, enter the Watch 

Name. Click on a value in the Value column to edit. To delete a watch variable or all watch variables, right-click a 

variable and select Delete Watch or Delete All Watches. 

The Log pane displays the message log when debugging the code and the results after the procedure or function has 

completed the execution. 
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Chapter 12 - Pub/Sub (Available only in Navicat 

Premium, Enterprise and Standard Edition) 

About Pub/Sub 

Pub/Sub is Publish and Subscribe, allows users to subscribe to channels and receive messages when messages are 

published to those channels. Users can listen to one or more channels and react to the messages as they come in. In 

the main window, click  Pub/Sub to open the Pub/Sub object list. 

Note: Available only for Redis. 

You can save the channels you are currently subscribed to as a profile to quickly resume subscriptions when you open 

the profile. 

Hint: Profiles (.npsbredis) are stored under the Settings Location. 

Pub/Sub Window 

The Pub/Sub Window consists of a toolbar, Channels pane and Messages pane. 

 

 Toolbar 

The toolbar of Pub/Sub provides the following functions: 

Button Description 

 Subscribe Subscribe to channels, patterns or shard channels. 

 Unsubscribe Unsubscribe the selected channels. 

 Pause Unsubscribe all channels temporarily. 

 Resume Resume all channels. 

http://192.168.1.247/online_manual/en/navicat/win_manual/#/con_adv_settings
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 Publish Pane Toggle a pane for posting a message to a channel. 

 Archive Messages Create an archive file for the current messages. 

 Mute Mute the channels. All new messages will not be received. 

 Clear Messages Clear all messages on the Messages pane. 

 Channels Pane 

The Channels pane shows all subscribed channels. 

 Messages Pane 

The Messages pane shows all messages in the subscribed channels. You can show/hide the messages in different 

states by right-clicking the grid. 

Message texts in different colors indicate: 

• Black - Messages sent to a channel 

• Grey - System messages 

• Blue - Publish / Received messages 

• Red - Error messages 

 Message Details Pane 

The Message Details pane shows the detailed information of the selected message. 

Subscribe Channels 

Channels exist on the system only when a subscriber is listening to messages on it, so there is no need to ever create 

or delete channels. 

Subscribe a channel 

1. Click  Subscribe. 

2. You can find out which channels are active on your Redis server. If no active channels, you can customize one. 

3. Click Subscribe. 

4. The subscribed channel appears on the Channels pane. 

Publish a message to a channel 

1. Click  Publish Pane. 

2. Choose a channel type and a channel. 

3. Enter the message. 
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4. Click Publish. 

Hint: You can right-click a channel on the Channels pane and select Publish To to post messages to that channel. 

Archive messages 

1. Click  Archive Messages. 

2. Enter the file name. 

3. Click Save. 

Hint: Archived files (.nrpsbmlog) are stored under the Settings Location. To open the folder, right-click an archived file 

in the Objects tab and select Open Containing Folder. 

Hide server messages from a channel 

1. Click  next to the channel name. 

Unsubscribe a channel 

1. Select a channel on the Channels pane. 

2. Click  Unsubscribe. 

Channel Colorings 

You can highlight channels by colors for identifying channels and their messages. It lets you instantly know which 

channel a message is from. The highlighted color displays in the Channels pane and the Messages pane. 

To highlight a channel, right-click a channel on the Channels pane and select Color. 
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Chapter 13 - Aggregation Pipeline (Available only 

in Navicat Premium, Enterprise and Standard 

Edition) 

About Aggregation Pipeline 

Aggregation Pipeline is a specific flow of operations that processs and transforms data, performs complex calculations, 

and generates aggregated results. Navicat provides the ability to create aggregation pipelines in a simple and instant 

way. In the main window, click  Pipeline to open the aggregation pipeline object list. 

You can save your settings as a profile for future use or setting automation tasks. 

Hint: Aggregation Pipeline (.nagg) are stored under the Settings Location. 

Note: Available only for MongoDB. 

Aggregation Pipeline Designer 

Aggregation Pipeline Designer is the basic Navicat tool for working with aggregation pipelines. 

Button Description 

 Import Query Import a script file to build the pipeline. 

 Preview All Preview All - Preview the output. 

Preview All with Reload - Reload the sampled documents and preview the 

output. 

 Run Execute the pipeline. 

 Explain Show the execution plan. 

 Stop Stop the executing pipeline. 

 Export Result Export the result of the pipeline. 

 

Pipeline Builder 

Pipeline Builder allows you to build a simple aggregation pipeline by defining stage operators. It consists of the 

following sections: Pipeline, Stage Editor, Input/Output Preview, Script Preview. 
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 Pipeline 

A diagram to illustrate the aggregation pipeline. You can see all stages at a glance and add, delete, and move them as 

needed. 

 Stage Editor 

The Stage Editor is where you edit the selected stage. 

 Input/Output Preview Pane 

The Input Preview and Output Preview panes allow you to view the input documents and results at each stage. 

 Script Preview 

You can view the aggregation pipeline script. 

Choose Source Collection 

The source input of the pipeline is a single collection or view. Select Source in the pipeline and fill in the following 

options. 

Option Description 

Source Collection Choose a collection or view as the source. 

Preview Sample Options Set the limit on the number of sampled documents. 

Work with Aggregation Pipeline Stage 

You can break down a complex query into easier stages. In each stage, you complete a different operation on the data, 

such as filtering, grouping, sorting, and transforming. You can check whether your query is functioning properly at 

every stage by examining both its input and output. There is no limit to the number of stages used in the query, or how 

you combine them. 
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Add Stage 

1. Hover over an arrow. 

2. Click the  icon. 

Move Stage 

1. Hover over a stage. 

2. Click and hold the  icon. 

3. Move it to the desired location. 

Enable / Disable Stage 

1. Hover over a stage. 

2. Turn on or off the stage. 

Check Stage Input / Output 

1. Hover over a stage. 

2. Click Preview. 

Delete Stage 

1. Right-click a stage and select Delete. 

Modify Pipeline Settings 

You can click Option to view and change pipeline settings. 

Pipeline Results 

You can click  Run to execute the pipeline. The Result tab should populate with the same results as those found in 

the last stage output. 

Pipeline Explain 

You can click  Explain to view the execution plan that helps you understand the performance of the pipeline. 
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Chapter 14 - Data Migration Tools 

About Data Migration Tools 

Navicat provides a number of powerful tools for working with data, including Import Wizard, Export Wizard, Data 

Transfer, Data Synchronization, Structure Synchronization, Dump SQL File and Execute SQL File. With those tools, 

you can migrate your data between different servers, databases and formats easily. 

Import Wizard 

About Import Wizard 

Import Wizard allows you to import data to tables/collections from CSV, TXT, XML, DBF and more. You can save your 

settings as a profile for future use or setting automation tasks. To open the Import Wizard window, click  Import 

Wizard from the object toolbar. 

Note: Available only for MySQL, Oracle, PostgreSQL, SQLite, SQL Server, MariaDB, MongoDB and Snowflake. 

Note: Lite edition only supports to import text-based files, such as TXT, CSV, XML and JSON. 

Hint: You can drag a supported file to the Table/Collection's Objects tab or a database/schema in the Navigation pane. 

Navicat will pop up the Import Wizard window automatically. If an existing table/collection is highlighted, Navicat will 

import the file to the highlighted table/collection. Otherwise, it will import the file to a new table/collection. 

Choose File Format 

Select one of the available import types for the source file. 

Note: The Excel file format is according to the Microsoft Office version installed in your computer. 

Choose Source File 

Click Add File(s) or Add URL to add import source files. Select the Encoding for the source file.  

Note: You can select more than one file to import. 

Excel 

Sheets will be shown in the Tables list. 

Access 

If there is security settings, i.e. database password and user level security in your access file, you are required to input 

the necessary information. Click the Security button for more settings: 

System Database File 

Locate the system security file of the Access file, e.g. D:\Temp\Security.mdw. 



 217 

 

Database Password 

Enter the password for the database if any. 

Logon Name 

Enter the user name set by the user level security. 

Logon Password 

Enter the password of that user. 

ODBC 

Setting up an ODBC Data Source Connection 

1. In Control Panel, select Administrative Tools. 

2. Select Data Sources (ODBC). 

3. Click the Add button in the User DSN tab. 

4. Select the appropriate ODBC driver, such as Microsoft ODBC for Oracle and click the Finish button. 

5. Enter the required information. 

6. Click the OK button to see your ODBC Driver in the list. 

Connecting to ODBC Data Source in Navicat 

1. Click Add Data Source. 

2. In the Provider tab, select the appropriate ODBC driver, such as Microsoft OLE DB Provider for ODBC 

Drivers. 

3. In the Connection tab, choose the data source from the Use data source name drop-down list and provide 

valid username and password. 

4. All available tables will be included in the Tables list if connection is success. 

Hint: If you are importing from Access or ODBC, the Add Query and Modify Query buttons open the Add Query 

dialog where you can construct query to import only certain rows from your source tables. In other words, import only 

rows that satisfy the criteria set by you. Tables and queries will be shown in the Tables list. To delete a query, select it 

and click the Delete Query button. 

Choose Delimiter 

TXT, CSV 
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Record Delimiter 

Specify the record separator of the file. 

Delimited 

Import the text file with delimited format. 

Fixed Width 

Import the text file with fixed-width format. To delimit the source column bounds, click on the desired position to create a 

break line. Simply drag it to move it or double-click it to remove it. 

 

Field Delimiter 

Specify the field separator. 

Text Qualifier 

Specify the character that encloses text values. 

XML, JSON 

Tag that identifies a table row / Tag that identifies a collection row 

Define a tag to identify rows. 

Consider tag attributes as table field / Consider tag attributes as collection field 

For example: 

<row age="17"> 

<id>1</id> 

<name>sze</name> 

</row> 
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With this option is on, Navicat will recognize "age" as a field together with "id" and "name", otherwise, only "id" and 

"name" will be imported as fields. 

Note: Navicat does not support multiple level of XML file. 

Choose Additional Options 

The following options depend on the file format chose in the first step. 

Field Name Row 

Indicate which row should Navicat recognize as field names. 

First Data Row 

Indicate which row should Navicat start reading the actual data. 

Last Data Row 

Indicate which row should Navicat stop reading the actual data. 

Note: If no field names are defined for the file, enter 1 for First Data Row and 0 for Field Name Row. 

Date Order, Date Delimiter 

Specify the format for date and the date separator. 

Time Delimiter 

Specify the time separator. 

Decimal Symbol 

Specify the decimal separator for decimal number. 

Date Time Order 

Specify the order of date and time. 

Binary Data Encoding 

Set binary data are imported as Base64 encoded or no encoding in the file. 

Choose Target Table / Collection 

You are allowed to define a new name or choose to import into an existing table/collection from the drop-down list. 

Note: If you type a new name in Target Table / Target Collection, the box in New Table / New Collection will be 

checked automatically. 



 220 

 

For importing multiple tables/collections, all tables/collections will be shown in the list. 

 

Adjust Field Structures and Map Fields 

Navicat will make assumption on the field types and length in the source table/collection. You are allowed to choose 

desired type from the drop-down list. 

Hint: For importing multiple tables/collections, select other tables/collections from the drop-down list 

 

If you are importing data into existing tables/collections, you might need to map the source field names manually to the 

target, or right-click and select Smart Match All, Direct Match All and Unmatch All from the pop-up menu for quick 

mapping. 

 

 

 

If you are importing via ODBC, the Condition Query button opens the WHERE dialog where you can specify a 

WHERE clause to import only certain rows from the source. In other words, import only rows that satisfy the criteria set 

by you. 

Hint: Do not include the word WHERE in the clause. 

Choose Import Mode 

Select the import mode that defines how the data being imported. 
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Hint: To activate the remaining options, you must enable Primary Key in the previous step. 

 

Click the Advanced button for more settings. The following options depend on the connection server type. 

Run multiple queries in each execution 

Execute multiple SQL statements at once, which will make the import process faster. 

Use extended insert statements 

Insert records using extended insert syntax. 

Example: 

INSERT INTO `users` VALUES ('1', 'Peter McKindsy', '23'), ('2', 'Johnson Ryne', '56'), ('0', 'Katherine', '23'); 

Maximum statement size 

Specify the maximum size (in KB) of individual extended INSERT statement that can be executed. If the row size 

exceeds this value, a normal INSERT statement will be used. 

Use empty string as NULL 

Import NULL value if the source data field contains empty string. 

Ignore foreign key constraint 

Ignore the checking of foreign key constraints during the import process. 

Continue on error 

Ignore errors that are encountered during the import process. 

Include Unique, Index and Foreign Key 

Include uniques, indexes and foreign keys during the import process. 

Note: Support only when the file type is MS Access database or ODBC. 
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Create Auto Increment Fields 

Create auto increment fields during the import process. 

Note: Support only when the file type is MS Access database, Paradox file or DBase file. 

Import Deleted Records 

Import the deleted records in the DBase file during the import process. 

Note: Support only when the file type is DBase file. 

Save and Start Import 

Click the Start button to begin the import process. The wizard will display the import progress, execution time, and 

success or failure messages.  

After the import process finished, you can click the Log button to open the log file. 

Hint: Click the Save button to save your settings as a profile. 

Export Wizard 

About Export Wizard 

Export Wizard allows you to export data from tables, collections, views, or query results to any available formats. You 

can save your settings as a profile for future use or setting automation tasks. To open the Export Wizard window, click 

 Export Wizard from the object toolbar. 

Note: Available only for MySQL, Oracle, PostgreSQL, SQLite, SQL Server, MariaDB, MongoDB and Snowflake. 

Note: Lite edition only supports to export text-based files, such as TXT, CSV, HTML, XML, SQL and JSON. 

Choose File Format 

Select one of the available export formats for the target file. 

Note: The Excel file format is according to the Microsoft Office version installed in your computer. Navicat 64-bit 

version does not support exporting to .mdb file. 

Choose Saving Path 

You can set the exported file name and location in this step. 

Check the box next to the object name that you want to export. If an existing object is highlighted in the object pane, it 

will be checked automatically and assigned a default file name and location. The file extension in the Export to text box 

changes according to the selected export type in the first step.  
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Note: For exporting query results, ensure the query is saved before running Export Wizard. Otherwise, no source 

object displayed in here. 

Select All Button Description 

Select All / Unselect All Select / unselect all source objects. 

Export selected to same file Export the selected objects into the same target file. When 

the file format is Excel, each object will be exported as a 

sheet in the Excel file. 

Export selected to same 

folder 

Export the selected objects into the same directory. 

 

Advanced Button Description 

Encoding Select the encoding for the exported file. 

Add timestamp Check this option if you want your file name specifies the 

timestamp of the export is run. Select the date/time format from 

the drop-down list. 

 

Choose Columns / Fields for Export 

You can select what fields to export. All the fields are selected in the list by default. If you want to omit some fields to be 

exported, uncheck the All Fields option first and then uncheck those fields in the list. 

Note: For exporting query result, the wizard will skip this step. 

Choose Additional Options 

The following options depend on the file format chose in the first step. 

Include column titles 

Field names will be included into the exported file if this option is on. 

Blank if zero 

Leave it blank if the field content is 0. 

Append 

Append records to the existing file 

Continue on error 

Ignore errors that are encountered during the export process. 

Use Attributes Format in XML 

Attributes Format 
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<RECORDS> 

<RECORD OrderNo="1003" ItemNo="1" PartNo="1313" Qty="5" Discount="0"></RECORD> 

<RECORD OrderNo="1004" ItemNo="1" PartNo="1313" Qty="10" Discount="50"></RECORD> 

</RECORDS> 

Non-Attributes Format 

<RECORDS> 

<RECORD> 

    <OrderNo>1003</OrderNo> 

    <ItemNo>1</ItemNo> 

    <PartNo>1313</PartNo> 

    <Qty>5</Qty> 

    <Discount>0</Discount> 

</RECORD> 

<RECORD> 

    <OrderNo>1004</OrderNo> 

    <ItemNo>1</ItemNo> 

    <PartNo>1313</PartNo> 

    <Qty>10</Qty> 

    <Discount>50</Discount> 

</RECORD> 

</RECORDS>  

Export as legacy format (with "RECORDS" key) 

Legacy Format 

{ 

    "RECORDS": [ 

        { 

            "COUNTRY_ID": AR 

            "COUNTRY_NAME": "Argentina" 

            "REGION_ID": 2 

        }, 

        { 

            "COUNTRY_ID": AU 

            "COUNTRY_NAME": "Australia" 

            "REGION_ID": 3 

        } 

    ] 

} 

New Format 

[ 

    { 

        "COUNTRY_ID": AR 
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        "COUNTRY_NAME": "Argentina" 

        "REGION_ID": 2 

    }, 

    { 

        "COUNTRY_ID": AU 

        "COUNTRY_NAME": "Australia" 

        "REGION_ID": 3 

    } 

] 

Record Delimiter, Field Delimiter, Text Qualifier 

Specify the record separator, the field separator and the character that encloses text values. 

Zero padding date 

Add a leading zero to pad days and months to two digits if necessary. 

Date Order, Date Delimiter 

Specify the format for date and the date separator. 

Time Delimiter 

Specify the time separator. 

Decimal Symbol 

Specify the decimal separator for decimal number. 

Binary Data Encoding 

Set binary data are exported as Base64 encoded or no encoding in the file. 

Save and Start Export 

Click the Start button to begin the export process. The wizard will display the export progress, execution time, and 

success or failure messages. 

After the export process finished, you can click the Open button to open the exported file or the log file. 

Hint: Click the Save button to save your settings as a profile. 
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Data Transfer (Available only in Navicat Premium, Enterprise and 

Standard Edition) 

About Data Transfer 

Navicat allows you to transfer objects from one database/schema to another, or to a sql file (RDBMS) or a Javascript 

file (MongoDB).The target database and/or schema can be on the same server as the source or on another server. To 

open the Data Transfer window, choose Tools -> Data Transfer from the menu bar. 

You can save your settings as a profile for future use or setting automation tasks. To open a saved profile, click the 

Load Profile button and select a profile from the list. 

Hint: Profiles are saved under the Profiles Location. 

Note: Available only for MySQL, Oracle, PostgreSQL, SQLite, SQL Server, MariaDB, MongoDB and Snowflake. 

Hint: You can drag tables/collections to a database/schema in the Navigation pane. If the target database/schema is 

within the same connection, Navicat will copy the tables/collections directly. Otherwise, Navicat will pop up the Data 

Transfer window. 

Choose Connections & Advanced Options (Step 1) 

Choose Source and Target Connections 

In the Data Transfer window, define connections, databases and/or schemas for Source Database and Target 

Database. You can click  to swap the source and target settings. 

You can also transfer your selected database objects directly to a text file. Select the File option. Choose the target 

path, SQL Format and Encoding for the file. 

Note: Navicat Premium supports transferring table with data across different server types, e.g. from MySQL to Oracle. 

If the source connection is MongoDB, Navicat Premium only can transfer data to MongoDB server. 

Choose Advanced Options 

Then, click the Options button to set the advanced options. The options depend on the source and target connection 

server types and sort in ascending order. 

Continue on error 

Ignore errors that are encountered during the transfer process. 

Convert object name to 

Check this option if you require convert object names to Lower case or Upper case during the process. 

Create collections 
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Check this option if you want to create collections in the target database. Suppose this option is unchecked and 

collections already exist in the target database, then all data will be appended to the destination collections. 

Create records 

Check this option if you require all records to be transferred to the destination database and/or schema. 

Create tables 

Check this option if you want to create tables in the target database. Suppose this option is unchecked and tables 

already exist in the target database/schema, then all data will be appended to the destination tables. 

Create target database/schema if not exist 

Create a new database/schema if the database/schema specified in the target server does not exist. 

Drop target objects before create 

Check this option if database objects already exist in the target database and/or schema, the existing objects will be 

deleted once the data transfer starts. 

Drop with CASCADE 

Check this option if you want to drop the dependent database objects with the cascade option. 

Include auto increment 

Include auto increment in the table with this option is on. 

Include character set 

Include character set in the table with this option is on. 

Include checks 

Include checks in the table with this option is on. 

Include definers 

Include the definers of the objects with this option is on. 

Include engine/table type 

Include table type with this option is on. 

Include excludes 

Include exclusion constraints in the table with this option is on. 

Include foreign key constraints 
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Include foreign keys in the table with this option is on. 

Include indexes 

Include indexes in the table with this option is on. 

Include other collection options 

Include other options in the collection with this option is on. 

Include other table options 

Include other options in the table with this option is on. 

Include owners 

Include the owners of the objects with this option is on. 

Include rules 

Include rules in the table with this option is on. 

Include triggers 

Include triggers in the table with this option is on. 

Include uniques 

Include uniques in the table with this option is on. 

Lock source tables 

Lock the tables in the source database and/or schema during the data transfer process. 

Lock target tables 

Lock the tables in the target database and/or schema during the data transfer process. 

Maximum statement size 

Specify the maximum size (in KB) of individual extended INSERT statement that can be executed. If the row size 

exceeds this value, a normal INSERT statement will be used. 

Use complete insert statements 

Insert records using complete insert syntax. 

Example: 

INSERT INTO `users` (`ID Number`, `User Name`, `User Age`) VALUES ('1', 'Peter McKindsy', '23'); 
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INSERT INTO `users` (`ID Number`, `User Name`, `User Age`) VALUES ('2', 'Johnson Ryne', '56'); 

INSERT INTO `users` (`ID Number`, `User Name`, `User Age`) VALUES ('0', 'katherine', '23'); 

Use DDL from SHOW CREATE TABLE 

If this option is on, DDL will be used from SHOW CREATE TABLE. 

Use DDL from sqlite_master 

If this option is on, DDL will be used from the SQLITE_MASTER table. 

Use delayed insert statements 

Insert records using DELAYED insert SQL statements. 

Example: 

INSERT DELAYED INTO `users` VALUES ('1', 'Peter McKindsy', '23'); 

INSERT DELAYED INTO `users` VALUES ('2', 'Johnson Ryne', '56'); 

INSERT DELAYED INTO `users` VALUES ('0', 'katherine', '23'); 

Use extended insert statements 

Insert records using extended insert syntax. 

Example: INSERT INTO `users` VALUES ('1', 'Peter McKindsy', '23'), ('2', 'Johnson Ryne', '56'), ('0', 'Katherine', '23'); 

Use hexadecimal format for BLOB 

Insert BLOB data as hexadecimal format. 

Use ignore insert statements 

Insert records using IGNORE insert SQL statements. All ignorable errors that occur while executing INSERT 

statements will be ignored. 

Use replace insert statements 

Insert records using REPLACE SQL statements. If a row in the target table has the same value as the source for a 

PRIMARY KEY or a UNIQUE index, the row in the target is deleted before the new row is inserted. 

Use single transaction 

Check this option if you want to use a single transaction during the data transfer process. 

Use transaction 
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Check this option if you want to use transaction during the data transfer process. 

Choose Objects & Transfer Mode (Step 2) 

Choose Objects to Transfer 

All database objects are unselected in the Database Objects list by default. Check the database objects that you want 

to transfer. 

 

(*) All the database objects being transferred to the target 

database/schema, all newly added database objects will also be 

transferred without amending the data transfer profile. 

(#/#) Only the checked database objects will be transferred. However, if 

you add any new database objects in the source database and/or 

schema after you create your data transfer profile, the newly added 

database objects will not be transferred unless you manually modify 

the Database Objects list. 

Choose Transfer Mode for Tables / Views 

You can customize the Transfer Mode for the selected table/view. If you choose Auto, Navicat will transfer the 

table/view using the default settings. If you want to customize the transfer settings, choose Advanced and set the 

following options: 

Option Description 

Target Name Enter the name of the table / view that will be created in the target 

database. 

All fields Transfer all fields in the table. 

Custom fields You can choose which fields to transfer. Click + and select the fields. 

Change the name of the target field if necessary. 

All rows Transfer all records in the table. 

Number of rows per batch Specify the number of rows of data per batch. If it is not enabled, all 

data in the table is sent to the target server as a single transaction. 

Custom recordsets Filter the records for transfer. Click + and enter an expression. 

Recordset Generator If your table is large, you may want to divide it to several record sets to 
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avoid connection timeout. The Recordset Generator can divide the 

records into a number of recordsets as evenly as possible between the 

start and end values of a field. Set Field Name, Start Value, End 

Value and Number of Recordsets in the pop-up window. 

SQL Preview Show the SQL statements for returning the recordsets. 

Use transaction for each 

recordset 

Use a transaction for each recordset during the data transfer process. 

Transfer as table The view will be transferred to the target database as a new table. 

 

Confirm & Start Data Transfer (Step 3) 

A summary table lists all selected objects that is being transferred to the target database. 

Continue on error 

Ignore errors that are encountered during the transfer process. 

Drop target objects before create 

Check this option if database objects already exist in the target database and/or schema, the existing objects will be 

deleted once the data transfer starts. 

Start Data Transfer 

Click the Start button to execute the data transfer process. The window will display the execution progress, execution 

time, and success or failure messages. 

Data Synchronization (Available only in Navicat Premium, 

Enterprise and Standard Edition) 

About Data Synchronization 

Navicat allows you to transfer data from one database and/or schema to another with detailed analytical process. In 

other words, Navicat provides the ability for data in different databases and/or schemas to be kept up-to-date so that 

each repository contains the same information. To open the Data Synchronization window, choose Tools -> Data 

Synchronization from the menu bar. 

You can save your settings as a profile for future use or setting automation tasks. To open a saved profile, click the 

Load Profile button and select a profile from the list. 

Hint: Profiles are saved under the Profiles Location. 

Note: SQL Server 2000 does not support this feature. For Oracle server, BLOB, CLOB, NCLOB, LONG and LONG 

RAW data are skipped during the data synchronization process. TIMESTAMP primary key cannot synchronize (insert, 
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update) with Database Link to 9i server. RAW primary key cannot synchronize (insert, update, delete) with Database 

Link to any server, without error. 

Note: Available only for MySQL, Oracle, PostgreSQL, SQLite, SQL Server, MariaDB, MongoDB and Snowflake. 

Navicat Premium and Navicat for MySQL support synchronizing between MySQL and MariaDB. 

Choose Connections & Comparing Options (Step 1) 

Choose Source and Target Connections 

In the Data Synchronization window, define connections, databases and/or schemas for Source Database and Target 

Database. You can click  to swap the source and target settings. 

Choose Comparing Options 

Then, click the Options button to set the comparing options. 

Insert records 

Insert records if the records do not exist in the target. 

Delete records 

Delete extra records from the target. 

Update records 

Update the target if the record is different from the source. 

Choose Table / Collection Mapping (Step 2) 

In this step, only tables/collections which contain identical names between the source and target are mapped in the list 

by default. If you do not want some tables/collections to be synchronized, disable them manually from the drop-down 

list. 

Keys and fields which contain identical names are also mapped. You can change the mapping in the Key Mapping and 

Field Mapping columns. 

After mapping the tables/collections, click Compare & Preview to view the comparison results (Step 3). If you want to 

skip the preview and deploy immediately, click Compare & Deploy. 

View Data Comparison Results (Step 3) 

After comparing data, the window shows the number of records that will be inserted, updated or deleted in the target. 

Uncheck the Show identical table and others / Show identical collection and others option to hide the 

tables/collections with identical data and the tables/collections with different structures. All tables/collections with 

different data and all actions are checked by default. Uncheck the checkbox that you do not want to apply to the target. 
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When you selected a table/collection in the list, the bottom pane shows data in the source and target. Values that differ 

between the source and target are highlighted. To view multiple lines data, right-click the grid and select Show 

Assistant Viewer. Uncheck the records that you do not want to apply to the target. 

Choose an option from the drop-down list to show the data. 

Option Description 

Difference Show all records that are different in the source and target. 

Insert Only show the records that do not exist in the target. 

Update Only show the records that exist in both source and target, but they have different 

values. 

Delete Only show the records that do not exist in the source. 

Same Show the records that exist in both source and target and they have identical 

values. 

All Rows Show all records in the source and target. 

 

Click the Next button to show the scripts of all selected tables/collections and records. 

Edit & Execute Selected Scripts (Step 4) 

You can view all scripts that will be executed in the target database in the Deployment Script tab. 

Deployment Options 

Button 

Description 

Deployment Options Continue on error - Ignore errors that are encountered during the 

execution process if necessary. 

Run multiple queries in each execution - Execute multiple SQL 

statements at once, which will make the transfer synchronization faster. 

Use transaction - Rollback all data when error occurs. 
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Include deployment query in message log - Show all executed queries 

in the Message Log tab. 

Edit Script Open the Edit Deployment Script window to rearrange the order of the 

scripts. 

Copy Script to Clipboard Copy all scripts from the Deployment Script tab to the clipboard. 

Open Script in Query 

Editor 

Open a new query window and display the scripts. 

In the Edit Deployment Script window, use the arrow buttons to move the scripts. 

Then, click the Start button to execute the scripts. The window will display the execution progress, execution time, and 

success or failure messages. 

Structure Synchronization (Available only in Navicat Premium, 

Enterprise and Standard Edition) 

About Structure Synchronization 

Navicat allows you to compare and modify the table structures and other objects with detailed analytical process. In 

other words, Navicat compares objects between two databases and/or schemas and states the differential in structure. 

To open the Structure Synchronization window, choose Tools -> Structure Synchronization from the menu bar. 

You can save your settings as a profile for future use. To open a saved profile, click the Load Profile button and select 

a profile from the list. 

Hint: Profiles are saved under the Profiles Location. 

Note: Available only for MySQL, Oracle, PostgreSQL, SQL Server, MariaDB, MongoDB and Snowflake. Navicat 

Premium and Navicat for MySQL support synchronizing between MySQL and MariaDB. 

Choose Connections & Comparing Options (Step 1) 

Choose Source and Target Connections 

In the Structure Synchronization window, define connections, databases and/or schemas for Source Database and 

Target Database. You can click  to swap the source and target settings. 

Choose Comparing Options 

Then, click the Options button to set the database/schema comparing options. The options depend on the connection 

server type and sort in ascending order. 

Compare auto increment value 

Check this option if you want to compare the auto increment values of tables. 
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Compare character set 

Check this option if you want to compare the character sets of tables. 

Compare checks 

Check this option if you want to compare checks. 

Compare collation 

Check this option if you want to compare the collations of tables. 

Compare definers 

Check this option if you want to compare the definers. 

Compare events 

Check this option if you want to compare events. 

Compare excludes 

Check this option if you want to compare table excludes. 

Compare foreign keys 

Check this option if you want to compare table foreign keys. 

Compare functions 

Check this option if you want to compare functions. 

Compare identity last value 

Check this option if you want to compare the identity last values of tables. 

Compare indexes 

Check this option if you want to compare indexes. 

Compare owners 

Check this option if you want to compare the owners of the objects. 

Compare partitions 

Check this option if you want to compare table partitions. 

Compare primary keys 

Check this option if you want to compare table primary keys. 
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Compare rules 

Check this option if you want to compare rules. 

Compare sequences 

Check this option if you want to compare sequences. 

Compare storage 

Check this option if you want to compare table storages. 

Compare table options 

Check this option if you want to compare other table options. 

Compare tables 

Check this option if you want to compare tables. 

Compare tablespace and physical attributes 

Check this option if you want to compare tablespace and physical attributes. 

Compare triggers 

Check this option if you want to compare triggers. 

Compare uniques 

Check this option if you want to compare table uniques. 

Compare views 

Check this option if you want to compare views. 

Drop with CASCADE 

Check this option if you want to drop the dependent database objects with the CASCADE option. 

Identifier Case Sensitivity 

Ignore or consider the case of identifiers when mapping, or use the server default setting. 

Start Comparison 

Click the Compare button to compare the source and target databases. 
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View Structure Comparison Results (Step 2) 

After comparing structures, the tree view shows the differences between the source and target databases or schemas. 

Check the objects you want to apply to the target. You can expand the table objects to view the detailed structure. 

You can choose to group the objects in the tree views by object types or operations by selecting Group by object type 

or Group by operation. 

Operation Description 

 

Object exists in both source and target databases/schemas, but they have different 

definition. The target object will be modified based on the source object. 

 

Object does not exist in the target database/schema. It will be created in the target. 

 

Object does not exist in the source database/schema. The target object will be deleted. 

 

Object exists in both source and target databases/schemas and they have identical 

definition. No operation will be applied. 

When you select an object from the comparison results, the DDL Comparison tab displays the statements for that 

object from both the source and the target databases side by side. Any differences in the statements, such as added, 

modified, or removed fields, are highlighted for quick identification. 

Furthermore, the Deployment Script tab shows the specific scripts that will be executed on the target database to apply 

the selected changes. 

Click the Next button to show the scripts of all selected objects. 

Edit & Execute Selected Scripts (Step 3) 

You can view all scripts that will be executed in the target database in the Deployment Script tab. 

Deployment Options Button Description 

Deployment Options Continue on error - Ignore errors that are encountered during the 

execution process if necessary. 

Include deployment query in message log - Show all executed 

queries in the Message Log tab. 

Edit Script Open the Edit Deployment Script window to rearrange the order of 

the scripts. 

Copy Script to Clipboard Copy all scripts from the Deployment Script tab to the clipboard. 

Open Script in Query Editor Open a new query window and display the scripts. 

In the Edit Deployment Script window, use the arrow buttons to move the scripts. 

Then, click the Start button to execute the scripts. The window will display the execution progress, execution time, and 

success or failure messages. 
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Dump & Execute SQL / Script File 

The Dump SQL File, Execute SQL File, Dump Script File and Execute Script File features allow you to dump your 

database, schema, tables or collections to a SQL or .js file or execute SQL or .js files in your connection, database or 

schema. 

Note: Available only for MySQL, Oracle, PostgreSQL, SQLite, SQL Server, MariaDB, MongoDB and Snowflake. 

To dump a file 

1. In the main window, right-click an opened database/schema or right-click the selected tables/collections, and 

select Dump SQL File or Dump Script File -> Structure Only or Structure And Data. 

2. Browse the save location and enter a file name. 

3. Click Save. 

Hint: After the dump process finished, you can click the Open button to open the file using Query Editor. 

To execute a file 

1. In the main window, right-click an opened connection, database or schema and select Execute SQL File or 

Execute Script File. 

2. Browse your SQL or .js file, choose the encoding of the file and enable appropriate options. 

Option Description 

Continue on error Ignore errors that are encountered during the execution process. 

Run multiple queries in 

each execution 

Execute multiple SQL statements at once, which will make the 

execution process faster. 

SET AUTOCOMMIT=0 / 

No Auto Commit 

Disable auto commit mode. 

3. Click Start. 

Hint: You can drag and drop a .sql or .js file to an opened connection, database or schema in the Navigation pane. 

Navicat will pop up the Execute SQL File or Execute Script File window automatically. 

Execute Command File 

The Execute Command File feature allow you to execute Redis command file (.redis) in your connection or database. 

Note: Available only for Redis. 

To execute a file 

1. In the main window, right-click an opened connection or database and select Execute Command File. 



 239 

 

2. Browse your .redis file, choose the encoding of the file and enable appropriate options. 

Option Description 

Batch Size Specify the maximal number of commands in a batch. 

Continue on error Ignore errors that are encountered during the execution process. 

3. Click Start. 

Hint: You can drag and drop a .redis file to an opened connection or database in the Navigation pane. Navicat will pop 

up the Execute Command File window automatically. 

MongoImport & MongoExport 

About MongoImport & MongoExport 

MongoDB provides two utilities for import and export data: MongoImport and MongoExport. You can import or export 

the data according to the specified conditions. 

MongoImport 

MongoImport allows you to import data from a JSON, CSV or TSV file into MongoDB database. 

Note: You must have mongoimport executable for this feature to work. 

To import a file 

1. In Navicat main window, right-click your database and select MongoImport. 

2. In the General and Advanced tabs, select the input file path, the target collection, the file type, and the 

appropriate import options. 

3. Click the Start button to begin the import process. The Message Log tab will display the import progress, 

execution time, and success or failure messages. 

You can save your settings as a profile for future use or setting automation tasks. To open a saved profile, click the 

Load Profile button and select a profile from the list. 

Hint: Profiles are saved under the Profiles Location. 

MongoExport 

MongoExport allows you to export MongoDB collections to a JSON or CSV file. 

Note: You must have mongoexport executable for this feature to work. 

To export collections 

1. In Navicat main window, right-click your database and select MongoExport. 
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2. In the General and Advanced tabs, select the export file path, the source collection, the file type, and the 

appropriate export options. 

3. Click the Start button to begin the export process. The Message Log tab will display the export progress, 

execution time, and success or failure messages. 

You can save your settings as a profile for future use or setting automation tasks. To open a saved profile, click the 

Load Profile button and select a profile from the list. 

Hint: Profiles are saved under the Profiles Location.  
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Chapter 15 - Data Generation (Available only in 

Navicat Premium, Enterprise and Standard 

Edition) 

About Data Generation  

With the column-intelligent data generation, you can populate selected tables with realistic and meaningful test data. 

The generated data in one column is based on the data in another. You can populate empty tables, or add extra rows to 

your existing tables, and control over the creation of the foreign key data. To open the Data Generation window, 

choose Tools -> Data Generation from the menu bar. 

You can save your settings as a profile for future use or setting automation tasks. To open a saved profile, click the 

Load Profile button and select a profile from the list. 

Hint: Profiles are saved under the Profiles Location. 

Note: Available only for MySQL, Oracle, PostgreSQL, SQLite, SQL Server, MariaDB, MongoDB and Snowflake. 

Choose Target Connection (Step 1) 

Choose Target Connection 

In the Data Generation window, define the target connection, database and/or schema. 

Choose Advanced Options 

Then, click the Options button to set the advanced options. The options depend on the target connection server type 

and sort in ascending order. 

Continue on error 

Ignore errors that are encountered during the data generation process. 

Empty collections before generating data 

Remove all data in the target collections before generating data. 

Empty tables before generating data 

Remove all data in the target tables before generating data. 

Run multiple insert statements 

Execute multiple INSERT statements at once, which will make the execution process faster. 
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Use extended insert statements 

Insert records using extended insert syntax. 

Example: INSERT INTO `users` VALUES ('1', 'Peter McKindsy', '23'), ('2', 'Johnson Ryne', '56'), ('0', 'Katherine', '23'); 

Use transaction 

Check this option if you want to use transaction during the data generation process. 

Choose Objects & Column Properties (Step 2) 

Choose Objects to Populate 

All tables are unselected in the Database Objects list by default. Check the tables and columns that you want to 

populate. 

 

You can copy all the settings from one object and paste the settings to other objects by right-clicking an object in the 

list. 

Choose Table / Collection Properties 

You can specify the volume of the data you want to generate for each table/collection. 

Navicat did not take dependencies into account when defining the order in which tables/collections data will be 

generated. Click the Table Generation Order/Collection Generation Order button to change the order if necessary. 

Choose Column Properties 

Navicat automatically assigns a generator to each column based on its table name, column name, data type, and 

length. Use the Generator combo box to select a generator from the list. 
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The following table shows the common properties. 

Option Description 

Include default values Generate default values. You can set the default value of the column, and 

set the Percentage of the default values in the column. 

Include null values Generate NULL values. You can set the Percentage of Null values in the 

column. 

Set unique Make the values generated for the column unique. 

Convert value to Convert the values to lower case, upper case or proper case (the first 

letter in each word is capitalized, the other letters are lower case). 

Disable data linkage 

between fields 

Unlink the data between this field with other fields. 

If this option is unchecked, Navicat will generate data with linkage 

between fields. Example: If the name field is "Robert Rose", the email 

field will be like "robertrose@outlook.com". 

 

Use Generator (Step 2.1) 

Number Generator 

The Number Generator generates numeric values such as integers and decimal numbers. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Start Specify the minimum numeric value. 

End Specify the maximum numeric value. 

Number Type Choose the type of the numeric values: Integer or Decimal Number. 

 

Date / Time / DateTime Generator 

The Date / Time / DateTime Generator generates dates and/or times. 

Generator Properties 

You can customize the generator by changing its properties. The properties depend on the generator you are chosen. 

Option Description 

Start Date Specify the minimum date value. 

End Date Specify the maximum date value. 

Whole Day Include any time of the day. 

Start Time Specify the minimum time value. 

End Time Specify the maximum time value. 

Day of the Week Choose the day of the week for the date value. 
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Sequence Generator 

The Sequence Generator generates randomized sequences of integers. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Start Specify first number in the sequence. 

Increment Specify the value added to the current sequence value to create a new value. 

Min Specify the lower bound of the sequence range. 

Max Specify the upper bound of the sequence range. 

Cycle The sequence continues to generate values after reaching either its maximum 

or minimum value. 

 

Enum Generator 

The Enum Generator generates values from specified value list. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Values Specify the values. Values are generated from the existing data of the 

column, where applicable. 

 

Text Generator 

The Text Generator generates dummy text values. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Number of Characters Specify the minimum and maximum number of characters. 

 

Image/Binary Generator 

The Image/Binary Generator generates images and Binary data, or randomly imports files in a specified folder. 

Generator Properties 

You can customize the generator by changing its properties: 
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Option Description 

Image Generator 

Image Width Specify the width of the image. 

Image Height Specify the height of the image. 

Image Format Choose the image file format. 

Randomly Pick From Folder 

Folder Path Specify a folder containing a number of images or binary data files. 

Filter with Extensions Specify the extension list for the files that are being imported. 

 

Foreign Key Generator 

The Foreign Key Generator generates foreign key values for a child table field based on the values contained in a 

parent table field. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Schema Choose the schema of the parent table. 

Table Choose a parent table. 

Field Choose a field in the parent table. Make sure that the child table column and 

the parent table column have compatible types. 

Generation Mode Choose the generation mode of the data: random data, no repeated data or 

specified number of repetitions. 

 

UUID Generator 

The UUID Generator generates a set of universally unique identifiers (UUIDs) based on the specified format. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

UUID Format Generate UUIDs with or without hyphens. 

Regular Expression Edit the regular expression. For more information about regular expression, 

see Regular Expression Generator. 

 

Regular Expression Generator 

The Regular Expression Generator generates values based on a regular expression. 

Generator Properties 
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You can customize the generator by changing its properties: 

Option Description 

Regular Expression Enter the regular expression. 

Syntax Elements 

The following table shows the syntax elements. 

Description Example Generates 

Basic 

ordinary chars Kelly Kelly 

individual chars [AB] A or B 

initial ] in char set []] ] 

[x-y] range [0-9] e.g. 2 or 7 

[chars] character set [A-Z0-9] e.g. 3 or M 

[exclude chars] character set [^abc] e.g. m or [ 

* zero or more abc* e.g. abcc or ab 

+ 1 or more abc+ e.g. abcccc or abc 

? Include or not abc? ab or abc 

(regexp) grouping (abc)*d e.g. abcabcd or d 

{num} repeat b{4} bbbb 

{min,max} repeat b{3,4} bbb or bbbb 

{min,} at least min repeats b{4,} e.g. bbbb or bbbbbbbbb 

() empty string () 

 

| alternatives True|False True or False 

empty alternative th(e|is|at) e.g. the or that 

Escapes 

backslash \\ \ 

dot \. . 

caret \^ ^ 

dollar sign \$ $ 

left curly bracket \{ { 

right curly bracket \} } 

left square bracket \[ [ 

right square bracket \] ] 

left parenthesis \( ( 

right parenthesis \) ) 

vertical bar \| | 

asterisk \* * 

plus mark \+ + 

question mark \? ? 

upper or lower-case letter or underscore or \w [A-Za- z_0-9] 
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digit 

all ASCII printable characters \W [ -~] 

digit \d [0-9] 

carriage return \r 

 

tab character \t 

 

space character \s 

 

 

Name Generator 

The Name Generator generates first, last or full names in English, Chinese or Japanese. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Format Type Generate first names, last names or full names. 

Languages Select the language of the names. 

 

Gender Generator 

The Gender Generator generates different genders in English, Chinese or Japanese. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Languages Select the language of the genders. 

 

Title Generator 

The Title Generator generates different titles in English, Chinese or Japanese. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Languages Select the language of the titles. 

 

Marital Status Generator 

The Marital Status Generator generates different marital status types in English, Chinese or Japanese. 

Generator Properties 
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You can customize the generator by changing its properties: 

Option Description 

Languages Select the language of the marital status. 

 

Phone Number Generator 

The Phone Number Generator generates random phone numbers which follow the phone number rules. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Format Choose the format of the phone numbers. If you choose to generate 

international phone numbers, the country code will be added. 

Include delimiters Add delimiters to the phone numbers. 

Regions Select the region of the phone numbers. 

 

Email Generator 

The Email Generator generates emails with the specified domain names. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Domains Enter a list of email domain names. 

 

Job Title Generator 

The Job Title Generator generates different job titles in English, Chinese or Japanese. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Languages Select the language of the job titles. 

 

Social Network ID Generator 

The Social Network ID Generator generates random social network account names. 



 249 

 

Payment Method Generator 

The Payment Method Generator generates payment methods from specified value list. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Values Specify the payment methods. 

 

Credit Card Type Generator 

The Credit Card Type Generator generates types of credit cards. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Types Select the credit card types. 

 

Credit Card Number Generator 

The Credit Card Number Generator generates credit card numbers for different credit card types. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Types Select the credit card type. 

 

Credit Card Date Generator 

The Credit Card Date Generator generates the issuance dates or expiration dates of credit cards. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Date Type Generate issuance dates or expiration dates. 

Date Range Choose the date range (MM/YY - MM/YY). 
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Company Name Generator 

The Company Name Generator generates company names in English, Chinese or Japanese. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Languages Select the language of the company names. 

 

Department Generator 

The Department Generator generates company department names in English, Chinese or Japanese. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Languages Select the language of the department names. 

 

Industry Generator 

The Industry Generator generates industry names in English, Chinese or Japanese. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Languages Select the language of the industry names. 

 

Address Generator 

The Address Generator generates line 1, line 2 or full addresses of US, UK, China or Japan. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Type Generate line 1, line 2 or full addresses. 

Regions Select the region of the addresses. 
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City Generator 

The City Generator generates city names in US, UK, China or Japan. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Regions Select the region of the cities. 

Languages Select the language of the city names. 

 

Region Generator 

The Region Generator generates region names or ISO 3166 country codes in English, Chinese or Japanese. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Format Generate region names, ISO 3166-1 alpha-2 or ISO 3166-1 alpha-3 country 

codes. 

Languages Select the language of the region names. 

 

Product Name Generator 

The Product Name Generator generates product names with the specified keywords. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Generate with keywords Specify keywords for generating the product names. 

 

Product Category Generator 

The Product Category Generator generates product category names in English, Chinese or Japanese. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Languages Select the language of the category names. 
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Color Generator 

The Color Generator generates color names in English, Chinese or Japanese. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Languages Select the language of the color names. 

 

Size Generator 

The Size Generator generates size (XS / S / M / L / XL) in English, Chinese or Japanese. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Languages Select the language of the size. 

 

Weight Unit Generator 

The Weight Unit Generator generates weight units from specified value list. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Values Specify the weight units. 

 

Barcode Generator 

The Barcode Generator generates barcodes based on different barcode types or the specified format. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Types Select the barcode types. You can customize Code39 barcode format in the 

Regular Expression box. For more information about regular expression, 

see Regular Expression Generator. 
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SKU Generator 

The SKU Generator generates stock keeping units (SKU) based on the specified format. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Regular Expression Edit the regular expression. For more information about regular expression, 

see Regular Expression Generator. 

 

IP Address Generator 

The IP Address Generator generates IPv4 or IPv6 addresses. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

IP Address Type Generate IPv4 or IPv6 addresses. 

Regular Expression Edit the regular expression. For more information about regular expression, 

see Regular Expression Generator. 

 

MAC Address Generator 

The MAC Address Generator generates random MAC addresses with the specified format. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Regular Expression Edit the regular expression. For more information about regular expression, 

see Regular Expression Generator. 

 

File Path Generator 

The File Path Generator generates file paths for Windows, macOS or Linux. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Path type Select the OS type of the file paths. 
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Include file name Append file names to the end of the paths. 

Extension Type Choose the file extension type. 

Extensions Edit the file extensions. 

 

File Name Generator 

The File Name Generator generates file names. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Include extension Append file extensions to the file names. 

Extension Type Choose the file extension type. 

Extensions Edit the file extensions. 

 

File Extension Generator 

The File Extension Generator generates file extensions. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Extension Type Choose the file extension type. 

Extensions Edit the file extensions. 

 

URL Generator 

The URL Generator generates URLs with the specified subdomains and top-level domains. 

Generator Properties 

You can customize the generator by changing its properties: 

Option Description 

Subdomain Enter a list of website subdomains. 

Top-Level-Domain Enter a list of top-level domains. 

 

Hostname Generator 

The Hostname Generator generates server hostnames with the specified subdomains and top-level domains. 

Generator Properties 
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You can customize the generator by changing its properties: 

Option Description 

Subdomain Enter a list of website subdomains. 

Top-Level-Domain Enter a list of top-level domains. 

 

Preview Data & Start Generation (Step 3) 

You can preview the data that will be generated for each table. 

Click the Start button to execute the data generation process. The window will display the execution progress, 

execution time, and success or failure messages. 

  



 256 

 

Chapter 16 - Data Dictionary (Available only in 

Navicat Premium, Enterprise and Standard 

Edition) 

About Data Dictionary 

Data Dictionary helps you manage and document your database systems efficiently. It acts as a centralized repository 

of metadata, providing comprehensive information about the structure, relationships, and properties of the database 

objects. You can create a data dictionary at server, database, schema level. To open the Data Dictionary window, 

choose Tools -> Data Dictionary from the menu bar. 

You can save your settings as a profile for future use or setting automation tasks. To open a saved profile, click the 

Load Profile button and select a profile from the list. 

Hint: Profiles are saved under the Profiles Location. 

Note: Available only for MySQL, Oracle, PostgreSQL, SQLite, SQL Server, MariaDB, MongoDB and Snowflake. 

Choose Databases (Step 1) 

In the Data Dictionary window, select the databases and/or schemas you want to generate data dictionary. 

Choose Objects & Change Order (Step 2) 

In the list, choose objects to include in the data dictionary. 

Navicat will generate the data dictionary contents based on the sequence of the objects on the list. You can select the 

objects and use the arrow buttons to change the order. 

Choose Template (Step 3) 

Navicat provides several templates for data dictionary files. You can choose the appropriate template and follow the 

remaining steps to customize your settings. 

Adjust Layout Settings (Step 4) 

You can adjust the layout of the template and view the preview on the left pane. 

Layout Properties 

Option Description 

Cover 

Include cover Add a cover page. 
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Header Logo Insert a preceding image in the header. 

Header Enter a header that appears once at the top of the cover page. 

Title Enter the title of the data dictionary. 

Subtitle Enter the subtitle of the data dictionary. 

Remarks Enter remarks that appear on the cover page. 

Background Image Default - Use the default background image. 

Custom - Insert a background image for the cover page. 

None - Explicitly not insert a background image.  

Footer Enter a footer that appears once at the bottom of the cover page. 

Table of Contents 

Include table of contents Add table of contents to the data dictionary. 

Header/Footer 

Include breadcrumbs 

header 

Add a breadcrumbs header that appears at the top of every page except the 

cover and table of contents. 

Heading Font Set the font style of the heading. 

Subheading Font Set the font style of the subheading. 

Include left footer Add a footer that appears at the bottom left of every page except the cover, 

table of contents and introduction. 

Include page number in 

right footer 

Add page numbers to the right footer of every page except the cover, table 

of contents and introduction. 

Footer Font Set the font style of the footer. 

Main Content 

Include Introduction Add a page for introducing the data dictionary. 

Introduction Enter the introduction. 

Font Set the font style of the introduction. 

Paper 

Paper Choose the paper size. 

Orientation Select a page orientation (Portrait or Landscape). 

Margin (CM) Set the margins of the document. 

 

Set File Path & Start Generation (Step 5) 

Set File Path & Other Options 

Option Description 

Export To File Specify the path of the data dictionary file. 

Append timestamp to file 

name 

Append timestamp information to the file name to show when the file is 

created. 

Overwrite existing file Overwrite if the file already exists. 

Continue on error Ignore errors that are encountered during the generation process. 

Start Generation 
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Click the Start button to generate the data dictionary. The window will display the generation progress, time, and 

success or failure messages. 

After the generation process finished, you can click the Open button to open the data dictionary file 
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Chapter 17 - BI (Available only in Navicat 

Premium and Enterprise Edition) 

About BI 

BI feature is designed to help you extract insights and make data-driven decisions by providing powerful data 

visualization, reporting, and analytics capabilities. In the main window, click  BI to open the workspace object list. 

Note: Available only for MySQL, Oracle, PostgreSQL, SQLite, SQL Server, MariaDB, MongoDB and Snowflake. 

Some of key features are listed here: 

• Support more than 20 chart types. 

• Customize multiple pages dashboard. 

• Visualize live data. 

• Add interactive controls. 

Hint: Workspace files (.nbi) are saved under the Profiles Location. To open the folder, right-click a workspace file and 

select Open Containing Folder. If the workspace is synchronized to Navicat Cloud or On-Prem Server, it will be 

stored in the cloud. 

Open an external workspace file 

1. In the menu bar, choose File -> Open External File -> BI Workspace. 

2. Browse the file and click Open in the dialog window. 

Save an opened external file as a Navicat workspace 

1. In Workspace Designer, choose File -> Save to Navicat. 

2. Enter the workspace name and choose the save location. 

3. Click OK. 

Save a Navicat workspace as an external file 

1. In Workspace Designer, choose File -> Save to File. 

2. Choose the save path and enter the file name. 

3. Click Save. 
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Workspace 

A workspace is the place that comprises dashboards, charts and data sources. You can create multiple dashboards, 

charts and data sources in a workspace. 

 

 Workspace Toolbar 

The Workspace Toolbar provides controls that you can use to create data sources, charts and dashboards. 

 Tab Bar 

The Tab Bar allows you to switch among the opened items. 

 Content Pane 

The Content pane shows all items in the workspace. To change the view, click the  Detail or  Icon button at the 

bottom of the window. 

Detail View displays additional information about each item. You can sort items in Detail View, click the column header 

by which you want to sort the items. 

Icon View displays your items as a grid of thumbnail images. You can filter the items by clicking a category (All, Data 

Source, Chart, Dashboard) in this view. 

 Properties Pane 

The  General tab shows the general information of the workspace or the selected item. 

The  Using tab shows the items that the selected item depends on. 

The  Used By tab shows the items that depend on the selected item. 
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If the Properties pane is hidden, choose View -> Show Properties from the menu bar. 

Data Source 

About Data Source 

Data sources reference tables in your connections or data in files/ODBC sources, and can select data from tables on 

different server types. The fields in the dataset can be used to construct a chart. When building a chart, you will need to 

specify the data source that the chart uses. 

 

 Connections Pane 

The Connections pane is the basic way to navigate with connections, databases, tables, queries. 

 Data Source Toolbar 

The Data Source Toolbar provides controls that you can use to manipulate the data. 

 Design Pane 

The Design pane allows you to build the data source visually. 

Navicat provides two modes for connecting your data: Live and Achieve. 

Live mode retrieves data from your servers whenever the data source is being used / loaded. It offers the convenience 

of real-time updates, with any changes in the underlying data reflected. 

Archive mode retrieves data from your servers during the data source creation, and stored the retrieved data in the 

workspace for later use by building charts. 

 Preview Pane 



 262 

 

The Preview pane displays the data of the data source. You can click  Column to show or hide the columns. 

 Properties Pane 

The  Properties tab shows the general information of the data source. You can add a remark to the data source. 

The  Used By tab shows the charts that depend on the data source. 

If the Properties pane is hidden, choose View -> Show Properties from the menu bar. 

Create Data Source 

The essential steps to create a data source are: 

1. In the Workspace window, click  New Data Source. 

2. Enter the name of the data source and select the desired connections, files or existing data sources. 

Option Description 

Database Create data source using existing connections in Navicat, or create a 

new connection in the workspace. For more information about 

connection settings, see Connections. 

File/ODBC Import data to the workspace, or link the data source to the data in a 

supported external file or ODBC source. For more information about 

import steps, see Import Wizard. 

Recent Connections Choose the connections used in other existing data sources in the 

workspace. 

3. Click OK. 

4. A tab will open for you to edit the data source. 

5. If you want to add more connections, click + and follow the steps. 

6. Drag and drop tables from the Connections pane to the Design pane. You can view the table data by clicking 

. 

7. Drag and drop a node to another to create the join. 

8. Configure the join type and join fields if necessary. 
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Hint: After creating the join, you can change the join settings at any time by clicking the join icon on the 

connector. 

9. Choose Live mode or Archive mode. 

10. Click Apply and Refresh Data to view the data. 

Add Query to Database Connection 

For database connections, you can save query results to create a new dataset. 

To create a new query 

1. On the Connections pane, double-click  New Data Source Query. 

2. Write the statement in Query Editor. You can also use Query Builder to build the query visually. 

3. Click Save Query. 

4. Enter the name of the query and click Save. 

To add an existing query 

1. On the Connections pane, double-click  New Data Source Query. 

2. Click  Import Query. 

3. Select a query. 

4. Click Import. 

5. Click Save Query. 

6. Enter the name of the query and click Save. 

Add Aggregation Pipeline to Database Connection 
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For MongoDB database connections, you can save aggregation pipeline results to create a new dataset. 

To create a new pipeline 

1. On the Connections pane, double-click  New Data Source Aggregation Pipeline. 

2. Build the pipeline using Pipeline Builder. 

3. Click Save Pipeline. 

4. Enter the name of the pipeline and click Save. 

To add an existing pipeline 

1. On the Connections pane, double-click  New Data Source Aggregation Pipeline. 

2. Click  Import Aggregation Pipeline. 

3. Select a pipeline. 

4. Click Import. 

5. Click Save Pipeline. 

6. Enter the name of the pipeline and click Save. 

Modify Data Source Connections 

My Connections 

To change a connection in My Connections to a workspace connection 

1. On the Connections pane, right-click a connection and select Convert to Workspace Connection. 

2. The connection will be moved to the "Workspace" section. 

To recreate a not found connection 

If the server connection in My Connections was removed, it will be moved to the "Not Found in My Connections" 

section. You may need to recreate the connection in order to connect the server. 

1. On the Connections pane, right-click a connection and select Recreate Connection in My Connections. 

2. Enter the connection properties. 

3. Click OK. 

Project Connections 

To change a project connection to a workspace connection 
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1. On the Connections pane, right-click a connection and select Convert to Workspace Connection. 

2. The connection will be moved to the "Workspace" section. 

To recreate a not found connection 

If the server connection in the project was removed, it will be moved to the "Not Found in Project" section. You may 

need to recreate the connection in order to connect the server. 

1. On the Connections pane, right-click a connection and select Recreate Connection in Project. 

2. Enter the connection properties. 

3. Click OK. 

Workspace Connections 

To edit the settings of a database connection 

1. On the Connections pane, right-click a database connection and select Edit Connection. 

2. Follow the steps to edit the connection. 

To change the user password of a database connection 

1. On the Connections pane, right-click a database connection and select Change Connection Password. 

2. Enter the database user password. 

3. Click OK. 

To edit the settings of a file connection 

1. On the Connections pane, right-click a file connection and select Edit File Connection Settings. 

2. Follow the steps to edit the connection. 

To change the path of a linked file connection 

1. On the Connections pane, right-click a file connection and select Change Linked File Path. 

2. Follow the steps to edit the connection. 

Filter / Sort / Project Data 

If your data source has many data or fields, you may find it easier to limit the data or fields to just the ones you want so 

you can simplify the data selections. 

Filter Data 
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Filter pane allows you to facilitate creating and applying filter criteria that you specify for the data. Click  Filter from 

the toolbar to activate the Filter pane. 

1. To add a new condition to the criteria, just simply click . If you want to add a condition with parentheses, 

click . 

2. Hint: To add parentheses to existing conditions, simply right-click on the selected conditions and select Group 

with Bracket. To remove the parentheses, right-click a bracket and select Delete Bracket or Delete Bracket 

and Conditions. 

3. Click on the field name (next to the checkbox) and choose a field from the list. 

4. Click on the operator (next to the field name) and choose a filter operator. 

Filter Operator Operator Description 

= The field is equal to 'value'. 

!= The field is not equal to 'value'. 

< The field is less than 'value'. 

<= The field is less than or equal to 'value'. 

> The field is greater than 'value'. 

>= The field is greater than or equal to 'value'. 

contains The field contains 'value'. 

does not contain The field does not contain 'value'. 

begin with The field starts with 'value'. 

does not begin with The field does not start with 'value'. 

end with The field ends with 'value'. 

does not end with The field does not end with 'value'. 

is null The field is NULL. 

is not null The field is NOT NULL. 

is empty The field is empty. 

is not empty The field is not empty. 

is between The field is between 'value1' and 'value2'. 

is not between The field is not between 'value1' and 'value2'. 

is in list The field is in the list of ('value1','value2',...). 

is not in list The field is not in the list of ('value1','value2',...). 

5. Click on <?> to activate the appropriate editor and enter the criteria values. The editor used in the criteria 

values box is determined by the data type assigned to the corresponding field. 

6. Click on the logical operator (next to the criteria values) to choose and or or. 

7. Repeat step 1-5 to add another new condition. 

8. Click Apply and Refresh Data to see the result of the filtering you made. 
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Hint: If you want to reverse the meaning of the conditions, right-click the selected conditions and select Toggle 

Negator. 

Sort Data 

Navicat offers the ability to sort and order data. Click  Sort from the toolbar to activate the Sort pane. 

1. To add a new criteria, just simply click . 

2. Click on the field name (next to the checkbox) and choose a field from the list. 

3. Click on the sorting order to choose ASC or DESC. 

4. Repeat step 1-3 to add another new criteria. 

5. Click Apply and Refresh Data to see the result of the sorting you made. 

Project Data 

You can choose which fields to include or exclude in the data source. Click  Projection from the toolbar to activate 

the Projection pane. 

1. Choose to Include or Exclude fields. 

2. To add a new criteria, just simply click . 

3. Click on the field name (next to the checkbox) and choose a field from the list. 

4. Repeat step 2-3 to add another new criteria. 

5. Click Apply and Refresh Data to see the result of the projection you made. 

Add Custom Fields 

You can extend your data with customized fields. New fields can be created by changing the field type, concatenating 

other fields, mapping to other values or sorting based on another field/customized order. 

Create Custom Field 

Type-Changed Field 

Field types (String, Number, Date/Time) are assigned to every field based on the actual data type of the field. If the field 

was not interpreted correctly, you can adjust the field type. 

1. In the bottom data grid, select a field and click  New Custom Field -> Type-Changed Field to get started. 

2. In the pop-up window, enter the Target Field Name. 

3. Choose the Target Field Type. 
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4. Choose the Source Field Name. 

5. Set the Source Field Data Format if necessary. 

6. Click OK. 

Concatenated Field 

You can add a new field and concatenate the data from two already existing fields. 

1. In the bottom data grid, select a field and click  New Custom Field -> Concatenated Field to get started. 

2. In the pop-up window, enter the Target Field Name. 

3. Double-click a field on the Source Fields pane to add it to the body. 

4. Edit the body and enable the Set null if all field values are null or empty option if necessary. 

5. Click OK. 

Mapped Field 

You can create a new field populated with the results of applying a mapping rule on every value in the source field. 

1. In the bottom data grid, select a field and click  New Custom Field -> Mapped Field to get started. 

2. In the pop-up window, enter the Target Field Name. 

3. Choose the Source Field Name. 

4. Click Add to create a new mapping rule. 

5. Enable the Compare source values with case sensitive option if necessary. 

6. Choose the action for the values that are not in the mapping rules. 

7. Click OK. 

Custom-Sorted Field 

You can create a new field to rearrange the order of the values, based on another field, or a custom order. When you 

sort this new field in the chart, it will be sorted in the order you set. 

1. In the bottom data grid, select a field and click  New Custom Field -> Custom-Sorted Field to get started. 

2. In the pop-up window, enter the Target Field Name. 

3. Choose the Source Field Name. 

4. [Reference Field] Choose the field which the sort order of the target field will be based on. 
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5. [Custom] Customize the order of the field values by moving the values to the Sorted Values list. 

6. Click OK. 

Calculated Field 

You can create a new field with a custom expression. You can use functions, fields and operators in the expression. 

1. In the bottom data grid, select a field and click  New Custom Field -> Calculated Field to get started. 

2. In the pop-up window, enter the Target Field Name. 

3. Enter an expression in the Body text box. 

4. Click OK. 

Edit Custom Field 

1. In the bottom data grid, right-click on the customized field and select Edit XXX Field. 

2. In the pop-up window, modify the field properties. 

3. Click OK. 

Delete Custom Field 

1. In the bottom data grid, right-click on the customized field and select Remove XXX Field. 

Examine Data Source Using Data Profiling 

You can profile a data source to unveil intricate patterns, trends, and relationships in the data, and identify 

discrepancies and errors in custom fields, enabling a meticulous examination of data integrity and accuracy. To initiate 

the profiling process, simply click  Data Profiling. See Data Profiling for details. 

Chart 

About Chart 

A chart provides visual representations of the data in your data source. It maps to a single data source, and can display 

correlations between several fields in the data. You can even make the chart interactive by adding a control chart. 

Note: You must add a data source before you can begin building charts. 



 270 

 

 

 Data Source Pane 

The Data Source pane is the basic way to navigate with the data sources. If the Data Source pane is hidden, choose 

View -> Show Data Source from the menu bar. 

 Chart Toolbar 

The Chart Toolbar provides controls that you can use to manipulate the data. 

 Metric Pane 

The Metric pane allows you to choose the chart type and add fields to the shelves from the Data Source Pane. If the 

Metric pane is hidden, choose View -> Show Metric from the menu bar. 

 Preview Pane 

The Preview pane displays the chart. 

 Properties Pane 

The  Properties tab includes the basic layout settings, data format settings and so on. The properties vary with the 

type of the chart. 

The  Using tab shows the data sources that the chart depends on. 

The  Used By tab shows the dashboards that depend on the chart. 

If the Properties pane is hidden, choose View -> Show Properties from the menu bar. 

Build Chart 

The essential steps to create a chart are: 
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1. In the Workspace window, click  New Chart. 

2. Select the data source and enter the name of the chart. 

3. A tab will open for you to edit the chart. 

4. Choose the Chart Type on the middle pane. 

 

Hint: The type of chart you will use is normally determined by the type of the data. 

5. Drag fields to the corresponding shelf in the Metric pane to set axis, values, etc. 

6. Select the properties on the right pane which can be further customized for your chart. 

Hint: Each chart type has different properties. 

7. The chart shows on the Preview pane. 

 

Set Field Alias 

You can create aliases for fields so that their labels appear differently in the chart. 

1. Click the down arrow in the field box. 

2. Select Set Alias. 

 

3. Enter the alias name. 
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Filter / Sort Data 

Filter Source Data in Chart 

You can use the Data Filter pane to filter the source data in the current chart. 

Filter Display Data in Chart 

You can filter the display data in 3 ways: 

 Click the down arrow in the field box and select Display Filter. 

 

 Use the Display Filter pane. 

 Right-click a series / data points on the chart. 

 

Hint: If you want to clear the filter, you need to use the Display Filter pane. 

Sort Data 

You can sort the data in 2 ways: 

 Click the down arrow in the field box and select Sort. 
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 Use the Sort pane. 

Apply Aggregate Function 

Aggregate functions allow you to summarize or change the granularity of your data. 

1. Click the down arrow in the field box. 

 

2. Select Aggregate and choose a aggregate function. 

Function Description 

Number 

Sum Return the sum of all values. Null values are ignored. 

Average Return the average of all the values. Null values are ignored. 

Count Return the number of items. Null values are not counted. 

Count(Distinct) Return the number of distinct items. Null values are not counted. 

Min Return the minimum value across all records. Null values are 

ignored. 

Max Return the maximum value across all records. Null values are 

ignored. 

Median Return the median value across all records. Null values are ignored. 

DateTime 

Count Return the number of items. Null values are not counted. 

Count(Distinct) Return the number of distinct items. Null values are not counted. 

Year Return the year of the date (0000-9999). 

Quarter Return the year of the date (0000-9999) and the quarter of the year 

(Q1-Q4). 

Month Return the year (0000-9999) and the month (01-12) of the date. 

Week Return the year of the date (0000-9999) and the week of the year 

(W01-W52, start of week is Sunday). 
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Day Return the date. 

Hour Return the date and the hour of the time (00-23). 

Minute Return the date, the hour of the time (00-23) and the minute of the 

time (00-59). 

Second Return the datetime. 

Quarter (Extract) Return the quarter of the year (Q1-Q4). 

Month (Extract) Return the month of the date (01-12). 

Week (Extract) Return the week of the year (W01-W52, start of week is Sunday). 

Day (Extract) Return the day of the date (01-31). 

Hour (Extract) Return the hour of the time (00-23). 

Minute (Extract) Return the minute of the time (00-59). 

Second (Extract) Return the second of the time (00-59). 

Text 

First Return the value of the first record. 

Last Return the value of the last record. 

Count Return the number of items. Null values are not counted. 

Count(Distinct) Return the number of distinct items. Null values are not counted. 

 

Add Range 

You can aggregate data into ranges without the need to create any additional calculations in the data source. 

1. Click the down arrow in the field box. 

 

2. Select Add Range. 

3. Edit the range settings. 

Option Description 

Range Type - Fixed 

Bin Size Either enter the size of a bin or click Calculate to let Navicat 

calculate a value for you. 

Range Type - Custom 

Stop Values Add the bin boundaries. 

4. Click OK. 
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Set Value Operation 

You can create a chart that shows a running total as values are added or subtracted. 

1. Click the down arrow in the field box. 

 

2. Select Value Operation and choose an operation. 

Operation Description 

Cumulative Sum the values cumulatively. 

Subtract Subtract the value with its previous value. 

 

Present Chart 

You can present the chart using the whole screen. The title bar, toolbars, tab bar, Data Source pane, Metric pane and 

Properties pane will be hidden while in this mode. To open a chart in present view, click  Present. 

To exit present view, press the ESC key and the workspace window will be returned to its previous state. 

Sort Chart 

In the Present mode, you can organize your data in a chart with one click. You can sort data series by a value. Simply 

click the  icon to sort on a different value and select the sorting order. 

Chart Types 

About Chart Types 

Navicat provides a variety of different chart types so data can be displayed in a meaningful way. 

Here is a complete list of available chart types: 

• Vertical Bar Chart 

• Vertical Stacked Bar Chart 

• Horizontal Bar Chart 

• Horizontal Stacked Bar Chart 

• Line Chart 
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• Area Chart 

• Stacked Area Chart 

• Bar and Line Chart 

• Stacked Bar and Line Chart 

• Waterfall Chart 

• Tornado Chart 

• Pie Chart 

• Donut Chart 

• Scatter Chart 

• Heatmap 

• Treemap 

• Value 

• Trend 

• KPI 

• Gauge 

• Table 

• Pivot Table 

• Control 

Bar Chart 

A bar chart provides high-level overviews of data trends by comparing values within a specific category. 

• Vertical Bar Chart 

• Vertical Stacked Bar Chart 

• Horizontal Bar Chart 

• Horizontal Stacked Bar Chart 
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Chart Properties 

Once you have selected a chart type, you can customize the chart by changing its properties: 

Option Description 

General 

Background Color Set the background color of the chart area. 

Show border Display the outer chart border. 

Border Color Set the color of the outer chart border. 

Show title Display the chart's main title. 

Title Specify the title of the chart. 

Title Font Set the font style of the title. 

Position Set the position of the title. 

Align Set the vertical or horizontal alignment of the title. 

Remarks Enter remarks for the chart. 

Legend 

Show legend Display the legend container. 

Position Set the position for the legend. 

Align Set the vertical or horizontal alignment of the legend. 

Label Color Set the color of the legend labels. 

Data 

Show Bar Labels Display the data labels of the selected series. 

Bar Label Contains Display the data values or/and the percentages on the labels. 

Bar Label Position Set the position of the bar labels. 

Use 100% stacked Use 100% stacked bars to show values for hierarchical data. (Each bar 

height is 100%, and the colored bar segments represent the components' 

relative contributions to the total bar.) 

Bar Label Font Set the font style of the bar labels. 

Use custom data value Customize the color of the labels of the data values. 
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color 

Positive Data Value Color Set the color of the positive value labels. 

Negative Data Value 

Color 

Set the color of the negative value labels. 

Show only top # Only the top # data are displayed. 

Style Plot discrete or continuous data series on the chart. 

Density Choose the density of the data series. 

Color Set the color palette of the data series. 

All Data Colors Allow setting the color for each series. 

Data Formats - Number 

Prefix Add prefix characters to all the numeric data on the chart. 

Unit Choose the unit to shorten the numeric data. 

Suffix Specify the suffix to label the customized unit. 

Divider Specify the divider for the customized unit. 

Thousand Separator Choose the thousands separator for numeric data. 

Decimal Separator Choose the decimal separator for numeric data. 

Decimal Places Specify decimal places for numeric data. 

Negatives Choose the format negative numbers are displayed. 

Data Formats - DateTime 

Date / Time Choose the date and time format of the data. 

Custom Customize the date and time format. 

X-Axis 

Show X-Axis title Display the title of X-Axis. 

X-Axis Title Specify the title of X-Axis. 

Font Set the font style of X-Axis title. 

Show X-Axis title at the 

end of axis 

Display the title at the end of X-Axis. 

Show X-Axis labels Display labels on X-Axis. 

Font / Bold Set the font style of X-Axis labels. 

X-Axis Label Rotation Rotate X-Axis labels. 

X-Axis Label Interval Change the interval between X-Axis labels. 

Show X-Axis Display X-Axis line. 

X-Axis Color Set the color of X-Axis line. 

Y-Axis 

Show Y-Axis title Display the title of Y-Axis. 

Y-Axis Title Specify the title of Y-Axis. 

Font Set the font style of Y-Axis title. 

Show Y-Axis title at the 

end of axis 

Display the title at the end of Y-Axis. 

Show Y-Axis labels Display labels on Y-Axis. 

Font / Bold Set the font style of Y-Axis labels. 
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Show Y-Axis Display Y-Axis line. 

Y-Axis Color Set the color of Y-Axis line. 

Show grid line Display the grid line of Y-Axis. 

Use custom range Set the range of the grid lines. Enter values in Start and End. The graph 

drawing beyond this range will be clipped off. 

Use custom interval Change the Interval on Y-Axis. 

Tick Interval Set the interval of the tick marks in axis units. 

Assistant Line 
 

Add an assistant line to the chart to show visual data trends, averages, 

normal distributions, etc. 
 

Remove the selected assistant line. 
 

Rename the selected assistant line. 

Value Select a data series for the assistant line. 

Group Value Select a group value for the assistant line. 

Type Choose the type of assistant line you want. 

Show R² value Display the R² value on the chart. 

Forward Forecast / 

Backward Forecast 

Specify the number of periods to include in a forecast. 

Align with other lines Align the assistant line with others. 

Period Specify the number of data points used to average the point value. 

Smooth Smooth the angles of the line. 

Use custom color Customize the color of the line. 

Line Color Set the color of the line. 

Cap Style Choose the cap style of the line. 

Dash Style Choose the dash style of the line. 

Join Style Choose the join style of the line. 

Visible Check this box to show the line. 

 

Line / Area Chart 

A line or area chart displays information as a series of data points connected by straight line segments. 

• Line Chart 

• Area Chart 

• Stacked Area Chart 
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Chart Properties 

Once you have selected a chart type, you can customize the chart by changing its properties: 

Option Description 

General 

Background Color Set the background color of the chart area. 

Show border Display the outer chart border. 

Border Color Set the color of the outer chart border. 

Show title Display the chart's main title. 

Title Specify the title of the chart. 

Title Font Set the font style of the title. 

Position Set the position of the title. 

Align Set the vertical or horizontal alignment of the title. 

Remarks Enter remarks for the chart. 

Legend 

Show legend Display the legend container. 

Position Set the position for the legend. 

Align Set the vertical or horizontal alignment of the legend. 

Label Color Set the color of the legend labels. 

Data 

Use smoothed line Plot a smooth line through the data points. 

Show Line Labels / Show 

Area Labels 

Display the data labels of the selected series. 

Line Label Contains Display the data values or/and the percentages on the labels. 

Line Label Pattern Select the values that will be displayed on the chart. 

Show markers Display the marker points on the line / area. 

Use 100% stacked Use 100% stacked areas to show values for hierarchical data. (The area 

height is 100%, and the colored area segments represent the components' 

relative contributions to the total area.) 

Use custom data value Customize the color of the labels of the data values. 
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color 

Positive Data Value Color Set the color of the positive value labels. 

Negative Data Value 

Color 

Set the color of the negative value labels. 

Show only top # Only the top # data are displayed. 

Density Choose the density of the data series. 

Color Set the color palette of the data series. 

Data Formats - Number 

Prefix Add prefix characters to all the numeric data on the chart. 

Unit Choose the unit to shorten the numeric data. 

Suffix Specify the suffix to label the customized unit. 

Divider Specify the divider for the customized unit. 

Thousand Separator Choose the thousands separator for numeric data. 

Decimal Separator Choose the decimal separator for numeric data. 

Decimal Places Specify decimal places for numeric data. 

Negatives Choose the format negative numbers are displayed. 

Data Formats - DateTime 

Date / Time Choose the date and time format of the data. 

Custom Customize the date and time format. 

X-Axis 

Show X-Axis title Display the title of X-Axis. 

X-Axis Title Specify the title of X-Axis. 

Font Set the font style of X-Axis title. 

Show X-Axis title at the 

end of axis 

Display the title at the end of X-Axis. 

Show X-Axis labels Display labels on X-Axis. 

Font / Bold Set the font style of X-Axis labels. 

X-Axis Label Rotation Rotate X-Axis labels. 

X-Axis Label Interval Change the interval between X-Axis labels. 

Show X-Axis Display X-Axis line. 

X-Axis Color Set the color of X-Axis line. 

Y-Axis 

Show Y-Axis title Display the title of Y-Axis. 

Y-Axis Title Specify the title of Y-Axis. 

Font Set the font style of Y-Axis title. 

Show Y-Axis title at the 

end of axis 

Display the title at the end of Y-Axis. 

Show Y-Axis labels Display labels on Y-Axis. 

Font / Bold Set the font style of Y-Axis labels. 

Show Y-Axis Display Y-Axis line. 

Y-Axis Color Set the color of Y-Axis line. 
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Show grid line Display the grid line of Y-Axis. 

Use custom range Set the range of the grid lines. Enter values in Start and End. The graph 

drawing beyond this range will be clipped off. 

Use custom interval Change the Interval on Y-Axis. 

Tick Interval Set the interval of the tick marks in axis units. 

Assistant Line 
 

Add an assistant line to the chart to show visual data trends, averages, 

normal distributions, etc. 
 

Remove the selected assistant line. 
 

Rename the selected assistant line. 

Value Select a data series for the assistant line. 

Group Value Select a group value for the assistant line. 

Type Choose the type of assistant line you want. 

Show R² value Display the R² value on the chart. 

Forward Forecast / 

Backward Forecast 

Specify the number of periods to include in a forecast. 

Align with other lines Align the assistant line with others. 

Period Specify the number of data points used to average the point value. 

Smooth Smooth the angles of the line. 

Use custom color Customize the color of the line. 

Line Color Set the color of the line. 

Cap Style Choose the cap style of the line. 

Dash Style Choose the dash style of the line. 

Join Style Choose the join style of the line. 

Visible Check this box to show the line. 

 

Bar and Line Chart 

Mixing bar and line chart in the same visual is a good way to emphasize the difference between series while still 

maintaining their relationship. 

• Bar and Line Chart 

• Stacked Bar and Line Chart 
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Chart Properties 

Once you have selected a chart type, you can customize the chart by changing its properties: 

Option Description 

General 

Background Color Set the background color of the chart area. 

Show border Display the outer chart border. 

Border Color Set the color of the outer chart border. 

Show title Display the chart's main title. 

Title Specify the title of the chart. 

Title Font Set the font style of the title. 

Position Set the position of the title. 

Align Set the vertical or horizontal alignment of the title. 

Remarks Enter remarks for the chart. 

Legend 

Show legend Display the legend container. 

Position Set the position for the legend. 

Align Set the vertical or horizontal alignment of the legend. 

Label Color Set the color of the legend labels. 

Data 

Use smoothed line Plot a smooth line through the data points. 

Show Labels Display the data labels of the selected series. 

Bar Label Contains Display the data values or/and the percentages on the labels. 

Bar Label Position Set the position of the bar labels. 

Bar Label Font Set the font style of the bar labels. 

Use 100% stacked bar Use 100% stacked bars to show values for hierarchical data. (Each bar 

height is 100%, and the colored bar segments represent the components' 

relative contributions to the total bar.) 

Line Label Contains Display the data values or/and the percentages on the labels. 
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Line Label Pattern Select the values that will be displayed on the chart. 

Show line markers Display the marker points on the line. 

Use custom data value 

color 

Customize the color of the labels of the data values. 

Positive Data Value Color Set the color of the positive value labels. 

Negative Data Value 

Color 

Set the color of the negative value labels. 

Show only top # Only the top # data are displayed. 

Style Plot discrete or continuous data series on the chart. 

Density Choose the density of the data series. 

Color Set the color palette of the data series. 

All Bar Data Colors Allow setting the color for each series. 

Data Formats - Number 

Prefix Add prefix characters to all the numeric data on the chart. 

Unit Choose the unit to shorten the numeric data. 

Suffix Specify the suffix to label the customized unit. 

Divider Specify the divider for the customized unit. 

Thousand Separator Choose the thousands separator for numeric data. 

Decimal Separator Choose the decimal separator for numeric data. 

Decimal Places Specify decimal places for numeric data. 

Negatives Choose the format negative numbers are displayed. 

Data Formats - DateTime 

Date / Time Choose the date and time format of the data. 

Custom Customize the date and time format. 

X-Axis 

Show X-Axis title Display the title of X-Axis. 

X-Axis Title Specify the title of X-Axis. 

Font Set the font style of X-Axis title. 

Show X-Axis title at the 

end of axis 

Display the title at the end of X-Axis. 

Show X-Axis labels Display labels on X-Axis. 

Font / Bold Set the font style of X-Axis labels. 

X-Axis Label Rotation Rotate X-Axis labels. 

X-Axis Label Interval Change the interval between X-Axis labels. 

Show X-Axis Display X-Axis line. 

X-Axis Color Set the color of X-Axis line. 

Y-Axis / Secondary Y-Axis 

Show Y-Axis title / Show 

Secondary Y-Axis title 

Display the title of Y-Axis. 

Y-Axis Title / Secondary 

Y-Axis Title 

Specify the title of Y-Axis. 
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Font Set the font style of Y-Axis title. 

Show Y-Axis title at the 

end of axis / Show 

Secondary Y-Axis title at 

the end of axis 

Display the title at the end of Y-Axis. 

Show Y-Axis labels / 

Show Secondary Y-Axis 

labels 

Display labels on Y-Axis. 

Font / Bold Set the font style of Y-Axis labels. 

Show Y-Axis / Show 

Secondary Y-Axis 

Display Y-Axis line. 

Y-Axis Color / Secondary 

Y-Axis Color 

Set the color of Y-Axis line. 

Show grid line Display the grid line of Y-Axis. 

Use custom range Set the range of the grid lines. Enter values in Start and End. The graph 

drawing beyond this range will be clipped off. 

Use custom interval Change the Interval on Y-Axis. 

Tick Interval Set the interval of the tick marks in axis units. 

Trend Line 
 

Add a trend line to the chart to show visual data trends. 
 

Remove the selected trend line. 
 

Rename the selected trend line. 

Value Select a data series for the trend line. 

Group Value Select a group value for the trend line. 

Type Choose the type of trend line you want. 

Show R² value Display the R² value on the chart. 

Forward Forecast / 

Backward Forecast 

Specify the number of periods to include in a forecast. 

Align with other trend lines Align the trend line with others. 

Period Specify the number of data points used to average the point value. 

Smooth Smooth the angles of the line. 

Use custom color Customize the color of the line. 

Line Color Set the color of the line. 

Cap Style Choose the cap style of the line. 

Dash Style Choose the dash style of the line. 

Join Style Choose the join style of the line. 

Visible Check this box to show the line. 
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Waterfall Chart 

A waterfall chart is a special type of bar chart. It is useful for understanding how the starting value is affected by a 

series of changes (increase or decrease). 

 

Chart Properties 

Once you have selected a chart type, you can customize the chart by changing its properties: 

Option Description 

General 

Background Color Set the background color of the chart area. 

Show border Display the outer chart border. 

Border Color Set the color of the outer chart border. 

Show title Display the chart's main title. 

Title Specify the title of the chart. 

Title Font Set the font style of the title. 

Position Set the position of the title. 

Align Set the vertical or horizontal alignment of the title. 

Remarks Enter remarks for the chart. 

Legend 

Show legend Display the legend container. 

Position Set the position for the legend. 

Align Set the vertical or horizontal alignment of the legend. 

Label Color Set the color of the legend labels. 

Data 

Show data values Display the values of the data series. 

Bar Label Position Set the position of the bar labels. 

Bar Label Font Set the font style of the bar labels. 

Total Bar Color Set the color of the Total bar. 

Subtotal Bar Color Set the color of the Subtotal bar. 

Total Bar Title Specify the title of the Total bar. 
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Use increase and 

decrease color 

Color the bars with Increase Color and Decrease Color. 

Increase Color Set the color of the bar when the value increases. 

Decrease Color Set the color of the bar when the value decreases. 

Use custom data value 

color 

Customize the color of the labels of the data values. 

Positive data value color Set the color of the positive value labels. 

Negative data value color Set the color of the negative value labels. 

Show only top # Only the top # data are displayed. 

Style Plot discrete or continuous bars on the chart. 

Density Choose the density of the bars. 

Group Value Sorting Sort the group values (from Decrease to Increase, or from Increase to 

Decrease). 

Color Set the color palette of the data series. 

All Data Colors Allow setting the color for each series. 

Data Formats - Number 

Prefix Add prefix characters to all the numeric data on the chart. 

Unit Choose the unit to shorten the numeric data. 

Suffix Specify the suffix to label the customized unit. 

Divider Specify the divider for the customized unit. 

Thousand Separator Choose the thousands separator for numeric data. 

Decimal Separator Choose the decimal separator for numeric data. 

Decimal Places Specify decimal places for numeric data. 

Negatives Choose the format negative numbers are displayed. 

Data Formats - DateTime 

Date / Time Choose the date and time format of the data. 

Custom Customize the date and time format. 

X-Axis 

Show X-Axis title Display the title of X-Axis. 

X-Axis Title Specify the title of X-Axis. 

Font Set the font style of X-Axis title. 

Show X-Axis title at the 

end of axis 

Display the title at the end of X-Axis. 

Show X-Axis labels Display labels on X-Axis. 

Font / Bold Set the font style of X-Axis labels. 

X-Axis Label Rotation Rotate X-Axis labels. 

X-Axis Label Interval Change the interval between X-Axis labels. 

Show X-Axis Display X-Axis line. 

X-Axis Color Set the color of X-Axis line. 

Y-Axis 

Show Y-Axis title Display the title of Y-Axis. 
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Y-Axis Title Specify the title of Y-Axis. 

Font Set the font style of Y-Axis title. 

Show Y-Axis title at the 

end of axis 

Display the title at the end of Y-Axis. 

Show Y-Axis labels Display labels on Y-Axis. 

Font / Bold Set the font style of Y-Axis labels. 

Show Y-Axis Display Y-Axis line. 

Y-Axis Color Set the color of Y-Axis line. 

Show grid line Display the grid line of Y-Axis. 

Use custom range Set the range of the grid lines. Enter values in Start and End. The graph 

drawing beyond this range will be clipped off. 

Use custom interval Change the Interval on Y-Axis. 

Tick Interval Set the interval of the tick marks in axis units. 

 

Tornado Chart 

A tornado chart is a special type of bar chart. It is useful for comparing data among different types of data or categories. 

 

Chart Properties 

Once you have selected a chart type, you can customize the chart by changing its properties: 

Option Description 

General 

Background Color Set the background color of the chart area. 

Show border Display the outer chart border. 

Border Color Set the color of the outer chart border. 

Show title Display the chart's main title. 

Title Specify the title of the chart. 

Title Font Set the font style of the title. 

Position Set the position of the title. 
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Align Set the vertical or horizontal alignment of the title. 

Remarks Enter remarks for the chart. 

Legend 

Show legend Display the legend container. 

Position Set the position for the legend. 

Align Set the vertical or horizontal alignment of the legend. 

Label Color Set the color of the legend labels. 

Data 

Show Bar Labels Display the data labels of the selected series. 

Bar Label Contains Display the data values or/and the percentages on the labels. 

Bar Label Position Set the position of the bar labels. 

Bar Label Font Set the font style of the bar labels. 

Use stack Use stacked bars to show values. 

Use 100% stacked Use 100% stacked bars to show values for hierarchical data. (Each bar 

height is 100%, and the colored bar segments represent the components' 

relative contributions to the total bar.) 

Stacked Bar Style Determine how the stacked section is displayed. 

Negative Data Bar 

Background Color 

Set the color of the negative data bars. 

Minimum Value Set the minimum value of the bar. 

Data Label Color Set the color of the data labels on the bars. 

Use custom data value 

color 

Customize the color of the labels of the data values. 

Positive data value color Set the color of the positive value labels. 

Negative data value color Set the color of the negative value labels. 

Show only top # Only the top # data are displayed. 

Style Plot discrete or continuous bars on the chart. 

Density Choose the density of the bars. 

Color Set the color palette of the data series. 

All Data Colors Allow setting the color for each series. 

Data Formats - Number 

Prefix Add prefix characters to all the numeric data on the chart. 

Unit Choose the unit to shorten the numeric data. 

Suffix Specify the suffix to label the customized unit. 

Divider Specify the divider for the customized unit. 

Thousand Separator Choose the thousands separator for numeric data. 

Decimal Separator Choose the decimal separator for numeric data. 

Decimal Places Specify decimal places for numeric data. 

Negatives Choose the format negative numbers are displayed. 

Data Formats - DateTime 

Date / Time Choose the date and time format of the data. 
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Custom Customize the date and time format. 

Y-Axis 

Axis position Set the position of Y-Axis. 

Show Y-Axis title Display the title of Y-Axis. 

Y-Axis Title Specify the title of Y-Axis. 

Font Set the font style of Y-Axis title. 

Fill missing values Use a continuous axis. The data series are positioned according to their 

domain value. 

Y-Axis Label Interval Change the interval between Y-Axis labels. 

Show Y-Axis labels Display labels on Y-Axis. 

Y-Axis Color Set the color of Y-Axis line. 

X-Axis 

Show X-Axis title Display the title of X-Axis. 

Left X-Axis Title Specify the title of the left X-Axis. 

Right X-Axis Title Specify the title of the right X-Axis. 

Font Set the font style of X-Axis title. 

Show X-Axis title at the 

end of axis 

Display the title at the end of X-Axis. 

Show X-Axis labels Display labels on X-Axis. 

Show X-Axis Display X-Axis line. 

X-Axis Color Set the color of X-Axis line. 

Show grid line Display the grid line of X-Axis. 

Use custom range Set the range of the grid lines. Enter values in Start and End. The graph 

drawing beyond this range will be clipped off. 

Use custom interval Change the Interval on X-Axis. 

Tick Interval Set the interval of the tick marks in axis units. 

 

Pie / Donut Chart 

A pie or donut chart displays data in a series of segments of a circle, with larger segments representing larger data 

values. 

• Pie Chart 

• Donut Chart 
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Chart Properties 

Once you have selected a chart type, you can customize the chart by changing its properties: 

Option Description 

General 

Background Color Set the background color of the chart area. 

Show border Display the outer chart border. 

Border Color Set the color of the outer chart border. 

Show title Display the chart's main title. 

Title Specify the title of the chart. 

Title Font Set the font style of the title. 

Position Set the position of the title. 

Align Set the vertical or horizontal alignment of the title. 

Remarks Enter remarks for the chart. 

Legend 

Show legend Display the legend container. 

Position Set the position for the legend. 

Align Set the vertical or horizontal alignment of the legend. 

Label Color Set the color of the legend labels. 

Data 

Show data labels Display data labels that clarify the data series. 

Show data values Display the values of the data series. 

Show data percentages Display the data percentages of the slices. 

Show label inside slice Position the slice labels inside the slice. Labels for smaller slices are hidden. 

Show label over other 

slices 

All labels are shown. Labels for smaller slices will overlap other slices. 

Show slice separator Add white borders between pie / donut slices. 

Data Label Color Set the color of the data label. 

Show only top # Only the top # data are displayed. 

Slice Group the small slices to a single slice (called Others). 
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Color Set the color palette of the data series. 

Data Formats - Number 

Prefix Add prefix characters to all the numeric data on the chart. 

Unit Choose the unit to shorten the numeric data. 

Suffix Specify the suffix to label the customized unit. 

Divider Specify the divider for the customized unit. 

Thousand Separator Choose the thousands separator for numeric data. 

Decimal Separator Choose the decimal separator for numeric data. 

Decimal Places Specify decimal places for numeric data. 

Negatives Choose the format negative numbers are displayed. 

Data Formats - DateTime 

Date / Time Choose the date and time format of the data. 

Custom Customize the date and time format. 

Group 

Show group title Display the title of the group. 

Group Title Specify the title of the group. 

Group Title Font Set the font style of the group title. 

 

Scatter Chart 

A scatter chart plots data with individual data points placed along the X and Y axes. 

 

Chart Properties 

Once you have selected a chart type, you can customize the chart by changing its properties: 

Option Description 
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General 

Background Color Set the background color of the chart area. 

Show border Display the outer chart border. 

Border Color Set the color of the outer chart border. 

Show title Display the chart's main title. 

Title Specify the title of the chart. 

Title Font Set the font style of the title. 

Position Set the position of the title. 

Align Set the vertical or horizontal alignment of the title. 

Remarks Enter remarks for the chart. 

Legend 

Show legend Display the legend container. 

Position Set the position for the legend. 

Align Set the vertical or horizontal alignment of the legend. 

Label Color Set the color of the legend labels. 

Data 

Show size values Display the size of the bubbles. 

Density Choose the density of the data series. 

Color Set the color palette of the data series. 

Data Formats - Number 

Prefix Add prefix characters to all the numeric data on the chart. 

Unit Choose the unit to shorten the numeric data. 

Suffix Specify the suffix to label the customized unit. 

Divider Specify the divider for the customized unit. 

Thousand Separator Choose the thousands separator for numeric data. 

Decimal Separator Choose the decimal separator for numeric data. 

Decimal Places Specify decimal places for numeric data. 

Negatives Choose the format negative numbers are displayed. 

Data Formats - DateTime 

Date / Time Choose the date and time format of the data. 

Custom Customize the date and time format. 

X-Axis 

Show X-Axis title Display the title of X-Axis. 

X-Axis Title Specify the title of X-Axis. 

Font Set the font style of X-Axis title. 

Show X-Axis title at the 

end of axis 

Display the title at the end of X-Axis. 

Show X-Axis labels Display labels on X-Axis. 

Font / Bold Set the font style of X-Axis labels. 

X-Axis Label Rotation Rotate X-Axis labels. 

X-Axis Label Interval Change the interval between X-Axis labels. 
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Show X-Axis Display X-Axis line. 

X-Axis Color Set the color of X-Axis line. 

Show grid line Display the grid line of X-Axis. 

Use custom range Set the range of the grid lines. Enter values in Start and End. The graph 

drawing beyond this range will be clipped off. 

Use custom interval Change the Interval on X-Axis. 

Tick Interval Set the interval of the tick marks in axis units. 

Y-Axis 

Show Y-Axis title Display the title of Y-Axis. 

Y-Axis Title Specify the title of Y-Axis. 

Font Set the font style of Y-Axis title. 

Show Y-Axis title at the 

end of axis 

Display the title at the end of Y-Axis. 

Show Y-Axis labels Display labels on Y-Axis. 

Font / Bold Set the font style of Y-Axis labels. 

Show Y-Axis Display Y-Axis line. 

Y-Axis Color Set the color of Y-Axis line. 

Show grid line Display the grid line of Y-Axis. 

Use custom range Set the range of the grid lines. Enter values in Start and End. The graph 

drawing beyond this range will be clipped off. 

Use custom interval Change the Interval on Y-Axis. 

Tick Interval Set the interval of the tick marks in axis units. 

Assistant Line 
 

Add an assistant line to the chart to show visual data trends, averages, 

normal distributions, etc. 
 

Remove the selected assistant line. 
 

Rename the selected assistant line. 

Value Select a data series for the assistant line. 

Group Value Select a group value for the assistant line. 

Type Choose the type of assistant line you want. 

Show R² value Display the R² value on the chart. 

Forward Forecast / 

Backward Forecast 

Specify the number of periods to include in a forecast. 

Align with other lines Align the assistant line with others. 

Period Specify the number of data points used to average the point value. 

Smooth Smooth the angles of the line. 

Use custom color Customize the color of the line. 

Line Color Set the color of the line. 

Cap Style Choose the cap style of the line. 

Dash Style Choose the dash style of the line. 

Join Style Choose the join style of the line. 
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Visible Check this box to show the line. 

 

Heatmap 

A heatmap represents data in a tabular format as a range of color. A more intense color represents a larger aggregated 

value for a particular data point. 

 

Chart Properties 

Once you have selected a chart type, you can customize the chart by changing its properties: 

Option Description 

General 

Background Color Set the background color of the chart area. 

Show Border Display the outer chart border. 

Border Color Set the color of the outer chart border. 

Show title Display the chart's main title. 

Title Specify the title of the chart. 

Title Font Set the font style of the title. 

Position Set the position of the title. 

Align Set the vertical or horizontal alignment of the title. 

Remarks Enter remarks for the chart. 

Legend 

Show legend Display the legend container. 

Position Set the position for the legend. 

Label Color Set the color of the legend labels. 

Data 

Show data values Display the values of the data series. 

Show data percentages Display the percentages of the data series. 
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Font Set the font style of data labels. 

Diverging Use diverging color scale. 

Use custom min/max 

values 

Customize the color of the min, center, and max values. Navicat calculates 

the cell color based on the color of these values. 

Min Color Set the color of the minimum value in the colormap. 

Center Color Set the color of the value at which to center the colormap. 

Max Color Set the color of the maximum value in the colormap. 

Min Value Specify the minimum value. 

Max Value Specify the maximum value. 

Data Formats - Number 

Prefix Add prefix characters to all the numeric data on the chart. 

Unit Choose the unit to shorten the numeric data. 

Suffix Specify the suffix to label the customized unit. 

Divider Specify the divider for the customized unit. 

Thousand Separator Choose the thousands separator for numeric data. 

Decimal Separator Choose the decimal separator for numeric data. 

Decimal Places Specify decimal places for numeric data. 

Negatives Choose the format negative numbers are displayed. 

Data Formats - DateTime 

Date / Time Choose the date and time format of the data. 

Custom Customize the date and time format. 

Column 

Show column title Display the title of the column. 

Column Title Specify the title of the column. 

Column Title Font Set the font style of the column title. 

Show column label Display the column label. 

Column Label Color Set the color of the column label. 

Row 

Show row title Display the title of the row. 

Row Title Specify the title of the row. 

Row Title Font Set the font style of the row title. 

Show row label Display the row label. 

Row Label Color Set the color of the row label. 

 

Treemap 

A treemap is an alternative way of visualizing the hierarchical structure while also displaying quantities for each 

category via area size. 
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Chart Properties 

Once you have selected a chart type, you can customize the chart by changing its properties: 

Option Description 

General 

Background Color Set the background color of the chart area. 

Show border Display the outer chart border. 

Border Color Set the color of the outer chart border. 

Show title Display the chart's main title. 

Title Specify the title of the chart. 

Title Font Set the font style of the title. 

Position Set the position of the title. 

Align Set the vertical or horizontal alignment of the title. 

Remarks Enter remarks for the chart. 

Legend 

Show legend Display the legend container. 

Position Set the position for the legend. 

Align Set the vertical or horizontal alignment of the legend. 

Label Color Set the color of the legend labels. 

Data 

Show data point names Display the names of the data points. 

Show data values Display the values of the data points. 

Show data percentages Display the data percentages of the data points. 

Data Label Color Set the color of the data label. 
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Tile Group the small tiles to a single tile (called Others). 

Color Set the color palette of the data points. 

Data Formats - Number 

Prefix Add prefix characters to all the numeric data on the chart. 

Unit Choose the unit to shorten the numeric data. 

Suffix Specify the suffix to label the customized unit. 

Divider Specify the divider for the customized unit. 

Thousand Separator Choose the thousands separator for numeric data. 

Decimal Separator Choose the decimal separator for numeric data. 

Decimal Places Specify decimal places for numeric data. 

Negatives Choose the format negative numbers are displayed. 

Data Formats - DateTime 

Date / Time Choose the date and time format of the data. 

Custom Customize the date and time format. 

 

Value 

A value displays a single aggregated value from a data field, e.g. total. 

 

Chart Properties 

Once you have selected a chart type, you can customize the chart by changing its properties: 

Option Description 

General 

Background Color Set the background color of the chart area. 

Show border Display the outer chart border. 

Border Color Set the color of the outer chart border. 

Show title Display the chart's main title. 

Title Specify the title of the chart. 

Title Font Set the font style of the title. 

Position Set the position of the title. 

Align Set the vertical or horizontal alignment of the title. 

Remarks Enter remarks for the chart. 

Data 

Data Label Font Set the font style of the data label. 

Negative Font Color Set the color of the negative value. 

Align Set the horizontal alignment of the data label. 
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Data Formats - Number 

Prefix Add prefix characters to all the numeric data on the chart. 

Unit Choose the unit to shorten the numeric data. 

Suffix Specify the suffix to label the customized unit. 

Divider Specify the divider for the customized unit. 

Thousand Separator Choose the thousands separator for numeric data. 

Decimal Separator Choose the decimal separator for numeric data. 

Decimal Places Specify decimal places for numeric data. 

Negatives Choose the format negative numbers are displayed. 

Data Formats - DateTime 

Date / Time Choose the date and time format of the data. 

Custom Customize the date and time format. 

 

Trend 

A trend displays that the current value is trending up or down compared to the previous value, and the percentage 

change. 

 

Chart Properties 

Once you have selected a chart type, you can customize the chart by changing its properties: 

Option Description 

General 

Background Color Set the background color of the chart area. 

Show border Display the outer chart border. 

Border Color Set the color of the outer chart border. 

Show title Display the chart's main title. 

Title Specify the title of the chart. 

Title Font Set the font style of the title. 

Position Set the position of the title. 

Align Set the vertical or horizontal alignment of the title. 

Remarks Enter remarks for the chart. 

Data 

Show previous value Display the previous value. 

Show difference Display the Value / Percentage difference between the current value and the 

previous value. 

Show indicator Display the up or down indicator. 
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Main Label Font Set the font style of the main label. 

Previous Value Color Set the color of the previous value. 

Target Met Color Set the color of the indicator and the percentage when the value is trending 

up. 

Target Missed Color Set the color of the indicator and the percentage when the value is trending 

down. 

Data Formats - Number 

Prefix Add prefix characters to all the numeric data on the chart. 

Unit Choose the unit to shorten the numeric data. 

Suffix Specify the suffix to label the customized unit. 

Divider Specify the divider for the customized unit. 

Thousand Separator Choose the thousands separator for numeric data. 

Decimal Separator Choose the decimal separator for numeric data. 

Decimal Places Specify decimal places for numeric data. 

Negatives Choose the format negative numbers are displayed. 

 

KPI 

A KPI displays a comparison between a key value and its target value with a progress bar. 

 

Chart Properties 

Once you have selected a chart type, you can customize the chart by changing its properties: 

Option Description 

General 

Background Color Set the background color of the chart area. 

Show border Display the outer chart border. 

Border Color Set the color of the outer chart border. 

Show title Display the chart's main title. 

Title Specify the title of the chart. 

Title Font Set the font style of the title. 

Position Set the position of the title. 

Align Set the vertical or horizontal alignment of the title. 

Remarks Enter remarks for the chart. 
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Data 

Main Label Displayed Display the Actual value or the Comparison percentage in the main label. 

Main Label Font Set the font style of the main label. 

Indicator Thickness Set the font size of the sub-label on the bar. 

Sub Label Color Set the color of the sub-label on the bar. 

Target Caption Specify the caption of the target label. 

Use custom target value Set the target value. 

Target Label Color Set the color of the target label. 

Target Met Color Set the color of the bar when the value reaches the target. 

Target Missed Color Set the color of the bar when value does not reach the target. 

Data Formats - Number 

Prefix Add prefix characters to all the numeric data on the chart. 

Unit Choose the unit to shorten the numeric data. 

Suffix Specify the suffix to label the customized unit. 

Divider Specify the divider for the customized unit. 

Thousand Separator Choose the thousands separator for numeric data. 

Decimal Separator Choose the decimal separator for numeric data. 

Decimal Places Specify decimal places for numeric data. 

Negatives Choose the format negative numbers are displayed. 

 

Gauge 

A gauge is a meter type chart. It has a circular arc and displays a single value which measures the progress toward the 

target value (the goal). 

 

Chart Properties 

Once you have selected a chart type, you can customize the chart by changing its properties: 

Option Description 

General 

Background Color Set the background color of the chart area. 
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Show border Display the outer chart border. 

Border Color Set the color of the outer chart border. 

Show title Display the chart's main title. 

Title Specify the title of the chart. 

Title Font Set the font style of the title. 

Position Set the position of the title. 

Align Set the vertical or horizontal alignment of the title. 

Remarks Enter remarks for the chart. 

Data 

Show pointer Display the needle. 

Pipe Width Percentage Set the percentage that the scale occupies the gauge area. 

Background Color Set the background color of the scale when the needle is not displayed. 

Target Color Set the color of the target line. 

Pointer Color Set the color of the needle. 

Value Display Display the actual data or the comparison percentage of the value. 

Value Font Set the font style of the value. 

Target Display Display the actual data or the comparison percentage of the target value. 

Target Caption Specify the caption of the target label. 

Use custom target value Set the target value. 

Target Font Set the font style of the target value. 

Min/Max Displayed Display the actual data or the comparison percentages of the minimum and 

maximum values. 

Use custom min value Set the value that the scale starts at. 

Use custom max value Set the value that the scale ends. 

Min/Max Font Set the font style of the minimum and maximum values. 

Partition Label Displayed Display the actual data or the comparison percentages of the partition 

labels. 

Partition Label Font Set the font style of the partition labels. 

Partition (Max. 8) Divide the scale into number of partitions. 

Partition Style Divide the scale equally or custom the starting percentage of each partition. 

Data Formats - Number 

Prefix Add prefix characters to all the numeric data on the chart. 

Unit Choose the unit to shorten the numeric data. 

Suffix Specify the suffix to label the customized unit. 

Divider Specify the divider for the customized unit. 

Thousand Separator Choose the thousands separator for numeric data. 

Decimal Separator Choose the decimal separator for numeric data. 

Decimal Places Specify decimal places for numeric data. 

Negatives Choose the format negative numbers are displayed. 
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Table 

A table represents data in a tabular view and calculates the total at the end of each column. 

 

Chart Properties 

Once you have selected a chart type, you can customize the chart by changing its properties: 

Option Description 

General 

Background Color Set the background color of the chart area. 

Show border Display the outer chart border. 

Border Color Set the color of the outer chart border. 

Show title Display the chart's main title. 

Title Specify the title of the chart. 

Title Font Set the font style of the title. 

Position Set the position of the title. 

Align Set the vertical or horizontal alignment of the title. 

Remarks Enter remarks for the chart. 

Data 

Font Set the font style of the field names and data. 

Show alternate row colors Apply color to alternate rows. 

Show vertical grid line Display the vertical grid line. 

Show horizontal grid line Display the horizontal grid line. 

Color Set the color palette of the data series. 

Data Formats - Number 

Prefix Add prefix characters to all the numeric data on the chart. 

Unit Choose the unit to shorten the numeric data. 

Suffix Specify the suffix to label the customized unit. 

Divider Specify the divider for the customized unit. 

Thousand Separator Choose the thousands separator for numeric data. 
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Decimal Separator Choose the decimal separator for numeric data. 

Decimal Places Specify decimal places for numeric data. 

Negatives Choose the format negative numbers are displayed. 

Data Formats - DateTime 

Date / Time Choose the date and time format of the data. 

Custom Customize the date and time format. 

Databar 

Style Format the cells by using data bars. 

Show bar only item Only show the data bars in the cells, without the numbers. 

Custom min/max values Customize the min and max values of the data bars. 

Min value Specify the minimum value of the data bar. 

Max value Specify the maximum value of the data bar. 

Positive bar color Set the color of the data bars with positive values. 

Negative bar color Set the color of the data bars with negative values. 

Axis color Set the color of the axis for separating the positive bar and the negative bar. 

Total 

Show total Display totals in the last row of the table. 

Total Color Set the color of the total values. 

 

Pivot Table 

A pivot table shows measure values for the intersection of two dimensions and represents data in a tabular view. 

 

Chart Properties 

Once you have selected a chart type, you can customize the chart by changing its properties: 

Option Description 

General 

Background Color Set the backgro6und color of the chart area. 

Show border Display the outer chart border. 

Border Color Set the color of the outer chart border. 

Show title Display the chart's main title. 
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Title Specify the title of the chart. 

Title Font Set the font style of the title. 

Position Set the position of the title. 

Align Set the vertical or horizontal alignment of the title. 

Remarks Enter remarks for the chart. 

Data 

Font Set the font style of the field names and data. 

Show alternate row colors Apply color to alternate rows. 

Show vertical grid line Display the vertical grid line. 

Show horizontal grid line Display the horizontal grid line. 

Color Set the color palette of the data series. 

Data Formats - Number 

Prefix Add prefix characters to all the numeric data on the chart. 

Unit Choose the unit to shorten the numeric data. 

Suffix Specify the suffix to label the customized unit. 

Divider Specify the divider for the customized unit. 

Thousand Separator Choose the thousands separator for numeric data. 

Decimal Separator Choose the decimal separator for numeric data. 

Decimal Places Specify decimal places for numeric data. 

Negatives Choose the format negative numbers are displayed. 

Data Formats - DateTime 

Date / Time Choose the date and time format of the data. 

Custom Customize the date and time format. 

Databar 

Style Format the cells by using data bars. 

Show bar only item Only show the data bars in the cells, without the numbers. 

Custom min/max values Customize the min and max values of the data bars. 

Min value Specify the minimum value of the data bar. 

Max value Specify the maximum value of the data bar. 

Positive bar color Set the color of the data bars with positive values. 

Negative bar color Set the color of the data bars with negative values. 

Axis color Set the color of the axis for separating the positive bar and the negative bar. 

Total 

Show row total Display totals in the last row of the table. 

Enter the name of the row total, and set the color of the values and the 

background color. 

Show column total Display totals in the last column of the table. 

Enter the name of the column total, and set the color of the values and the 

background color. 

Show row subtotal Display totals in the last row of the group. 

Enter the name of the row subtotal, and set the color of the values and the 
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background color. 

Show column subtotal Display totals in the last column of the group. 

Enter the name of the column subtotal, and set the color of the values and 

the background color. 

 

Control 

A control allows you to filter the data series of all charts in the dashboard that have the same data source during the 

presentation. 

 

Chart Properties 

Once you have selected a chart type, you can customize the chart by changing its properties: 

Option Description 

General 

Background Color Set the background color of the chart area. 

Show border Display the outer chart border. 

Border Color Set the color of the outer chart border. 

Show title Display the chart's main title. 

Title Specify the title of the chart. 

Title Font Set the font style of the title. 

Position Set the position of the title. 

Align Set the vertical or horizontal alignment of the title. 

Remarks Enter remarks for the chart. 

Data 

Data Label Color Set the color of the data label. 

Style Show the data as a list, a range or a combo box. 

Data Formats - Number 

Prefix Add prefix characters to all the numeric data on the chart. 

Unit Choose the unit to shorten the numeric data. 

Suffix Specify the suffix to label the customized unit. 
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Divider Specify the divider for the customized unit. 

Thousand Separator Choose the thousands separator for numeric data. 

Decimal Separator Choose the decimal separator for numeric data. 

Decimal Places Specify decimal places for numeric data. 

Negatives Choose the format negative numbers are displayed. 

Data Formats - DateTime 

Date / Time Choose the date and time format of the data. 

Custom Customize the date and time format. 

 

DateTime Formats 

The following table shows specifiers you can use to create user-defined data formats for DateTime fields in a chart. 

Specifier Description 

D Display the day as a number without a leading zero (1-31). 

DD Display the day as a number with a leading zero (01-31). 

M Display the month as a number without a leading zero (1-12). 

MM Display the month as a number with a leading zero (01-12). 

MMM Display the month as an abbreviation (Jan-Dec). 

MMMM Display the month as a full month name (January-December). 

MMMMM Display the month as a narrow name (J-D). 

YY Display the year in two-digit numeric format with a leading zero (00-99). 

YYYY Display the year in four-digit numeric format (0000-9999). 

h Display the hour as a number without a leading zero using the 12-hour 

clock (1-12). 

hh Display the hour as a number with a leading zero using the 12-hour 

clock (01-12). 

H Display the hour as a number without a leading zero using the 24-hour 

clock (0-23). 

HH Display the hour as a number with a leading zero using the 24-hour 

clock (00-23). 

m Display the minute as a number without a leading zero (0-59). 

mm Display the minute as a number with a leading zero (00-59). 

S Display the second as a number without a leading zero (0-59). 

SS Display the second as a number with a leading zero (00-59). 

wd Display the day as a single letter abbreviation (S-S). 

Wd Display the day as an abbreviation (Sun-Sat). 

WD Display the day as a full name (Sunday-Saturday). 

w Display the week of the year (1-52, start of week is Sunday). 

WW Display the week of the year (W01-W52, start of week is Sunday). 

q Display the quarter of the year (1-4). 

http://192.168.1.247/online_manual_v16/en/navicat/win_manual/#/charts_chart_datetime
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QQ Display the quarter of the year (Q1-Q4). 

p Display an uppercase AM with any hour before noon; display an 

uppercase PM with any hour between noon and 11:59 P.M. 

 

Dashboard 

About Dashboard 

Dashboard is a collection of charts which allows you to create and view your data visualizations. When you modify a 

chart, any dashboards containing it will reflect the changes. 

 

 Pages Pane 

The Pages pane shows thumbnail images of each page in the dashboard. If the Pages pane is hidden, choose View -> 

Show Pages from the menu bar. 

 Dashboard Toolbar 

The Dashboard Toolbar provides controls that you can use to refresh the data and present the dashboard. 

 Design Pane 

You can design your dashboard on the Design pane. All added objects can be moved (by dragging them with mouse or 

by keyboard), resized, aligned to the grid, etc. 

 Properties Pane 

The  Dashboard Properties tab includes the basic layout settings. The properties vary with the type of the object. 

The  Using tab shows the charts and data sources that the dashboard depends on. 

If the Properties pane is hidden, choose View -> Show Properties from the menu bar. 
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Build Dashboard 

The essential steps to create a dashboard are: 

1. In the Workspace window, click  New Dashboard. 

2. Enter the name of the dashboard. 

3. Click OK. 

4. A tab will be opened for your newly created dashboard. 

5. Design your dashboard. 

6. Select the properties on the right pane which can be further customized for your dashboard. 

Note: Each object has different properties. 

Hint: You can refresh dashboard to update data in charts with the most current data from their respective data sources. 

To manually refresh the dashboard, click  Refresh Data. 

Working with Grids 

Show Grid 

To turn the grid on in the dashboard, choose View -> Show Grid from the menu bar. 

Snap to Grid 

To align objects on the dashboard with the grid, choose View -> Snap to Grid from the menu bar. 

Add Pages 

The Pages pane shows all pages in the dashboard. It displays thumbnails of your dashboard pages. 

To add a new page 

1. On the Dashboard tab, click the + button on the Pages pane. 

2. A blank page will be added and selected. 

Properties 

The available properties of a page: 

Option Description 

General 

Dashboard Page Size Customize the size of pages in the dashboard. 

Remarks Enter remarks for the dashboard. 
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Page # 

Background Set the background color of the page. If you choose Image Fill, you can 

choose the image file and the scaling option. 

Opacity Set the opacity of the image. 

Page Note Enter the reference, comment, or explanation of the page. 

 

Add Charts 

Charts provide visual representations of the data in your data source. 

To add a chart 

1. On the Dashboard tab, click  Add Chart. 

2. All available charts in the workspace will be shown as thumbnails. If no charts are available, click  New 

Chart to create one. For detailed instructions on creating charts, see Build Charts. 

3. Drag a chart to the Design pane. 

Properties 

The available properties of a chart: 

Option Description 

Position Customize the position of the chart. 

Size Customize the size of the chart. 

Target Charts Choose which charts in the dashboard the chart can control. 

Chart Interaction 

As an interaction control Set the chart as an interaction control. 

Related charts None - Disable the interaction behavior of the chart. 

Highlight - Cross-highlight the chart on the dashboard by the selected data 

point. The unrelated data is still visible but dimmed. 

Filter - Cross-filter the chart on the dashboard by the selected data point. 

The unrelated data isn't visible. 

 

Add Text Labels 

Text labels are typically used to help document the dashboard, such as adding a dashboard title, URL links. 

To add a text label 

1. On the Dashboard tab, click  Add Text. 

2. Place it on the dashboard. 

3. Enter the caption. 
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Properties 

The available properties of a text label: 

Option Description 

Position Customize the position of the label. 

Size Customize the size of the label. 

Caption Enter the caption of the label. 

Horizontal Alignment / 

Vertical Alignment 

Specify the text alignment of the label caption. 

Padding Set the horizontal and vertical padding for the text. 

Font Set the font style of the label caption. 

Bold Apply a bold style to the label caption. 

Italic Apply an italic style to the label caption. 

Background Color Set the background color of the label. 

Opacity Set the opacity of the background color. 

URL Enter URL path to set the text as a hyperlink. 

 

Add Images 

You can insert images (BMP, JPG, JPEG or PNG files) to your dashboard for design or identification purposes. 

To add an image 

1. On the Dashboard tab, click  Add Image. 

2. Select an image file in the Open dialog box. 

Properties 

The available properties of an image: 

Option Description 

Opacity Set the opacity of the image. 

Position Customize the position of the image. 

Size Customize the size of the image. 

Original Size Reset the image to its original size. 

URL Enter URL path to set the image as a hyperlink. 

 

Add Shapes 

Navicat includes some pre-defined shapes for creating a dashboard: line, arrow, rectangle, ellipse, database, cloud, 

trigger, server, desktop, mobile, man, woman. 

To add a shape 
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1. On the Dashboard tab, click  Add Shape and choose a shape type. 

2. Place it on the dashboard. 

To add a vertex on a line or an arrow 

1. Select a line or an arrow on the dashboard. 

2. Press and hold the SHIFT key and click on it. 

To delete a vertex on a line or an arrow 

1. Select a line or an arrow on the dashboard. 

2. Press and hold the SHIFT key and click on the vertex. 

Properties 

The available properties of a shape: 

Option Description 

Position Customize the position of the shape. 

Size Customize the size of the shape. 

Only for rectangle, ellipse, database, cloud, trigger, server, desktop, mobile, 

man and woman. 

Color Set the color of the shape. 

Show border Display the outer shape border. 

Only for rectangle, ellipse, database, cloud, trigger, server, desktop, mobile, 

man and woman. 

Border Color Change the color of the shape's border. 

Only for rectangle, ellipse, database, cloud, trigger, server, desktop, mobile, 

man and woman. 

Border Width Choose the thickness of the border. 

Only for rectangle, ellipse, database, cloud, trigger, server, desktop, mobile, 

man and woman. 

Line Width Choose the thickness of the shape. 

Cap Style Choose the cap style of the line/arrow. 

Dash Style Choose the dash style of the line/arrow. 

Join Style Choose the join style of the line/arrow. 

Begin Arrow Style Choose the style of the arrow's back. 

End Arrow Style Choose the style of the arrow's front. 

 

Arrange Objects 

You can arrange the objects on a dashboard page in the following ways: 
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• Move objects forward and backward to layer them. 

• Align an object with other objects. 

• Distribute the objects horizontally or vertically. 

• Group objects to more easily move them as a single unit and synchronize the axis of the related charts. 

• Lock objects to prevent them from moving, modifying, or deleting. 

Move Objects Forward / Backward 

To send an object to the back of the dashboard, right-click it and select Send to Back. 

To bring an object to the front of the dashboard, right-click it and select Bring to Front. 

Align Objects 

Select multiple objects, then right-click and select Alignment -> Align Left, Align Center, Align Right, Align Top, 

Align Middle or Align Bottom. 

Change Objects Distribution 

Select multiple objects, then right-click and select Distribute -> Horizontal or Vertical. 

Group Objects 

Select multiple objects, then click Group on the Properties pane and enable the following properties if necessary. 

Option Description 

Link Scrolling Synchronize the scrollbar of all charts. 

Link Highlight Hover over a data point on one of the charts will highlight the same data 

points on the others. 

Show Hints When 

Highlight 

Pop up the hint labels when hovering over a data point on one of the charts. 

Ungroup Objects 

Select the group, then click Ungroup on the Properties pane. 

Lock Objects 

Select an object, then click Lock on the Properties pane. 

Unlock Objects 

Select the locked object, then click Unlock on the Properties pane. 
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Present Dashboard 

You can present the dashboard using the whole screen. The title bar, toolbar, tab bar, Pages pane, Control List and 

Properties pane will be hidden while in this mode. To open a dashboard in present view, click  Present. 

Use the arrow keys to navigate between pages. 

To exit present view, press the ESC key and the workspace window will be returned to its previous state. 

Chart Interaction 

All charts on a dashboard with the same data source can be interconnected. If you select a data point on one of the 

charts, all the other charts on the dashboard page that contain the same data will change based on your selection. 

You can turn off chart interaction, or change the behavior to cross-filtering or cross-highlighting in the dashboard 

properties. 

 

If you have added a control chart to your dashboard, you can filter the data series of all charts by using the control. 

Sort Chart 

In the Present mode, you can organize your data in a chart with one click. You can sort data series by a value. 

1. Hover over a chart until you see the  icon in the upper-right corner. 

2. Click the  icon to sort on a different value and select the sorting order. 

Print & Export Dashboard 

Print to a printer 

Choose File -> Print to send your dashboard pages directly to the printer. You can set the printer option in the pop-up 

window. 

Export to a file 

Choose File -> Export To and choose the file format to create a PDF, PNG, SVG or JPG file of your dashboard pages. 
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Switch Theme 

Charts and dashboards are not affected by the software theme selected in Options. If you want use a Dark theme for 

your charts, click  Switch Theme to change the theme. 
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Chapter 18 - Automation (Available only in 

Navicat Premium, Enterprise and Standard 

Edition) 

About Automation 

Navicat allows you to automate executing jobs at one or more regular intervals, beginning and ending at a specific date 

and time using Windows Task Scheduler. Automation can be created for Query, Backup, Data Transfer, Data 

Synchronization, Data Generation, Data Dictionary, Aggregation Pipeline, BI, Model,.Import, Export, MongoDump, 

MongoImport, MongoExport, MapReduce. You can define a list of jobs to be performed within one batch job, either run 

it manually, at the specified time or periodically. In the main window, click  Automation to open the automation 

object list. 

Hint: Batch Job files are saved under the Profiles Location. 

Hint: You can run a batch job in Windows Command Prompt with this command: 

navicat.exe -batchjob BatchJobName 

Example: navicat.exe -batchjob job1 

Create Batch Job (Step 1) 

Add Jobs to Batch Job 

In the bottom pane of the General tab, select the job type, and then browse the connection, database and/or schema to 

locate jobs if necessary. 
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Move jobs from the Available Jobs list to the Selected Jobs list by double-clicking or dragging them. To delete the jobs 

from the Selected Jobs list, remove them in the same way. You are allowed to run profiles from different servers in a 

single batch job. 

To rearrange the sequence of the selected jobs, use the  Move Up or  Move Down buttons. 

If you want to backup whole server, you can select the connection and select Backup Server xxx. 

You can export BI dashboards and model data dictionaries to PDF files. Adding a BI workspace file to the Selected 

Jobs list will allow you to choose the export file format and specify the target directory. You can enable the Append 

timestamp to file name option to append timestamp to the name of the exported file. 

Exported files can be added to the batch job as mail attachment. Select the job in the Selected Jobs list and click  

Attach to Email or  Detach from Email to add or remove the mail attachment. 

Set Advanced Options & Email Notification 

Continue on error 

Ignore errors that are encountered during the job execution process. 

Send Email 

Navicat allows you to generate and send personalized emails with results returned from a schedule. The results can be 

emailed to multiple recipients. 

When 

Specify when to send notification emails: the task completed successfully and/or failed. 

From 

Specify email address of sender. For example, someone@navicat.com. 

To, CC 

Specify email addresses of each recipient, separating them with a comma or a semicolon (;). 

Subject 

Specify the email subject with customized format. 

Body 

Write email content. 

Host (SMTP Server) 

Enter your Simple Mail Transfer Protocol (SMTP) server for outgoing messages. 
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Port 

Enter the port number you connect to your outgoing email (SMTP) server. 

Use authentication 

Check this option and enter User Name and Password if your SMTP server requires authorization to send email. 

Secure connection 

Specify the connection to use TLS, SSL secure connection or Never. 

Send Test Mail 

Navicat will send you a test mail indicating success or failure. 

Save / Run Batch Job 

Before setting schedule, click the  Save button to save the batch job. 

You can run the batch job manually by clicking the  Start button. The Message Log tab displays the execution 

progress, execution time, and success or failure messages. 

Schedule Batch Job (Step 2) 

You can click  Set Task Schedule to set schedule for running a batch job and click  Delete Task Schedule to 

remove the schedule. 

 

If you choose Run whether user is logged on or not in the General tab, then you must provide your OS user 

password in Windows Scheduler when you save the schedule. 



 319 

 

 

Note: Please save the batch job before setting schedule. Passwords must be saved in the Connection window before 

running your schedule.  
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Chapter 19 - Backup & Restore 

About Backup & Restore 

A secure and reliable server is closely related to performing regular backups, as failures will probably occur sometimes 

- caused by attacks, hardware failure, human error, power outages, etc. 

Navicat provides backup and restore tools for users to backup/restore database objects. 

 Built-in backup and restore tool for MySQL / PostgreSQL / SQLite / MariaDB / Snowflake 

 Oracle Data Pump 

 SQL Server Backup & Restore 

 MongoDump & MongoRestore 

 Built-in backup and restore tool for Redis 

MySQL / PostgreSQL / SQLite / MariaDB / Snowflake (Available 

only in Navicat Premium, Enterprise and Standard Edition) 

About Built-in Backup & Restore Tool 

The built-in backup & restore tool allows you to backup/restore database objects for your database. You can save your 

settings as a profile for future use or setting automation tasks. In the main window, click  Backup to open the 

backup object list. 

Hint: Backup files are saved under the Settings Location. To open the folder, right-click a backup file and select Open 

Containing Folder. 

Note: Available only for MySQL, PostgreSQL, SQLite, MariaDB and Snowflake. 

Backup 

General Properties 

In this tab, you can view the server and database information. Enter a comment for the backup file if necessary. 

Object Selection 

In this tab, choose database objects you wish to backup. 

(*) All the database objects being backed up, all newly added database 

objects will also be backed up without amending the backup profile. 

(#/#) Only the checked database objects will be backed up. However, if 
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you add any new database objects in the database and/or schema 

after you create your backup profile, the newly added database 

objects will not be backed up unless you manually modify the Objects 

list. 

Advanced Properties 

Note: The following options depend on the connection server type and sort in ascending order. 

Lock All Tables 

Lock all objects while backup is being processed. 

Use Single Transaction (InnoDB only) 

If a table uses InnoDB storage engine, with this option is on, Navicat uses transaction before the backup process starts. 

Use specified file name 

Define your file name for backup. Otherwise, your backup file will be named with "YYYYMMDDhhmmss" format. 

Restore 

Restore feature will firstly drop the selected objects of the database, then recreate the new objects according to your 

backup. Finally, inserting the data. 

Restore a backup to an existing database/schema 

1. In the main window, open a database/schema. 

2. Click Backup and select an existing backup file. 

3. Click Restore Backup from the object toolbar. 

4. Choose the restore options and click Restore. 

Restore a backup to a new database/schema 

1. Create and open a new database/schema. 

2. Click Backup. 

3. In the Objects tab, right-click anywhere and select Restore Backup from. 

4. Browse the backup file. 

5. Choose the restore options and click Restore. 

Hint: You can also restore Navicat macOS and Linux backups. 
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Note: You must have Create, Drop and Insert privileges (MySQL/MariaDB or PostgreSQL) to run the restore. 

General Properties 

In this tab, you can view the target server and database information and the backup file information. 

Object Selection 

In this tab, choose database objects you wish to restore. 

Advanced Properties 

Note: The following options depend on the connection server type, the backup file version and sort in ascending order. 

Continue on error 

Ignore errors that are encountered during the restore process. 

Create indexes 

Create indexes for the restored table with this option is on. 

Create tables 

Create tables during the restore process with this option is on. 

Create records 

Restore table records with this option is on. Otherwise, only table structures will be restored. 

Create triggers 

Create triggers for the restored table with this option is on. 

Empty table 

Delete all table records in the database/schema. 

Lock tables for write 

Lock the tables to prevent user to modify tables during the restore process. 

Insert auto increment values 

Insert auto increment values in the database/schema. 

Overwrite existing events 

Overwrite if events already exist in the database/schema. 

Overwrite existing functions 
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Overwrite if functions already exist in the database/schema. 

Overwrite existing indexes 

Overwrite if indexes already exist in the database/schema. 

Overwrite existing sequences 

Overwrite if sequences already exist in the database/schema. 

Overwrite existing tables 

Overwrite if tables already exist in the database/schema. 

Overwrite existing triggers 

Overwrite if triggers already exist in the database/schema. 

Overwrite existing types 

Overwrite if types already exist in the database/schema. 

Overwrite existing views 

Overwrite if views already exist in the database/schema. 

Run multiple queries in each execution 

Check this option if you want to run multiple queries in each execution, which will make the restore process faster. 

Use extended insert statements 

Check this option if you want to insert records using extended insert syntax. 

Example: INSERT INTO `users` VALUES ('1', 'Peter McKindsy', '23'), ('2', 'Johnson Ryne', '56'), ('0', 'Katherine', '23'); 

Use transaction 

Check this option if you want to rollback all data when error occurs. 

Extract SQL 

Extract SQL allows extracting SQL into a SQL file from your backup file. 

Extract a backup file that is in your database/schema 

1. Open a database/schema. 

2. Click Backup and select an existing backup file. 

3. Click Extract SQL from the object toolbar. 
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4. Choose the Extract SQL options and click Extract. 

5. Choose a path for the SQL file. 

Extract a backup file that is in any location 

1. Open any one of your databases/schemas. 

2. Click Backup. 

3. In the Objects tab, right-click anywhere and select Extract SQL from. 

4. Click Extract SQL from the object toolbar. 

5. Browse the backup file. 

6. Choose the Extract SQL options and click Extract. 

7. Choose a path for the SQL file. 

Oracle Data Pump (Available only in Navicat Premium, Enterprise 

and Standard Edition) 

About Oracle Data Pump 

Data Pump includes two utilities: Data Pump Export and Data Pump Import. Data Pump Export is for unloading data 

and metadata into a dump file set. Data Pump Import is for loading an export dump file set into a target system. In the 

main window, click  Data Pump to open the data dump object list. 

To change the directory of the dump file set, right-click anywhere in the Objects tab and select Change Directory. 

Note: Data Pump is added in Oracle 10g or later. You require SYSDBA role to perform it. Dump file sets are stored in 

servers. 

Oracle Data Pump Export 

Before executing Data Pump Export, click the Generate SQL button to review the SQL statements. Then, you can click 

the Execute button to run the export process. 

You can save the Data Pump Export settings to a profile for future use. Data Pump Export profiles (.nbakora) are saved 

under the Settings Location. 

To show the hidden tabs (advanced options), check the Show Advanced Options option. 

General Properties 

Job Name 
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Specify the name of the job. 

Mode 

Choose the export mode: FULL, TABLESPACE, SCHEMAS, TABLE. 

Content 

Choose which data to export. 

Export Data 

Select which objects to export. If you select the TABLE export mode, choose a schema in the Export Schema(Table 

Mode) drop-down list. 

Dump Files 

Add dump files to the dump file set for the export. 

Metadata Filter 

In this tab, you can include or exclude specific objects types. 

Data Filter 

Query 

Specify a subquery that is added to the end of the SELECT statement for a table. 

Sample 

Specify a percentage for sampling the data blocks to be moved. 

Remap Data 

In this tab, you can specify remap functions for column data. 

Encryption 

Encryption Content 

Choose what to encrypt in the dump file set. 

Encryption Algorithm 

Choose a cryptographic algorithm to perform encryption. 

Encryption Mode 

Choose the encryption mode: Transparent, Encryption Password, Dual. 
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Encryption Password 

If you choose the Encryption Password or Dual encryption mode, enter a password to encrypt data written to the dump 

file. 

Confirm Password 

Re-type your password. 

Advanced Properties 

Thread Number 

Enter the maximum number of worker processes that can be used for the job. 

Reuse File 

Check this option to overwrite a preexisting file. 

Enable XMLCLOBS 

Check this option to enable data options for XMLCLOBS. 

Enable Cluster 

Check this option to start workers on instances usable by the job. 

Service Name 

Specify a service name that used to constrain the job to specific instances or to a specific resource group. 

Source Edition 

Specify the application edition. 

Version 

Specify the version of database objects to be extracted. 

Compression Type 

Specify which data to compress before writing to the dump file set. 

Transportable 

If you select the TABLE export mode, choose to never or always use the transportable option. 

Database Link 

Choose a database link to the remote database that will be the source of data and metadata for the job. 
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Estimate 

Choose the estimate method for the size of the tables should be performed before starting the job. 

Access Method 

Choose an alternative method to unload data if the default method does not work. 

Log File Directory 

Choose the directory for saving the log file. 

Log File Name 

Enter the name of the log file. 

Flashback SCN 

Enter the system change number (SCN) that used to enable the Flashback Query utility. 

Flashback Time 

Select a timestamp for finding a SCN. 

Oracle Data Pump Import 

Before executing Data Pump Import, click the Generate SQL button to review the SQL statements. Then, you can click 

the Execute button to run the import process. 

To show the hidden tabs (advanced options), check the Show Advanced Options option. 

General Properties 

Job Name 

Specify the name of the job. 

Mode 

Choose the import mode: FULL, TABLESPACE, SCHEMAS, TABLE. 

Content 

Choose which data to import. 

Table Exists Action 

Specify the action to be performed when data are loaded into a preexisting table. 

Import Data 
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Select which objects to import. If you select the TABLE import mode, specify the schema name in the Schema text box. 

Dump Files 

Add dump files to the dump file set for the import. 

Network 

Database Link 

Choose a database link to the remote database that will be the source of data and metadata for the job. 

Estimate 

Choose the estimate method for the size of the tables should be performed before starting the job. 

Flashback SCN 

Enter the system change number (SCN) that used to enable the Flashback Query utility. 

Flashback Time 

Select a timestamp for finding a SCN. 

Transportable 

If you select the TABLE export mode, choose to never or always use the transportable option. 

DataFile Path 

Specify the full file specification for a datafile in the transportable tablespace set.  

Filter 

Include/Exclude 

Include or exclude specific objects types. 

Query 

Specify a subquery that is added to the end of the SELECT statement for a table. 

Remap Data 

Remap Data 

Specify remap functions for column data. 

Remap DataFiles 

Specify the remapping for data files. 
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Remap Objects 

Remap Schemas 

Specify the remapping for schemas. 

Remap TableSpaces 

Specify the remapping for tablespaces. 

Remap Tables 

Specify remap functions for tables. 

Advanced Properties 

Thread Number 

Enter the maximum number of worker processes that can be used for the job. 

Reuse datafiles 

Check this option to reuse existing data files for creating tablespace. 

Skip unusable indexes 

Check this option to skip loading tables that have indexes that were set to the Index Unusable state. 

Streams configuration 

Check this option to import any general Streams metadata that may be present in the export dump file. 

Skip const error 

Check this option to skip constraint violations and continue the load. 

Disable append hint 

Check this option to prevent the append hint from being applied to the data load. 

Cluster 

Check this option to start workers on instances usable by the job. 

Service Name 

Specify a service name that used to constrain the job to specific instances or to a specific resource group. 

Target Edition 

Specify the database edition into which objects should be imported. 
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Version 

Specify the version of database objects to be extracted. 

Access Method 

Choose an alternative method to unload data if the default method does not work. 

Partition Options 

Choose how to handle partitioned tables during the import operation. 

Encryption Password 

Enter the password if an encryption password was specified in Data Pump Export. 

Segment Attributes, Segment Creation, Storage, OID, PCTSpace 

Choose the objects that the transformations to be applied to. 

Log File Directory 

Choose the directory for saving the log file. 

Log File Name 

Enter the name of the log file. 

SQL Server Backup & Restore (Available only in Navicat Premium, 

Enterprise and Standard Edition) 

About SQL Server Backup & Restore 

The SQL Server Backup feature provides an important safeguard for protecting your SQL Server data. In the main 

window, click  SQL Server Backup to open the backup object list. 

If you want to backup with the setting of an existing backup file, you can right-click a backup file in the Objects tab and 

select Backup From This Setting. 

Note: Backup files are stored in servers. 

If you want to restore from a backup file that is not listed in the Objects tab, you can right-click anywhere in the Object 

pane and select Restore From File. 

SQL Server Backup 

Before starting the backup process, click the Generate SQL button to review the SQL statements. Then, you can click 

the Backup button to run the backup process. 
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You can save the backup settings to a profile for future use. Backup profiles (.nbakmssql) are saved under the Settings 

Location. 

To show the hidden tabs (advanced options), check the Show Advanced Options option. 

General Properties 

Backup Set Name 

Specify the name of the backup set. 

Description 

Specify the description of the backup set. 

Backup Type 

Choose the type of the backup that you want to perform: Full Backup, Differential Backup, Transaction-Log Backup. 

Copy-only 

Check this option to specify that the backup is a copy-only backup. 

New Media Set 

Create a new media set for this backup. To add backup devices or files to the list, click the Add device button. 

Existing Media Set 

Choose an existing media set for the backup. 

Components 

In this tab, you can choose to backup the whole database, the partial database, or specific files or groups. 

Advanced Properties 

Never expire 

Specify the backup set never expires. 

Expire after 

Specify the number of days that must elapse before this backup media set can be overwritten. 

Expire on 

Specify when the backup set expires and can be overwritten. 

Password 
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Enter a password for the backup set. 

Format media set 

Check this option to specify that a new media set be created. 

New Name 

Enter the name of the new media set. 

Description 

Specify the description of the media set. 

Overwrite all backups 

Check this option to specify that all backup sets should be overwritten, but preserves the media header. 

Check media name and backup set expiration 

Check this option to check the expiration date and time of the backup sets on the media before overwriting them. 

Media Set Name 

Specify the media name for the entire backup media set. 

Password 

Enter a password for the media set. 

Truncate the transaction log 

Choose this option to truncate the transaction log. 

Backup the tail log and set database to recovery state 

Choose this option to back up the tail of the log and leaves the database in the RESTORING state. 

Verify backup 

Check this option to verify the backup. 

Perform checksum 

Check this option to enable the backup checksums. 

Continue on error 

Ignore errors (such as invalid checksums or torn pages) that are encountered during this backup. 

Compression 
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Choose whether backup compression is performed on this backup. 

SQL Server Restore 

Before starting the restore process, click the Generate SQL button to review the SQL statements. Then, you can click 

the Restore button to run the restore process. 

General Properties 

Restore to database 

Select a database to restore. 

Source of backup set 

If you chose Restore From File in the Objects tab, you can add backup devices or files to the list by clicking the Add 

device button. 

Latest possible 

Choose this option if do not have the restore point. 

Specific time 

Choose this option to specify that the database be restored to the state it was in as of the date and time. 

Marked transaction 

Choose this option to recover to a specified recovery point. 

Include marked transaction 

Check this option to include the specified transaction in the recovery. 

Restore plan 

If you chose Restore From File in the Objects tab, you can choose the database backup files from the list. 

Advanced Properties 

Restore database files to 

Specify that the data or log file should be moved by restoring it to the Restore To location. 

WITH REPLACE 

Check this option to include the WITH REPLACE argument. 

WITH RESTRICTED_USER 
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Check this option to include the WITH RESTRICTED_USER argument. 

WITH KEEP_REPLICATION 

Check this option to include the WITH KEEP_REPLICATION argument. 

RECOVERY 

Choose this option to roll back all uncommitted transactions. 

NORECOVERY 

Choose this option to not roll back the uncommitted transactions. 

STANDBY 

Specify a Standby file that allows the recovery effects to be undone. 

MongoDump & MongoRestore 

About MongoDump & MongoRestore 

MongoDB provides two utilities for backup and restore operations: MongoDump and MongoRestore. They are useful 

for creating backups of small database and restoring data. 

MongoDump 

MongoDump can read data from a MongoDB database and create high fidelity BSON files. 

Note: You must have mongodump executable for this feature to work. 

To dump a file 

1. In Navicat main window, right-click your database or collection and select MongoDump. 

2. In the General and Advanced tabs, select the output path and the appropriate dump options. 

3. Click the Start button to begin the dump process. The Message Log tab will display the dump progress, 

execution time, and success or failure messages. 

You can save your settings as a profile for future use or setting automation tasks. To open a saved profile, click the 

Load Profile button and select a profile from the list. 

Hint: Profiles are saved under the Profiles Location. 

MongoRestore 

MongoRestore can load data from a binary database dump created by MongoDump into a MongoDB database. 

Note: You must have mongorestore executable for this feature to work. 
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To restore database 

1. In Navicat main window, right-click your database and select MongoRestore. 

2. In the General and Advanced tabs, select the input file/directory path and the appropriate restore options. 

3. Click the Start button to begin the restore process. The Message Log tab will display the restore progress, 

execution time, and success or failure messages. 

You can save your settings as a profile for future use. To open a saved profile, click the Load Profile button and select 

a profile from the list. 

Hint: Profiles are saved under the Profiles Location. 

Redis (Available only in Navicat Premium, Enterprise and 

Standard Edition) 

About Built-in Backup & Restore Tool 

The built-in backup & restore tool allows you to backup/restore database objects for your database. You can save your 

settings as a profile for future use or setting automation tasks. In the main window, click  Backup to open the 

backup object list. 

Hint: Backup files are saved under the Settings Location. To open the folder, right-click a backup file and select Open 

Containing Folder. 

Note: Available only for Redis. 

Backup 

General Properties 

In this tab, you can view the server and database information. Enter a comment for the backup file if necessary. 

Options 

Key Pattern 

Enter a key pattern. Navicat only backs up keys that match the specified pattern. 

Data Types 

Choose the type of data to back up. 

Include volatile keys 

Include keys with timeout expiration set. 
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Store TTL information 

Back up the Time-to-Live (TTL) information of volatile keys. 

Use specified file name 

Define your file name for backup. Otherwise, your backup file will be named with "yyyymmddhhmmss" format. 

Restore 

Restore feature will firstly delete the keys in the selected namespaces, then recreate the keys. 

Restore a backup to an existing database 

1. In the main window, open a database. 

2. Click Backup and select an existing backup file. 

3. Click Restore Backup from the object toolbar. 

4. Choose the restore options and click Restore. 

Restore a backup to another database 

1. Open another database. 

2. Click Backup. 

3. In the Objects tab, right-click anywhere and select Restore Backup from. 

4. Browse the backup file. 

5. Choose the restore options and click Restore. 

Hint: You can also restore Navicat macOS and Linux backups. 

General Properties 

In this tab, you can view the target server and database information and the backup file information. 

Details 

In this tab, you can view the backup settings and summary. 

Namespace Selection 

In this tab, choose namespaces you wish to restore. 

Advanced Properties 

Data Types 
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Choose the type of data to restore. 

Include persistent keys 

Include keys that will never expire. 

Include volatile keys 

Include keys with timeout expiration set. 

Include TTL information 

Restore the Time-to-Live (TTL) information of volatile keys. You can choose to restore the remaining TTL, the original 

expiration time or a custom TTL. 

Delete key before restoring if key exists 

If keys already exist in the target database, the existing keys will be deleted once the restore process starts. 

Delete all keys of the target database before restoring 

Delete all keys in the target database once the restore process starts. 

Delete asynchronously 

Delete keys from the server asynchronously. The operation will be executed in a background thread. 

Disable replies from server 

Stop the server from replying to commands. 

Continue on error 

Ignore errors that are encountered during the restore process. 

Extract Command 

Extract Command allows extracting commands into a Redis command file from your backup file. 

Extract a backup file that is in your database 

1. Open a database. 

2. Click Backup and select an existing backup file. 

3. Click Extract Command from the object toolbar. 

4. Choose the Extract Command options and click Extract. 

5. Choose a path for the command file. 
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Extract a backup file that is in any location 

1. Open any one of your databases. 

2. Click Backup. 

3. In the Objects tab, right-click anywhere and select Extract Command from. 

4. Browse the backup file. 

5. Choose the Extract Command options and click Extract. 

6. Choose a path for the command file. 
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Chapter 20 - Server Security 

About Server Security 

Navicat provides a powerful tool for you to manage server user accounts and the privileges of database objects. All 

information of users and privileges are stored in the server. In the main window, click  User or  Role to open the 

user/role object list. 

MySQL / MariaDB User & Role Management 

User Designer 

General Properties 

User Name 

Define a name for the user account. 

Host 

Enter a host name or an IP address where the user connected from. % means any host. 

Plugin 

Select the account authentication plugin for the user. 

Password 

Specify a login password for the user. 

Confirm Password 

Re-type the login password. 

Expire Password Policy 

Select the password expiration policy for the user account. 

Advanced Properties 

Max queries per hour, Max updates per hour, Max connections per hour 

Specify the maximum number of queries, updates, and connections that a user can perform during any given one-hour 

period. 0 means no limit. 

Max user connections 

Specify the maximum number of simultaneous connections that a user can make. 
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Use OLD_PASSWORD encryption 

Use the OLD_PASSWORD() function to generate a hash value for storing user password. 

SSL Type 

Specify the SSL/TLS-related options for the user account. 

ANY Require SSL encryption when the user connects. 

SPECIFIED Require a valid certificate when the user connects. Provide Certificate Issuer, 

Certificate Subject, or SSL Cipher. 

X509 Require a valid certificate when the user connects. 

Member Of 

Note: Roles are available for MySQL 8.0 or later or MariaDB 10.0.5 or later. 

In the grid, check the Granted or Default option against the role listed in Name to assign this user to be a member of 

the selected role. 

Server Privileges 

In the grid, check the Granted option against the server privilege listed in Privilege to assign this user to have that 

privilege. To grant or revoke all privileges, right-click on the grid and select Grant All or Revoke All. 

Privileges 

To edit specific object privileges for the user, click  Add Privilege to open the window and follow the steps below: 

1. Expand the node in the tree view until reaching to the target object. 

2. Check the object to show the grid on the right pane. 

3. In the grid, check the State option against the privilege listed in Privilege to assign this user to have that 

privilege. To grant or revoke all privileges, right-click on the grid and select Grant All or Revoke All. 

Role Designer 

Note: Roles are available for MySQL 8.0 or later or MariaDB 10.0.5 or later. 

General Properties 

Role Name 

Define a name for the role. 

Member Of 
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In the grid, check the Granted option against the role listed in Name to assign this role to be a member of the selected 

role. 

Members 

In the grid, check the Granted option against the role/user listed in Name to assign the selected role/user to be a 

member of this role. 

Server Privileges 

In the grid, check the Granted option against the server privilege listed in Privilege to assign this role to have that 

privilege. To grant or revoke all privileges, right-click on the grid and select Grant All or Revoke All. 

Privileges 

To edit specific object privileges for the role, click  Add Privilege to open the window and follow the steps below: 

1. Expand the node in the tree view until reaching to the target object. 

2. Check the object to show the grid on the right pane. 

3. In the grid, check the State option against the privilege listed in Privilege to assign this role to have that 

privilege. To grant or revoke all privileges, right-click on the grid and select Grant All or Revoke All. 

Oracle User & Role Management 

User Designer 

General Properties 

User Name 

Define a name for the user. 

Authentication 

Select the authentication method. 

PASSWORD Create a user. Specify a Password and re-type it in Confirm Password. Check the 

Expire Password option to force the user to change the password on the first attempted 

login. 

EXTERNAL Create a user authorised by an external service. Enter the certificate distinguished name 

or the Kerberos principal name in External Name. 

GLOBAL Create a user authorised by the enterprise directory service. Enter the X.509 name at the 

enterprise directory service that identifies the user in X.500 Name. 

Default Table Space 
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Choose the default tablespace for objects that the user creates. 

Temporary Table Space 

Choose the tablespace or tablespace group for the user's temporary segments. 

Profile 

Choose the profile that assign to the user. 

Lock Account 

Lock the user's account and disable access. 

Member Of 

In the grid, check the Granted, Admin Option or As Default option against the role listed in Role Name to assign this 

user to be a member of the selected role. 

Quotas 

In the grid, specify the maximum amount of space that the user can allocate in the tablespaces. Enter the Quota and 

choose the Unit. Unlimited lets the user allocate space in the tablespace without bound. Multiple tablespaces can be 

set. 

Server Privileges 

In the grid, check the Granted or Admin Option option against the server privilege listed in Privilege to assign this 

user to have that privilege. To grant or revoke all privileges, right-click on the grid and select Grant All, Grant All With 

Grant Option or Revoke All. 

Privileges 

To edit specific object privileges for the user, click  Add Privilege to open the window and follow the steps below: 

1. Expand the node in the tree view until reaching to the target object. 

2. Check the object to show the grid on the right pane. 

3. In the grid, check the Granted or Grant Option option against the privilege listed in Privilege to assign this 

user to have that privilege. To grant or revoke all privileges, right-click on the grid and select Grant All, Grant 

All With Grant Option or Revoke All. 

Role Designer 

General Properties 

Role Name 
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Define a name for the role. 

Authentication 

Select the authentication method. 

PASSWORD Create a role. Specify a Password and re-type it in Confirm Password. 

EXTERNAL Create a role authorised by an external service. 

GLOBAL Create a role authorised by the enterprise directory service. 

NOT IDENTIFIED Create a role without a password. 

Member Of 

In the grid, check the Granted or Admin Option option against the role listed in Role Name to assign this role to be a 

member of the selected role. 

Members 

In the grid, check the Granted or Admin Option option against the user listed in Member to assign the selected user to 

be a member of this role. 

Server Privileges 

In the grid, check the Granted or Admin Option option against the server privilege listed in Privilege to assign this role 

to have that privilege. To grant or revoke all privileges, right-click on the grid and select Grant All, Grant All With 

Grant Option or Revoke All. 

Privileges 

To edit specific object privileges for the role, click  Add Privilege to open the window and follow the steps below: 

1. Expand the node in the tree view until reaching to the target object. 

2. Check the object to show the grid on the right pane. 

3. In the grid, check the Granted option against the privilege listed in Privilege to assign this role to have that 

privilege. To grant or revoke all privileges, right-click on the grid and select Grant All or Revoke All. 

Maintain User 

Navicat provides a complete solution for maintaining Oracle users. 

1. In the main window, select users in the Objects tab. 

2. Right-click the selected users. 

3. Choose Maintain, and then choose a maintain option from the pop-up menu. 

Option Description 
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Expire Password Set the password of the user account to expire. 

Lock Account Lock the user account and disable access. 

Unlock Account Unlock the user account and enable access. 

 

PostgreSQL User, Group & Role Management 

User Designer 

Note: Users are available for PostgreSQL 8.0 or below. 

General Properties 

User Name 

Define a name for the user. 

User ID 

Specify an ID for the user. 

Password 

Specify a login password for the user. 

Confirm Password 

Re-type the login password. 

Password Encryption 

Choose whether the password is stored ENCRYPTED or UNENCRYPTED in the system catalogs. 

Expiry Date 

Set a datetime that the user's password will expire. If this option is omitted, the password will be valid for all time. 

Superuser 

Check this option to determine the user is a superuser. 

Can create database 

Check this option to allow the user to create databases. 

Member Of 

In the grid, check the Granted option against the group listed in Group Name to assign this user to be a member of the 

selected group. 
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Privileges 

To edit specific object privileges for the user, click  Add Privilege to open the window and follow the steps below: 

1. Expand the node in the tree view until reaching to the target object. 

2. Check the object to show the grid on the right pane. 

3. In the grid, check the Granted or Grant Option option against the privilege listed in Privilege to assign this 

user to have that privilege. To grant or revoke all privileges, right-click on the grid and select Grant All, Grant 

All With Grant Option or Revoke All. 

Group Designer 

Note: Groups are available for PostgreSQL 8.0 or below. 

General Properties 

Group Name 

Define a name for the group. 

Group ID 

Specify an ID for the group. 

Members 

In the grid, check the Granted option against the user listed in Member to assign the selected user to be a member of 

this group. 

Privileges 

To edit specific object privileges for the group, click  Add Privilege to open the window and follow the steps below: 

1. Expand the node in the tree view until reaching to the target object. 

2. Check the object to show the grid on the right pane. 

3. In the grid, check the Granted option against the privilege listed in Privilege to assign this group to have that 

privilege. To grant or revoke all privileges, right-click on the grid and select Grant All or Revoke All. 

Role Designer 

Note: Roles are available for PostgreSQL 8.1 or later. 

General Properties 

Role Name 



 346 

 

Define a name for the role. 

Role ID 

Specify an ID for the role. 

Can login 

Check this option to allow the role to log in. 

Password 

Specify a login password for the role. 

Confirm Password 

Re-type the login password. 

Password Encryption 

Choose whether the password is stored ENCRYPTED or UNENCRYPTED in the system catalogs. 

Connection Limit 

Specify how many concurrent connections the role can make. -1 means no limit. 

Expiry Date 

Set a datetime that the role's password will expire. If this option is omitted, the password will be valid for all time. 

Superuser 

Check this option to determine the role is a superuser. 

Can create database 

Check this option to allow the role to create databases. 

Can create role 

Check this option to allow the role to create roles. 

Inherit privileges 

Check this option to determine the role inherits the privileges of roles it is a member of. 

Can update system catalog 

Check this option to allow the role to update system catalog. 

Can replicate 
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Check this option to allow the role to initiate streaming replication or put the system in and out of backup mode. 

Can bypass RLS 

Check this option to allow the role to bypasses every row-level security (RLS) policy. 

Member Of 

In the grid, check the Granted or Admin Option option against the role listed in Role Name to assign this role to be a 

member of the selected role. 

Members 

In the grid, check the Granted or Admin Option option against the role listed in Member to assign the selected role to 

be a member of this role. 

Privileges 

To edit specific object privileges for the role, click  Add Privilege to open the window and follow the steps below: 

1. Expand the node in the tree view until reaching to the target object. 

2. Check the object to show the grid on the right pane. 

3. In the grid, check the Granted or Grant Option option against the privilege listed in Privilege to assign this 

role to have that privilege. To grant or revoke all privileges, right-click on the grid and select Grant All, Grant 

All With Grant Option or Revoke All. 

SQL Server Login, Role & User Management 

Login Designer 

Note: The following options and tabs depend on the server version and the authentication type. 

General Properties 

Login Name 

Define a name for the login. 

Authentication Type 

Select the authentication type of the login. 

Password 

Specify a password for the login. 

Confirm Password 
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Re-type the login password. 

Specify Old Password 

Check this option to enter the old password used by this account when editing the login. 

Enforce Password Policy 

Check this option to force password to follow password policy of SQL Server. 

Enforce Password Expiration 

Check this option to force password to have expiry date. 

User Must Change Password at Next Login 

Check this option to force user to change password every time when login. 

Default Database 

Select the default database when login. 

Default Language 

Select the default display language when login. 

Certificate Name 

Select the certificate to be used for the login. 

Asymmetric Key Name 

Select the asymmetric key to be used for the login. 

Enabled 

Check this option to enable the login. 

Credential 

Select the credentials to be mapped to the login. 

Roles 

In the list, assign this server login to be a member of the selected server role. 

User Mapping 

In the grid, check the Database and enter the User and Default Schema to create user for login the database and 

specify the first schema will be searched by the server. 
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Server Permissions 

In the grid, check the Grant, With Grant Option or Deny option against the server permissions listed in Permission to 

assign this login to have that permission. To grant, deny or revoke all permissions, right-click on the grid and select 

Grant All, Grant All With Grant Option, Deny All or Revoke All. 

Endpoint Permissions 

In the grid, check the permissions against the endpoint listed in Endpoint to assign this login to have that endpoint 

permission. Click the checkbox twice to grant the permission with Grant Option. Click the checkbox three times to deny 

the permission. 

Login Permissions 

In the grid, check the permissions against the endpoint listed in Login to assign this login to have that login permission. 

Click the checkbox twice to grant the permission with Grant Option. Click the checkbox three times to deny the 

permission. 

Server Role Designer 

Note: Azure SQL Database does not support Server Role. 

In the Members tab, assign the selected login to be a member of this server role. 

Database User Designer 

Note: The following options and tabs depend on the server version and the user type. 

General Properties 

User Name 

Define a name for the database user. 

Authentication 

Select the security type for database user. 

Login Name 

Assign a SQL Server login that the database user uses. 

Default Schema 

Select the default schema that will own objects created by the database user.  

Certificate Name 

Select the certificate to be used for the database user. 
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Asymmetric Key Name 

Select the asymmetric key to be used for the database user. 

Roles 

In the list, assign this database user to be a member of the selected database role. 

Owned Schemas 

In the list, check the schemas that are owned by the database user. 

Database Permissions 

In the grid, check the Grant, With Grant Option or Deny option against the database permissions listed in Permission 

to assign this database user to have that permission. To grant, deny or revoke all permissions, right-click on the grid 

and select Grant All, Grant All With Grant Option, Deny All or Revoke All. 

Object Permissions 

To edit specific object permissions for the database user, click  Add Permission to open the window and follow the 

steps below: 

1. Expand the node in the tree view until reaching to the target object. 

2. Check the object to show the grid on the right pane. 

3. In the grid, check the Grant, With Grant Option or Deny option against the permission listed in Privilege to 

assign this database user to have that permission. To grant, deny or revoke all permissions, right-click on the 

grid and select Grant All, Grant All With Grant Option, Deny All or Revoke All. 

Database Role Designer 

Note: The following options and tabs depend on the server version. 

General Properties 

Role Name 

Define a name for the database role. 

Owner 

Assign the owner for the database role. 

Member Of 

In the list, assign this database role to be a member of the selected database roles. 
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Members 

In the list, assign the selected database users and roles to be a member of this database role. 

Owned Schemas 

In the list, check the schemas that are owned by the database role. 

Database Permissions 

In the grid, check the Grant, With Grant Option or Deny option against the database permissions listed in Permission 

to assign this database role to have that permission. To grant, deny or revoke all permissions, right-click on the grid and 

select Grant All, Grant All With Grant Option, Deny All or Revoke All. 

Object Permissions 

To edit specific object permissions for the database role, click  Add Permission to open the window and follow the 

steps below: 

1. Expand the node in the tree view until reaching to the target object. 

2. Check the object to show the grid on the right pane. 

3. In the grid, check the Grant, With Grant Option or Deny option against the permission listed in Privilege to 

assign this database role to have that permission. To grant, deny or revoke all permissions, right-click on the 

grid and select Grant All, Grant All With Grant Option, Deny All or Revoke All. 

Application Role Designer 

Note: Azure SQL Database does not support Application Role. The following options and tabs depend on the server 

version. 

General Properties 

Role Name 

Define a name for the application role. 

Default Schema 

Select the default schema that will own objects created by the application role.  

Password 

Specify a password for the application role. 

Confirm Password 

Re-type the password. 
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Owned Schemas 

In the list, check the schemas that are owned by the application role. 

Database Permissions 

In the grid, check the Grant, With Grant Option or Deny option against the database permissions listed in Permission 

to assign this application role to have that permission. To grant, deny or revoke all permissions, right-click on the grid 

and select Grant All, Grant All With Grant Option, Deny All or Revoke All. 

Object Permissions 

To edit specific object permissions for the application role, click  Add Permission to open the window and follow 

the steps below: 

1. Expand the node in the tree view until reaching to the target object. 

2. Check the object to show the grid on the right pane. 

3. In the grid, check the Grant, With Grant Option or Deny option against the permission listed in Privilege to 

assign this application role to have that permission. To grant, deny or revoke all permissions, right-click on the 

grid and select Grant All, Grant All With Grant Option, Deny All or Revoke All. 

SQLite User Management 

Note: By default, a SQLite database does not require user authentication (no-authentication-required database). After 

you created a user, the database will be marked as requiring authentication (authentication- required database). Then, 

user need to provide username and password when connecting to the database file. 

General Properties 

User Name 

Define a name for the user account. 

Password 

Specify a login password for the user. 

Confirm Password 

Re-type the login password. 

Administrator 

Check this option to give the admin privilege to the user. 
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MongoDB User & Role Management 

User Designer 

General Properties 

User Name 

Define a name for the user. 

Password 

Specify a login password for the user. 

Confirm Password 

Re-type the login password. 

Password Digestor 

Indicate whether the server or the client digests the password. 

Mechanisms 

Specify the SCRAM mechanisms for creating SCRAM user credentials. 

Custom Data 

In this tab, you can enter any information associated with this user. 

Built-In Roles 

In the list, assign this user to be a member of the selected built-in role. 

User-Defined Roles 

In the list, assign this user to be a member of the selected user-defined role. 

Authentication Restrictions 

To edit specific authentication restrictions that the server enforces on the user, click  Add Restriction. 

Client Source 

Specify a list of IP addresses or CIDR ranges to restrict the client’s IP address. 

Server Address 

Specify a list of IP addresses or CIDR ranges to which the client can connect. 
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Role Designer 

General Properties 

Role Name 

Define a name for the role. 

Built-In Roles 

In the list, assign this role to be a member of the selected built-in role. 

User-Defined Roles 

In the list, assign this role to be a member of the selected user-defined role. 

Members (Roles) 

In the list, assign the selected role to be a member of this role. 

Members (Users) 

In the list, assign the selected user to be a member of this role. 

Authentication Restrictions 

To edit specific authentication restrictions that the server enforces on the role, click  Add Restriction. 

Client Source 

Specify a list of IP addresses or CIDR ranges to restrict the client’s IP address. 

Server Address 

Specify a list of IP addresses or CIDR ranges to which the client can connect. 

Privileges 

To edit specific object privileges for the role, click  Add Privilege to open the window and follow the steps below: 

1. Expand the node in the tree view until reaching to the target object. 

2. Check the objects that you want to grant the privileges on. 

3. In the grid, check the State option against the privilege listed in Privilege to assign this role to have that 

privilege. To grant or revoke all privileges, right-click on the grid and select Grant All or Revoke All. 
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Redis User Management 

You can define users in Redis Access Control Lists (ACLs) to protect access to your data. Navicat provides a graphical 

interface for you to create, edit and delete users. 

Note: Users are available for Redis 6 or later. 

General Properties 

User Name 

Define a name for the user account. 

Can login 

Enable the user account. 

Require Password 

Require the user to log in with a password. 

Add Password 

Add a password or a SHA-256 hash value to the list of valid passwords for the user. 

Privileges 

You can create new privilege groups (selectors) to add multiple sets of rules to the user. New privilege groups are 

evaluated after the main privilege group, and are evaluated according to the order they are defined. Click  Add 

Privilege Group / Add Privilege Groups with Batch. 

Commands 

To allow and disallow commands, click  Add Command / Add Commands with Batch. @all implies all the 

commands, both those currently present in the server, and those that will be loaded via modules in the future. 

Keys 

To allow and disallow certain keys and key permissions, click  Add Key / Add Keys with Batch. You can enable 

Grant privilege of all keys to allow the user to access all keys. 

Channels 

To allow and disallow Pub/Sub channels, click  Add Channel / Add Channels with Batch. You can enable Grant 

privilege of all channels to allow the user to access all Pub/Sub channels. 
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Snowflake User & Role Management 

User Designer 

General Properties 

User Name 

Define a login name for the user. 

First Name / Last Name 

Define the first and last name of the user. 

Password 

Specify a login password for the user. 

Confirm Password 

Re-type the login password. 

Default Role 

Specify the primary role that is active by default for the user’s session upon login. 

Default Warehouse 

Specify the virtual warehouse that is active by default for the user’s session upon login. 

Default Namespace 

Specify the virtual namespace that is active by default for the user’s session upon login. To specify a schema, enter the 

fully-qualified schema name in the form of <db_name>.<schema_name>. 

Days To Expiry 

Specify the number of days after which the user status is set to “Expired” and the user is no longer allowed to log in. If 

this option is omitted, the user will never expire. 

Mins To Unlock 

Specify the number of minutes until the temporary lock on the user login is cleared. 

Use all Secondary Roles 

Check this option to grant all secondary roles to the user. 

Disable account 
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Check this option to disable the user. 

Must change password at next login 

Check this option to force the user to change password on next login (including first/initial login). 

Member Of 

In the grid, check the Granted option against the role listed in Name to assign this user to be a member of the selected 

role. 

Role Designer 

General Properties 

Role Name 

Define a name for the role. 

Member Of 

In the grid, check the Granted option against the role listed in Role Name to assign this role to be a member of the 

selected role. 

Members 

In the grid, check the Granted option against the role listed in Member to assign the selected role to be a member of 

this role. 

Privileges 

To edit specific object privileges for the role, click  Add Privilege to open the window and follow the steps below: 

1. Expand the node in the tree view until reaching to the target object. 

2. Check the object to show the grid on the right pane. 

3. In the grid, check the Granted or Grant Option option against the privilege listed in Privilege to assign this 

role to have that privilege. To grant or revoke all privileges, right-click on the grid and select Grant All, Grant 

All With Grant Option or Revoke All. 

Database Role Designer 

General Properties 

Database Role Name 

Define a name for the database role. 
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Members 

In the grid, check the Granted option against the role listed in Member to assign the selected role to be a member of 

this role. 

Privileges 

To edit specific object privileges for the role, click  Add Privilege to open the window and follow the steps below: 

1. Expand the node in the tree view until reaching to the target object. 

2. Check the object to show the grid on the right pane. 

3. In the grid, check the Granted or Grant Option option against the privilege listed in Privilege to assign this 

role to have that privilege. To grant or revoke all privileges, right-click on the grid and select Grant All, Grant 

All With Grant Option or Revoke All. 

Privilege Manager 

Besides setting privileges in each user, Privilege Manager provides another view on privileges in a connection and its 

database objects. 

Note: Available only for MySQL, Oracle, PostgreSQL, SQL Server, MariaDB, MongoDB and Snowflake. 

To add privileges, click  Privilege Manager from the user object toolbar and follow the steps below: 

1. Expand the node in the tree view until reaching to the target object. 

2. Choose the object and click  Add Privilege to open the window. 

3. Check the user on the left pane. 

4. In the grid, check the relevant options against the privileges listed in Privilege to assign the selected user to 

have that object privilege. 
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Chapter 21 - Other Advanced Tools 

Server Monitor (Available only in Navicat Premium, Enterprise and 

Standard Edition) 

Navicat provides Server Monitor to view properties of selected servers. Choose Tools -> Server Monitor and choose 

the preferred server type from the menu bar. 

Note: Available only for MySQL, Oracle, PostgreSQL, SQL Server, MariaDB, MongoDB, Redis and Snowflake. 

Process List 

This tab displays a list of processes from all selected servers. The process list provides the following detailed 

information. It depends on the database type you are chosen. 

If you want to take action on auto-refreshing the process list in assigned seconds, choose View -> Set Auto Refresh 

Time and enter a refresh time value. To enable or disable the Auto Refresh feature, choose View -> Auto Refresh. 

Note: Effect will take once you assign the value. 

To set a selected process always show on the top of the grid, right-click and select On Top. To cancel this setting, 

choose Cancel On Top. 

To stop a selected process, click the  End Process button. 

Variables 

Note: Available only for MySQL, Oracle, PostgreSQL, MariaDB, MongoDB, Redis and Snowflake. 

This tab displays a list of all server variables and their values. 

You can edit MySQL, MariaDB, Oracle and Redis variable values here. Click or press CTRL+ENTER to open an 

editor for editing. 

Status 

Note: Available only for MySQL, Oracle, PostgreSQL, MariaDB, MongoDB and Redis. 

This tab displays a list of all server status and their values. 

Schema Analysis (Available only in Navicat Premium, Enterprise 

and Standard Edition) 

Schema Analysis is used for verifying your schemas, visualizing data distributions and identifying data outliers. To start, 

select a collection or a view in the Objects tab and click  Analyze Schema, or click  Analyze in the data editor. 
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Note: Available only for MongoDB. 

Hint: Schema Analysis Profiles (.nsatmongodb) are stored under the Settings Location. 

Toolbar 

Option / Button Description 

 Filter Filter the documents for analyzing. 

 Projection Include or exclude fields for analyzing. 

Analyze: Select the sample documents from the collection for analyzing. 

 Analyze Start analyzing the sample documents. 

 Stop Stop analyzing the sample documents. 

Results 

After the analysis has completed, you will see the schema analysis results. The results visually display information 

about the type and data distribution of all fields. 

If a field has multiple field types, you can click the field type bar on the left, and the chart will show the data distribution 

chart of that type. 
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Command Monitor (Available only in Navicat Premium, Enterprise 

and Standard Edition) 

Command Monitor is a real-time command monitoring tool that allows you to monitor every command processed by 

the Redis server instantly. It can help you understand what is happening to the database. To open the monitor, 

right-click on the connection and select Command Monitor. 

Note: Available only for Redis. 

Note: Command Monitor may reduce the performance of the Redis server significantly. 

The toolbar provides the following functions: 

Button Description 

 Start Start monitoring the Redis server. 

 End Stop monitoring the Redis server. 

 Word Wrap Break long words and wrap onto the next line. 

 Export Export the commands to a text file. 

 Clear Clear the commands. 

 

Virtual Grouping 

Virtual Group aims to provide a platform for logical grouping objects by categories, so that all objects are effectively 

preserved. It can be applied on Connection, Table, Collection, Data, View, Materialized View, Function, Index, Trigger, 

MapReduce, GridFS, Pub/Sub, Query, Aggregation Pipeline, Backup, Automation, Model and BI. 

Hint: The vgroup.json file is saved under the Profiles Location. 

If you want to hide the group structure, choose View -> Navigation Pane -> Flatten Connection and choose View -> 

Flatten Object List. 

Create a new group 

1. In the main window, right-click on the Navigation pane or the Objects tab and select New Group or Manage 

Group -> New Group. 

2. Enter a name for the new group. 

Move an object to a group 

1. In the main window, right-click an object and select Manage Group -> Move To. 

2. Select an existing group. 

Move an object to the top-level 
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1. In the main window, right-click an object and select Manage Group -> Exclude From Group. 

Hint: You can also use the drag and drop method to move objects. 

Connection Colorings 

Navicat provides highlighting connections by colors for identifying connections and their database objects. It lets you 

immediately know which connection you're connected to when you working on database objects. The highlighted color 

displays in the Navigation pane and the menu bar or the tab of its object window. 

To highlight a connection, right-click a connection in the Navigation pane and select Color. 

 

Find in Database/Schema (Available only in Navicat Premium, 

Enterprise and Standard Edition) 

Navicat provides a Find in Database/Schema feature offers searching table and view records or object structures 

within a database and/or schema. To open the Find in Database/Schema window, choose Tools -> Find in 

Database/Schema from the menu bar. 

Note: Available only for MySQL, Oracle, PostgreSQL, SQLite, SQL Server, MariaDB, MongoDB and Snowflake. 

1. Select a target Connection, Database and/or Schema. 

2. Enter the search string in Find what. 

3. Choose to find Data or Structure in the Look in drop-down list. 

4. Choose the Search Mode: Contains, Whole Word, Prefix or Regular Expression. 

5. Check the Case Insensitive box to disable case sensitive search if necessary. 
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6. When finding Structure, you can choose to search different objects: Tables, Collections, Views, Functions, 

Queries, Indexes, Triggers, Events and/or Materialized Views. 

7. Click the Find button and then double-click an object in the Find Results list to view the record or the 

structure. 

Console 

Console allows you to use a command-line interface to work with your server. In other words, it provides interactive 

text-based screen for you to query input and result output from databases. To open the Console window, open a 

connection and choose Tools -> Console from the menu bar or press F6. 

Hint: You are allowed to open multiple console windows which each represents a different connection. 

Oracle 

For Oracle servers, you must have SQL*Plus executable for this feature to work. By default, Navicat will look for 

SQL*Plus under client folder (e.g. ORACLE_HOME\bin). However, if Navicat cannot locate SQL*Plus under the 

SQL*Plus default path, you are prompted to locate the executable. 

Note: SQL*Plus does not support Unicode. 

MongoDB 

For MongoDB servers, you must have Mongo Shell executable for this feature to work. If Navicat cannot locate Mongo 

Shell under the Mongo Shell default path, you are prompted to locate the executable. 

Redis 

For Redis servers, code completion and syntax highlighting are supported. It lets you type Redis commands smoothly. 

Snowflake 

For Snowflake servers, you must have SnowSQL executable for this feature to work. If Navicat cannot locate 

SnowSQL under the SnowSQL default path, you are prompted to locate the executable. 

Dameng 

For Dameng servers, you must have DISQL executable for this feature to work. If Navicat cannot locate DISQL under 

the DISQL default path, you are prompted to locate the executable. 

Focus Mode (Available only in Navicat Premium, Enterprise and 

Standard Edition) 

Focus is a feature that helps you reduce distractions and set boundaries. It removes everything from the screen except 

the form you are working and enters the full screen mode. 
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When you want to concentrate on a specific activity, you can turn it on by simply clicking the  icon. 

The following tools support Focus Mode: 

• Data Editor 

• Object Designer 

• Query 

• Aggregation Pipeline 

• Automation 

• Model 

• BI 

• Server Monitor 

To exit Focus Mode, you can simply click the  icon at the top right. 

Share via URI 

Navicat allows you share an object with your teammates by the URI of the object. Navicat users can use the generated 

URI to access the object. 

Here are the objects that can be shared: 

• Connection 

• Database / Schema 

• Table / Collection / Data 

• View / Materialized View 

• Function / Procedure 

• Query / Aggregation Pipeline 

• Model 

• BI 

Obtain URI 

You can obtain the URI of an object in the General tab of the Information pane. Simply click Share and copy the URI in 

the popup window. You can enable Hide host info to remove the connection host parameter in the URI. 
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Open Object via URI 

1. In the main window, choose File -> Open with Navicat URI. 

2. Paste the URI. 

3. Click OK. 

4. Change the connection mapping by clicking Other Options if necessary. 

Option Description 

Mapped Connection Automatically map the connection in the URI to the connection with 

the most similar information in Navicat. 

Existing Connection Choose an existing connection in Navicat. 

New Connection Create a new connection in Navicat. 

5. Open the object. 

Favorites (Available only in Navicat Premium, Enterprise and 

Standard Edition) 

Favorites are links to objects that you visit frequently. By adding a path to your favorites list, you can go to that objects 

with a single click, instead of having to navigate the connection, database and/or schema in the Navigation pane. 

Add a link to Favorites 

1. Open an object, e.g. table. 

2. Choose File / Favorites -> Add to Favorites or press SHIFT+CTRL+#. If the object is opened in tabbed 

window, you can right-click the tab and select Add to Favorites. 

3. Enter Favorite Name and select Favorite ID if the Add to Favorites window pops up. 

Open an object from Favorites 

1. Choose Favorites -> favorite_name or press CTRL+#. 

Remove links from Favorites 

 Choose Favorites -> Clear Favorites -> favorite_name to remove a link. 

 Choose Favorites -> Clear Favorites -> Clear All to remove all links from the favorites list. 

Note: # represents 1, 2, 3, 4, 5, 6, 7, 8 or 9. 
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Dark Theme 

In Dark Theme, Navicat uses a darker color palette for all windows, views, menus, and controls. It works on all 

supported versions of Windows. 

To change your theme, choose Tools -> Options -> General. Then, select Dark. 

Search Filter 

Navicat provides search filters for searching your objects in the Navigation pane, the Objects tab, the Model Designer 

window and other tree structures. 

In the Navigation pane or other tree structures, click on the tree to focus and enter a search string directly. If 

connections have opened in the Navigation pane, the filter will also apply to their database objects.  

In the Objects tab, click  and enter a search string in the Search text box. 

In the Model Designer window, simply enter a search string in the Search text box.  

You can remove the filter by deleting the search string. 
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Chapter 22 - Configurations 

Options Settings 

Navicat provides several options for customizing its user interface and performance. 

To open the Options window, choose Tools -> Options from the menu bar. 

General 

General 

Theme 

Choose to use the theme of your Windows OS or a Dark theme. 

Hint: Restart Navicat to take effect. 

Allow opening multiple forms for same object 

Check this option to allow opening multiple instances of an object. 

Show objects under schema in navigation pane 

Display database objects using the tree structure in the Navigation pane. To expand a node, simply double-click it. 

Hint: Reopen the database/schema to take effect. 

Show objects under table in navigation pane 

Display table elements (e.g. fields, indexes, foreign keys) using the tree structure in the Navigation pane. To expand a 

node, simply the arrow to the left of the table name. 

Hint: Reopen the database/schema to take effect. 

Show toolbar caption 

Show text on toolbar buttons in sub-windows. Otherwise, only buttons will be presented. 

Hint: Restart Navicat to take effect. 

Show function wizard 

Display the function wizard (MySQL, Oracle, PostgreSQL, SQL Server or MariaDB) when you create a new 

function/procedure. 

Ask to save new queries/profiles before closing 
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With this option is on, Navicat will prompt you to save new queries or profiles every time when you quit the relevant 

sub-window. 

Check for updates on startup 

Check this option to allow Navicat checks for new version when it starts. 

Use safe confirm dialog (Main Window) 

With this option is on, Navicat will prompt a double confirmation dialog for safe deletion when deleting objects in the main 

window. 

Usage Data 

Share Usage Data 

Check this option to let your device sends us information about how you use Navicat to help us improve it. You can 

view the information being shared by clicking the Usage Data button. 

Tabs 

Open new tab in 

Set new pop-up windows to open as: 

Option Description 

Main Window Open a new tab in the main window. 

Last Tab Window Open a new tab in the last opened window (including the main window). 

Last Tab Window (Except 

Main Window) 

Open a new tab in the last opened window, or a new window if there isn't any 

opened windows. 

New Window Open a new window. 

On Startup 

Control what tabs appear when you launch Navicat: 

Option Description 

Open Objects tab only Open the Objects tab only, and no other tabs. 

Continue where you left off Open the Objects tab, and reopen the same tabs you were opened when you 

last quit Navicat. 

Open a specific tab or set 

of tabs 

Open the Objects tab, and open the tabs you choose in Set Tabs. 

Hint: Restart Navicat to take effect. 
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Code Completion 

Use code completion 

When you type the . (dot) symbol or a character, the editor will offer you a pop-up list that showing some suggestions for 

the code completion. 

Auto update code completion info 

With this option is on, Navicat will get the latest database information for code completion from your server automatically 

when you open the database/schema. Otherwise, you will need to update it manually in the Query window. 

Include system objects when updating code completion info 

When this option is on, code completion suggestions will also include system objects. In some cases, including system 

objects may slow down the code completion feature, especially in large databases. 

Note: Only available for MySQL, MariaDB and PostgreSQL. 

Auto select first suggestion 

Select the first item automatically when the suggestion list pops up. Therefore, pressing ENTER or TAB will insert the 

selected item. Otherwise, you need to use arrow keys to select the suggestion item. 

Clear Code Completion Info 

Delete the information for code completion feature that stored on your device. 

Editor 

General 

Show line number 

Display line numbers at the left side of the editor for easily reference. 

Use code folding 

Code folding allows codes to collapse as a block and only the first line displayed in the editor. 

Use brace highlighting 

Highlight the pair of braces when your cursor moves to either one brace for easily reference. 

Use syntax highlighting 
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Syntax highlight helps viewing codes clearly. Codes are highlighted in the editor with different colors and fonts 

according to the categories they belong to. This feature can be limited by setting the maximum file size (e.g. 10) in 

Disable if file size is larger than (MB) to increase performance. 

Use word wrap 

Enable the word wrap mode in the editor. 

Tab Width 

Enter the number of characters that a tab occupies, e.g. 5. 

Insert spaces when pressing Tab 

Insert space characters when the Tab key is pressed. 

Font and Colors 

Editor Font 

Define the font and its size used by editors. 

Colors 

Format your queries in the editor with colored syntax highlighting to improve readability. Set font colors to mark out 

different text fragments: Common, Keyword, String, Number, Comment and Background. Click on the color boxes and 

choose your desired color from the Color-Selection dialog window. 

Records 

Records 

Limit records  records per page 

Check this option if you want to limit the number of records showed on each page in the grid/foreign key data selection 

globally. Otherwise, all records will be displayed in one single page. 

Note: To adjust the settings for particular table/collection, see Data Editor. 

Auto Begin Transaction 

Check this option to start a new transaction automatically when changing records in the table/collection. Otherwise, 

auto commit is on and you need click the  Begin Transaction button in Data Editor to start a transaction manually. 

When starting a transaction in Data Editor, you can use the  Commit or  Rollback buttons to commit or rollback 

the changes. See Data Editor. 

Grid 
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Grid Font 

Define the font and its size used by grid in Data Editor. 

Display Format 

Data of types date, time and datetime can be formatted when displayed on data grids. Type the format here to change 

the format. If the formats are left blank, default format will be used. Default formats will be the system datetime formats. 

 

The following table shows specifiers you can use to create user-defined datetime formats. 

Date Time Fields 

Specifier Description 

c Display the date using the format given by the system global variable, followed 

by the time using the format given by the system global variable. The time is not 

displayed if the date-time value indicates midnight precisely. 

d Display the day as a number without a leading zero (1-31). 

dd Display the day as a number with a leading zero (01-31). 

ddd Display the day as an abbreviation (Sun-Sat). 

dddd Display the day as a full name (Sunday-Saturday). 

ddddd Display the date using the format given by the system global variable. 

dddddd Display the date using the format given by the system global variable. 

m Display the month as a number without a leading zero (1-12). If the m specifier 

immediately follows an h or hh specifier, the minute rather than the month is 

displayed. 

mm Display the month as a number with a leading zero (01-12). If the mm specifier 

immediately follows an h or hh specifier, the minute rather than the month is 

displayed. 

mmm Display the month as an abbreviation (Jan-Dec) using the strings given by the 

system global variable. 

mmmm Display the month as a full name (January-December) using the strings given 

by the system global variable. 

yy Display the year as a two-digit number (00-99). 

yyyy Display the year as a four-digit number (0000-9999). 

h Display the hour without a leading zero (0-23). 

hh Display the hour with a leading zero (00-23). 

n Display the minute without a leading zero (0-59). 
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nn Display the minute with a leading zero (00-59). 

s Display the second without a leading zero (0-59). 

ss Display the second with a leading zero (00-59). 

t Display the time using the format given by the system global variable. 

tt Display the time using the format given by the system global variable. 

am/pm Use the 12-hour clock for the preceding h or hh specifier, and display 'am' for 

any hour before noon, and 'pm' for any hour after noon. The am/pm specifier 

can use lower, upper, or mixed case, and the result is displayed accordingly. 

a/p Use the 12-hour clock for the preceding h or hh specifier, and display 'a' for any 

hour before noon, and 'p' for any hour after noon. The a/p specifier can use 

lower, upper, or mixed case, and the result is displayed accordingly. 

ampm Use the 12-hour clock for the preceding h or hh specifier, and display the 

contents of the system global variable for any hour before noon, and the 

contents of the system global variable for any hour after noon. 

/ Date separator. In some locales, other characters may be used to represent the 

date separator. 

: Time separator. In some locales, other characters may be used to represent the 

time separator. 

'xx'/"xx" Characters enclosed in single or double quotes are displayed as-is, with no 

formatting changes. 

Format specifiers may be written in uppercase or lowercase letters; both produce the same result. 

Show Thousands Separator 

Check this option to show the thousands separator for numeric data. 

Use system locale decimal & thousands separator 

Check this option to use the system separators that are defined in the regional settings in OS. Otherwise, use dot (.) as 

the decimal separator and comma (,) as the thousands separator. 

Data Profiling 

Colors 

Customize colors for bars, spotlights and not null/valid values. 

AI 

Show AI features 

Show the integrated AI Assistant and Ask AI functionalities in the Navicat UI. If disabled, the associated buttons and 

options will not be visible. 

Enable AI Assistant 
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AI Assistant helps you work more efficiently on query writing. After enabled AI Assistant, you can click + and choose an 

AI provider to add an assistant. 

Hint: By enabling AI Assistant, you agree to our Navicat AI Assistant Disclaimer. 

AI Assistant 

AI Assistant Name 

Enter the name of the AI Assistant. 

AI Provider 

Show the name of the AI Provider. 

API Host 

Enter the API host address. Navicat will automatically fill in the host for you when you select the AI Provider. 

API Key 

Enter your API key or token. 

Model 

Browse the chat model you have downloaded in the format <MODEL>:<PARAMETERS>. 

Max Tokens 

Set the maximum number of tokens to limit the model's response. 

Temperature 

Adjust the randomness of the generated output by AI Assistant. Higher temperatures result in more random and 

creative outputs, while lower temperatures result in more predictable and conservative outputs. 

Instruction 

Enter the instruction to set the tone and rules for the conversation. The instruction guides the AI in its responses, 

ensuring relevance and appropriate behavior. For example, "Respond succinctly" or "Avoid technical terms in your 

response". This helps the AI in delivering tailored, pertinent responses that meet your specific requirements effectively. 

AI Assistant UI 

Action for Enter key 

Choose the action for the ENTER key, either sending message or starting a new line. 

Enable Compare with Other Assistants 
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Allow you to compare AI responses from the current assistant with those from other AI assistants. 

Auto Recovery 

Query / Model / BI 

Save automatically after modifications in queries, model workspaces or BI workspaces by defining the Auto Save 

Interval (seconds) (e.g. 30). 

File Locations 

Logs Location 

Navicat provides number of log files to keep track on the actions have been performed in Navicat and they are located 

in the Logs Location path. 

Profiles Location 

By default, most of Navicat files and profiles are stored in Settings Location. However, some files and profiles are 

located in the Profiles Location paths. 

File in Profiles Location Server Type File Extension 

Automation MySQL .nbatmysql 

Oracle .nbatora 

PostgreSQL .nbatpgsql 

SQLite .nbatsqlite 

SQL Server .nbatmssql 

MariaDB .nbatmariadb 

MongoDB .nbatmongodb 

Redis .nbatredis 

Snowflake .nbatsnowflake 

Premium (Cross Server) .nbatpremium 

BI (Workspace) All .nbi 

Code Snippet All .nsnippet 

Data Dictionary MySQL .nddimysql 

Oracle .nddiora 

PostgreSQL .nddipgsql 

SQLite .nddisqlite 

SQL Server .nddimssql 

MariaDB .nddimariadb 

MongoDB .nddimongodb 

Snowflake .nddisnowflake 

Premium (Cross Server) .nddipremium 

Data Generation MySQL .ndgrmysql 
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Oracle .ndgrora 

PostgreSQL .ndgrpgsql 

SQLite .ndgrsqlite 

SQL Server .ndgrmssql 

MariaDB .ndgrmariadb 

MongoDB .ndgrmongodb 

Snowflake .ndgrsnowflake 

Data Synchronization MySQL .ndsymysql 

Oracle .ndsyora 

PostgreSQL .ndsypgsql 

SQLite .ndsysqlite 

SQL Server .ndsymssql 

MariaDB .ndsymariadb 

MongoDB .ndsymongodb 

Snowflake .ndsysnowflake 

Data Transfer MySQL .ndtfmysql 

Oracle .ndtfora 

PostgreSQL .ndtfpgsql 

SQLite .ndtfsqlite 

SQL Server .ndtfmssql 

MariaDB .ndtfmariadb 

MongoDB .ndtfmongodb 

Snowflake .ndtfsnowflake 

Premium (Cross Server) .ndtfpremium 

Model (Workspace) MySQL, Oracle, PostgreSQL, 

SQLite, SQL Server, MariaDB, 

MongoDB and Snowflake 

.nmodel 

MongoDump MongoDB .nmdpmongo 

MongoExport MongoDB .nmepmongo 

MongoImport MongoDB .nmipmongo 

MongoRestore MongoDB .nmrsmongo 

Structure Synchronization MySQL .nssymysql 

Oracle .nssyora 

PostgreSQL .nssypgsql 

SQL Server .nssymssql 

MariaDB .nssymariadb 

MongoDB .nssymongodb 

Snowflake .nssysnowflake 

Virtual Grouping All vgroup.json - stores how the objects are 

categorized. 

Export Wizard 
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Set the default export directory when exporting data. 

Connectivity 

General 

Verify server certificate against CA 

Enable this option to verify that the server certificate against the list of trusted CA. 

Proxy 

Enable the Use proxy option to configure Navicat to use proxy in order to make its network connections. 

Proxy Type 

Specify the type of your proxy server: HTTP or SOCKS5. 

Host 

The host name of your proxy server. 

Port 

The port number of your proxy server. 

User Name / Password 

If your proxy server requires authentication, you can enter a username and a password. 

Connectivity Diagnosis 

Click Test Connectivity to test the network connectivity between the web service and your machine. 

Environment 

Executables 

SQL*Plus 

Specify the location of SQL*Plus used in the console of Oracle connections. SQL*Plus is included in Oracle Client / 

Oracle Instant Client. 

Mongo Shell Path 

Specify the location of Mongo Shell used in the console of MongoDB connections. 

MongoDump Executable Path 



 377 

 

Specify the location of the mongodump executable that used for MongoDump. 

MongoRestore Executable Path 

Specify the location of the mongorestore executable that used for MongoRestore. 

MongoImport Executable Path 

Specify the location of the mongoimport executable that used for MongoImport. 

MongoExport Executable Path 

Specify the location of the mongoexport executable that used for MongoExport. 

SnowSQL 

Specify the location of SnowSQL used in the console of Snowflake connections. 

DISQL 

Specify the location of disql used in the console of Dameng connections. 

External Editor 

Choose the file path of an external editor for opening queries. 

OCI Environment 

OCI library (oci.dll) 

Specify the location of the OCI library (oci.dll) for Oracle connection. By default, it is set to the bundled one in Navicat 

installation folder. 

Hint: Restart Navicat to take effect. 

Oracle Instant Client is the simplest way to deploy a full Oracle Client application built with OCI, OCCI, JDBC-OCI, or 

ODBC drivers. It provides the necessary Oracle Client libraries in a small set of files. You can also download Oracle 

Instant Client through - 

Oracle Instant Client 

Download the appropriate Instant Client packages for your platform and the CPU. All installations REQUIRE the Basic 

or Basic Lite package. Unzip the packages and set the path points to it. 

Advanced 

Enable diagnostic logging 

Generate a log file in Logs Location to assist with tracking down any problems in Navicat. 

https://www.oracle.com/database/technologies/instant-client/downloads.html
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Hint: Restart Navicat to take effect. 

Allow multiple Navicat instances 

Check this option to allow opening multiple instances of Navicat. Uncheck this item means that clicking on the Navicat 

shortcut will re-activate the running instance of Navicat and not launch a new copy. 

Register on "Open with" List 

Register Navicat program to the "Open with" list in Windows. 

Register Navicat URI Protocol 

Register Navicat URI protocol in Windows. When clicking a Navicat URI link, Navicat opens and adds the corresponding 

Navicat On-Prem Server using the parameters in the URI. 
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Chapter 23 - Hot Keys 

Navicat Hot Keys 

Common 

Keys Action 

CTRL+SHIFT+# (# represents 1 to 9) Add to Favorites 

F8 Navicat Main Window / Objects Tab 

CTRL+TAB or SHIFT+CTRL+TAB Next Window / Tab 

CTRL+Q New Query 

F11 Focus Mode 

CTRL+U Open with Navicat URI 

F1 Help 

Navicat Main Window 

Keys Action 

CTRL+# (# represents 1 to 9) Open Favorites Link 

F6 Console 

CTRL+L History Log 

F12 Show Only Active Objects 

CTRL+N New Object 

CTRL+SHIFT+F Find in Database/Schema 

ER Diagram View 

Keys Action 

F5 Refresh 

ESC Select 

H Move Diagram 

R New Foreign Key 

DELETE Delete Selected Foreign Key 

CTRL+= or CTRL+Mousewheel Up Zoom In 

CTRL+- or CTRL+Mousewheel Down Zoom Out 

CTRL+0 Reset Zoom 

Table / Collection Designer 

Keys Action 

CTRL+O Open Table / Collection 

CTRL+F Find Field 

F3 Find Next Field 

SHIFT+F3 Find Previous Field 
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Data Editor 

Keys Action 

CTRL+D Design Object (Table, Collection, View, Materialized 

View) 

CTRL+Q Query Object (Table, Collection, View, Materialized 

View) 

CTRL+F Find Text 

F3 Find Next Text 

CTRL+G Go to Row 

CTRL+LEFT ARROW Move to First Column of Current Record 

CTRL+RIGHT ARROW Move to Last Column of Current Record 

CTRL+HOME Move to First Row of Current Column 

CTRL+END Move to Last Row of Current Column 

CTRL+PAGE UP or CTRL+UP ARROW Move to First Row of Current Page 

CTRL+PAGE DOWN or CTRL+DOWN ARROW Move to Last Row of Current Page 

CTRL+R Apply Filter / Apply Sort 

SHIFT+ARROW Select Cells 

CTRL+ENTER Edit Data with Opening Editor 

INSERT or CTRL+N Add Record 

CTRL+DELETE Delete Records 

CTRL+S Apply Record Changes 

ESC Discard Record Changes 

CTRL+T Stop Loading Data 

View / Materialized View Designer 

Keys Action 

CTRL+O Import SQL 

CTRL+E Switch to Definition 

CTRL+R Preview 

ALT1 Switch to Result Tab 

Query Designer 

Keys Action 

CTRL+O Open External File 

CTRL+E Select Current Statement 

CTRL+R Run / Run Selected 

CTRL+SHIFT+R Run Current Statement 

CTRL+T Stop 

ALT+# (# represents 0 to 9) Switch to Result Tab 

Query Editor 
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Keys Action 

CTRL+SHIFT+V Paste from Clipboard Stack 

CTRL+/ Comment / Uncomment Line 

CTRL+F Find Text 

F3 Find Next Text 

CTRL+I Ask AI 

CTRL+= Zoom In 

CTRL+- Zoom Out 

CTRL+0 Reset Zoom 

Query Builder 

Keys Action 

CTRL+= Zoom In 

CTRL+- Zoom Out 

CTRL+0 Reset Zoom 

Debugger 

Keys Action 

F9 Run 

F10 Step Over 

F11 Step In 

SHIFT+F11 Step Out 

Model 

Keys Action 

Workspace 

CTRL+D Design Object 

Model 

CTRL+N New Object 

Diagram 

CTRL+P Print 

ESC Select 

H Move Diagram 

T New Table/Collection/Entity 

V New View 

R New Foreign Key/Relation 

A New Label 

N New Note 

I New Image 

L New Layer 

CTRL++ or CTRL+Mousewheel Up Zoom In 
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CTRL+- or CTRL+Mousewheel Down Zoom Out 

CTRL+0 Reset Zoom 

BI 

Keys Action 

CTRL+D Design Object 

CTRL+R Refresh Data 

F5 Present Dashboard 

CTRL+P Print Dashboard 
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Chapter 24 - Trace Logs 

Log Files 

Navicat provides number of log files to keep track on the actions have been performed in Navicat and they are located 

in the logs directory, e.g. C:\Users\Guest\Documents\Navicat\Premium\logs\. You are allowed to change the log files 

location under Options.  

File Description 

history.log Store the statements or scripts of all operations executed over databases and database 

objects in Navicat. To open the history.log file in the History Log Viewer, choose Tools 

-> History Log or press CTRL+L. 

Note: This log will be overwritten while Navicat is being restarted. 

cmdline.log Store information for Navicat command line process and all operations while running 

batch jobs. 

LogImport.txt Record detailed information on every error (indicating success or failure) that occurred 

during the import process. 

Note: This log will be overwritten on each import. 

navicat.log Store information to assist with tracking down any problems in Navicat. You can enable 

this log in Options. 

Note: This log will be overwritten while Navicat is being restarted. 

History Log Viewer 

History Log Viewer shows the statements or scripts that are executed or executing in Navicat. If you just want to display 

error messages, click  Show Error Only. You can also change the information shown by choosing from the View 

menu -  

 Show Date 

 Show Time 

 Show Server Name 

 Show Session ID 

 Show Connection Type 

 Show Execute Time 

Note: When you click  Pause, any actions that you do while history is paused will show after resuming. 


